Subject: [magma] IGMPv4

From: Indranil Bhattacharya <[email-masked]>
Date: Thu, 17 Dec 2009 01:18:43 +0530

Hello,

        Is there work going on IGMPV4/MLDV3? Where can I find documents on
this?

Thanks,
Indranil

---

From: Brian Haberman <[email-masked]>
Date: Wed, 16 Dec 2009 20:51:35 -0500

Indranil Bhattacharya wrote:
> Hello,
>  
>         Is there work going on IGMPV4/MLDV3? Where can I find documents 
> on this?
>  

There are no proposals for additional work on IGMP or MLD.

Regards,
Brian

---

From: Bharat Joshi <[email-masked]>
Date: Thu, 17 Dec 2009 08:42:00 +0530

Hi,

     Though there are no proposals for IGMPv4 right now but a good effort to simplify the IGMPv3/MLDv2 protocol is going on in MBONED. You can take a look at tools.ietf.org/html/draft-ietf-mboned-lightweight-igmpv3-mldv2

     BTW, do you see any issues in current version of IGMP/MLD because of which you are asking for the next version?

Thanks,
Bharat
________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Brian Haberman [[email-masked]]
Sent: Thursday, December 17, 2009 7:21 AM
To: Indranil Bhattacharya
Cc: [email-masked]
Subject: Re: [magma] IGMPv4

Regards,
Brian

_______________________________________________
magma mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/magma

**************** CAUTION - Disclaimer *****************
This e-mail contains PRIVILEGED AND CONFIDENTIAL INFORMATION intended solely 
for the use of the addressee(s). If you are not the intended recipient, please 
notify the sender by e-mail and delete the original message. Further, you are not 
to copy, disclose, or distribute this e-mail or its contents to any other person and 
any such actions are unlawful. This e-mail may contain viruses. Infosys has taken 
every reasonable precaution to minimize this risk, but is not liable for any damage 
you may sustain as a result of any virus in this e-mail. You should carry out your 
own virus checks before opening the e-mail or attachment. Infosys reserves the 
right to monitor and review the content of all messages sent to or from this e-mail 
address. Messages sent to or from this e-mail address may be stored on the 
Infosys e-mail system.
***INFOSYS******** End of Disclaimer ********INFOSYS***

---

From: Indranil Bhattacharya <[email-masked]>
Date: Thu, 17 Dec 2009 12:46:14 +0530

Thanks Brian and Bharat. No, I do not see any issue. I just asked.

Regards,
Indranil

On Thu, Dec 17, 2009 at 8:42 AM, Bharat Joshi <[email-masked]>wrote:

> Hi,
>
>     Though there are no proposals for IGMPv4 right now but a good effort to
> simplify the IGMPv3/MLDv2 protocol is going on in MBONED. You can take a
> look at tools.ietf.org/html/draft-ietf-mboned-lightweight-igmpv3-mldv2
>
>     BTW, do you see any issues in current version of IGMP/MLD because of
> which you are asking for the next version?
>
> Thanks,
> Bharat

---

From: "Alvaro Fernandez" <[email-masked]>
Date: Thu, 17 Dec 2009 09:58:38 +0100

Hi

I think there are issues with IGMPv3. I suggested IGMPv4 some time ago.

I think that some issues are:

1. Mixing include and exclude sources -> information of sources of SSM (source specific multicast) is lost when mixing and PIM router can not use SSM
2. Separating include / exclude -> group timer and exclude list are not neccessary
3. No exclude list -> all the timers of exclude sources =0 -> no need for timers in exclude sources
4. No need for timers in Include sources when the routers keeps information of every host and channel -> no include timers (the reason is in GMI)
5. no exclude timers + no include timers -> timers are not necessary -> everything is much simpler, 

1,2,3,4,5 -> the state machine of the router is decribed with 8 lines (without source timers, group timers, exclude lists and Q(G,S))

regards

Alvaro

PS. BCP79/ more than 10 applications filed in USPTO / first one will be isued in 12 days.

-----Mensaje original-----
De: [email-masked] en nombre de Indranil Bhattacharya
Enviado el: jue 17/12/2009 8:16
Para: Bharat Joshi
CC: [email-masked]
Asunto: Re: [magma] IGMPv4

Regards,
Indranil

---

From: Bharat Joshi <[email-masked]>
Date: Fri, 18 Dec 2009 09:47:45 +0530

Hi Alvaro,

     Did you check out following draft?
http://tools.ietf.org/html/draft-ietf-mboned-lightweight-igmpv3-mldv2

     To simplify the IGMPv3/MLDv2, this draft has removed the 'Exclude' filter mode. Because of which, the protocol has become very light-weight. Care has been taken to keep it backward compatible as well. I think most of your issues will get resolved with this.

Thanks,
Bharat
________________________________________
From: Alvaro Fernandez [[email-masked]]
Sent: Thursday, December 17, 2009 2:28 PM
To: Indranil Bhattacharya; Bharat Joshi
Cc: [email-masked]
Subject: RE: [magma] IGMPv4

Hi

regards

Alvaro

-----Mensaje original-----
De: [email-masked] en nombre de Indranil Bhattacharya
Enviado el: jue 17/12/2009 8:16
Para: Bharat Joshi
CC: [email-masked]
Asunto: Re: [magma] IGMPv4

Regards,
Indranil