Subject: [magma] IGMP Querier - Non Querier - Startup Queries

From: rajasekar bonthala <[email-masked]>
Date: Fri, 12 Feb 2010 13:47:23 +0530

Hi ,

Let us take a set up like this :

Router 1 --------- HUB -------------- Router 2

Router 1 :

Interface IP Address is 192.168.1.7
IGMP Query interval is 60
IGMP Robustness is 4

Router 2 :

Interface IP Address is 192.168.1.8
IGMP Query interval is 60
IGMP Robustness is 4
Querier timeout is 70

Now lets say if
i enable IGMP in Router 2.
After router 2 transmitting 2 startup queries , if i enable igmp in Route 1
and
After router 1 transmitting 2 startup queries if i disable igmp in router 1,
then after 70 seconds router 2 becomes the Querier.

Then should it continue with the rest of the start up queries pending.

Thanks,
RajaSekhar

Thanks,
RajaSekhar

---

From: Bharat Joshi <[email-masked]>
Date: Fri, 12 Feb 2010 14:14:35 +0530

Rajasekar,

      Startup queries are sent to converge and elect the querier as soon as possible.

      Router 2 already knows that router-1 is querier and if other-querier-present timer fires, it declares itself the querier and start sending general queries. There is no need to send startup queries at this point of time. AFAIK, startup queries are send only when IGMP is enabled on an interface. 

      So to answer your question, router-2 should start sending general queries.

Thanks,
Bharat
________________________________________
From: [email-masked] [[email-masked]] On Behalf Of rajasekar bonthala [[email-masked]]
Sent: Friday, February 12, 2010 1:47 PM
To: [email-masked]; [email-masked]
Subject: [magma] IGMP Querier - Non Querier - Startup Queries

Hi ,

Router 1 :

Router 2 :

Now lets say if
i enable IGMP in Router 2.
After router 2 transmitting 2 startup queries , if i enable igmp in Route 1 and
After router 1 transmitting 2 startup queries if i disable igmp in router 1, then after 70 seconds router 2 becomes the Querier.

Thanks,
RajaSekhar

Thanks,
RajaSekhar

**************** CAUTION - Disclaimer *****************
This e-mail contains PRIVILEGED AND CONFIDENTIAL INFORMATION intended solely 
for the use of the addressee(s). If you are not the intended recipient, please 
notify the sender by e-mail and delete the original message. Further, you are not 
to copy, disclose, or distribute this e-mail or its contents to any other person and 
any such actions are unlawful. This e-mail may contain viruses. Infosys has taken 
every reasonable precaution to minimize this risk, but is not liable for any damage 
you may sustain as a result of any virus in this e-mail. You should carry out your 
own virus checks before opening the e-mail or attachment. Infosys reserves the 
right to monitor and review the content of all messages sent to or from this e-mail 
address. Messages sent to or from this e-mail address may be stored on the 
Infosys e-mail system.
***INFOSYS******** End of Disclaimer ********INFOSYS***

---

From: Bharat Joshi <[email-masked]>
Date: Fri, 12 Feb 2010 14:14:35 +0530

Rajasekar,

Thanks,
Bharat

Hi ,

Router 1 :

Router 2 :

Now lets say if

Thanks,
RajaSekhar

Thanks,
RajaSekhar

---

From: rajasekar bonthala <[email-masked]>
Date: Fri, 12 Feb 2010 15:02:43 +0530

Thanks a lot Bharath.

RajaSekhar

On Fri, Feb 12, 2010 at 2:14 PM, Bharat Joshi <[email-masked]>wrote:

>      Router 2 already knows that router-1 is querier and if
> other-querier-present timer fires, it declares itself the querier and start
> sending general queries. There is no need to send startup queries at this
> point of time. AFAIK, startup queries are send only when IGMP is enabled on
> an interface.
>
> From: [email-masked] [[email-masked]] On Behalf Of
> rajasekar bonthala [[email-masked]]
> After router 1 transmitting 2 startup queries if i disable igmp in router
> 1, then after 70 seconds router 2 becomes the Querier.
>

---

From: rajasekar bonthala <[email-masked]>
Date: Fri, 12 Feb 2010 15:02:43 +0530

Thanks a lot Bharath.

RajaSekhar