Subject: [magma] MLDv2 router in the presence of MLDv1 Multicast Address Listeners

From: "K.Kawaguchi" <[email-masked]>
Date: Mon, 27 Sep 2010 12:16:21 +0900

Hi all,

I have a simple question for MLDv2 interoperation with MLDv1.

RFC3810
---
8.3.  Multicast Router Behavior

8.3.2.  In the Presence of MLDv1 Multicast Address Listeners

   MLDv2 BLOCK messages are ignored, as are source-lists in TO_EX()
   messages (i.e., any TO_EX() message is treated as TO_EX( {} )).  On
   the other hand, the Querier continues to send MLDv2 queries,
   regardless of its Multicast Address Compatibility Mode.
---

Is the follwing a correct right too?

   "Any IS_EX() message is treated as IS_EX( {} )."

Best Regards
--
Kiyoaki Kawaguchi

---

From: Indranil Bhattacharya <[email-masked]>
Date: Mon, 27 Sep 2010 11:42:20 +0530

Hi Kiyoaki Kawaguchi,

                                Yes, I would think so. Otherwise there is a
possibility of some sources getting deleted. When MLDv1 receiver is present
in the LAN, this will not be acceptable.

Thanks,
Indranil

On Mon, Sep 27, 2010 at 8:46 AM, K.Kawaguchi <[email-masked]> wrote:

> _______________________________________________
> magma mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/magma
>

---

From: "K.Kawaguchi" <[email-masked]>
Date: Tue, 28 Sep 2010 15:42:51 +0900

Hi Indranil-san, Kunal-san,

Thank you for the answers.
I understood.

Best Regards
--
Kiyoaki Kawaguchi

---

From: Kunal Shah <[email-masked]>
Date: Mon, 27 Sep 2010 12:16:25 -0400

Yes. Dat is correct. 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of K.Kawaguchi
Sent: Sunday, September 26, 2010 8:16 PM
To: [email-masked]
Subject: [magma] MLDv2 router in the presence of MLDv1 Multicast Address Listeners

Hi all,

RFC3810
---

Best Regards
--
Kiyoaki Kawaguchi