Subject: [magma] Question about group ID ipv6 multicast addresses

From: Kunal Shah <[email-masked]>
Date: Fri, 17 Sep 2010 17:14:13 -0400

Hi all,

I was looking at the RFC 3307 and after reading section 4, I had the following questions:

1. Permanent mcast addresses use Group Ids 0x00000001 to 0x3FFFFFFF . Does this mean this range of group IDS is reserved and cannot be used with non permanent addresses??

2. Also can the group ID range 0x40000000 to 0x7FFFFFFF be used by customers for their content channels??

Thanks
Kunal

---

From: Brian Haberman <[email-masked]>
Date: Mon, 20 Sep 2010 16:59:22 -0400

On 9/17/10 5:14 PM, Kunal Shah wrote:
> 1. Permanent mcast addresses use Group Ids 0x00000001 to 0x3FFFFFFF .
> Does this mean this range of group IDS is reserved and cannot be used
> with non permanent addresses??

Yes.

> customers for their content channels??

That range is intended for use with IPv6 multicast addresses derived
using RFC 3306.  You should note that the IANA considerations state that
group IDs in this range are allocated based on Expert Review.  So, if
the customer is sourcing well-known application data, then it may make
sense to use this range.

Regards,
Brian

---

From: Kunal Shah <[email-masked]>
Date: Mon, 20 Sep 2010 17:13:58 -0400

Hi Brian,

Thaks for your resonse. For group ID range 0x40000000 to 0x7FFFFFFF, can these group IDs be ever present in mcast addresses contained in MLD reports i.e Can customers have their STBs send out MLD joins for mcast addresses containing group IDs in this range??

If group ID ranges 0x00000001 to 0x3FFFFFFF and 0x40000000 to 0x7FFFFFFF cannot be present in mcast addresses coming in a MLD report, does this mean only the range 0x80000000 to 0xFFFFFFFF can be used with mcast addresses inside MLD reports??

Thanks
Kunal

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Brian Haberman
Sent: Monday, September 20, 2010 1:59 PM
To: [email-masked]
Subject: Re: [magma] Question about group ID ipv6 multicast addresses

Yes.

> customers for their content channels??

That range is intended for use with IPv6 multicast addresses derived using RFC 3306.  You should note that the IANA considerations state that group IDs in this range are allocated based on Expert Review.  So, if the customer is sourcing well-known application data, then it may make sense to use this range.

Regards,
Brian
_______________________________________________
magma mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/magma

---

From: Brian Haberman <[email-masked]>
Date: Tue, 21 Sep 2010 09:26:29 -0400

On 9/20/10 5:13 PM, Kunal Shah wrote:
> Hi Brian,
> 
> Thaks for your resonse. For group ID range 0x40000000 to 0x7FFFFFFF,
> can these group IDs be ever present in mcast addresses contained in
> MLD reports i.e Can customers have their STBs send out MLD joins for
> mcast addresses containing group IDs in this range??

Yes.  A node should send an MLD Report for all joined multicast
addresses except the All-Hosts address.  That is clearly stated in the
MLD specifications.

> 
> If group ID ranges 0x00000001 to 0x3FFFFFFF and 0x40000000 to
> 0x7FFFFFFF cannot be present in mcast addresses coming in a MLD
> report, does this mean only the range 0x80000000 to 0xFFFFFFFF can be
> used with mcast addresses inside MLD reports??
> 

I think you are confused.  All of the group IDs can occur in multicast
addresses.  What RFC 3307 does is specifies the type of multicast
address that can contain each of the group ID ranges.

Regards,
Brian