Subject: [magma] Question about proxy implemenation in RFC 4605

From: Kunal Shah <[email-masked]>
Date: Fri, 29 Oct 2010 20:46:35 -0400

Hi all,

According to RFC 4605, a router creates a membership database after merging the subscriptions on individual interfaces. Lets say that 3 IGMPv3 capable interfaces are as follows:

Interface 1 has host reporting Include S1 -> I(S1)
Interface 2 has host reporting Exclude S2 -> E(0,S2)
Interface 3 has host reporting Exclude nothing -> E(0,0)

For a device doing IGMPv3 proxy, the final membership record for group G is (G, EXCLUDE, NULL). Now lets say the host on interface 3 goes away, because of which the subscription on interface 3 would expire and there wont be any IGMPv3 state on interface 3.  How would the new membership record for PROXY be calculated?? The RFC does not suggest any way to do this. Would IGMP process have to go through each interface again and then recompute the new membership record?? This would be very inefficient especially if there are multiple interfaces.
Is there a better way to recompute the new membership record??

Thanks
Kunal

---

From: "Alvaro Fernandez" <[email-masked]>
Date: Sat, 30 Oct 2010 19:36:20 +0200

Hi Kunal

I read it years ago but I think RFC 4605 explains that the downstream network interface should behave like a router, so the solution is in the state machine explained in RFC3376 for the IGMPv3 router

Álvaro

-----Mensaje original-----
De: [email-masked] en nombre de Kunal Shah
Enviado el: sáb 30/10/2010 2:46
Para: [email-masked]
Asunto: [magma] Question about proxy implemenation in RFC 4605
 
Hi all,

Thanks
Kunal