Subject: [magma] Question about fast-leave implementation

From: Kunal Shah <[email-masked]>
Date: Thu, 28 Oct 2010 18:46:50 -0400

Hi all,

Is there any reason to send out a query in fast-leave is enabled on the interface?? Enabling fast-leave allows deleting the cache immediately on receiving a leave. If the cache is deleted immediately, hosts on the interface will see traffic loss, which makes me think that fast-leave is enabled when the interface is gauranteed to receive a leave when the last host goes away or there is only one host on the interface. So does it make any sense in sending out a query on receiving a leave if fast-leave is enabled??

Thanks
Kunal

---

From: "Beeram, Suresh KumarReddy" <[email-masked]>
Date: Fri, 29 Oct 2010 18:21:27 +0000

Hi Kunal,
Eventhough Fast-leave enabled on interface if no of hosts greater than one for particular group we need to send query..
Only difference with normal behavior was when no of hosts is only one. Then FL enabled interface immediately deletes
cache entry without sending Query

Apart from that no other reason to send out query on FL enabled interface..

Thanks
B Suresh Reddy
From: [email-masked] [mailto:[email-masked]] On Behalf Of Kunal Shah
Sent: Friday, October 29, 2010 4:17 AM
To: [email-masked]
Subject: [magma] Question about fast-leave implementation

Hi all,

Thanks
Kunal

---

From: Hitoshi Asaeda <[email-masked]>
Date: Sat, 30 Oct 2010 14:41:44 +0900 (JST)

Hi Kunal,

> Is there any reason to send out a query in fast-leave is enabled on
> the interface?? Enabling fast-leave allows deleting the cache
> immediately on receiving a leave. If the cache is deleted
> immediately, hosts on the interface will see traffic loss, which
> makes me think that fast-leave is enabled when the interface is
> gauranteed to receive a leave when the last host goes away or there
> is only one host on the interface. So does it make any sense in
> sending out a query on receiving a leave if fast-leave is enabled??

Good question.

In fact, I've been working the function that supports fast leave.
You may want to read the following draft;
http://tools.ietf.org/html/draft-asaeda-mboned-explicit-tracking-01

This draft is currently submitted to MBONED.

Any commnet is welcome.

Regards,
--
Hitoshi Asaeda