Subject: [magma] A question on multicast states in non-querier

From: Bharat Joshi <[email-masked]>
Date: Mon, 14 Feb 2011 10:31:40 +0530

Hi All,

      If there are two IGMP routers on a LAN, one of them gets elected as querier and another as non-querier.

      The querier sends query and hosts on that LAN reply with the reports. Querier sees those report and create a database. Non-querier also sees those report and would create the same database.

      Question is whether Multicast routing protocol running on non-querier's upstream interface should use this database to join/leave the multicast group or not?

      IIRC, it is required because the DR for that LAN could be the non-querier router and if we do not join upstream, multicast data won't flow to this router. Is this a correct thinking?

Regards,
Bharat
**************** CAUTION - Disclaimer *****************
This e-mail contains PRIVILEGED AND CONFIDENTIAL INFORMATION intended solely 
for the use of the addressee(s). If you are not the intended recipient, please 
notify the sender by e-mail and delete the original message. Further, you are not 
to copy, disclose, or distribute this e-mail or its contents to any other person and 
any such actions are unlawful. This e-mail may contain viruses. Infosys has taken 
every reasonable precaution to minimize this risk, but is not liable for any damage 
you may sustain as a result of any virus in this e-mail. You should carry out your 
own virus checks before opening the e-mail or attachment. Infosys reserves the 
right to monitor and review the content of all messages sent to or from this e-mail 
address. Messages sent to or from this e-mail address may be stored on the 
Infosys e-mail system.
***INFOSYS******** End of Disclaimer ********INFOSYS***

---

From: Indranil Bhattacharya <[email-masked]>
Date: Mon, 14 Feb 2011 13:28:23 +0530

Hi Bharat,

              You are right. DR will use the database. It is necessary
because in LAN DR is seldom the querier. DR election is based on highest ip
address whereas querier election is based on lowest ip address.

Thanks,
Indranil

On Mon, Feb 14, 2011 at 10:31 AM, Bharat Joshi <[email-masked]>wrote:

>      The querier sends query and hosts on that LAN reply with the reports.
> Querier sees those report and create a database. Non-querier also sees those
> report and would create the same database.
>
>      Question is whether Multicast routing protocol running on
> non-querier's upstream interface should use this database to join/leave the
> multicast group or not?
>
>      IIRC, it is required because the DR for that LAN could be the
> non-querier router and if we do not join upstream, multicast data won't flow
> to this router. Is this a correct thinking?
>
> Regards,
> Bharat
> _______________________________________________
> magma mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/magma
>