Subject: [magma] Question about IGMPv3 state change

From: Kunal Shah <[email-masked]>
Date: Mon, 14 Feb 2011 14:58:55 -0500

Hi all,

I have a question about IGMPv3 state machine. If a group is in EX(X,Y) and a TO_IN(A) is received, the new state according to the RFC is EX (X+A, Y-A). I think this mean remove all the elements of A from Y and add all elements of A to X. This also implies that sources not removed from Y will still end up being added to X. My question is why cant we add only those elemets of A to X which are removed from Y as opposed to adding all the elements of A to X ??

If only the elements that are removed from Y are added to X, the new state would look like EX (X+(Y*A), Y-A).

Am I missing something here??

Kunal

---

From: Indranil Bhattacharya <[email-masked]>
Date: Mon, 28 Feb 2011 18:56:31 +0530

Hi Kunal,

x = s1,s2
y= s3,s4
a=s2,s3

x+a = s1,s2,s3
y-a = s4
Does it answer your question?

Thanks,
Indranil

On Tue, Feb 15, 2011 at 1:28 AM, Kunal Shah <[email-masked]> wrote:

>  Hi all,
>
> I have a question about IGMPv3 state machine. If a group is in EX(X,Y) and
> a TO_IN(A) is received, the new state according to the RFC is EX (X+A, Y-A).
> I think this mean remove all the elements of A from Y and add all elements
> of A to X. This also implies that sources not removed from Y will still end
> up being added to X. My question is why cant we add only those elemets of A
> to X which are removed from Y as opposed to adding all the elements of A to
> X ??
>
> _______________________________________________
> magma mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/magma
>
>