Subject: [maitai] Formats for Representing TP Rooms

From: Peter Musgrave <[email-masked]>
Date: Wed, 17 Nov 2010 11:09:14 +0800

Hi all, 

I was digging around looking at existing representation formats. 

The one which is trying to gain traction in HTML5 is X3D (http://en.wikipedia.org/wiki/X3D). Clearly full blown X3D would be overkill - but I will try and find some time to dig through basic representation and see if makes any sense. I suspect the idea of doing 3D geometry and finding planes etc. may appear to physics folks like Marshal and I but not have wider appeal...

Not sure if stuff like Qt has a similar 3D challenge.

In the "list of configurations" I did see an interesting example of a system deployed by Soft Foundry in which there were two columns of three monitors with a much bigger central monitor in between (with the overall setup looking a bit like a giant letter H). This is a good representation corner case - since it involves monitors on different horizontal planes. 

It might make sense to generate a whole bunch of potential representation formats (including e.g. the one Cullen's draft proposed) and then assess them based on what we need to get from them. Perhaps this is best done in a "throw away draft" - since it is a format which allows people to look in and make suggestions. 

If this seems like a good idea, I can try and collect this info and dump it into a doc...

Cheers, 

Peter Musgrave

---

From: Tom Kristensen <[email-masked]>
Date: Wed, 17 Nov 2010 12:13:42 +0100

> Not sure if stuff like Qt has a similar 3D challenge.

Interesting for sure, just a bit scare of the complexity of a full
feature 3D representation. We'll see how it might look like.

> If this seems like a good idea, I can try and collect this info and dump it into a doc...

Seems like a good idea to me. We need to do a survey on existing
similar approaches and later a categorization, characterisation of
some sort and finally an analysis based on what we need to represent.

-- Tom

-- 
# Cisco                         |  http://www.cisco.com/telepresence/
## [email-masked]  |  http://www.tandberg.com
###                               |  http://folk.uio.no/tomkri/

---

From: Marshall Eubanks <[email-masked]>
Date: Wed, 17 Nov 2010 06:44:00 -0500

Dear Peter;

> The one which is trying to gain traction in HTML5 is X3D (http://en.wikipedia.org/wiki/X3D). Clearly full blown X3D would be overkill - but I will try and find some time to dig through basic repres…

The actual standard is here http://www.web3d.org/x3d/specifications/x3d_specification.html

There is no reason that profiles couldn't be set up so that the full description is there, but well known rooms with standard configurations would be preset and not require any extensive computations. 

It occurs to me that one advantage of a full 3-D description of a room is that the location of microphones or speakers could be included as well, and that could be very useful in mapping sounds to screens. 

Regards
Marshall 

> _______________________________________________
> maitai mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/maitai
>

---

From: Ingemar Johansson S <[email-masked]>
Date: Thu, 18 Nov 2010 07:33:19 +0100

Hi

I have not looked into the X3D spec. but to me it seems like an idea worth looking closer at. 

What would be ideal is if he representation could be layered in some way like an onion (now I sound like Shrek..). 
The core layer would be real simple, additonal layers give more detail. 
For instance a for a hand held terminal it makes no sense to provide with a detailed description while a full immersive endpoint may even want to describe how the attendees sit..
Likewise a layered approach be useful for an MCU. Some implementations may not have the CPU power to do detailed rendering and it may even be so that todays research has not yet been able to define how rendering of e.g audio is actually done best.

That said..., it is often good to be practical and try to re-use something already existing (like X3D) than to try to invent something completely new.

/Ingemar

> -----Original Message-----
> From: Marshall Eubanks [mailto:[email-masked]] 
> Sent: den 17 november 2010 12:44
> To: Peter Musgrave
> Cc: [email-masked]
> Subject: Re: [maitai] Formats for Representing TP Rooms
> 
> Dear Peter;
> 
> > The one which is trying to gain traction in HTML5 is X3D 
> (http://en.wikipedia.org/wiki/X3D). Clearly full blown X3D 
> would be overkill - but I will try and find some time to dig 
> through basic representation and see if makes any sense. I 
> suspect the idea of doing 3D geometry and finding planes etc. 
> may appear to physics folks like Marshal and I but not have 
> wider appeal...
> 
> The actual standard is here 
> http://www.web3d.org/x3d/specifications/x3d_specification.html
> 
> There is no reason that profiles couldn't be set up so that 
> the full description is there, but well known rooms with 
> standard configurations would be preset and not require any 
> extensive computations. 
> 
> It occurs to me that one advantage of a full 3-D description 
> of a room is that the location of microphones or speakers 
> could be included as well, and that could be very useful in 
> mapping sounds to screens. 
> 
> Regards
> Marshall 
> 
> 
> 
> > 
> > In the "list of configurations" I did see an interesting 
> example of a system deployed by Soft Foundry in which there 
> were two columns of three monitors with a much bigger central 
> monitor in between (with the overall setup looking a bit like 
> a giant letter H). This is a good representation corner case 
> - since it involves monitors on different horizontal planes. 
> > 
> > It might make sense to generate a whole bunch of potential 
> representation formats (including e.g. the one Cullen's draft 
> proposed) and then assess them based on what we need to get 
> from them. Perhaps this is best done in a "throw away draft" 
> - since it is a format which allows people to look in and 
> make suggestions. 
> >