Subject: [manet-dlep-rg] Design team heads up

From: "Stan Ratliff (sratliff)" <[email-masked]>
Date: Thu, 21 Nov 2013 20:23:01 +0000

Gents, 

I looking at the email threads going on, and recollecting some of the conversations in Vancouver, I thought it best to give you this FYI. I've CCd Adrian and Joe so that everyone is in the loop, and also in the case where I might be operating under a false notion that needs correcting…. those caveats being issued, here goes. 

1. Authors.  The author list for DLEP is unchanged. I seem to recall some conversation in Vancouver (can't remember where it originated) where DT members were referring to themselves as DLEP authors. This isn't the case. The Design Team is just that - the Design Team. I've put additional text in the acknowledgements section recognizing the efforts of the DT. At least for me, the author list is pretty much sacrosanct. It takes strong consensus amongst the existing authors to modify that list in any way.

2. It is entirely possible that the Design Team may not reach consensus on some issues. Ultimately, the issue isn't whether the DT reaches consensus, but that the Working Group reach consensus. So we as a design team may well have issues that we need to "take to the list" to let the WG as a whole weigh in on. 

That being said, we've made a lot of progress, and are making the spec better. I think the WG as a whole will be quite happy with what we've come up with (touch wood). Let's please keep the momentum going. 

Regards,
Stan

---

From: Teco Boot <[email-masked]>
Date: Fri, 22 Nov 2013 17:19:31 +0100

I verified operation of a telnet server on a old type BGAN terminal (E500).
It is compatible with 3GPP TS 27.007.
It is multi-hop unicast reachable from routers and other node types. 
Multiple connections can be same source, same destination. Think of NAT. Interfaces on my routers pointing towards Internet have NAT.

Although 3GPP TS 27.007 is a standard, the satcom extensions are not. 
For LTE, it doesn't look much better.

Attached a screenshot with two active 3GPP TS 27.007 sessions.
Device provides IP address and default gateway. But SQ is zero, it is in pointing mode. So it is a blackhole.
Having DLEP on this type of equipment would help a lot.

Teco

lease {
  interface "eth1";
  fixed-address 192.168.0.2;
  server-name "BGAN-UT";
  option subnet-mask 255.255.255.0;
  option routers 192.168.0.1;
  option dhcp-lease-time 30;
  option dhcp-message-type 5;
  option dhcp-server-identifier 192.168.0.1;
  option dhcp-renewal-time 10;
  option dhcp-rebinding-time 10;
  renew 5 2013/11/22 16:11:19;
  rebind 5 2013/11/22 16:11:20;
  expire 5 2013/11/22 16:11:40;
}

---

From: Rick Taylor <[email-masked]>
Date: Fri, 22 Nov 2013 16:19:30 +0000

Thanks for making that clear Stan,

I, for one, am interested in getting DLEP standardized and ready for a production environment.  Matters of authorship and associated kudos are not a concern to me.

My only desire for consensus amongst the DT is so that we can give you (the authors) a good steer in the direction we believe DLEP should go. 

If I wanted to add some gloss to my CV, I could just produce a draft describing a standard use of the words: IF, THEN and ELSE ;-)

Rick

________________________________________
From: manet-dlep-rg [[email-masked]] on behalf of Stan Ratliff (sratliff) [[email-masked]]
Sent: 21 November 2013 20:23
To: ([email-masked]) [email-masked] Group
Cc: Adrian Farrel; Joseph Macker
Subject: [manet-dlep-rg] Design team heads up

Gents,

Regards,
Stan
_______________________________________________
manet-dlep-rg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/manet-dlep-rg

---

From: "Stan Ratliff (sratliff)" <[email-masked]>
Date: Fri, 22 Nov 2013 17:19:52 +0000

OK. 

I talked with the Persistent Systems folks this week at MILCOM. Their response was that they don't care whether the radio (modem) is the TCP client or server. 

So, if they don't care, I'll change my position to "I don't care, either". Other than the fact that I think making the modem the server looks completely backwards to me. Let's wrap this point up and move on… what is the consensus of the DT as to what should be in the spec? 

One side note I feel compelled to point out - if the consensus is to make the modem the TCP server, and there's pushback in the WG on it, don't expect me to defend the position.  One other comment inline:

> Multiple connections can be same source, same destination. Think of NAT. Interfaces on my routers pointing towards Internet have NAT.

While multiple connections on a telnet server makes sense, I don't think multiple connections makes sense on DLEP. 

Stan

> <Schermafbeelding 2013-11-22 om 16.03.33.png>
> 
> 
> lease {
>   interface "eth1";

---

From: Teco Boot <[email-masked]>
Date: Fri, 22 Nov 2013 19:13:19 +0100

> While multiple connections on a telnet server makes sense, I don't think multiple connections makes sense on DLEP. 

For your router: I understand.
DLEP is definitely not *only* for routers. I don't mind, the nodes I have t deal with do DTN kind of things; they forward messages. Multiple of those nodes share same radio. Radio has the capabilities, e.g. the PS radio's definitely do. Same for BGAN units. My list in longer.

Teco