Subject: Re: [manet-dlep-rg] Session iniation and discovery

From: Martin Duke <[email-masked]>
Date: Wed, 4 Dec 2013 10:04:32 -0800

I'm late but I endorse what Rick and Stan came up with.

On Fri, Nov 22, 2013 at 10:28 AM, Teco Boot <[email-masked]> wrote:

> +1 judgement as Stan.
>
> You know my preference: make radio the TCP server.
>
> Op 22 nov. 2013, om 17:58 heeft Rick Taylor <
> [email-masked]> het volgende geschreven:
>
> > Extra note:
> >
> > d) The IANA assigned port for DLEP is used for both multicast UDP and
> TCP.  It is the same port number.
> >
> > ________________________________________
> > From: manet-dlep-rg [[email-masked]] on behalf of Rick
> Taylor [[email-masked]]
> > Sent: 22 November 2013 16:57
> > To: [email-masked] Group, ([email-masked])
> > Subject: [manet-dlep-rg] Session iniation and discovery
> >
> > Gents,
> >
> > Am I right in thinking we are achieving some kind of consensus on
> session initiation and discovery?  My understanding of the proposal is:
> >
> > Discovery:
> >
> > 1) Router SHOULD send 'Advertise' UDP messages on IANA assigned
> link-local multicast address:port at periodic interval ANNOUNCE_INTERVAL.
> > 'Advertise' messages MUST contain the DLEP version TLV.
> > 'Advertise' messages MAY contain alternate TCP address TLV.  (E.g. ipv4
> fallback)
> > 'Advertise' messages MAY contain alternate TCP port TLV.
> > 'Advertise' messages MAY contain secondary reliable transport protocol
> endpoint address TLV.  (E.g. SCTP address)
> >
> > Initiation:
> >
> > 0) Router listens on a TCP port, the port SHOULD be the IANA assigned
> DLEP port.
> >
> > 1) Modem connects to a TCP endpoint either discovered from 'Advertise'
> messages, or from alternate discovery mechanism (e.g. mDNS), or a-priori
> configuration.
> >
> > 2) Modem MUST send 'Initialize' message.
> > 'Initialize' message MUST contain DLEP version TLV.
> > 'Initialize' message MUST contain Identification TLV.
> > 'Initialize' message MUST contain for all mandatory DLEP metric TLVs
> with values.
> >
> > 2) Router MUST reply with 'Accept' message, or shut down the connection.
> > 'Accept' message MUST contain DLEP version TLV.
> > 'Accept' message MUST contain Identification TLV.
> > 'Accept' message MUST contain Status TLV.  This will indicate: Success,
> Reject, etc... (TBD)
> > 'Accept' message MAY contain secondary reliable transport protocol
> endpoint address TLV.  (E.g. SCTP address)
>
> Isn't this in the transport layer?
>
>
> >
> > 2a) If Status TLV is a failure: Router MUST and Modem SHOULD close the
> TCP connection.
>
> I think it is better to specify which node MUST close the connection.
> That's the one that sends the Reject. The FIN follows. Why SHOULD the other
> start closing the connection? It can wait on FIN, it MUST come. Or wait for
> heartbeat dead time, as safeguard.
>
>
> > 2b) If Status TLV is a success: Session is established.
> >
> > 3) Router MAY stop any active discover process.
>
> Not sure what you mean, if TCP server is on modem.
> Router SHOULD continue to listen to discovery packets.
> FYI: new BGAN terminals support some kind of bonding. Some deploy an RF
> link with Tx&Rx-only modems.
>
> >
> > 4) Router MAY stop listening for more connections on the TCP port.
> >
> > Notes:
> >
> > a) Stan probably has different names for the messages.
> > b) I have made the Router the TCP server in this example, because it
> forces the modem to announce it's capabilities/TLVs in the 'Initialize'
> message, and I believe it's the way Stan is leaning.
> > c) If the roles are reversed then the 'Accept' message must carry the
> mandatory TLVs, and an extra 'Unacceptable' message is required from the
> Router to Modem explaining why the Router closed the connection if it
> doesn't like the TLVs from the Modem.
>
> So this is the three-way handshake.
> I didn't understand why the Router didn't send the full set of supported
> TLVs. OK, Ik know this is more relevant for link metrics from modem to
> router. But for protocol specification, I haven't a clear picture what we
> designed.
>
> Teco
>
>
> >
> > Does this sound right?  Or am I way off?
> >
> > I'd just like to get this part fixed as I have more topics up for
> debate, and I reckon we could announce this as progress on the WG list.
> >
> > Rick
> > _______________________________________________
> > manet-dlep-rg mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/manet-dlep-rg
> > _______________________________________________
> > manet-dlep-rg mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/manet-dlep-rg
>
> _______________________________________________
> manet-dlep-rg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet-dlep-rg
>

---

From: "Stan Ratliff (sratliff)" <[email-masked]>
Date: Wed, 4 Dec 2013 18:55:47 +0000

All,

Great. DLEP document is in-flight. I've had some set-backs recently - had to have some outpatient surgery on Monday (that was fun… NOT!), so it's taking longer than I had anticipated. But look for an updated DLEP in your inboxes soon…

Regards,
Stan

On Dec 4, 2013, at 1:04 PM, Martin Duke <[email-masked]<mailto:[email-masked]>> wrote:

On Fri, Nov 22, 2013 at 10:28 AM, Teco Boot <[email-masked]<mailto:[email-masked]>> wrote:
+1 judgement as Stan.

Op 22 nov. 2013, om 17:58 heeft Rick Taylor <[email-masked]<mailto:[email-masked]>> het volgende geschreven:

> Extra note:
>
> d) The IANA assigned port for DLEP is used for both multicast UDP and TCP.  It is the same port number.
>
> From: manet-dlep-rg [[email-masked]<mailto:[email-masked]>] on behalf of Rick Taylor [[email-masked]<mailto:[email-masked]>]
> To: [email-masked]<mailto:[email-masked]> Group, ([email-masked]<mailto:[email-masked]>)
> Am I right in thinking we are achieving some kind of consensus on session initiation and discovery?  My understanding of the proposal is:
>
> Discovery:
>
> 1) Router SHOULD send 'Advertise' UDP messages on IANA assigned link-local multicast address:port at periodic interval ANNOUNCE_INTERVAL.
> 'Advertise' messages MAY contain alternate TCP address TLV.  (E.g. ipv4 fallback)
> 'Advertise' messages MAY contain secondary reliable transport protocol endpoint address TLV.  (E.g. SCTP address)
>
> Initiation:
>
> 0) Router listens on a TCP port, the port SHOULD be the IANA assigned DLEP port.
>
> 1) Modem connects to a TCP endpoint either discovered from 'Advertise' messages, or from alternate discovery mechanism (e.g. mDNS), or a-priori configuration.
>
> 'Initialize' message MUST contain for all mandatory DLEP metric TLVs with values.
>
> 'Accept' message MUST contain Status TLV.  This will indicate: Success, Reject, etc... (TBD)
> 'Accept' message MAY contain secondary reliable transport protocol endpoint address TLV.  (E.g. SCTP address)

>
> 2a) If Status TLV is a failure: Router MUST and Modem SHOULD close the TCP connection.

I think it is better to specify which node MUST close the connection. That's the one that sends the Reject. The FIN follows. Why SHOULD the other start closing the connection? It can wait on FIN, it MUST come. Or wait for heartbeat dead time, as safeguard.

Not sure what you mean, if TCP server is on modem.
Router SHOULD continue to listen to discovery packets.
FYI: new BGAN terminals support some kind of bonding. Some deploy an RF link with Tx&Rx-only modems.

> b) I have made the Router the TCP server in this example, because it forces the modem to announce it's capabilities/TLVs in the 'Initialize' message, and I believe it's the way Stan is leaning.
> c) If the roles are reversed then the 'Accept' message must carry the mandatory TLVs, and an extra 'Unacceptable' message is required from the Router to Modem explaining why the Router closed the connection if it doesn't like the TLVs from the Modem.

So this is the three-way handshake.
I didn't understand why the Router didn't send the full set of supported TLVs. OK, Ik know this is more relevant for link metrics from modem to router. But for protocol specification, I haven't a clear picture what we designed.

Teco

> I'd just like to get this part fixed as I have more topics up for debate, and I reckon we could announce this as progress on the WG list.
>
> Rick
> [email-masked]<mailto:[email-masked]>
> [email-masked]<mailto:[email-masked]>

_______________________________________________
manet-dlep-rg mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/manet-dlep-rg

_______________________________________________
manet-dlep-rg mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/manet-dlep-rg

---

From: Henning Rogge <[email-masked]>
Date: Wed, 4 Dec 2013 20:24:34 +0100

Looking forward to it Stan. :)

Henning Rogge

On Wed, Dec 4, 2013 at 7:55 PM, Stan Ratliff (sratliff)
<[email-masked]> wrote:
> All,
>
> Great. DLEP document is in-flight. I've had some set-backs recently - had to
> have some outpatient surgery on Monday (that was fun… NOT!), so it's taking
> longer than I had anticipated. But look for an updated DLEP in your inboxes
> soon…
>
> Regards,
> Stan
>
> On Dec 4, 2013, at 1:04 PM, Martin Duke <[email-masked]> wrote:
>
>> Op 22 nov. 2013, om 17:58 heeft Rick Taylor
>> <[email-masked]> het volgende geschreven:
>>
>> > Extra note:
>> >

-- 
We began as wanderers, and we are wanderers still. We have lingered
long enough on the shores of the cosmic ocean. We are ready at last to
set sail for the stars - Carl Sagan

---

From: Rick Taylor <[email-masked]>
Date: Thu, 5 Dec 2013 12:48:04 +0000

Good to hear Stan,

Hope you're back on your feet and doing okay.

I have been meaning to write a reversed version of the session initiation with the modem as the server just to see how it works out, but I'll use another email.  Is anyone interested in me doing this, or are we set on having the router as the TCP server?

Rick
________________________________________
From: Henning Rogge [[email-masked]]
Sent: 04 December 2013 19:24
To: Stan Ratliff (sratliff)
Cc: Martin Duke; [email-masked] Group, ([email-masked]); Teco Boot; Rick Taylor
Subject: Re: [manet-dlep-rg] Session iniation and discovery

Henning Rogge