Subject: RE: [Manet-dt] Unknown TLVs

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Tue, 27 Sep 2005 17:36:36 +0100

I think the intent is (briefly as I'm just going home).

- Ignore for processing.
- Include for forwarding.

Now let's see if the other OLSRv2 authors agree...

Christopher

I know, top posting bad. See first line.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Ian Chakeres
Sent: 27 September 2005 16:34
To: Thomas Clausen
Cc: [email-masked]
Subject: [Manet-dt] Unknown TLVs

               *** WARNING ***

This mail has originated outside your organization, either from an
external partner or the Global Internet.

     Keep this in mind if you answer this message.

In OLSRv2, if an unknown message tlv or address tlv is reached, what is
the behavior?

Ian

_______________________________________________
Manet-dt mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet-dt

********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************

_______________________________________________
Manet-dt mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet-dt

---

From: Thomas Clausen <[email-masked]>
Date: Tue, 27 Sep 2005 18:50:35 +0200

I think that I agree with Chris.....

....also on that top-posting is bad.

FYI, this is among the things which is explicit in the next version of 
the olsrv2-draft (coming soon to an IETF-server near you)

--thomas

---

From: "Joe Macker" <[email-masked]>
Date: Tue, 27 Sep 2005 20:18:16 -0400

I was talking this out with Justin a bit one day.

Would you stop processing all further TLVs or try to parse over the ones you
don't understand.
If the first option, then the order of TLVs is important to specify. 

> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Thomas Clausen
> Sent: Tuesday, September 27, 2005 12:51 PM
> To: Dearlove, Christopher (UK)
> Cc: [email-masked]
> Subject: Re: [Manet-dt] Unknown TLVs
> 
> FYI, this is among the things which is explicit in the next 
> version of the olsrv2-draft (coming soon to an IETF-server near you)
> 
> --thomas
> 
> 
> > In OLSRv2, if an unknown message tlv or address tlv is 
> reached, what 
> > is the behavior?
> >
> > Ian
> >

---

From: "Pedro M. Ruiz" <[email-masked]>
Date: Tue, 27 Sep 2005 17:37:24 -0700

I think that the usual behavior in other protocols is what Christopher 
explained. If there is an unknown TLV, one continues processing just in 
case there are other TLVs you understand later on.

I particularly like more this approach than stop processing and 
specifying an order. Otherwise, everytime you extend a protocol with a 
new option, you need to figure out (and specify) the new order. In fact, 
when many TLV fields are optional it is not easy to establish such a 
total order.

Anyway, fully agree with Joe about the importance of specifying the 
order in case of not processing further.

--Pedro

Joe Macker wrote:

>>[mailto:[email-masked]] On 
>>    
>>
>>>Behalf Of Ian Chakeres

---

From: Thomas Clausen <[email-masked]>
Date: Wed, 28 Sep 2005 02:57:31 +0200

> If the first option, then the order of TLVs is important to specify.

I think the intent was thus:

	- all "mandatory" (i.e. specified by the OLSRv2 spec) TLVs
	  MUST come before any "optional" TLVs

Thereby, a "minimal" node COULD process only mandatory TLVs, then stop 
(discard the rest), and still be compliant to the spec.

However recommended behavior is as Chris states, that unknown TLVs be 
ignored for processing, but still included for forwarding.

I'll have to look at the notes (which are at work) from the last 
Extreme Editing session to recall the arguments -- but Chris/Justin may 
remember?