Subject: RE: [Manet-dt] fmt default handling bits

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Tue, 20 Dec 2005 09:37:27 +0000

>Can we built the same functionality into the common format
>message-type and tlv type?

We have considered this. There are a number of problems

(a) There is a limited number of bits in the type field,
    8, of which 2 are already used. Using 2 more is
    probably more than we can afford given the number
    of extensions just to OLSR that are considered, let
    alone other protocols.

(b) At the moment a feature of the message format is that
    if processing standard features only you can stop
    as soon as you get to a nonstandard feature and not
    even bother parsing it. This defeats that objective.

(c) An extension that is likely to be of early interest
    to many is the addition of a message signature using
    a message TLV. (See for example Secure OLSR paper.)
    This interacts badly with TLVs that are added and
    removed.

********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************

_______________________________________________
Manet-dt mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet-dt

---

From: "Charles E. Perkins" <[email-masked]>
Date: Tue, 20 Dec 2005 01:52:46 -0800

Hello Chris,

>    of extensions just to OLSR that are considered, let
Do you mean that OLSRv2 will have more than 16 message types?

>    even bother parsing it. This defeats that objective.
Could you say more about that?  Do you mean a nonstandard TLV attached
to a standard message type?

>    This interacts badly with TLVs that are added and
Abiding by this would eliminate the possibility of any mutable
TLVs, which is a pretty heavy restriction to put in the current
design for the whole future life of whatever we are designing.

Regards,
Charlie P