Subject: RE: [Manet-dt] Packet Format Document - index start/stop for messagetlvs

From: "Luke Klein-Berndt" <[email-masked]>
Date: Wed, 18 Jan 2006 16:32:02 -0500

I am not sure if this was answered offline, but I think this could be an
interesting question. 2 bytes per TLV would defiantly add up pretty
quickly... but if you are using some sort of static pointer to different
fields, you are going to want as few variances as possible. 

If they are required to be there to allow for common parsing, perhaps we can
use them for other purposes for message related TLVs. Might even allow for
zero length values fields if you can cram everything into those 16 bits.

Luke Klein-Berndt
NIST OLES
301-975-8021

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Ian Chakeres
Sent: Wednesday, December 14, 2005 10:47 AM
To: Dearlove, Christopher (UK)
Cc: [email-masked]
Subject: Re: [Manet-dt] Packet Format Document - index start/stop for
messagetlvs

Comments inline.

<snip>

> >I noticed the index-start and index-stop are always there even for
> >single index tlvs. For msg-tlvs these aren't really needed. What was
> >the motivation of always including these two fields?
>
> Common parsing logic.

I think we should discuss whether to include the start/stop for
message tlv. I'm not sure it is worth the 2 byte overhead for each
message-tlv. I'd like to discuss it.  I don't think it would impact
the parser logic very much either way.

Are you open to discussing it or do you feel strongly that the fields
should remain for message-tlvs?

Ian

_______________________________________________
Manet-dt mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet-dt

_______________________________________________
Manet-dt mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet-dt

---

From: Ian Chakeres <[email-masked]>
Date: Sat, 21 Jan 2006 13:34:37 -0800

Luke and I feel that msg-tlv should not have index start/stop, since
they are wasted bits.

Does anyone else have a opinion about whether these fields
should/shouldn't be included  in msg-tlv? Or an indication of how
these fields could be useful to msg-tlv?

Ian