Subject: RE: [Manet-dt] IANA Port & Multicast Addresses

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Thu, 29 Jun 2006 17:38:02 +0100

> We have been discussing this internally too. I think the
> question is, is it possible to have a node on a MANET
> link that is a neighbor of a MANET router but does not
> participate in the MANET routing protocol itself? If so,
> then it might make sense to have an "All MANET Nodes"
> multicast address that is different from "All MANET
> Routers". (And if not, why not?)

I would narrow this further to whether it is possible
using OLSRv2, DYMO or SMF as those are what we are
working on. If it turns out there's a later protocol
(e.g. an autoconf protocol) that this is relevant for
then we can add this later. Either IANA's multicast
addresses aren't running out, so we can wait, or they
are, so we really shouldn't take one we don't absolutely
need.

But ignoring all that and just trying to consider the
question, let's consider a node that is part of the
MANET in the sense that it's similarly wirelessly
equipped but won't participate in a protocol. Then
it will see some broadcast packets - in fact it will
see all of them if flooding is blind, and everyone
transmits every packet, but it won't (in general)
see all of them if flooding is optimised (MPR, CDS,
whatever). It's a definite step below e.g. OLSR
willingness zero nodes that (in OLSRv2, and slightly
simplifying) take part in the HELLO aspects of OLSRv2,
but not the TC aspects. But if the node refuses to
participate at all then the absolute best other nodes
can do is drop back to blind flooding, or else try
some sort of method to deduce such node's existence
based on something they do, which if it became reliable
I'd call participating in a protocol. Or at least that's
the best I can see.

I actually did consider such nodes in some theoretical
idea I played around with once, but there were two
points about that work: I didn't think that aspect of it
was a good idea, and it also was just that - theoretical.

********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************

_______________________________________________
Manet-dt mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet-dt

---

From: "Templin, Fred L" <[email-masked]>
Date: Thu, 29 Jun 2006 09:44:32 -0700

What about a theoretical node that would participate in the
neighbor discovery protocol on a MANET link but not the MANET
routing protocol? That node would be able to form bidirectional 
links with neighboring MANET routers, but all of the traffic
directed to it would have to go through a router. Should we
allow for such a possibility?

Fred
[email-masked]