Subject: Re: [Manet-dt] Review Request

From: Philippe Jacquet <[email-masked]>
Date: Tue, 03 Apr 2007 22:46:52 +0200

Hello,

About SMF, I am asking some questions for clarification

I don't understand very well the purpose of the protocol. Maybe this is 
because I don't have a clear view of its application context.

Is SMF intended to be the only routing protocol running in a network or 
will it run together with a unicast protocol?

Best regards,

Philippe

_______________________________________________
Manet-dt mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet-dt

---

From: "Justin Dean" <[email-masked]>
Date: Wed, 4 Apr 2007 13:08:57 -0400

SMF is designed such that is may run in a stand alone mode where only
multicast routing is required or it can be run alongside a unicast protocol
(either sharing information or not).  In the past there have been some
implementations of OLSR which allow for encapsulating packets and using the
s-mpr forwarding tree to disiminate the packets to all nodes in the network.
This solution works for some networks but was tied to the running of OLSR.
SMF takes away that requirement and allows for multicast routing which can
be independent of what unicast routing protocol may or may not be running on
the network.  

One application which may help understand the usage might be emergancy
response teams using wireless VIP to communicate with others who are close
without any specific need for point to point communication.

Justin

-----Original Message-----
From: Philippe Jacquet [mailto:[email-masked]] 
Sent: Tuesday, April 03, 2007 4:47 PM
Cc: 'manet'; [email-masked]
Subject: [manet] Re: [Manet-dt] Review Request

Hello,

Is SMF intended to be the only routing protocol running in a network or will
it run together with a unicast protocol?

Best regards,

Philippe

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Philippe Jacquet <[email-masked]>
Date: Thu, 05 Apr 2007 20:44:53 +0200

A network with never a call to unicast routing? Do you have an example 
of this?

Philippe

---

From: Brian Adamson <[email-masked]>
Date: Mon, 9 Apr 2007 14:10:47 -0400

I have had some experience with several different 
military systems that work sans unicast routing. 
These have included some multicast VoIP (imagine 
a multi-hop walkie-talkie network) along with 
some other low duty cycle applications (e.g. 
position reporting) that are group scope 
communication (serviceable by SMF) ... there are 
several cases like this where unicast routing 
(and its overhead) may be unnecessary, 
particularly in systems with more limited 
throughput than the wireless LAN link layer 
technologies we are used to playing with.

While in the past, these have been stand-alone 
networks, there is increased interest in 
inter-connecting these networks to backbone or 
infrastructure networks.  Some of these nets may 
be of limited capacity, etc and be dedicated to a 
small set of applications/services that are group 
communications only.   These application might 
tap into multicast data sources from the 
infrastructure/backbone networks and thus the IP 
is useful instead of some proprietary protocol 
suite.  The result may be an SMF edge network, 
multi-hop, but without unicast routing ... You 
might also imagine SMF co-existing with an 
on-demand unicast routing protocol that is used 
somewhat sparingly ... SMF would perform 
proactive neighborhood discovery to support S-MPR 
or whatever and the unicast routing would only be 
invoked upon demand

At 8:44 PM +0200 4/5/07, Philippe Jacquet wrote:
>A network with never a call to unicast routing? 
>Do you have an example of this?
>
>Philippe
>
>Justin Dean a écrit :
>>From: Philippe Jacquet 
>>[mailto:[email-masked]] Sent: 
>>Tuesday, April 03, 2007 4:47 PM

-- 
Brian

Brian Adamson
<[email-masked]>