Subject: RE: Call for Comments on Issues ID

From: Charles Perkins <[email-masked]>
Date: Thu, 5 Mar 1998 19:29:10 -0800 (PST)

I made an unfortunate typo:

> MADDRCONF or MADHCP have the appropriate first three initials.
> 
> If the addresses are assigned to facilitate renumbering, then
> movement will require address reassignment.  That's MAD.

I meant to say "facilitate aggregation".

Regards,
Charlie P.

---

From: Bora Akyol <[email-masked]>
Date: Thu, 5 Mar 1998 20:56:44 -0700

Is it possible to separate IP address used for routing from the functional
address of the computer. For example my computer can
always be called corrado.bbn.com BUT it can have a different IP address
based on where it is. This would be somewhat similar to the temporary
routing number used in GSM telephone systems. This way we can
still utilize addresses that uses aggregation and also keep an address/name
that does not change. I guess I am thinking of a much faster version of
Dynamic DNS.

Thanks for listening
Bora

----------
From: 	Charles Perkins
Sent: 	Thursday, March 05, 1998 9:45 AM
To: 	MANET
Cc: 	[email-masked]
Subject: 	RE: Call for Comments on Issues ID 

Erik, Chip,

> > More seriously, have we considered exactly how IP addresses
> > are expected to work in an ad-hoc network? Maybe we have,
> > and I'm just forgetting....
> > 
> > -- Chip
> 
> Unique numbering, which is used for addressing MANET hosts,
> seems to be critical to all the proposals.  When I have asked
> in the past, during WG meetings, where these numbers come
> from, the answer has been 'they are just there' - perhaps from
> a MAC address.  It seems like prenumbering is a requirement for 
> any MANET protocol.  Or would dynamic host configuration make 
> sense in an ad hoc protocol (MADHCP? Stateless MAADDRCONF?)

If the addresses are assigned randomly, then it might be very
hard to perform duplicate detection (DAD in ND).

If the addresses depend on the MAC address, then things are better
(assuming life in MAC World is better), and that's fine.

Let's just say the addresses are predefined.

Regards,
Charlie P.

---

From: Charles Perkins <[email-masked]>
Date: Thu, 5 Mar 1998 20:46:10 -0800 (PST)

Chip,

Note that these are just my answers, and other people
might desire to have different answers.

> 1. Do we expect the radio interface on a computer
>    (host/router) to have an IP address?

Yes -- but, let's just call it a wireless interface.

> 2. If so, isn't it true that this IP address is of the
>    form [network,host], with a mask that shows the
>    dividing line between these two portions?

Yes, sort-of, but ...

> 3. Isn't it true that all the computers on this radio
>    network must have the same network part, ie,
>    agree on [network,*] and mask?

No, because I claim that ad-hoc networking breaks the
subnet model into worthless little pieces.

> 4. Isn't it true that all the computers on this radio
>    network must have distinct host numbers, ie, each
>    have a unique value for [*,host]?

Sure!

> 5. Do all these people have to manually configure the
> radio IP addresses so this will work?

No.

> 6. Or is there some "missing piece" protocol that does
> this for them, ie, a MADARP or MADHCP equivalent?

No.

> 7. Or was this not really a goal, just a pleasant thought?

Here, I rely on my previous note.

> I know I'm beating a fairly dead horse, but I really
> do not understand if this group has a common opinion
> (and I'm the only one in the dark), or whether we all
> think manual configuration is the right answer, or we
> all acknowledge that there's a missing piece but consider
> it outside the scope of this group, or what.

I think that the ad-hoc nodes "inherit" an IP address from
the "real world", or from preconfiguration at the company
headquarters, or that they just have it by virtue of their
MAC address, but it's there.  However, once the infrastructure
is gone, the [network,*] is no longer relevant for routing
purposes.

Moreover, I hope this model is adopted as the sphere of
applicability of MANET protocol design, because otherwise
I think the problem is virtually unsolvable in our time.

But, I might be wrong!

Regards,
Charlie P.

---

From: Bora Akyol <[email-masked]>
Date: Fri, 6 Mar 1998 07:39:46 -0700

Yes

Routers can do the aggregation, but should we worry about scalability of
the addressing and routing tables. I know that we can do things like Mobile IP, but decoupling addressing from routing has its advantages such as smaller routing tables and faster routers. Having a directory service for temporarily assigned addresses and using a unique key will help this idea and will also allow functionality similar to anycast as an added bonus.

Comments anyone?

Bora

----------
From: 	Charles Perkins
Sent: 	Thursday, March 05, 1998 1:56 PM
To: 	[email-masked]
Subject: 	RE: Call for Comments on Issues ID 

Bora,

> that does not change. I guess I am thinking of a much faster version of

But why not keep using the same address, and just not have
the "routers" do any aggregation?

Regards,
Charlie P.

---

From: [email-masked] (Peter Sholander)
Date: Fri, 6 Mar 1998 15:56:30 -0700

Bora,

I like your notion of temporary addresses, but there seem to be practical
issues.  How does the computer know where it is ?  In cellular telephony
(or mobile IP) this occurs via a HLR/VLR (or HA/FA) pair, of course.  However,
do MANETs always have infrastructure connectivity, and hence access to a
HLR/VLR pair ?  If not then how does the computer obtain a temporary address
that is location-based ?  Is the temporary address GPS-based ?  Or ??

Regards,
Pete Sholander

Sandia National Labs
PO Box 5800, M/S 0449
Albuquerque, NM  87185-0449
USA

Email: [email-masked]
Voice: +1-505-284-4101
Fax:   +1-505-844-9641

> From [email-masked] Thu Mar  5 22:17 MST 1998
> From: Bora Akyol <[email-masked]>
> To: MANET <[email-masked]>,
>         "'Charles Perkins'"
> 	 <[email-masked]>
> Cc: "[email-masked]" <[email-masked]>

---

From: Bora Akyol <[email-masked]>
Date: Fri, 6 Mar 1998 23:10:02 -0500

The idea is that the temporary address is assigned through a MADHCP process
and
the newly assigned address is reported to a distributed directory service
from which the
interested parties can obtain routing and temporary address information. If
there is a MANET
gateway to the net in contact then the gatewat may assign the address
otherwise the hosts can decide on any address themselves like AppleTalk. If
there are multiple GWs, then a slave/master server
scheme can be used.

Since there was no gateway in their network then the inability to update the
distributed directory service
in the latter case does not matter.

I should write a flow diagram for this and email it to the list.

Bora Akyol

BBN Technologies

-----Original Message-----
From: Peter Sholander <[email-masked]>
To: [email-masked] <[email-masked]>; [email-masked]
<[email-masked]>
Date: Friday, March 06, 1998 6:32 PM
Subject: RE: Call for Comments on Issues ID