Subject: Re: Hand Configuration of Ad Hoc Nets?

From: Erik Guttman <[email-masked]>
Date: Mon, 9 Mar 1998 07:08:31 -0800 (PST)

Charlie wrote:

> I just don't see you can justify it in the general case, which
> would basically require a new DAD for every node in the system
> every time a new link gets established.

So you are claiming that either

 1. Every node is preconfigured with an address
 2. Every node is configured with an address in a fixed network
    before entering an ad hoc network
 3. Constant DAD is necessary in the DAD to 'defend addresses.'
 
What if you took an optimistic approach, like Appletalk, and simply
took an address and then defended it as needed.  You would do DAD
initially and possibly periodically *AND* cleverly if there were 
inconsistencies discovered.  

> My note
> was intended to suggest that we focus on topology maintenance
> _separate_ from address assignment.  I really think it's the only
> approach that makes sense in 1998.
>

Say I am a router and I discover two 'different' routes to the same
address.  In the AODV sense, these would be inconsistent source sequence
numbers.  In the TORA sense, this would involve different temporal
values.  In the DSR sense, this would be hard, perhaps...  Anyway,
if there was something fishy, you could initiate DAD at that point.
This is not a worked out suggestion, just an intuition that you might
combine the routing with DAD in a clever way so as to not be stuck
with 1 or 2 above.

This does add a lot of DAD overhead to the system, however. 

Erik

---

From: "Miguel Sanchez" <[email-masked]>
Date: Mon, 9 Mar 1998 21:21:06 -0000

Hi everybody,

I also have the impression, like some of you, that the ad-hoc network basic goal is to solve the routing problem in a network not connected to the internet. And the likely second goal, to glue it to the internet. 

However I missed all your meetings and this is only a personal impression. But, in fact, it reflects my way of thinking on this networks. Most of the applications I think of, are first of all, related to the ad-hoc networking, that, in a second place would also benefit from being connected to internet. (Please remember that military applications are so sensitive to so many factors that could get a direct pipe to the ad-hoc network instead of using others countries internet infrastructure).

If we agree that internet connection is an "a posteriori" item, we can concentrate on the configuration issue. I  think that afirmations like "this is a trivial issue" can led us to a poor solution. I recall you that manet proposal talks about hundreds of nodes (routers) not 10.000 or 100.000). 

Automatic assignment of addresses could be implemented either by a central location or in a distributed way. Preconfigured adresses could be based on data-link addresses (or other manufacturer serial number) that would be different (or inexistent) from one technology to other. Therefore, this latter mecanism is not applicable (if you want to maintain independence of data link level).

Implementing an automatic assignment of addresses based on a central location seems to me a risky approach (it is a single point of failure). But a distributed configuration is difficult to implement :-(

As you see I stalled. I think automatic configuration would be useful, but ... Is this really a goal we must deal with or not? Perhaphs we are trying to solve too much problems (some of them away of the manet group) ...

For the moment, I will think that addresses have been pre-assigned (but I do not know how).

Sorry about the length of the message. 

Regards,

Miguel Sanchez
Universidad Politecnica de Valencia (SPAIN)

---

From: Walt Lazear <[email-masked]>
Date: Mon, 16 Mar 1998 08:31:47 -0500

Chip,
	Thanks for the reply.  I may have misled you about how I
use OSPF.  The environment I was aiming for was Army tactical
operations centers (TOCs) interconnected with radios (NTDR's,
in the latest exercise).  They run OSPF on the TOC internal LANs,
but BGP over the radio net.  And the number of TOCs on the
radio net would be limited to perhaps two dozen, if even that
many.  In this environment, the bridged ethernet is really a WAN.
I've heard that BBN is aiming for many hundreds of NTDR radios
on a single net and that is not my environment.

At 05:25 PM 3/13/98 -0500, Chip Elliott wrote:
>At 12:48 PM 3/13/98 -0500, Walt Lazear wrote:
>>The approach I've taken in a research project to create self-configuring
>>routers is to treat the radio medium as a broadcast ethernet.  That is,
>>the radios play their own game to create the illusion of a single
>>broadcast realm and they heal partitions and do any link-level
>>relaying that is required to maintain this illusion.  This let
>>me use DHCP to provision addresses for the routers.  It also let
>>me use Router Discovery (with a slight addition of an AS number)
>>to discover my BGP neighbors dynamically.  Tie this with OSPF
>>locally and you get flow-through AS's dynamically configured.
>>It's working in our lab now, but with LANs instead of radios.
>
>Walt,
>
>Just another data point, but various of the BBN projects take
>the same general approach. That is, we like to treat the radio
>level like a bridged Ethernet, so a packet takes just one IP
>hop to get across the entire ad hoc network, no matter how many
>radio hops.
>
>It seems to me that there are, however, two general minuses
>to this approach:
>
>1. The standard Internet routing protocols scale extremely poorly
>on a single big Ethernet. OSPF is by far the worst miscreant. Our NTDR
>setup calls for 400-1,000 OSPF routers on the ad hoc network (ie, each
>is doing IP level forwarding between its attached Ethernet and
>serial ports and ad hoc network). Since OSPF traffic grows
>O(n**3), it just isn't feasible to use standard OSPF on the
>radio net if you treat it as one big Ethernet.
>

As mentioned above, I was not trying to use LAN-oriented protocols
such as OSPF on the WAN radio net.  My treatment was to use the
radio net as a WAN interconnection between TOCs. 

>2. Furthermore, as the MANET group has said, it is very nice
>to be able to do radio routing across a number of different
>radio / infrared / etc. technologies. In general, these may need
>to use radically different subnet protocols. So we seem to have
>agreed on the idea that routing should be done at the IP layer,
>at least within the context of the MANET group.
>

Routing at the IP layer is exactly where I do it (OSPF locally,
BGP remotely).  This allows my dynamic address assignment and
neighbor discover to work over a radio net as well as over the
Army's future version of an ATM net (fronted by router and
ethernet edges).

One of the subtleties in my design is that there is no Autonomous
System associated with the radio net.  That is, the previous style
of radio router had some interior protocol (RIP or OSPF) as its
only interface to the world outside the radio net.  The router also
spoke an interior protocol across the net.  Thus, one way to
design this into a larger internet was to place another router
between the subscriber LAN and the radio router and make this
new router the "edge" of the radio net's AS.  This router would
speak BGP to outsiders and the interior protocol to the radio router.
Then there was a third router for the edge of the TOC.  Thus, it took 
three routers to interface the TOC and the radio net.

In my design, the radio router speaks OSPF to the TOC and BGP to
other radio routers at other TOCs.  One router takes the place
of three (and reduces care and feeding chores). How the radios 
interconnect and chatter to build and retain the subnet is up to 
the radio designer...the illusion is that of a bridged ethernet to the
routers.  As with your NTDR design, it is but one IP hop to any
neighbor.

>Needless to say, I think that doing ad hoc routing down at
>the subnet layer (a la Ethernet bridges) has more good points
>than bad points. But reasonable people can disagree, right?
>

No disagreement there!

	Walt

>Cheers,
>-- Chip