Subject: Re: implementation of Adhoc Networks

From: Chai Keong Toh <[email-masked]>
Date: Tue, 02 Nov 1999 15:47:54 -0500

Sorry for the typo error. The correct one is:

www.ece.gatech.edu/~cktoh/ad.html

C-K.

Josephson, William wrote:
> 
> Thanks for the info.
> 
> My browser is unable to find the server http://www.ece.gatech.edy
> or the address http://www.ece.gatech.edy/~cktoh/ad.html.
> 
> Thank you
> 
> Bill Josephson
> 
> -----Original Message-----
> From: Chai Keong Toh [mailto:[email-masked]]
> Sent: Tuesday, November 02, 1999 2:30 PM
> To: Josephson, William
> Cc: 'Sulabh Agarwal'; [email-masked]; 'John Zavgren'
> Subject: Re: implementation of Adhoc Networks
> 
> Hi,
> 
> We have a working testbed of ABR at GTech in our laboratory.
> Hello,
> 
> Our implementation is on a Linux platform.
> 
> We have performed field trials and a couple of experiments.
> Please see: www.ece.gatech.edy/~cktoh/ad.html
> 
> Publications/papers will be available soon.
> 
> C-K. Toh
> ===============================
> Josephson, William wrote:
> >
> > Sulabh,
> >
> > Yes I am right now attempting to simulate a wireless network on an
> > Ethernet.  I am using Linux and I just started.
> >
> > Here's an abstract I've sent to a conference:
> >
> > -----Original Message-----
> > From: Sulabh Agarwal [mailto:[email-masked]]
> > Sent: Tuesday, November 02, 1999 12:38 AM
> > To: [email-masked]
> > Subject: implementation of Adhoc Networks
> >
> > Hi,
> >         I'm trying to build a Linux Based implementation of adhoc
> > networks, which can be used as a test bed for testing various routing
> > protocols in a real life scenario. I wanted to know whether somebody else
> > has done or is doing any work similar to this. If so please let me know as
> > it would be of immense help to me. Waiting eagerly for a response.
> >         Thanx.
> >
> > With Regards,
> > _Sulabh
> > Agarwal________________________________________________________________
> >
> > Student, IIT Delhi.                             C-25, Nilgiri Hostel.
> >
> > B.Tech (final yr.), Comp. Sc. & Engg.           Ph.  Ext.:
> > (011)6521278,6968829.
> > Email: [email-masked]                 Int. : 8319
> >
> ____________________________________________________________________________
> > ___
> >         If you're not living life on the edge, you're wasting space.
> >
> ____________________________________________________________________________
> > ___
> >
> >     ---------------------------------------------------------------
> >
> >                              Name: SimAbstractOutline.doc
> >                Part 1.2      Type: application/msword
> >                          Encoding: base64
> 
> --
> Prof. C-K. Toh, PhD, CEng
> Director, Mobile Multimedia & HiSpeed Network Lab,
> School of Electrical and Computer Engineering
> Georgia Institute of Technology, Atlanta, Georgia
> GA 30332, USA. Fax: 404 894 7883 Tel: 404 894 7468
> --------------------------------------------------

-- 
Prof. C-K. Toh, PhD, CEng
Director, Mobile Multimedia & HiSpeed Network Lab, 
School of Electrical and Computer Engineering
Georgia Institute of Technology, Atlanta, Georgia
GA 30332, USA. Fax: 404 894 7883 Tel: 404 894 7468 
--------------------------------------------------

---

From: Lusheng Ji <[email-masked]>
Date: Tue, 2 Nov 1999 17:22:19 -0500 (EST)

hi, another testbed implementation for your info.  already done at Maryland.  
we did it on Linux 2.1 kernel.  the testbed contains the IMEP, TORA, and LAM 
unicast/multicast routing stack.  firstly demonstrated in ATIRP conference 
(College Park, 02/99).  the report was published at the IEEE WCNC99 
conference (New Orleans, 09/99).

---

From: "Josephson, William" <[email-masked]>
Date: Tue, 02 Nov 1999 17:37:31 -0500

My work is different than yours in that I am attempting to simulate wireless
networks on wired LANs.  The benefit, I see that one would not need to
retrofit a large number of computer resources with 802.11 adapters.  Also
the mobility would be simulated rather than performed with the mobile nodes.
Also, experiments with non-standard MAC protocols could be performed. I
think my work may be similiar, or even the same as that performed by BBNT.
They
have performed wireless network simulation on an Ethernet with SCO UNIX.

Dr. Toh, I apologize for any confusion I may have caused about the html
references.
I entered http//www.ece.gatech.edy/~cktoh/ad.html the first time.  For some
reason
www.ece.gatech.edy/~cktoh/ad.hmtl works fine.

Thanks

Bill

-----Original Message-----
From: Chai Keong Toh [mailto:[email-masked]]
Sent: Tuesday, November 02, 1999 2:30 PM
To: Josephson, William
Cc: 'Sulabh Agarwal'; [email-masked]; 'John Zavgren'
Subject: Re: implementation of Adhoc Networks

Hi,

C-K. Toh

---

From: Chip Elliott <[email-masked]>
Date: Wed, 03 Nov 1999 16:58:23 -0500

Howdy,

That's correct about the BBN work with ad hoc network
simulations on an Ethernet. We have about 100 PCs on a few
Ethernet segments; each PC can in theory emulate up to 4
actual routers (though we've only done 1 router per PC so far).

This testbed uses live routing / forwarding code --
ie, the PCs are "real" routers. Similarly each PC acts as
a traffic source and/or sink, with statistics collection in
each. We add a "shim" to the Ethernet driver to make the
Ethernet have characteristics resembling the actual radio
channel (hidden terminals, spatial reuse, etc).

This testbed has been used extensively for 3 or 4 years
in developing and shaking down the NTDR protocols. We're
also planning on using it in the DARPA SUO program.

One key advantage of this approach is that one can run
repeatable experiments, varying only one parameter at a time.
For instance, we can run a set mobility / traffic script with
various versions of the routing protocols and see how the
performance changes (quantitatively) with the different protocols.
That's hard to do with a large number of real radios.

Cheers,

-- Chip