Subject: RE: FW: Geo-routing & radio

From: "Spector, Andrew L" <[email-masked]>
Date: Thu, 16 Nov 2000 12:28:40 -0800

I think that GPS-based ADDRESSING (vice routing) was intended to add value
as follows.

The Internet attachment point, ie. the sacrosanct IP address would be
location based.  That would add value in the form of (a) public safety and
(b) location-specific applications.

You'd have to consult RFP 2009 to see what the intention was.  I recall the
flavor was more addressing with routing an issue.  That's to say the
terrestrial/fixed routers were infrastructure.

a.

-----Original Message-----
From: Chip Elliott [mailto:[email-masked]]
Sent: Thursday, November 16, 2000 11:57 AM
To: Joe Macker; Li Li; [email-masked]'
Subject: Re: FW: Geo-routing & radio

Joe,

Amen brother.

One example I've always given in the halls:

* When I call California, my call does not proceed hop by hop,
  switch by switch, always in the general direction of
  California!

Instead the phone system is arranged as a hierarchy of
access networks that lead into long-haul links, etc.
Real IP networks are built in a similar fashion.

Obviously, there's a strong desire to reduce the network
diameter by introducing "long lines" & hierarchy.

These examples are very apropos when one starts
thinking of building very large ad hoc networks.

Cheers,

Chip

---

From: "Li Li" <[email-masked]>
Date: Thu, 16 Nov 2000 16:51:25 -0500

Hi Dave,

I agree with what you said. We should be careful when we cite simulation
results. The real support should come from real test-bed or real deployment
in real application scenarios. Are there any work on evaluating geographic
and/or non-geographic ad-hoc routing in a real setting?

Li

> Doing geographic routing in an ad hoc network is a very different
> question.  I think it can sometimes help, but you have to be
> very careful in interpreting simulation results of such ideas,
> since the simulation scenarios may not accurately reflect the
> RF propagation problems that would be encountered in real life.
> The simulation performance comparison between LAR and DSR, mentioned
> earlier, is an example of this.  I think LAR may be a very good
> idea sometimes, but I don't think the published simulations
> necessarily do support or don't support that.
>
> Dave
>
> --
> David B. Johnson, Associate Professor
> of Computer Science and Electrical and Computer Engineering
>
> Department of Computer Science - MS 132    [email-masked]
> Rice University                            http://www.cs.rice.edu/~dbj/
> 6100 Main Street                           Phone: (713) 348-3063
> Houston, Texas 77005-1892 USA              Fax:   (713) 348-5930
>
>
>
>
> >You'd have to consult RFP 2009 to see what the intention was.  I recall
th
> e

---

From: Dave Johnson <[email-masked]>
Date: Thu, 16 Nov 2000 15:39:50 -0600

The Rutgers work was in "geocasting", which is similar to
multicasting or broadcasting, but delivers a message to everyone
within a geographic area.  The "destination address" is really a
geometric description of the geographic area intended.  Their
work was in a traditional Internet context and used a mostly
conventional routing protocol, if I remember correctly, to have
routers exchange information on the geometric constraints of the
geographic areas reachable through them "downstream" over each
link to a neighbor router.  The work was thus not subject to
problems of RF propagation being different from geographic
distance and direction, since it used the Internet to deliver
the packets to all routers in the intended area.

					Dave