Subject: Re: FW: Geo-routing & radio

From: Joe Macker <[email-masked]>
Date: Thu, 16 Nov 2000 13:37:13 -0500

At 12:26 PM 11/16/00 -0500, Li Li wrote:

>-----Original Message-----
>From: Chip Elliott [mailto:[email-masked]]
>Sent: Thursday, November 16, 2000 11:59 AM
>To: Li Li
>Subject: Geo-routing & radio
>
>
> >
> >It seems to me if GPS is available. Routing algorithm that exploit GPS
> >should be used (the one you cited here) instead of using AODV which is
>not
> >designed explicitly with GPS in mind. Protocols like DREAM, LAR and
>GPSR
> >will perform better if GPS is available.  The evaluation of GPSR vs.
>DSR in
> >the GPSR papers show this. Any counter arguements?
> >
>
>Li,
>
>The basic problem with geo-routing schemes is that
>geographic proximity is often not a good predictor
>of RF pathloss.
>
>This is especially true in "urban canyons",
>within buildings, etc, but is also true in the
>great outdoors. Often these RF propagation maps
>look like someone sneezed on a map.
>
>Thus the "shortest path" between two RF network nodes
>may well look nothing like a geographic great circle.
>
>In addition, of course, if the routing is in
>any way load- or RF-dependent (eg tries to route
>around interference), geographic routing must be
>augmented or supplemented by these additional
>criteria.
>
>For an experiment, I'm trying to attach a fairly
>realistic pathloss map (jpeg) that I found on the web.
>It's at: http://www.qsl.net/fara/dxcluster/propo/overview2.html.
>This particular model employs a Longley-Rice propagation model
>that factors in terrain, the antenna pattern, propagation
>loss at the designated frequency, receive sensitivity,
>transmit ERP, receiver antenna height, and transmit antenna height.
>
>Best wishes,
>
>Chip Elliott
>Principal Engineer
>Mobile Networks, BBN

Li:

Chip makes some good points..
A few other  considerations for added 2 cents.

(1) some heterogeneous routed networks (e.g., combination of satellite 
..(one hop can connect widely disperse parts of the internetwork) in 
combination with more homogeneous LOS link technologies) can make 
geo-routing questionable ... when I think IP routing I always think 
heterogeneity.

(2) the geographic scale of many networks that are envisionable may make 
the GPS data meaningless or even highly incorrect. (a) multi-device home 
networks with RF power control (b) intrabuilding with multiple floors etc 
... I doubt I'm even getting a GPS fix in many cases here  ...... I can't 
get fixes in a few of my office building room at this very minute (c) 
networks with non-geographically balanced topologies .. lots of these in 
existence (d) spaceborne networks .. ray bradbury likes these ;-)

....... so pragmatically I think there are some serious issues with your 
statements ... sometimes it might be a useful metric given the right 
conditions and architecture assumptions, but I don't believe this is in any 
way generalizable or should be a requirement.

Cheers,
-Joe

---

From: Chip Elliott <[email-masked]>
Date: Thu, 16 Nov 2000 14:56:41 -0500

Joe,

Amen brother.

One example I've always given in the halls:

* When I call California, my call does not proceed hop by hop,
  switch by switch, always in the general direction of
  California!

Instead the phone system is arranged as a hierarchy of
access networks that lead into long-haul links, etc.
Real IP networks are built in a similar fashion.

Obviously, there's a strong desire to reduce the network
diameter by introducing "long lines" & hierarchy.

These examples are very apropos when one starts
thinking of building very large ad hoc networks.

Cheers,

Chip