Subject: Re: AODV HELLO PACKET TRADEOFF

From: "Rajan, Hridesh (Hridesh)" <[email-masked]>
Date: Thu, 16 Nov 2000 15:59:25 +0530

Hello,
Sorry for taking up this conversation after a long time. Actually I was away
on  vacation.
--- "Charles E. Perkins" <[email-masked]> wrote:
> 
> Hello Hridesh,
> 
> > The message complexity required for local
> connectivity
> > can be adjusted according to mobilty.
> 
> Does this mean "message frequency"?
> 

Yes, just like algorithmic complexity, this term can be used for evaluating
algorithms exchanging
messages.

> How can a node tell if it is moving fast or slow?
> 

It can use a system like GPS. Some algorithms have been proposed using this
concept. I am citing two here. 

Stefano Basagni et. al. A Distance Routing Effect Algorithm for Mobility, In
proc. ACM/IEEE MobiCom
pp. 76-84, oct. 1998

Jinyang Li, John Jannotti, Douglas S. J. De Couto, David R. Karger, and
Robert Morris, A Scalable Location
Service for Geographic Ad Hoc Routing,In the Proceedings of the 6th ACM
International Conference on Mobile 
computing and Networking (MobiCom '00), Boston, Massachusetts, August 2000,
pages 120-130. 

> >                                          Let us
> assume
> > that there are nodes which do not change position
> over
> > 
> > time. In that case it will be wastage to
> continuously
> > send location updates in the form of Hello
> packets. It
> > will also be a good idea to restrict hello packets
> > propogation on the basis of the information of
> > position change in it.
> 
> What does it mean, "hello packets propagation"?
> Aren't hello messages, when transmitted for the
> purpose
> of neighborhood detection, discarded after
> processing
> (i.e., not forwarded)?
> 

Packets are discarded but the information they disseminate propagate. This
information propagation can be 
restricted on the basis of their relevance to the node to which it is
forwarded. Like say there is a path 
from 2-8 (2,3,5,7,8)which as a result of the movement of the node 8
transforms to (2,3,5,8). In this case 
there is no need to propagate this information beyond 5.

> > Mobility can also affect the duration of validity
> of
> > a routing entry.It can be safely assumed that if
> there
> > is no movement there is no need to send routing
> > updates, because the old path is still valid.
> Further
> > the Hello packets will be minimal in the case of
> ON
> > DEMAND routing when there are a few packets to be
> sent
> > after a long interval.
> 
> But a node cannot tell if it has moved or not,
> especially in relation to its neighbors, without
> some signal that can be used for detection.

There is no need to tell whether it has moved relative to its neighbors.
Knowledge of its' own movement
through GPS is sufficient to trigger routing updates i.e. the hello packets.

> And, I'm not sure how your last statement follows
> from the previous ideas.

It didn't followed from the previous ideas, just a slip of thought, please
ignore it.

> Regards,
> Charlie P.

Please correct me wherever I have drifted away from the main line of
discussion.

Regards,
Hridesh

---

From: "Li Li" <[email-masked]>
Date: Thu, 16 Nov 2000 11:11:08 -0500

> computing and Networking (MobiCom '00), Boston, Massachusetts, August
2000,

It seems to me if GPS is available. Routing algorithm that exploit GPS
should be used (the one you cited here) instead of using AODV which is not
designed explicitly with GPS in mind. Protocols like DREAM, LAR and GPSR
will perform better if GPS is available.  The evaluation of GPSR vs. DSR in
the GPSR papers show this. Any counter arguements?

Li