Subject: RE: Geo-Routing & Radio

From: "Spector, Andrew L" <[email-masked]>
Date: Thu, 16 Nov 2000 10:18:23 -0800

Two thoughts.

1.  Dr. Tomasz Imielinski (and Julio Navas) at Rutgers
(http://www.winlab.rutgers.edu/pub/Index.html) were doing landmark work on
GPS routing.  I believe they had a project to experiment on the Rutgers
campus with GPS-based routing.  They also published an interesting
research/experimental RFC-2009 on the subject.  They would be a good place
to pick up the trail.  SAIC has had a lot of involvement in GPS from many
perspectives but I don't believe GPS-based routing is one of them.  Ron
Rahmel has recently been involved in a leading edge GPS application and
could be a resource on that.

2.  We have been doing work for DARPA in characterization of paths and
channels through actual measurements resulting in the "impulse response" of
a given path and channel.  There's also been some comparison done with
respected/classic propagation models.  Dr. Gerry Gerace is the project
manager on the propagation work and would be our person to touch on that
issue.

regards.

ANDREW L. SPECTOR
Chief Engineer - C3AIT Group
Science Applications International Corp.

858-826-5335
858-826-3103 FAX (New FAX number)
mailto:[email-masked]

-----Original Message-----
From: Li Li [mailto:[email-masked]]
Sent: Thursday, November 16, 2000 9:26 AM
To: [email-masked]'
Subject: FW: Geo-routing & radio

-----Original Message-----
From: Chip Elliott [mailto:[email-masked]]
Sent: Thursday, November 16, 2000 11:59 AM
To: Li Li
Subject: Geo-routing & radio
>
>It seems to me if GPS is available. Routing algorithm that exploit GPS
>should be used (the one you cited here) instead of using AODV which is
not
>designed explicitly with GPS in mind. Protocols like DREAM, LAR and
GPSR
>will perform better if GPS is available.  The evaluation of GPSR vs.
DSR in
>the GPSR papers show this. Any counter arguements?

Li,

The basic problem with geo-routing schemes is that
geographic proximity is often not a good predictor
of RF pathloss.

This is especially true in "urban canyons",
within buildings, etc, but is also true in the
great outdoors. Often these RF propagation maps
look like someone sneezed on a map.

Thus the "shortest path" between two RF network nodes
may well look nothing like a geographic great circle.

In addition, of course, if the routing is in
any way load- or RF-dependent (eg tries to route
around interference), geographic routing must be
augmented or supplemented by these additional
criteria.

For an experiment, I'm trying to attach a fairly
realistic pathloss map (jpeg) that I found on the web.
It's at: http://www.qsl.net/fara/dxcluster/propo/overview2.html.
This particular model employs a Longley-Rice propagation model
that factors in terrain, the antenna pattern, propagation
loss at the designated frequency, receive sensitivity,
transmit ERP, receiver antenna height, and transmit antenna height.

Best wishes,

Chip Elliott
Principal Engineer
Mobile Networks, BBN

 << File: map2b.jpg >>

---

From: Li Li <[email-masked]>
Date: Thu, 16 Nov 2000 12:26:26 -0500

-----Original Message-----
From: Chip Elliott [mailto:[email-masked]]
Sent: Thursday, November 16, 2000 11:59 AM
To: Li Li
Subject: Geo-routing & radio

not
GPSR
DSR in

Li,

Best wishes,

Chip Elliott
Principal Engineer
Mobile Networks, BBN

---

From: "Spector, Andrew L" <[email-masked]>
Date: Thu, 16 Nov 2000 13:46:33 -0800

Dave.  

I think our recollections of the RFC-2009 stuff are congruent.

Our modeling and propagation work are synergistic so I think we may be able
to add value to net simulations in this regard.

a.

-----Original Message-----
From: Dave Johnson [mailto:[email-masked]]
Sent: Thursday, November 16, 2000 1:40 PM
To: Spector, Andrew L
Cc: 'Chip Elliott'; Joe Macker; Li Li; [email-masked]'
Subject: Re: FW: Geo-routing & radio

The Rutgers work was in "geocasting", which is similar to
multicasting or broadcasting, but delivers a message to everyone
within a geographic area.  The "destination address" is really a
geometric description of the geographic area intended.  Their
work was in a traditional Internet context and used a mostly
conventional routing protocol, if I remember correctly, to have
routers exchange information on the geometric constraints of the
geographic areas reachable through them "downstream" over each
link to a neighbor router.  The work was thus not subject to
problems of RF propagation being different from geographic
distance and direction, since it used the Internet to deliver
the packets to all routers in the intended area.

Doing geographic routing in an ad hoc network is a very different
question.  I think it can sometimes help, but you have to be
very careful in interpreting simulation results of such ideas,
since the simulation scenarios may not accurately reflect the
RF propagation problems that would be encountered in real life.
The simulation performance comparison between LAR and DSR, mentioned
earlier, is an example of this.  I think LAR may be a very good
idea sometimes, but I don't think the published simulations
necessarily do support or don't support that.

					Dave

--
David B. Johnson, Associate Professor
of Computer Science and Electrical and Computer Engineering

Department of Computer Science - MS 132    [email-masked]
Rice University                            http://www.cs.rice.edu/~dbj/
6100 Main Street                           Phone: (713) 348-3063
Houston, Texas 77005-1892 USA              Fax:   (713) 348-5930

>I think that GPS-based ADDRESSING (vice routing) was intended to add value
>as follows.
>
>The Internet attachment point, ie. the sacrosanct IP address would be
>location based.  That would add value in the form of (a) public safety and
>(b) location-specific applications.
>
>You'd have to consult RFP 2009 to see what the intention was.  I recall th
e
>flavor was more addressing with routing an issue.  That's to say the
>terrestrial/fixed routers were infrastructure.
>
>a.
>
>From: Chip Elliott [mailto:[email-masked]]
>Sent: Thursday, November 16, 2000 11:57 AM
>To: Joe Macker; Li Li; [email-masked]'
>Subject: Re: FW: Geo-routing & radio
>
>Joe,
>
>Amen brother.
>
>One example I've always given in the halls:
>
>* When I call California, my call does not proceed hop by hop,
>  switch by switch, always in the general direction of
>  California!
>
>Instead the phone system is arranged as a hierarchy of
>access networks that lead into long-haul links, etc.
>Real IP networks are built in a similar fashion.
>
>Obviously, there's a strong desire to reduce the network
>diameter by introducing "long lines" & hierarchy.
>
>These examples are very apropos when one starts
>thinking of building very large ad hoc networks.
>
>Cheers,
>
>Chip