Subject: Need help for installing CMU simulator

From: "wooighee" <[email-masked]>
Date: Mon, 15 Jan 2001 18:00:58 +0900

Hello

 I am trying to install the ad-hockey simulator in this page:
http://www.monarch.cs.cmu.edu/cmu-ns.html

I have downloaded and unpacked the file in the following directory:

------------------------------------------------------
ghee@zambezi(107)% ls
README      ad-hockey/  cmu-docs/   install*
ns-2/       otcl/       tclbox/     tkbox/
TclCL/      bin/        gt-itm/     nam-1/
ns-src/     tcl8.0/     tk8.0/      xgraph/
------------------------------------------------------

But when I tried to install the simulator, I got the fialed message:

--------------------------------------------------------
ghee@zambezi% ./install
:

lib -L../tkbox/lib -ltk8.0 -R../tclbox/lib -L../tclbox/lib -ltcl8.0 -R/usr/o
penwin/lib -L/usr/openwin/lib -lXext -lX11 -lsocket -lnsl -ldl -ldl -lm -ldl
ld: Warning: File ../TclCL/libtclcl.a : is ignored : cannot allocate archive
simbol table
ld: Fatal Error: Library -ltclcl: cannot find
ld: Warning: File../otcl/libotcl.a : is ignored : cannot allocate archive
simbol table
ld: Fatal Error: Library -lotcl: cannot find
ld: Warning: File../tkbox/lib/libtk8.0.a : is ignored : cannot allocate
archive simbol table
ld: Warning: File../tclbox/lib/libtcl8.0.a : is ignored : cannot allocate
archive simbol table
ld: Fatal error: File processing errors. No output written to ns
make: *** [ns] Error 1
Ns make failed! Exiting ...
ghee@zambezi%
----------------------------------------------------------------------------

The installation stopped at this error message:

If you have any idea please kindly indicate me.
Thank you very much.

Regards
Ghee
-------------------------------------------------------------------

---

From: "S.M.Tripathi" <[email-masked]>
Date: Mon, 15 Jan 2001 22:11:47 +0530 (IST)

See the mailing list [email-masked]. There you will be able to get lot
more stuff. Also try on fro ns2 at the www.isi.edu.

Shailendra