Subject: research topics

From: Robin Poss <[email-masked]>
Date: Thu, 18 Jan 2001 12:37:48 -0800 (PST)

Maybe these proposals will be inappropriate on this
list, sorry in advance if this is the case.

Maybe they have already been discussed over and over,
sorry again.

First idea:
-----------
How about implementing power control at every mobile
node in an ad-hoc network, in order to keep the number
of neighbors known to this node inferior to a certain
number n, chosen cleverly to achieve reasonable
coverage nonetheless? Maybe this could reduce power
consumption and/or overhead, and reduce it enough to
be worth the corresponding coverage loss.

Second idea:
-------------
How about a "dual" mobile phone, able to switch
between a normal cellphone mode and an ad-hoc mode,
the decision to swich being based, for example, on
maximizing battery life, or minimizing bandwidth
usage? In ad-hoc mode, the phone would use a chain of
other phones not to reach the party called, but to
reach the nearest (or otherwise clerverly chosen) base
station.

Maybe the overhead won't be that bad in this case
since all the phones of a region will try to reach the
same base station.

Natural human selfishness hinders the development of
ad-hoc phones:"Why should my battery power enable
conversations between strangers?"
Switching to ad-hoc mode when doing so saves battery
power (if such a thing is possible) would reverse this
situation and put selfishness on our side.

Of course the hand off decision making and procedure
will get very complicated.

Maybe there are some situations where functioning in
ad-hoc mode would actually reduce the phone's emitting
power [compared to normal cell-phone mode], which is a
good marketing argument for the brain tumor concerned
general public.

And maybe the telecommunication industry would be more
willing to subsidize research in this domain, since
their base stations/infrastructure/services are still
used, so they still can make some money out of it.

There is also a possibility that in crowded areas some
base stations would become useless, the mesh of ad-hoc
enabled phones doing all the work cheaper than they
would. It's a kind of paradox: less base stations
needed in the more crowded areas.

Pushing the concept further the phone could choose
between 3 modes:
**Fully cell-phone
**ad-hoc to reach the nearest base station
**completely ad-hoc (and free, unlimited connection
time in this version)

Such a phone with these 3 options could be targeted
and sold to communities where people usually have a
cell phone anyway, and ususally call parties who are
not too far away:
*University and Company Campuses
*Families
*Ski resorts
...
This would be attractive for them since most of the
communications would be free. Imagine talking to a
friend over the phone: 83% of the last sentence you
said was transmitted in full ad-hoc mode,5 % in semi
ad-hoc mode, and the rest in normal cellphone mode.
Verizon will only bill you for 17% of this sentence. 

I was told that Nextel already offers a phone which
can be used as a talkie-walkie. This is a first step.
I think "3G TR 25.924 ,Opportunity Driven Multiple
Access" deals with a similar idea.

--
Robin

__________________________________________________
Do You Yahoo!?
Get email at your own domain with Yahoo! Mail. 
http://personal.mail.yahoo.com/

---

From: Ram Ramanathan <[email-masked]>
Date: Thu, 18 Jan 2001 18:05:15 -0500

> Date: Thu, 18 Jan 2001 12:37:48 -0800 (PST)
> From: Robin Poss <[email-masked]>
> Subject: research topics
> To: [email-masked]
> MIME-Version: 1.0
> Content-Type: text/plain; charset=us-ascii
> Sender: [email-masked]
> Precedence: bulk
> 

Good topic. BBN has done some work on this idea. Look at

R. Ramanathan and R. Hain "Topology control using transmit power
adjustment" Proc. IEEE Infocom, 2000 (Tel Aviv)

Or for the larger project of which this is a part, look at
www.ir.bbn.com/projects/dawn/dawn-index.html (badly needs to be
brought up to date, so contact me for details if interested).

This is only the tip of the proverbial iceberg.  There's lots more 
juicy research that can be done in this area.

-Ram.

---

From: Zygmunt Haas <[email-masked]>
Date: Thu, 18 Jan 2001 19:35:19 -0500 (EST)

Hi,

> > First idea:

Take a look at the following work:

M. Sanches, P. Manzoni, and Z.J. Haas, "Determination of Critical
Transmission Range in Ad-Hoc Networks," Multiaccess, Mobility and
Teletraffic for Wireless Communications (MMT'99), Venice, Italy, October
6-8, 1999 
(it's on our web page: http://www.ee.cornell.edu/~haas/wnl.html)

Also, Miguel Sanches's work on power control in ad hoc networks.

Zygmunt Haas.
==-=-=-==-====
~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-
Prof. Zygmunt J. Haas                    tel: +1-607-255-3454
Wireless Networks Laboratory		                  
School of Electrical Engineering         fax: +1-607-255-9072 
Cornell University
323 Frank Rhodes Hall			 e-mail: [email-masked]
Ithaca, NY 14853			 
U.S.A                             http://www.ee.cornell.edu/~haas/wnl.html
~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-

---

From: Kui Wu <[email-masked]>
Date: Thu, 18 Jan 2001 17:11:26 -0700 (MST)

> Maybe they have already been discussed over and over,

Another email from Yahoo, but really good points. Hey, who said we should 
limit the domains in this list? 

> situation and put selfishness on our side.

Saving battery in ad-hoc mode may not be feasible. How about let the
phones serving in ad-hoc mode earn some "points", which can be converted
into money or bonus. :-)). If that is true, I would like to switch my cell
phone in ad-hoc mode.

Kui

---

From: Zygmunt Haas <[email-masked]>
Date: Thu, 18 Jan 2001 20:21:05 -0500 (EST)

Hi Kui,

> into money or bonus. :-)). If that is true, I would like to switch my cell

The paper by Jean-Pierre Hubaux in the Mobihoc'00 studied credit-like 
schemes for rewarding nodes that forward traffic in ad hoc networks.
Some very interesting ideas are in that paper, which assumes that the
nodes are not necessarily collaborating.

Zygmunt.
===--======
~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-
Prof. Zygmunt J. Haas                    tel: +1-607-255-3454
Wireless Networks Laboratory		                  
School of Electrical Engineering         fax: +1-607-255-9072 
Cornell University
323 Frank Rhodes Hall			 e-mail: [email-masked]
Ithaca, NY 14853			 
U.S.A                             http://www.ee.cornell.edu/~haas/wnl.html
~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-
--------------------------------------------------------------------------
Words of Wisdom:
"Turns out that not where, but who you are with that really matters." 
						       David Matthews
--------------------------------------------------------------------------

---

From: brian raymor <[email-masked]>
Date: Thu, 18 Jan 2001 20:40:36 -0500

> into money or bonus. :-)). If that is true, I would like to switch my cell

The terminodes project (www.terminodes.org) is exploring incentives for
collaboration in ad-hoc networks. In their paper, "Towards Mobile Ad-Hoc WANS:
Terminodes", there is a description of a terminode currency called nuggets which
can be exchanged using various models to enable packet forwarding. Robert
Axelrod's TIT-FOR-TAT strategy also seems useful in this context.

...brian

---

From: Bora Akyol <[email-masked]>
Date: Thu, 18 Jan 2001 20:16:51 -0800

>>>>> "Robin" == Robin Poss <[email-masked]> writes:

    Robin> First idea: ----------- How about implementing power
    Robin> control at every mobile node in an ad-hoc network, in
    Robin> order to keep the number of neighbors known to this
    Robin> node inferior to a certain number n, chosen cleverly
    Robin> to achieve reasonable coverage nonetheless? Maybe
    Robin> this could reduce power consumption and/or overhead,
    Robin> and reduce it enough to be worth the corresponding
    Robin> coverage loss.

This has been discussed quite a few times. Nick Bambos (now at
Stanford) had published on this topic 
as well.

    Robin> Second idea: ------------- How about a "dual" mobile
    Robin> phone, able to switch between a normal cellphone mode
    Robin> and an ad-hoc mode, the decision to swich being
    Robin> based, for example, on maximizing battery life, or
    Robin> minimizing bandwidth usage? In ad-hoc mode, the phone
    Robin> would use a chain of other phones not to reach the
    Robin> party called, but to reach the nearest (or otherwise
    Robin> clerverly chosen) base station.

802.11b has this support built-in when used in ad-hoc mode as
    well as Metricom ricochet modems (first gen at least).

Bora

---

From: Frank Kargl <[email-masked]>
Date: Fri, 19 Jan 2001 07:47:58 +0100

Hi ...

> Second idea:

We are currently trying to implement such a solution based on bluetooth
enabled cellphones. Unfortunately the needed equipment is rather
difficult to obtain esp. as manufacturers are quite anxious about giving
development kids of their cellphone software to others.

Our basic idea is a phone that uses ad-hoc technology, if a partner is
reachable via the ad-hoc network. In case of a reachable telephony
gateway in the network (either IP telephony or POTS) this can be used
(which is usually much cheaper than the GSM service). Finally there's a
fallback to GSM.

The main obstacles we have identified so far:
- power consumption of phones in ad-hoc mode (as you said)
- security considerations (routing calls through other phones)
- GSM service provider won't be to eager to deploy such a solution as
this would diminish their profit.

We'll try to publish details of our work as soon as prototypes and
results are working.

Regards ... Frank

-- 
-----------------------------------------------------------------------
 Frank Kargl          Multimedia Computing, University of Ulm, Germany
 Mail:[email-masked] http://www.uni-ulm.de/~fkargl/
-----------------------------------------------------------------------
   Use the SOURCE, Luke !  I feel a great disturbance in the SOURCE.
            But beware of the Microsoft side of the SOURCE !

---

From: "Jeff Monks" <[email-masked]>
Date: Fri, 19 Jan 2001 02:06:31 -0600

> Stanford) had published on this topic

Yes, there has been work done in this domain from several different angles:
1) Utalizing a greater number of intermediate hops such that significantly
less power is required at each transmission.

R. Wattenhofer, L. Li, P. Bahl, and Y. Wang, "Ditributed Topology Control
for Power Efficient Operation in Multihop Wireless Ad Hoc Networks", To
appear in INFOCOM 2001.

2) Minimizing the TX power to that needed to reach the intended destination

a) For maximizing spectral reuse

S.-L. Wu, Y.-C. Tseng, and J.-P. Sheu, "Intelligent Medium Access
for Mobile Ad Hoc Networks with Busy Tones and Power Control," IEEE Journal
on Selected Areas in Communications, Vol. 18, September 2000, pp.
1647-57.

J. Monks, V. Bharghavan, and W. Hwu, "A Power Controlled Multiple Access
Protocol for Wireless Packet Networks," To appear in INFOCOM 2001.

b) For Energy efficiency

J. Ebert, B. Stremmel, E. Weiderhold, and A. Wolisz, "An Energy-efficient
Power Control Approach for WLANs," IEEE Journal Of Communications and
Networks, Vol. 18, September 2000.

There are quite a few others too and there are still opportunities for
additional work in this area.
>     well as Metricom ricochet modems (first gen at least).

True, 802.11 has support for both communicating with a single base station
and ad hoc mode.  However, I think this falls far short of what is covered
by this topic.  802.11 would require a significant amount of provisioning
and added mechanisms to be able to support this dual mode in a way that
would provide benefits in coverage and extended battery life.  In addition,
802.11 uses a shared channel paradigm and this type of implementation would
really require two separate channels (one devoted to each mode) such that
the mechanisms in each mode do not conflict (if they are to be used
together).  Otherwise, the longer range cellular communication would
interfere with the short ranged ad hoc communications.  I'm not as familiar
with the Ricochet modems, but I don't believe they used a combination of
base station mode (for lack of a better term) and ad hoc mode.  I know there
are several people (both academic and industry) who are currently doing
research in this area and I have thought that it was an interesting area for
quite some time.  I guess you could kind of think of a cell phone with a
Bluetooth transmitter/receiver as a rudimentary form of dual base station/ad
hoc mode device though it (like 802.11) does not (currently) adaptively use
the two environment to manage the wireless resource and its energy reserves.
This is where there is still a great deal of interesting research to be done
in this domain.

Robin> I was told that Nextel already offers a phone which
Robin> can be used as a talkie-walkie. This is a first step.
Actually, from what I understood talking to some guys from Motorola was that
these devices still communicate through the cellular base stations.  They
only simplify the communication by reducing the signaling overhead since it
sends individual data frames without first making a request and waiting for
the accept and the frames stay on a single operators network (i.e. they are
not switched onto the PSTN).

Robin> I think "3G TR 25.924 ,Opportunity Driven Multiple
Robin> Access" deals with a similar idea.
Hmmm not sure about this one.

-Jeff

---

From: Duncan Thomson <[email-masked]>
Date: Fri, 19 Jan 2001 08:41:39 -0500

Bora Akyol wrote:
> 802.11b has this support built-in when used in ad-hoc mode...

Could you please elaborate on this?  I have the IEEE 802.11 standard,
and I don't see this capability described.  My version is a few years
old.  Do I need to get the most recent version?  Could you please
provide some more details on where we can find a description of this
capability in 802.11.  Has anyone implemented it?

Duncan Thomson
Sr. Technical Advisor
Network and Communications Engineering
The MITRE Corp.

---

From: [email-masked] (Amritansh Raghav)
Date: Fri, 19 Jan 2001 09:32:36 -0800

Afaik, 802.11 (a or b) has no such feature. Ad-hoc mode in 802.11 simply
means peer to peer communication with other nodes in the same BSS
(essentially confined to a single layer 2 segment). Multihop communication
would require something above 802.11

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Duncan Thomson
Sent: Friday, January 19, 2001 5:42 AM
To: Bora Akyol
Cc: Robin Poss; [email-masked]
Subject: Re: research topics

Duncan Thomson
Sr. Technical Advisor

---

From: gabriel montenegro <[email-masked]>
Date: Sat, 20 Jan 2001 02:05:56 +0100

brian raymor wrote:

> collaboration in ad-hoc networks.

chiming in with brian...
from a somewhat different field, there's mojonation in which users gain
'mojo currency' as they offer resources to the network:

       http://www.mojonation.net/docs/technical_overview.shtml

-gabriel

---

From: daniel russo <[email-masked]>
Date: Sat, 20 Jan 2001 00:12:16 -0500

> adjustment" Proc. IEEE Infocom, 2000 (Tel Aviv)

hmmm... 
isnt dropping the transmit power in some nodes but not others
*purposely* introducing undirectional links into the network. 
I guess this is just another reason to take undirectional links
seriously in ad hoc networks.

thanks,
daniel

---

From: "misan" <[email-masked]>
Date: Sat, 20 Jan 2001 14:13:14 -0800

Hi all,

Here you have a pointer to the file Robin Poss referenced:

ftp://ftp.3gpp.org/Specs/December_99/25_series/25924-100.zip

Cheers,

Miguel Sanchez

---

From: Ya Xu <[email-masked]>
Date: Tue, 23 Jan 2001 17:08:26 -0800 (PST)

> First idea:

Very good topic. We have done some work on this idea at USC/ISI:

http://www.isi.edu/isi-technical-reports.html

TR-2000-527.pdf (Top of Page)  
Adaptive Energy-Conserving Routing for
Multihop Ad Hoc Networks Ya Xu, John Heidemann, Deborah Estrin
October 2000, 14 pages           

We are currently doing further investigations on this direction.

thanks

-Ya