Subject: CMU extensions to ns: Installation problem

From: "wooighee" <[email-masked]>
Date: Wed, 24 Jan 2001 15:11:24 +0900

Hello
   I am trying to install the CMU extensions to ns simulator.
When I tried to "make" at the ns-src, I got the following error:
If you have any idea on this error please kindly inform me.
Thank you very much.
Regards
Ghee
----------------------------------------------------------------------------
---------------
ghee@yukon(305)% make
:
:
In file included from random.h:40,
                 from random.cc:42:
config.h:50: conflicting types for `typedef signed char int8_t'
/usr/include/sys/int_types.h:62: previous declaration as `typedef char
int8_t'
random.cc:45: declaration of C function `int srandom(...)' conflicts with
/usr/include/stdlib.h:182: previous declaration `void srandom(unsigned int)'
here
make: *** [random.o] Error 1
ghee@yukon(306)%
----------------------------------------------------------------------------
---------------

---

From: Nitin Nagar <[email-masked]>
Date: Wed, 24 Jan 2001 09:38:02 -0800 (PST)

Hi
For the first error concerning srandom(), Just comment that particular
line out and for seond line relace your config.h with the compiled version
of your ns-2 version 3.0 config.h file, It should work that way
nitin

------------------------------------------------------------------------------
Nitin Nagar                            
Graduate Teaching Assistant                   (R) (775) 348-7176
Dept. of Computer Science                     [email-masked]
University of Nevada,Reno
http://www.cs.unr.edu/~nagar
Reno NV-89557

Address:46 West 10th Street Reno NV-89503     
                                                          
------------------------------------------------------------------------------