Subject: Throughput measurement in Ad-Hoc Networks

From: Diego Pamio <[email-masked]>
Date: Tue, 30 Jan 2001 10:23:45 -0500 (EST)

Hi.

Does anybody knows how to obtain a throughput measurement of an ad-hoc
network?

Thanks.

Lucas F. Ledesma
Diego N. Pamio
Facultad de Ingeniería
Universidad Católica de Córdoba
Argentina

______________________________________________
FREE Personalized Email at Mail.com
Sign up at http://www.mail.com/?sr=signup

---

From: Ravi <[email-masked]>
Date: Wed, 31 Jan 2001 10:05:26 +0530 (IST)

hi,
if u have not already gone through the paper by P.R.Kumar,
University of Illinios, u can go through it, it talks about
throughputs.

the name of the paper is "New technological vistas for systems
and control: The example of wireless networks".
it was published in may 8, 2000.

ravi.

--------------------------------------------------------------------------
           |-----------------------------------------------|
           |                                               |
           |     Ravi Kumar Sinha                          |
           |    [ [email-masked] ]               |
           |    [ [email-masked] ]        |
           |    [ [email-masked] ]               |
           |                                               |
           |     ph. (080) 3602095 -------> (Percolat Lab.)|
           |         (080) 3092368/ext->321 (Percolat Lab.)|
           |         (080) 3092906 ---> (Computing lab-1)  |
           |         (080) 3092539 ----> Hostel.(R-79).    |
           |-----------------------------------------------|
--------------------------------------------------------------------------

---

From: Paul <[email-masked]>
Date: Wed, 31 Jan 2001 14:55:41 +0100

[email-masked] said:
> Hi.
> We are trying to measure the throughput of an ad-hoc Network that we
> have simulated using ns (2.1b7a). Does anyone know how to do this? We
> tried to use per-flow monitors but it seems it doesn't work in ad-hoc
> networks because it needs a (wired) link between the nodes.

> Thank you.

> Lucas F. Ledesma

A simple mean is to add during the simulation all the bits sent in all the 
packets in
the whole ad-hoc network. 
The ratio of this number of bits by the simulation duration will give you a 
throughput in bit per second. 

This throughput may exceed the "air" rate of the modem because you may have 
spatial reuse.   
If you want to avoid this phenomenon you can divide this throughput by the 
ratio
between the surface of your ad-hoc network by the surface of the modem 
coverage area. You should have then a 
throughput less than the "air" rate of the modem. This figure can be used to 
evaluate your
medium access scheme.

Paul Muhlethaler 

> Lucas F. Ledesma Diego N. Pamio Facultad de Ingeniería Universidad
> Católica de Córdoba Argentina