Subject: RE: where exactly does AODV protocol fit in?

From: "Rajan, Hridesh (Hridesh)" <[email-masked]>
Date: Mon, 16 Apr 2001 22:10:46 +0530

Hello Satish,

Let me first give you a brief idea of Mobile Ad Hoc
Networks.An Adhoc Mobile Network is an autonomous system
of mobile routers (and associated hosts) connected by 
wireless links--the union of which form an arbitrary graph.
The routers are free to move randomly and organize 
themselves arbitrarily; thus, the network's wireless 
topology may change rapidly and unpredictably. Such a 
network may operate in a standalone fashion, or may be 
connected to the larger Internet.

In contrast with the cellular wireless networks(GSM,
AMPS etc.) these networks do not interact using a
base station(BSS in case of GSM), all the packet 
routing is collabaratively done.

So any routing algortihm that is ment for these networks
essentially works in the mobile hosts themselves. In other
words mobile hosts themselves acts as a router.

Hope this helps. For other information you can refer to 
my article available on the URL 
http://hrideshwww.tripod.com/MANET.html which gives a brief
introduction to the issues in these networks.

regards,
Hridesh

> -----Original Message-----
> From: Satish Reddy [mailto:[email-masked]]
> Sent: Monday, April 16, 2001 4:21 PM
> To: [email-masked]
> Subject: where exactly does AODV protocol fir in?
> 
> 
> hello,
>    first i would like to thank you for your support in my 
> queries.i have
> been through the sites that you have refered to.but still none of them
> specifies which physical device does this AODV protocol sit 
> in.is it in
> the routers or the mobile hosts itself or is it in the centralized
> controller.it would be of great help if you can make this point clear.
> thanking you once again for your support
> satish
>

---

From: Shailesh Humbad <[email-masked]>
Date: Mon, 16 Apr 2001 18:08:24 -0400

Hello everyone,

Does anyone know of any MANET routing protocols or systems specifically geared towards vehicles on the highways and roads?  They should take advantage of at least one of the following: geographic position information, known road layouts, known likelihoods of node density, or fixed position 'helper' nodes?  I'm trying to argue in my thesis that a MANET would be both feasible on congested roadways, and suitable for mitigating the congestion.  Not a new concept, but the protocols I've seen so far seem very theoretical and not applied, and I question if they would work on a network of 100,000 nodes.  GPSR (Greedy Perimeter Stateless Routing) combined with a location service seems most feasible, but I wonder if there is further application specific work.  Please pardon me if I'm missing something; I would appreciate your comments.

Regards,
Shailesh

---

From: "Pranav" <[email-masked]>
Date: Tue, 17 Apr 2001 12:41:56 +0530

Hi Hridesh,

The URL you sent is very good, it cleared most of my doubts. But still I
have some questions,

Presently, does this protocol exist in live network( mobile host) ?

Has this protocol relationship with 3G hosts ?

Regards,

Pranav.

---

From: [email-masked]
Date: Wed, 18 Apr 2001 14:12:19 +0200

Dear Shailesh,

There are two issues for the use of ad hoc networking on roads.

First issue is the organisation of the network which is illimited in
theory. In this case clustering, hierarchical addressing are welcome.
Geographic and road references could be useful here.

Second issue is the relative speed of mobile nodes that can make very
unstable links. One way to cope with this could be to give different
subnetwork allocations to each car flows (up and down) or to have special
protocol optimization regarding fast moving nodes. But maybe it is a
secondary issue.

Philippe
   
A 18:08 16/04/01 -0400, Shailesh Humbad a écrit :
>Hello everyone,
>
>Does anyone know of any MANET routing protocols or systems specifically
geared towards vehicles on the highways and roads?  They should take
advantage of at least one of the following: geographic position
information, known road layouts, known likelihoods of node density, or
fixed position 'helper' nodes?  I'm trying to argue in my thesis that a
MANET would be both feasible on congested roadways, and suitable for
mitigating the congestion.  Not a new concept, but the protocols I've seen
so far seem very theoretical and not applied, and I question if they would
work on a network of 100,000 nodes.  GPSR (Greedy Perimeter Stateless
Routing) combined with a location service seems most feasible, but I wonder
if there is further application specific work.  Please pardon me if I'm
missing something; I would appreciate your comments.

---

From: "Julien.Cartigny" <[email-masked]>
Date: Wed, 18 Apr 2001 17:21:29 +0200 (CEST)

I saw a MIT's paper about this idea:

"CarNet: A Scalable Ad Hoc Wireless Network System" by R. Morris and
J. Jannotti and J. Li  and D. Decouto and F. Kaasho
ek

http://citeseer.nj.nec.com/morris00carnet.html

> missing something; I would appreciate your comments.

------------------------------------------------------------------
CARTIGNY Julien 
These d'informatique dans l'equipe RD2P  a l'universite de Lille 1 
(Phd of Computer Science at the University of Lille 1 / France)
 
"Rosebud" - Citizen Kane/Orson Wells

---

From: "Jeff Boleng" <[email-masked]>
Date: Wed, 18 Apr 2001 16:42:54 -0400 (EDT)

The current IEEE Communications magazine (April 2001, Vol 39. No. 4) has a
relevant article as well:

Broadband Communications on the Highways of Tomorrow
Charles D. Gavrilovich, Jr.

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Julien.Cartigny
Sent: Wednesday, April 18, 2001 9:21 AM
Cc: [email-masked]
Subject: Re: geographic protocols

---

From: "Pranav" <[email-masked]>
Date: Tue, 17 Apr 2001 12:41:56 +0530

Hi Hridesh,

Regards,

Pranav.