Subject: Re: [manet] Security Considerations of AODV

From: Manel Guerrero Zapata <[email-masked]>
Date: Mon, 22 Apr 2002 11:19:03 +0300

Hi Pete,

If Attackers broadcast the packets correctly and also do
the tunneling thing the watchdog won't detect anything
so the pathrater won't change its metrics.
So no, theses kind of misbehaving detection schemes
do not detect attacks that use tunneling.

BR/Manel

ext Pete Sholander wrote:
> Couldn't techniques like Mary Baker's "path rater algorithm" (she's a Stanford prof?) protect against this attack if nodes are using broadcast channels.  Other nodes would notice the bad nodes and vote to exclude them?
> 
> 
>>>>Manel Guerrero Zapata <[email-masked]> 04/18/02 12:16PM >>>
>>>>
> Hi Claude,
> 
> you didn't miss anything ;)
> That's why I said: "although there are certain possible attacks against
> the authentication of the hop count"...
> That is exactly the attack you can perform:
> Bad guys can avoid the increasing of the hop count when they
> forward the packet.
> 
> So the first part of a composed attack would be to try
> that enough bad guys get in one of the paths the RREQ travels through
> and try to be close enough to the optimal path so the difference that
> they cheat is enough to be selected as best path.
> That is not as easy as you might thing.
> If nodes move you have to have a lot of bad guys moving close to the best
> path, or just a huge amount of bad guys (people accept that if a 1/3 of
> the guys are bad there is not much you can do).
> I thing that in the real world the probability that the bad guys get the
> path going through them is not much higher than if the they wouldn't be cheating
> (because if you put a lot of bad guys close to the best path, even if they
> do account for the hop count they also get the possibility to be in the
> best path).
> 
> Therefore I thing hash chains are pretty reasonable, and _very very cheap_!
> There are other mechanisms to protect the hop count but they are so much more
> expensive that they are not really feasible ones.
> But if you (or somebody else) come with a better idea, I'll be glad to
> study it.
> 
> Regards,
> 
> 	Manel
> 
> 
> P.D.: Another way to do the attack is that no matter how close they are to the path,
> but be one hop away from src & dst and have a whole path of bad guy
> no matter how long it is. (but then you need more bad boys than hops
> has the optimal path and being just one hop away form src & dst)
> So I thing bad guys will have a hard time doing this (now: imagine all nodes
> moving).
> 

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Manel Guerrero Zapata <[email-masked]>
Date: Mon, 22 Apr 2002 11:19:03 +0300

Hi Pete,

BR/Manel