Subject: [manet] Link layer notification

From: Sumit Gwalani <[email-masked]>
Date: Thu, 25 Apr 2002 18:48:12 -0700 (PDT)

Hello all,

Just wondering if anyone can help me with the following:

How can I implement "detecting link level notfication to determine
connectivity" ?
Are there any tools available for this?

Thanks,
Sumit

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Phil Neumiller" <[email-masked]>
Date: Fri, 26 Apr 2002 07:51:31 -0400

Hi Sumit,

This is a "very good" question.  I have tried for a couple years now to get some work started in the
IETF with respect to L2 triggers.  I think there was a BOF in Minneapolis, but I missed that.  I am
not sure where the work currently stands.  Can somebody refresh us on this work?

For what its worth, I have always wondered why the top half of TCP/IP is fair game for standardization
i.e. sockets for example, yet the bottom half has to remain secretive/proprietary/custom.  I have always
liked the idea of exposing the underbelly of IP to L2's, i.e. create service access/provision points
underneath IP that provide L2 layers an API into IP' underbelly.  

This being said, some of the most critical things we would need to communicate to IP from a wireless
L2 would be detetion of pilots and/or beacons and signal strength information.  There are many
other things that would be useful as well like how the TOS and TTL fields are interpreted by the MAC.
Maybe I should just write a draft and see what the IESG does with it???

---

From: "Phil Neumiller" <[email-masked]>
Date: Fri, 26 Apr 2002 07:51:31 -0400

Hi Sumit,

---

From: "Dr. Chane L. Fullmer" <[email-masked]>
Date: Fri, 26 Apr 2002 07:04:51 -0700

Hi All..

A couple of years back I presented a formal Link API design at the DC IETF 
meeting that was drafted in the DARPA GloMo project.  Perhaps its time to 
drag it out and take another look?  Provisions were made to pass 
information across the LL/IP interface, as well as to other protocols (ie, 
a Neighbor Protocol).

--regards
   --chane

(Joe: are the slides archived on-line somewhere... ??)

>i.e. sockets for example, yet the bottom half has to remain 
>secretive/proprietary/custom.  I have always

---

From: "Dr. Chane L. Fullmer" <[email-masked]>
Date: Fri, 26 Apr 2002 07:04:51 -0700

Hi All..

--regards
   --chane

---

From: "Phil Neumiller" <[email-masked]>
Date: Fri, 26 Apr 2002 10:40:59 -0400

Yes, it would be very interesting to see.  I am not so much interested in standardizing the
LLC/MAC layer API for the use of IP, as I am standardizing the bottom half of IP looking
in from an LLC/MAC perspective.  Think of me as an LLC/MAC that wants to make
effective use of the stack above me and vice versa.  The age old protocol stack pattern
has been pretty much top down from day one.  I would like more of object oriented
perspective on the layers where we can look at the IP stack as a layer pattern with a top
and bottom and the bottom gets specified as nicely and cleanly as the top has been.  Any
steps in this direction with respect to wireless LLC/MACs would be extermely beneficial.
I am sure optical devices would benefit as well.

-Phil

---

From: "Phil Neumiller" <[email-masked]>
Date: Fri, 26 Apr 2002 10:40:59 -0400

-Phil

---

From: Sumit Gwalani <[email-masked]>
Date: Fri, 26 Apr 2002 13:51:23 -0700 (PDT)

Yes i agree,

thanks for the information

-Sumit

---

From: Sumit Gwalani <[email-masked]>
Date: Fri, 26 Apr 2002 13:51:23 -0700 (PDT)

Yes i agree,

-Sumit