Subject: [manet] Minneapolis Minutes

From: Joe Macker <[email-masked]>
Date: Tue, 02 Apr 2002 11:50:29 -0500

Minutes of the Mobile Ad-hoc Networks WG (manet)
53rd IETF Proceedings
MONDAY, March 18 at 1930-2200

Minutes taken by Jorjeta Jetcheva
==============================

CHAIRS:

Joseph Macker <[email-masked]>
M. Scott Corson <[email-masked]> (ABSENT)

AGENDA:

1. Agenda Bashing (5 min)
2. Status of AODV EXPERIMENTAL Submission Progress (10 min)
Updates of Current Drafts 
3. DSR update: Johnson (Rice) (20 min)
	<draft-ietf-manet-dsr-07.txt>
4. TBRPF Update Ogier/Templin (SRI) (30 min)
	<draft-ietf-manet-tbrpf-05.txt>
5. OLSR update Clausen (INRIA) (30 min)
	<draft-ietf-manet-olsr-06.txt>
New Discussions
6. Manet extensions to OSPF, Baker (CISCO) (20 min)
7. Redirects for MANET Templin (SRI) (20 min)
	<draft-templin-manet-redirect-00.txt>,
8. Other Activity and Implementation Announcements (10 min)
9. Open Discussion <Remaining>

Minutes
-------

1. Agenda bashing

2. Charlie Perkins presented AODV EXPERIMENTAL submission progress:

 - Changes since draft 09 (current draft version is 10)
 - New version of draft will be released before April which will 
   incorporate late last call comments from Yih-Chun Hu, Manuel Zapata
   and input from the Routing ADs Bill Fenner and Alex Zinin.
-  AODV interoperability testing at UC Santa Barbara is taking place
   next week using seven different implementations of AODV.
-  AODV workshop after Mobihoc 2002 in Lausanne, Switzerland.  The 
   workshop is intended to "provide vision for the future evolution of
   AODV".

3. Yih-Chun Hu presented updates to the DSR draft (version 7)

 - Added black lists to enable routing in the presence of 
   unidirectional links.
 - Added multiple interface support.
 - Specified fragmentation and reassembly for DSR based on existing
   standards.
 - Still to do: 
	* Integrating Route Requests and Route Replies for CIDR blocks.
      * Would like to add the DSR flow state mechanism as an option to
        the DSR draft.
      * Applicability statement (up to 100 nodes; mobility up to 15 
        seconds per transmission radius). 

Discussion with the WG chairs regarding authors' desire to add flow
state back into the DSR draft.  QoS was removed from the flow state draft at the 
request of the WG chairs.  The DSR authors suggested that flow state be included 
in DSR before DSR goes through WG last call.  The WG Chairs suggested soliciting 
opinions from the mailing list on this issue before making a decision.

4. Richard Ogier presented an update to the TBRPF draft including the following:

   - Overview of TBRPF.
   - Changes from version 03 to version 05
   - IPR Issues Raised:
        * Only protects SRI if TBRPF does not become an IETF standard.
        * If TBRPF (or any part of it) becomes a standard, anyone can
          use it for any purpose for free.
        * SRI will give licenses to people who would like to implement 
 	    TBRPF before it becomes an IETF standard.
 
Related to IPRs, a question was raised regarding IETF action on
investigating potential AODV related IPR.  The WG chair replied that 
(Bradner/Coya) had previously been consulted on process and appropriate IETF 
action was taken by Coya (IBM was contacted) based upon input from the WG 
chairs.

  - Clarification of the advantages of modular neighbor sensing.
  - Overview of TBRPF routing.
  - Some perceived drawbacks of using OLSR MPRs were presented.

A comment was raised that the presentation of MPR disadvantages was misleading, 
because it discussed only a partial topology mode application of MPRs where 
several implementors have applied MPRs in a more flexible manner, including full 
topology modes.  Also, it was noted that MPR advantages were not mentioned to 
balance out the arguments presented.

A TBRPF document review by the WG chair suggested that OLSR references and 
references to non-static documents be avoided/removed from the TBRPF 
specification.  There were numerous cross references and comparisons that were 
seen as not appropriate for a specification document.

  - Potential advantages of using differential topology updates were
    presented
  - It was pointed at that there was no link-layer notification OLSR 
    implementation from INRIA yet

In response, Joe Macker mentioned that NRL has an independently developed an ns-
2 OLSR v4 implementation that includes link-layer notification.

  - Support for multiple interfaces was recently added
  - IPv6 operation is discussed

Joe Macker raised the question of whether declaring a link down as a result of a 
single link layer failure notifications in TBRPF and other protocols is a good 
idea. He suggested that this is a drastic measure given that time varying 
effects may cause such failure but is not an indication that the link is 
actually down.  To minimize route flapping, etc further filtering on such 
signals was suggested.

  - The TBRPF flooding mechanism was reviewed

  - Simulation of OLSR and TBRPF: still trying to determine why 
    different performance results are reported by different groups 
    using the same code

  - TBRPF ns-2 and linux code is available from the SRI website.

Thomas Clausen pointed out that his comments on the complexity of the TBRPF 
draft were made regarding the draft's readability rather than the complexity of 
the protocol itself.

5. Thomas Clausen presented updates to the OLSR draft

  - The OLSR draft is stable and mature: no core changes since version
    00.
  - Updates from version 05 to version 06: no major changes
  - OLSR overview
  - Neighborhood management
  - Support for multiple interfaces
  - Generalized and discussed MPR heuristics
  - Graphs showing OLSR simulation results for MPR coverage for 50 and
    100 nodes for the MPR mechanism in the 05 draft and the improved
    MPR mechanism which includes the new heuristics described in the 06 
    draft.
  - Fast rerouting with link-layer notification described
  
Joe Macker raised the issue that the OLSR draft does not specify how packet 
duplicate detection is performed in the presence of packet aggregation. Thomas 
Clausen responded that possible implementations of duplicate detection in the 
context of packet aggregation will be discussed in future versions of the OLSR 
draft.

6. Fred Baker presented: OSPF v3 as a Manet Routing Protocol
  
  - Commercial manet protocols: what is important in the market place? 
	* application-specific protocols may be of interest
      * ease of deployment is key
  - Issues with OSPF v2  
  - OSPF v3 was presented as a better potential framework for
    implementing a set of manet extensions
  - A Manet interface type was discussed and related implications to
    an OSPF extension
  - A number of approaches and scenarios relating to inter-Area   
    mobility were presented as well

Fred Templin raised the question of whether there will be too many prefixes to 
keep track of. Fred answered that this shouldn't be a big problem as the number 
of prefixes will not be too large.

Dave Johnson pointed out that the concept of areas has been considered 
before in an ISPAN '99 paper published by the Rice/CMU Monarch project.  
Movement between areas is accomplished through Mobile IP.  This mechanism has 
also been implemented and tested in a DSR testbed.

  - A link state metric equation was presented	

    Richard Ogier suggested that path length should be included in the
    metric.  Fred Baker agreed.

  - Installing IPv4 routes (OSPF v3 is an IPv6 protocol)

The WG chair clarified that Fred Baker is not suggesting a replacement for the 
current proactive MANET protocol proposals, but that his proposal has likely 
application for a number of envisioned scenarios.

Charlie Perkins argued that areas may not be applicable to all ad hoc network 
environments and to protocols advocating an on-demand approach to routing.

A question is raised about whether OSPFv3 handles partitions.  Fred Baker 
answered that it can be done but not easily.

7. Fred Templin presented ICMP redirect issues in MANET

8. Announcements and General WG discussion

Yih-Chun Hu reported that a new implementation of DSR on Windows CE 
from the University of Dublin is now available.  A new implementation
of DSR under linux is also available.  Contact [email-masked] for
more information. 

Joe Macker announced that NRL has made available the OLSR Linux implementation 
with NRL modifications (this code is based upon INRIA v3 code).  It has been 
applied in live testbeds with 10-20 mobile nodes.  There is also a v4 based ns2 
model which is being released.  This model includes several optional modes 
including link layer notification and a full topology mode.  The project 
releases can be found at <http://pf.itd.nrl.navy.mil>.

Dave Johnson advertised Mobihoc 2002 to be held in the summer of 2002 in 
Lausanne, Switzerland.

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: zb <[email-masked]>
Date: Thu, 04 Apr 2002 17:40:30 +0900

hi all,

  Can anyboday tell me the difference between routing table and precursor
list in AODV?
Sorry to ask this stupid question if it is. I need to understand them in
network formation.

thanks,

bin
*************************************
Zhen Bin

i-Networking lab,
Samsung Advanced Institute of Technology,
San14-1, NongSeo-ri, Kiheung-Eup,
Yongin, Kyungki-do, 440600, Korea

82-31-2809569 (fax)
82-31-2809534 (o)
82-31-2122268 (h)
*************************************

---

From: zb <[email-masked]>
Date: Thu, 04 Apr 2002 17:40:30 +0900

hi all,

thanks,

bin

i-Networking lab,

82-31-2809569 (fax)
82-31-2809534 (o)
82-31-2122268 (h)