Subject: [manet] Questions on draft-ietf-manet-aodv-10.txt

From: "Phil Neumiller" <[email-masked]>
Date: Fri, 19 Apr 2002 10:26:29 -0400

Hi,

Some Nitpicks...

1).  Page 3, second to last paragraph.  Grammar.

      ... containing the IP address for each [of] its neighbors ...
                                                                ^
                                                                 | Add word "of"

2). All.  Document organization.  When trying to implement the draft, one would 
     find it particularly convenient if all the references on how to handle the reception
     of a particular message i.e. RREQ, RREP, etc. were in the same subsection.
     I would prefer four new sections be aggregated into the draft, with subsection 
     titles of:

"Handling RREQ Messages"
"Handling RREP Messages", etc... i.e. for each AODV message type.

An implementation question...

3).  AODV specifies the creation of its own route table structure.  RFC 1396 
      (IP Forwarding Table MIB) specifies the format for route tables that
      are used in many device implementations, for example, the Microsoft Windows
      route table.  Is there any reason, why AODV does not specify the interaction
      between its route table and the route table that may be present on the host
      (and conflicting with) it.  Also, would it not be advisable to modify RFC 1396 to
      accomodate MANET protocols?  This way we could get down to one route
      table on host and router platforms right?  The precusror list does not necessarily
      need to be in there.  Also, the route table could be treated like a relational
      database indexed on IP destination addr so the redundant information could
      be put into the "real route table".  This is particularly important on embedded 
      devices.

Thanks,

Phil

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Phil Neumiller" <[email-masked]>
Date: Fri, 19 Apr 2002 10:32:01 -0400

Sorry replace 1396 with 1354 in previous mailing
> 
> 3).  AODV specifies the creation of its own route table structure.  RFC 1354 
>       (and conflicting with) it.  Also, would it not be advisable to modify RFC 1354 to

---

From: "Phil Neumiller" <[email-masked]>
Date: Fri, 19 Apr 2002 10:32:01 -0400

---

From: Charlie Perkins <[email-masked]>
Date: Fri, 19 Apr 2002 10:07:47 -0700

Hello Phil,

Thanks for your comments!

> "Handling RREP Messages", etc... i.e. for each AODV message type.

This is quite ambitious for a document that is almost "finished"!
Maybe it would be better to delay such a reorganization for some
future revision past Experimental?  (I hope!)

> 3).  AODV specifies the creation of its own route table structure.    ....
>                      Is there any reason, why AODV does not specify the interaction
>       (and conflicting with) it.

I think it should be better to cast any discussion in the AODV specification
in such a way that it is NOT interpreted as creation of a new route table.
AODV needs more things than are in a vanilla route table, but they can
be adjuncts to a route table -- or, with more complexity, a mirror of the
route table that is consulted in conjuction with route table accesses.
It's really a platform issue, and I believe the protocol specification has
to be kept separate from considerations about structure of a route table.
Surely kernel programmers don't have to restrict their route table interface
routines to using only the variables defined in some MIB.

>  Also, would it not be advisable to modify RFC 1396 to

Presumably, this is not suggested as part of AODV.

Regards,
Charlie P.

---

From: Charlie Perkins <[email-masked]>
Date: Fri, 19 Apr 2002 10:07:47 -0700

Hello Phil,

Regards,
Charlie P.