Subject: [manet] Standardizing IP's Under-specified Underbelly Draft Kickoff Party - Was Link API

From: "Phil Neumiller" <[email-masked]>
Date: Tue, 30 Apr 2002 08:37:52 -0400

Hi,

OK, seems like there is some interest.  Here is the list of interested folks I have so far.  
Have I missed anybody?  

[email-masked] - Scott Corson
[email-masked] - Einar Vollset
[email-masked] - Michael Gerharz
[email-masked] - Rex Buddenberg
[email-masked] - Mike Sasuta
[email-masked] - Dr. Chane Fullmer

If anybody else is interested in working on the draft please let me know.  If we come up with
a draft fairly quickly it may be submitted into the L2 tiggers BOF I suppose depending on
how/when that happens.  Either way we can see what the IESG says when we submit it.

I plan to send my first version of the drafty draft to the above folks in plain vanilla ASCII,
i.e. no IETF formatting at first.  Everybody can take a swipe at it and  mail it back to me.  

Meanwhile...  Here is a draft problem statement....  Please pile on.

Problem Statement
=============
Many years of development have gone into the TCP/IP protocol suite, primarily from a "top
down" design perspective where layer upon layer have been built upon each other.  Each
layer functions as a client accessing the server layer below it.  This model has served the global
Internet extremely well for many hears.  However, as software design methodologies have
progressed so have software design patterns.  The IP stack is highly standardized on
its "top" side, but it is proprietary/hidden and somewhat of a black art on its bottom side.

With the advent of ubiquitous wireless devices, it is extremely important to allow L2 devices
to form a tight coupling with the IP (L3) layer.  Wireless devices have links that can change
state on the order of milliseconds and routing, QoS, and security decisions, if they are to be
implemented at the IP layer, must interact quickly.  Currently, there are no standard event 
notification methods or triggering mechanisms into the under-specified under-belly of the IP
stack.

Proposed Title:  Steps Toward Standardizing IP's Underspecified Underbelly
(I hate this title, but it gets the point across)

Thanks,

Phil

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "wooighee" <[email-masked]>
Date: Tue, 30 Apr 2002 22:39:16 +0900

Hello,

I have read the AODV internet draft version 10.

In the draft, it is stated that the control packet
length is 32. May I know whether it means 32 bits or
32 bytes ?

I am still new in ad-hoc networking research.

Thank you for your kind advice.

Regards,
Ricky

---

From: "wooighee" <[email-masked]>
Date: Tue, 30 Apr 2002 22:39:16 +0900

Hello,

Regards,
Ricky

---

From: Guillaume Chelius <[email-masked]>
Date: Tue, 30 Apr 2002 16:06:27 +0200 (CEST)

-----------------
Guillaume Chelius
PhD student
Ares Team, Inria, Citi Insa-Lyon
Tel: (+33) 472 436 421
Email: [email-masked]

---

From: Guillaume Chelius <[email-masked]>
Date: Tue, 30 Apr 2002 16:09:10 +0200 (CEST)

Hello, 

Sorry for my last mail, a poor manipulation error.
I'm also interested in working for this draft, if you accept my participation.

Thanks, 
Guillaume Chelius.

-----------------
Guillaume Chelius
PhD student

---

From: Guillaume Chelius <[email-masked]>
Date: Tue, 30 Apr 2002 16:09:10 +0200 (CEST)

Hello, 

Thanks, 
Guillaume Chelius.

-----------------
Guillaume Chelius
PhD student

---

From: "Luke Klein-Berndt" <[email-masked]>
Date: Tue, 30 Apr 2002 10:04:41 -0400

Hi,

That is probably 32 bytes -
RREQ are 24 bytes
RREP are 20 bytes
and RERR can vary in size.

IP addresses are usaully 32 bits long (in IPv4). Sequence numbers in AODV
are also 32 bits. 32 bits translates into 4 bytes because there are 8 bits
in a byte. Here is an article which goes a little more in depth:
http://www.loadstar.com/articles/bytes.htm .

Hope this helps,

Luke Klein-Berndt

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> wooighee
> Sent: Tuesday, April 30, 2002 9:39 AM
> To: [email-masked]
> Subject: [manet] AODV control packet length: 32 bits ? 32 bytes?
>
>
> Hello,
>

---

From: "Luke Klein-Berndt" <[email-masked]>
Date: Tue, 30 Apr 2002 10:04:41 -0400

Hi,

Hope this helps,

Luke Klein-Berndt

---

From: Guillaume Chelius <[email-masked]>
Date: Tue, 30 Apr 2002 16:06:27 +0200 (CEST)

-----------------
Guillaume Chelius
PhD student

---

From: "wooighee" <[email-masked]>
Date: Wed, 1 May 2002 11:55:35 +0900

Hi,

Thank you for your advice.

That means the Reserved Field in RREQ is 13 bits
and the Reserved Field in RREP is 9 bits, right?

Thank you.

Regards,
Ricky

---

From: "wooighee" <[email-masked]>
Date: Wed, 1 May 2002 11:55:35 +0900

Hi,

Thank you.

Regards,
Ricky