Subject: [manet] QoS issues in MANETs

From: Harpreet Arora <[email-masked]>
Date: Fri, 26 Apr 2002 14:50:27 -0400

Hi,

I am interested in finding the feasibility of a differentiated services model 
for MANETs. WHile thinking about the implementation of diffserv in MANETs, I 
came across the follwing problem : diffserv aims to push the complexity to the 
edge of the network, by dividing the network into edge and core nodes. How can 
we do this in a MANET? Specifically, how can we differentiate the network of 
nodes into edge and core nodes? Since the nodes are mobile, I feel that every 
node should have the capability of acting as an edge node, which would mark, 
meter and police the packets, and also as a core node, which would simply 
forward the packets on the basis of the DSCP. The nodes can assume either 
functionality depending on the situation. But what node assumes what 
functionality is the question. Any suggestions?

Harpreet
Research Assistant
ECE Department, Drexel University
Philadelphia, PA-19104

********************************************************************
A dream is just a dream. A goal is a dream with a plan and a deadline.

A candle brightens the world around it. Unfortunately, it creates a shadow of its own. It still serves the purpose it is meant for. **********************************************************************

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Andrew T. Campbell" <[email-masked]>
Date: Tue, 30 Apr 2002 17:59:37 -0400

Hello Harpreet:

My research group looked at stateful (INSIGNIA Project) and
stateless (SWAN Project) approaches to building QOS into MANETS.
SWAN (for stateless wireless ad hoc networks) is a diffserv-like
approach and may answer some of your good questions.

SWAN is rather simple but effective. It uses rate control for
UDP and TCP best-effort traffic, and sender-based admission control
for UDP real-time traffic. SWAN uses ECN to dynamically regulate
admitted real-time traffic in the face of network dynamics brought on
by mobility and/or traffic overload conditions. SWAN does not require the
support of a QOS-capable MAC. Rather, soft real-time services are built
using existing best effort wireless MAC technology.

For details of the mode take a look at our INFOCOM 2002 paper. It
includes simulation, analysis, and results from an experimental
wireless testbed that shows real-time applications experience low
and stable delays under various multi-hop, traffic and mobility conditions:

Gahng-Seop Ahn, Andrew T. Campbell, Andras Veres and Li-Hsiang Sun, "SWAN:
Service Differentiation in Stateless Wireless Ad Hoc Networks", Proc. IEEE
INFOCOM'2002, New York, New York, 2002 (to be published).

You can get the paper from:

http://comet.columbia.edu/swan/

The SWAN ns simulation and testbed code will be made available
in June 2002.

QOS is not on the table in the MANET WG so this is more academic
right now.

Best,
---
Andrew
http://comet.columbia.edu/~campbell

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Harpreet Arora
> Sent: Friday, April 26, 2002 2:50 PM
> To: manet
> Subject: [manet] QoS issues in MANETs
> Importance: High
>
>
> Hi,
>
> A candle brightens the world around it. Unfortunately, it
> creates a shadow of its own. It still serves the purpose it
> is meant for.
> **********************************************************************
>
>

---

From: "Andrew T. Campbell" <[email-masked]>
Date: Tue, 30 Apr 2002 17:59:37 -0400

Hello Harpreet:

Best,
---
Andrew