Subject: Re: [manet] Link API was [ Link layer notification ]

From: "James Kempf" <[email-masked]>
Date: Tue, 30 Apr 2002 08:16:19 -0700

There was a pre-BOF, I believe the decision was to use the PILC mailing
list for discussion. Aaron and Carl, who were chairs can say more. I
assume we will be having a full BOF in Yokohama.

            jak

----- Original Message -----
From: "Phil Neumiller" <[email-masked]>
To: "James Kempf" <[email-masked]>; "Scott Corson"
<[email-masked]>; <[email-masked]>; "Dr. Chane L. Fullmer"
<[email-masked]>
Cc: "Carl Williams" <[email-masked]>; "Aaron Falk"
<[email-masked]>
Sent: Tuesday, April 30, 2002 4:48 AM
Subject: Re: [manet] Link API was [ Link layer notification ]

> James,
>
> I was unable to make that BOF.  Did it happen?  Is there a list?  I
was going to write up
> a draft and just throw it at the IESG to see if it sicks and where
they stick it.  My interests
> are WLAN/MANET primarily.  I do not want to create anything to heavy,
just something
> immediately useful facilitating QoS and security issues with ad hoc
wireless devices.  Is there
> a web page for the BOF?
>
> Thanks,
>
> Phil
>
> ----- Original Message -----
> From: "James Kempf" <[email-masked]>
> To: "Phil Neumiller" <[email-masked]>; "Scott Corson"
<[email-masked]>; <[email-masked]>; "Dr. Chane L. Fullmer"
> <[email-masked]>
> Cc: "Carl Williams" <[email-masked]>; "Aaron Falk"
<[email-masked]>
> Sent: Monday, April 29, 2002 6:12 PM
> Subject: Re: [manet] Link API was [ Link layer notification ]
>
>
> > Phil,
> >
> > I think these would be of potential interest to the L2 triggers BOF.
> >
> >             jak
> >
> > ----- Original Message -----
> > From: "Phil Neumiller" <[email-masked]>
> > To: "Scott Corson" <[email-masked]>; <[email-masked]>; "Dr.
Chane L.
> > Fullmer" <[email-masked]>
> > Cc: "James Kempf" <[email-masked]>
> > Sent: Monday, April 29, 2002 12:35 PM
> > Subject: Re: [manet] Link API was [ Link layer notification ]
> >
> >
> > > Hi Scott,
> > >
> > > I have some drafty draft stuff too.  Is anybody else interested in
> > this?  I will start writing a draft
> > > since I  have been "complaining" about this for years, so its time
for
> > me to put up or shut up.  :-)
> > > I will start the water boiling for the spaghetti and mail my own
> > drafty draft to folks that are
> > > interested.  Also, if I missing some major body of work that has
> > happened on this matter in
> > > the IETF or elsewhere could somebody kindly point it out to me
(its
> > pretty hard to keep up
> > > with so much stuff)?
> > >
> > >     The most essential things to me seem to be:
> > >
> > > 1).  A generic interrupting system, where L2 can "call" (or call
back
> > /  publish / tigger) something to
> > >       the underbelly of IP and tell it something has happened.
That
> > something could simply be
> > >       a code with no qualification or a code with complete TLV
> > qualification, as long as the IP
> > >       layers interpretation is consitent there is not a problem.
> > >
> > >        This type of mechanism could be the basis for a generic L2
> > signaling mechanism.  It could also
> > >        be the basis for passing link status up to (and even more
> > importantly through the IP layer
> > >        as out of band data (OOBD)).  Routing mechanisms residing
above
> > or at the IP layer would
> > >        very much like to use information passed from the link
layer.
> > I suggest using the model view
> > >        controller model for this.
> > >
> > >         Subscriber --->  Publisher
> > >            ^                         ^
> > >            |                          |
> > >          View --------> Model <---- Controller
> > >
> > >        Where say a MANET routing protocol is a subcriber to
certain
> > classes of L2 information such as
> > >         pilot notification or received signal strentgth indication
> > RSSI.  Some of these will be wireless
> > >         specific, some optics specific etc, but either way they
are
> > not tied to any particular L2.
> > >
> > > 2).   Certain categories of these triggers are essential "base
class"
> > triggers, i.e. get a hunk of
> > >        signaling info (possibly in the form of TLV) up to IP
> > efficiently.  The more L2 independent
> > >        the better (please don't suggest ASN.1!).
> > >
> > > 3).    It is necessary for IP to support a plethora of
LLC/MAC(L2s)
> > simultaneously.  Each of these
> > >          L2s will have different behaviour classifications for
TTL,
> > TOS fields etc.  It will be important
> > >          to abstract the behaviors across many different L2s so
that
> > the particular L2 does not have
> > >          to be identified, only its interaction pattern with IP.
> > >
> > > 4).    One could also postulate multiple stacks on a host (IPv4
and
> > IPv6 at least) where it may be
> > >          desirable for the L2 to send IPv4 packets one way and
others
> > another way.  Also, one could
> > >           imagine running multiple stacks per virtual machine on
some
> > hosts and having the L2 send
> > >           the traffic to the properly bound host IP stack (IPsec
with
> > multiple many hostile users comes
> > >           to mind).
> > >
> > > Thanks,
> > >
> > > Phil
> > >
> > >
> > > ----- Original Message -----
> > > From: "Scott Corson" <[email-masked]>
> > > To: "'Phil Neumiller'" <[email-masked]>;
> > <[email-masked]>; "Dr. Chane L. Fullmer" <[email-masked]>
> > > Sent: Monday, April 29, 2002 2:30 PM
> > > Subject: RE: [manet] Link API was [ Link layer notification ]
> > >
> > >
> > > >
> > > > > Yes, it would be very interesting to see.  I am not so much
> > > > > interested in standardizing the
> > > > > LLC/MAC layer API for the use of IP, as I am standardizing
> > > > > the bottom half of IP looking
> > > > > in from an LLC/MAC perspective.
> > > >
> > > > Phil,
> > > >
> > > > I'll second that, and I can see you're interested in building
> > something
> > > > useful... ;-)
> > > >
> > > > I've got a drafty draft written along these lines in hopes of an
> > eventual L2
> > > > triggers BOF...very drafty of course as I've zero time to put
into
> > this.
> > > > Maybe we should each throw some pasta at the IESG wall and see
if
> > anything
> > > > sticks.  ;-)
> > > > -Scott

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "James Kempf" <[email-masked]>
Date: Tue, 30 Apr 2002 08:16:19 -0700

jak

----- Original Message -----
From: "Phil Neumiller" <[email-masked]>
To: "James Kempf" <[email-masked]>; "Scott Corson"

was going to write up
just something
<[email-masked]>
Chane L.
for
(its
back
That
above
layer.
certain
are
class"
LLC/MAC(L2s)
TTL,
that
and
others
some
with
into
if