Subject: [manet] Questions about INSIGNIA

From: Liangping Ma <[email-masked]>
Date: Tue, 14 May 2002 12:32:41 -0400 (EDT)

Hello, everyone,

    I am implementing INSIGNIA in Glomosim and have several questions to
ask. First, at what layer the MAX and MIN bandwidth requirement should be
specified. Second, how many services are available in INSIGNIA? What is
the difference between BQ and BE? It seems to me packets can be
delivered as best effort, and reserved, which inturn includes BQ and EQ.

    Thanks!

Sincerely yours,
Liangping Ma

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Seoung-Bum Lee <[email-masked]>
Date: Tue, 14 May 2002 23:29:58 -0400 (EDT)

Hello,

First of all, glad to hear that INSIGNIA is being implemented in Glomosim.
Well, the MAX and MIN requirements of INSIGNIA should be specified by 
the application. 

INSIGNIA uses three service levels, namely  [1] best effort, [2] minimum
and [3] maximum service. 
All published simulation works of INSIGNIA used three levels of services 
but the number of service levels can be more than three (any number of 
service levels can be set).
 
In fact, in the released NS2 implementation of INSIGNIA, the 
number of service levels is N (N+1 including best effort service). 

The N service levels are;
(This is merely an example that is included in the package. You are
free to introduce more sophisticated ones.)

- best effort     : all packets are BE
- service level 1 : min packets are RES, rests are BE
- service level 2 : min + (max - min) / N are RES, rests are BE
- service level 3 : min + 2 * (max - min) / N are RES, rests are BE
- service level 4 : min + 3 * (max - min) / N are RES, rests are BE
...
- service level N : all packets are RES
(RES packets have priority over BE packet.)

As for your other question about the definition of BQ and BE;
- BQ/EQ is payload type 
- RES/BE is service mode
For detailed information and definition of INSIGNIA, please refer to;  
"INSIGNIA: An IP-Based Quality of Service Framework for Mobile Ad Hoc 
Networks", Journal of Parallel and Distributed Computing(Academic Press), 
Special issue on Wireless and Mobile Computing and Communications, 
Vol. 60 No. 4 pg. 374-406, April 2000".

You can also download the paper from "comet.columbia.edu/insignia"

Thank you.

> delivered as best effort, and reserved, which inturn includes BQ and EQ.

Best Regards,

-----------------------------------------------------
 Seoung-Bum Lee
 
 COMET Group, Columbia University
 e-mail : [email-masked]
 http://www.comet.columbia.edu/~sbl

 * Push your limits! 
-----------------------------------------------------

---

From: Seoung-Bum Lee <[email-masked]>
Date: Tue, 14 May 2002 23:29:58 -0400 (EDT)

Hello,

 

Thank you.

Best Regards,

 * Push your limits!