Subject: RE: [manet] Dumb Question?

From: "Nast, Douglas P" <[email-masked]>
Date: Tue, 14 May 2002 13:02:10 -0700

Zygmunt,

I think your idea is very interesting, as it addresses the latency issue for
routes in your zone (which is important in military apps), and offers the
promise of scalability:  The reactive inter-zone idea is reminiscent of the
hierarchical architecture of OSPF, which essentially operates LS intra-area
and DV inter-area.  How would you contrast your zone idea to OSPF areas?

Doug Nast, Boeing

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, May 14, 2002 11:56 AM
To: Mullen, John P. (Contractor)
Cc: [email-masked]
Subject: RE: [manet] Dumb Question?

Hi John,

> I just started reading _Ad Hoc Networking_, edited by Charles Perkins.  In
> "A DoD Perspective on Mobile Ad Hoc Networks," James Freebersyser
speculates
> on p. 33 that it is unlikely a single protocol will be able to operate
> efficiently over the full range of conditions under which a military MANET
> must operate.  If he is correct, the issue may never be fully resolved.

Yes, I read this book too (:-) ...

I hate to bring this point over again ... and self-promote our work ... 
but the issue of "efficient operation over a wide range of conditions" can
and should be addressed by a *hybrid* routing scheme, where the "proactive" 
and "reactive" behavior are "mixed" in the amounts that match these
operational conditions. In other words, *adaptivity* is the key issue
here.

One such an example of a hybrid scheme is (of course, you have guessed)
the ZRP protocol, in which the amount of proactive vs reactive behavior is
*dynamically* adjusted through a single parameter - the zone radius.

Now imagine this - one could use the AODV (or DSR, or your favorite
reactive protocol) as the reactive protocol in ZRP and OLSR (or TBRPF, or
your favorite proactive protocol) as the proactive protocol in ZRP (I
tried to offend the smallest number of people here (;-)). This is why ZRP
is a framework for ... for exactly this - for "efficient operation over a 
wide range of conditions". So, maybe, there is a hope to resolve this
issue after all.

Zygmunt.
==-=-=====
~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-
Prof. Zygmunt J. Haas                    http://people.ece.cornell.edu/haas 
Wireless Networks Laboratory		 http://wnl.ece.cornell.edu
School of Electrical Engineering         
Cornell University			 tel: +1-607-255-3454
323 Frank Rhodes Hall			 fax: +1-607-255-9072
Ithaca, NY 14853			 e-mail: [email-masked]
U.S.A                             
	WNL web page: http://wnl.ece.cornell.edu
~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Charlie Perkins <[email-masked]>
Date: Wed, 15 May 2002 07:26:04 -0700

Hello Douglas,

We have results for scaling AODV up to 10,000 nodes.
We know that we can do better by improving the packet
delivery ratio.  In a few weeks, I reckon we'll have some
specific directions for algorithm improvement.

ZDP is theoretically able to do better, simply because it
admits as special cases all on-demand protocols.  However,
I have never seen any results showing ZDP on a network
of 10,000 nodes (simulated).

Regards,
Charlie P.

---

From: Charlie Perkins <[email-masked]>
Date: Wed, 15 May 2002 07:26:04 -0700

Hello Douglas,

Regards,
Charlie P.

---

From: [email-masked]
Date: Wed, 15 May 2002 09:36:45 -0700

Charlie,

You results sound impressive.  I assume you are 
using plain AODV (without any hierarchical extension).
I would like to know more details about your results,
e.g., how many nodes are traffic sources, what is 
the average number of neighbors, node speed, and
session duration.

Richard

---

From: [email-masked]
Date: Wed, 15 May 2002 09:36:45 -0700

Charlie,

Richard

---

From: [email-masked]
Date: Wed, 15 May 2002 14:58:48 -0400 (EDT)

Hi Charlie,

Well, I agree with you that since pure on-demand protocol is a
special case of a hybrid scheme, such as ZRP, a hybrid scheme
performance is bound to produce at least as good results as any of the two
extremes - purely proactive and purely proactive schemes. In fact, our
study (for example, the paper in your book) shows that it can reduce the
control traffic to a small fraction of those two extremes. These results
have been confirmed both analytically and through simulation.

Your point regarding scalability is a very valid point. We are currently
evaluating the scalability of the hybrid (ZRP) approach for thousands to
tens of thousands of nodes. This is not a trivial task, taking into the
account the simulation runtime duration. But the preliminary results are
*very* encouraging, to say the least. Stay tuned ....

Zygmunt.
==-=-=====

---

From: [email-masked]
Date: Wed, 15 May 2002 14:58:48 -0400 (EDT)

Hi Charlie,

Zygmunt.
==-=-=====

---

From: Cesar Santivanez <[email-masked]>
Date: Fri, 17 May 2002 20:14:52 -0400

Hi all,

When evaluating a routing protocol performance, we need to consider not only the network
size but also the traffic and mobility rate. Also, the traffic distribution is of paramount importance,
since uniformly distributed traffic will favor proactive approaches while a more reduced sets of destination
(in a period of time) will favor reactive approahes. Also, not only the impact of the control overhead
need to be considered, but also the effect of route information latency, etc. in route optimality,
and the final efferct of route sub-optimality in th esystem performance.

We have developed a methodology for the study of scalability of ad hoc networks, defining the total overhead as the metric that encompass the effect of control overhead (either proactive updates
or reactive route discovery packets) and the effect of sub-optimal routes (more transmissions that
required. We applied out methodology for comparing several ad-hoc routing
protocols, including standard link state,  hierarchical link state, ZRP, and Hazy Sighted
Link State (HSLS). Both, the methodology and our results (based on a set of realistics assumptions,
of which the more controversial may be the uniform traffci distribution ;-) can be found in
our upcoming INFOCOM'02 paper:

C. Santivanez, B. McDonald, I. Stavrakakis, and R. Ramanathan., "On the Scalability of Ad Hoc Routing Protocols," to appear in Proceedings of IEEE INFOCOM'02, New York, June, 2002.

A copy of this paper may be found at :

http://www.ir.bbn.com/documents/articles/index.html

Among other things, we found that ZRP - by being able to dynamically adapts its zone size
reduced de rate of increase of overhead w.r.t. network size (N) from N^2
for pure proactive or reactive approaches, to N^1.66.   Multilevel Hierarchical link state,
further reduced the overhead to a little more than N^1.5, and HSLS by balancing
the control overhead and the negative impact of route innacuracies reduced the
total overhead to N^1.5. We noted that ZRP behaves as a 2-level hierarchy system, while
multi-level Hierarchical link state and HSLS behave as having as many level as needed.

The results also relate total overhead to traffic intensity (assuming uniformly distributed
source-destinations) and mobility.  An important conclusion of these results is that as mobility
increases, it pays off to allow the control overhead to increase, but not linearly
with the rate of link changes, that is, to allow nodes to have a distorted view of the network.
Also, as traffic rate increases, it pays off to let the control overhead to increase as well,
since the quality of the routes become more important as these routes are used more intensively ...

I hope these results will help the discussion ...

Cesar

---

From: Cesar Santivanez <[email-masked]>
Date: Fri, 17 May 2002 20:14:52 -0400

Hi all,

Cesar