Subject: Re: [manet] fixed address for MANET?

From: "A A" <[email-masked]>
Date: Sat, 07 Dec 2002 22:56:33 +0000

>1. Why do we dynamic assign the address instead of
>fix (IPV6 have enough address) a unique address for
>each MANET terminal? This ways should be very
>similar with the MAC addresses for Ethernet NIC. By
>this we can save more energy and latency.

Fix IPv6 address will sure save some energy, but latency will most probably 
remain the same, because of the fact that to configure an IPv6 properly you 
still have to rely on an router advertisement. How early you get that 
information depends on multicasting protocols used in the ad-hoc network. In 
this way it is very similar to DHCP (gateway )server working in IPv4 
environment. Therefore there will always be some delay factor present.

>2.Nearly all the paper use the IP address as the
>MANET address. IP address is become the standerd,
>isn't it?

There is nothing in ad-hoc network protocol which dictate IP address usage. 
Most probably for ad-hoc network logical names like A, B, C, or D will work 
fine, as everything boils to (selective) multicasting. But for internet 
conectivity the node would be requring a topological correct address. This 
address may be configured in the node, or ad-hoc network can continue using 
the logical address space and the gateway providing connectivity to outside 
world may implement some mechanism for address translation

Hope that helped,
Abdul

>From: Xuming Fang <[email-masked]>
>To: MANET Mailing List <[email-masked]>
>Subject: Re: [manet] fixed address for MANET?
>Date: Sat, 7 Dec 2002 02:05:31 -0800 (PST)
>
>I have the same question.
>
>X. Fang
>
>--- Qi Fan <[email-masked]> wrote:
> > BlankHello
> >
> > Recently, I have read some papers about the address
> > configuration for MANET. Here I have some questions:
> >
> > 1. Why do we dynamic assign the address instead of
> > fix (IPV6 have enough address) a unique address for
> > each MANET terminal? This ways should be very
> > similar with the MAC addresses for Ethernet NIC. By
> > this we can save more energy and latency.
> >
> > 2.Nearly all the paper use the IP address as the
> > MANET address. IP address is become the standerd,
> > isn't it?
> >
> > Any comments? I would be very appricate for your
> > infomation.
> >
> > All the best.
> >
> > ------------------------------------
> > Qi Fan
> >
> > Center for Telecommunications Research
> > King's College London
> >
> >
> >
> >
>
>
>__________________________________________________
>Do you Yahoo!?
>Yahoo! Mail Plus - Powerful. Affordable. Sign up now.
>http://mailplus.yahoo.com
>_______________________________________________
>manet mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/manet

_________________________________________________________________
Add photos to your e-mail with MSN 8. Get 2 months FREE*. 
http://join.msn.com/?page=features/featuredemail

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Nils Agne Nordbotten" <[email-masked]>
Date: Sun, 8 Dec 2002 00:38:21 +0100

> environment. Therefore there will always be some delay factor present.

If MANETs were assigned a fixed IPv6 prefix, it would be possible to assign
a unique address for use within the MANET based on this prefix and a unique
interface id. If nodes wished to access the internet a second global address
would be needed however (or maybe using Mobile IP.)

Regards
Nils

---

From: "Nils Agne Nordbotten" <[email-masked]>
Date: Sun, 8 Dec 2002 00:38:21 +0100

Regards
Nils

---

From: Charlie Perkins <[email-masked]>
Date: Sun, 08 Dec 2002 09:31:09 -0800

Hello Abdul,

> environment. Therefore there will always be some delay factor present.

This is not true, depending on other assumptions.  For instance,
a mobile device may already have an IP address configured before it
enters the ad hoc network.  If there is no infrastructure, or even if
there is, the device can keep its already configured address.

> There is nothing in ad-hoc network protocol which dictate IP address usage.

That's true, but if it's not IP, it may or may not belong in the IETF.
IP-addressible devices seem very naturally suited for consideration
within the IETF.

> fine, as everything boils to (selective) multicasting.

Sure, any naming scheme can be made to work, but NOT everything
boils down to multicasting.   It depends on your assumptions.

Regards,
Charlie P.

---

From: Charlie Perkins <[email-masked]>
Date: Sun, 08 Dec 2002 09:31:09 -0800

Hello Abdul,

Regards,
Charlie P.

---

From: Charlie Perkins <[email-masked]>
Date: Sun, 08 Dec 2002 13:04:17 -0800

Hello Petar,

One can certainly justify using alternative addressing schemes.
I just question whether that work is appropriate for management
within an IETF working group.  I don't question whether it is
valuable work.

Regards,
Charlie P.

Petar Popovski wrote:

>             ...............
> But, wouldn't it be more beneficial if the addresses in ad hoc networks are
> also ad hoc? For example, instead of 32 bits for IP address, the network
> address for a node would consist of log2(N) bits as unique ID + bits for
> description of services supported at some node.

---

From: Charlie Perkins <[email-masked]>
Date: Sun, 08 Dec 2002 13:04:17 -0800

Hello Petar,

Regards,
Charlie P.