Subject: [manet] 802.11 - minor optimization

From: "Nitin H. Vaidya" <[email-masked]>
Date: Fri, 20 Dec 2002 17:57:28 -0600 (CST)

Hello all:

Anyone on the list from 802.11 standards group ?
Here is a trivial idea worth 2 cents (more like 5%) ...

A simple optimization for 802.11 that might improve
performance 5% without any real change to the protocol :

As I understand 802.11 DCF, the backoff intervals are chosen
in the range of [0,CW] and then the backoff counter is
decremented at the END of each idle slot. Transmit immediately
when counter reaches 0.

Suggested modification:

  Choose backoff interval in the range [1,cw], and decrement
  backoff counter at the START of each slot. Transmit immediately
  when counter reaches 0.

CW in 802.11 is specifed as 2^k-1 for interger k. With the above
change CW should be simply 2^k so that the range of values
for backoff remains same as 802.11 (or, to put it differently,
choose new backoff as 802.11 backoff + 1).

Unless I am mistaken, the above change can save 1 idle
slot for each transmitted packets (with some exceptions).

To see this consider the case when 4 nodes (A, B, C, D) receive
a packet from upper layers while the channel is busy. Let us say that
they choose backoff intervals 0, 1, 2, 3 with the original 802.11,
and 1, 2, 3, 4 with the new modification.

In the original 802.11:

   A will transmit DIFS + 0 slot after current transmission ends.
   B will transmit DIFS + 1 slot after A's transmission.
   C will transmit DIFS + 1 slot after B's transmission.
   D will transmit DIFS + 1 slot after C's transmission.

With the modification:

   A will transmit DIFS + 0 slot after current transmission ends.
   B will transmit DIFS + 0 slot after A's transmission.
   C will transmit DIFS + 0 slot after B's transmission.
   D will transmit DIFS + 0 slot after C's transmission.

So we save 1 slot for each of the last 3 transmissions -- in general,
1 slot may be saved whenever a non-zero backoff counter is chosen
by original 802.11 for a packet that arrives on a busy channel.

Any reason not to use the above modification to 802.11 ?
About 5 minutes of thought went into this suggestion, so if there
is a bug in my argument, feel free to point it out.

Happy holidays!

- nitin

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Nitin H. Vaidya" <[email-masked]>
Date: Fri, 20 Dec 2002 18:16:45 -0600 (CST)

On Fri, 20 Dec 2002, Nitin H. Vaidya wrote:

.  >>
.  >>Hello all:
.  >>
.  >>Anyone on the list from 802.11 standards group ?
.  >>Here is a trivial idea worth 2 cents (more like 5%) ...
.  >>
.  >>A simple optimization for 802.11 that might improve
.  >>performance 5% without any real change to the protocol :
.  >>
.  >>As I understand 802.11 DCF, the backoff intervals are chosen
.  >>in the range of [0,CW] and then the backoff counter is
.  >>decremented at the END of each idle slot. Transmit immediately
.  >>when counter reaches 0.
.  >>
.  >>Suggested modification:
.  >>
.  >>  Choose backoff interval in the range [1,cw], and decrement
.  >>  backoff counter at the START of each slot. Transmit immediately
.  >>  when counter reaches 0.

I guess this is easier to understand if described a bit differently
(although equivalent to above): choose between [1,CW], and decrement at
the end of DIFS idle interval as well as at the end of each idle slot.

End of DIFS is the start of the first slot after DIFS -- this slot may 
turn out to be idle or busy, but all counters are decremeneted at the
end of DIFS before status of the slot is known. Depending on how
you look at it, later decrements occur at the end of idle slots, or start 
of next slot after an idle slot (the next slot may turn out to be
busy or idle).

.  >>CW in 802.11 is specifed as 2^k-1 for interger k. With the above
.  >>change CW should be simply 2^k so that the range of values
.  >>for backoff remains same as 802.11 (or, to put it differently,
.  >>choose new backoff as 802.11 backoff + 1).
.  >>
.  >>Unless I am mistaken, the above change can save 1 idle
.  >>slot for each transmitted packets (with some exceptions).
.  >>
.  >>To see this consider the case when 4 nodes (A, B, C, D) receive
.  >>a packet from upper layers while the channel is busy. Let us say that
.  >>they choose backoff intervals 0, 1, 2, 3 with the original 802.11,
.  >>and 1, 2, 3, 4 with the new modification.
.  >>
.  >>In the original 802.11:
.  >>
.  >>   A will transmit DIFS + 0 slot after current transmission ends.
.  >>   B will transmit DIFS + 1 slot after A's transmission.
.  >>   C will transmit DIFS + 1 slot after B's transmission.
.  >>   D will transmit DIFS + 1 slot after C's transmission.
.  >>
.  >>With the modification:
.  >>
.  >>   A will transmit DIFS + 0 slot after current transmission ends.
.  >>   B will transmit DIFS + 0 slot after A's transmission.
.  >>   C will transmit DIFS + 0 slot after B's transmission.
.  >>   D will transmit DIFS + 0 slot after C's transmission.
.  >>
.  >>So we save 1 slot for each of the last 3 transmissions -- in general,
.  >>1 slot may be saved whenever a non-zero backoff counter is chosen
.  >>by original 802.11 for a packet that arrives on a busy channel.
.  >>
.  >>Any reason not to use the above modification to 802.11 ?
.  >>About 5 minutes of thought went into this suggestion, so if there
.  >>is a bug in my argument, feel free to point it out.
.  >>
.  >>Happy holidays!
.  >>
.  >>- nitin
.  >>
.  >>_______________________________________________
.  >>manet mailing list
.  >>[email-masked]
.  >>https://www1.ietf.org/mailman/listinfo/manet
.  >>