Subject: Re: Re: [manet] fixed address for MANET?

From: Abhishek Prakash Tayal <[email-masked]>
Date: Sun, 8 Dec 2002 00:21:18 +0530 (IST)

I dont know exactly but i think as the MobileAdhoc Networks are not 
permanently setup network.So it is not a good idea to assign them a 
permanent ip address. Although it will surely save some energy and latency 
but we are wasting one address also.
May be it depends on the life and use of a Mobile AdHoc Node..

Date: Sat, 7 Dec 2002 02:05:31 -0800 (PST)
From: Xuming Fang <[email-masked]>
Subject: Re: [manet] fixed address for MANET?
To: MANET Mailing List <[email-masked]>

I have the same question.

X. Fang

--- Qi Fan <[email-masked]> wrote:
> BlankHello
> 
> Recently, I have read some papers about the address
> configuration for MANET. Here I have some questions:
> 
> 1. Why do we dynamic assign the address instead of
> fix (IPV6 have enough address) a unique address for
> each MANET terminal? This ways should be very
> similar with the MAC addresses for Ethernet NIC. By
> this we can save more energy and latency.
> 
> 2.Nearly all the paper use the IP address as the
> MANET address. IP address is become the standerd,
> isn't it?
> 
> Any comments? I would be very appricate for your
> infomation.
> 
> All the best.
> 
> ------------------------------------
> Qi Fan
>  
> Center for Telecommunications Research
> King's College London
> 
> 
> 
> 

__________________________________________________
Do you Yahoo!?
Yahoo! Mail Plus - Powerful. Affordable. Sign up now.
http://mailplus.yahoo.com

-- 
Abhishek Prakash Tayal								
ME Scholar
Room # G 64
Students Hostel
Indian Institute of Scince
Bangalore-12, India
Ph 3942468-227(Intel Lab)
3942621	  (Hostel Block)
****************************************************************
Wanna look my home page visit http://people.csa.iisc.ernet.in/aptayal/
****************************************************************

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Abhishek Prakash Tayal <[email-masked]>
Date: Sun, 8 Dec 2002 00:21:18 +0530 (IST)

X. Fang

---

From: Ryuji Wakikawa <[email-masked]>
Date: Sat, 07 Dec 2002 12:24:57 -0800

> May be it depends on the life and use of a Mobile AdHoc Node..

I agree

If a node needs a permanent ip address, the node can carry its home
address. The node may not start MIP6 operation (sending BU, etc) unless
it communicates with the global Internet. 
The Home address can be used as the unique address of the node in the
manet cloud.

If the node does not have home address, the node should acquire an
address at the attached manet network. 

regards,
ryuj

> > Any comments? I would be very appricate for your

regards,
ryuji

---

From: Ryuji Wakikawa <[email-masked]>
Date: Sat, 07 Dec 2002 12:24:57 -0800

I agree

regards,
ryuj

regards,
ryuji