Subject: [manet] TCP performance analysis in mobile ad hoc network

From: WANG Yu-mei <[email-masked]>
Date: Wed, 11 Dec 2002 22:23:1 +0800

Hello.
  I'm eager to get a help from people who is good at TCP performance analysis, expecially that in mobile Ad hoc networks.
 
  I'm now doing some researches on TCP performance analysis in mobile ad hoc network. When I delopy  different TCP variants (TCP Tahoe, Reno, NewReno, SACK, Vegas) to compare their behavior in ad hoc network with DSR routing protocol, I found there is no obvious rules between different TCP variants for TCP throughput corresponding to different moving speed and pause time. That means, e.g. when the moving speed of the nodes is 5m/s, TCP Reno is better than Tahoe, while when the speed is 10m/s, Reno is even worse than Tahoe, which is quite different from the results reported in former papers and diferent from traditional imagination about TCP in wired networks. 

  I want to know the reason for my mysterious simulation results. Is it because of my wrong simulation method or because of TCP inherent characteristics? Thank you very much.

Best Regards.  
          
--
Yumei Wang 
School of Information Engineering, BUPT, China
TEl: +86-10-62283147(o)
-------------------------------------------------

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: WANG Yu-mei <[email-masked]>
Date: Thu, 12 Dec 2002 21:23:15 +0800

I've done simulations with ns-allinone-2.1b7a, and the simulation configurations are almost the same with those defined in the classical paper "A performance comparison of Multi-hop wireless ad hoc network routing protocols".

On 2002-12-12 11:39:00 you wrote：
>It would help if you can explain your simulation method
>
>
>>From: WANG Yu-mei <[email-masked]>
>>Reply-To: [email-masked]
>>To: "[email-masked]" <[email-masked]>
>>Subject: [manet] TCP performance analysis in mobile ad hoc network
>>Date: Wed, 11 Dec 2002 22:23:1 +0800
>>
>>Hello.
>>   I'm eager to get a help from people who is good at TCP performance 
>>analysis, expecially that in mobile Ad hoc networks.
>>
>>   I'm now doing some researches on TCP performance analysis in mobile ad 
>>hoc network. When I delopy  different TCP variants (TCP Tahoe, Reno, 
>>NewReno, SACK, Vegas) to compare their behavior in ad hoc network with DSR 
>>routing protocol, I found there is no obvious rules between different TCP 
>>variants for TCP throughput corresponding to different moving speed and 
>>pause time. That means, e.g. when the moving speed of the nodes is 5m/s, 
>>TCP Reno is better than Tahoe, while when the speed is 10m/s, Reno is even 
>>worse than Tahoe, which is quite different from the results reported in 
>>former papers and diferent from traditional imagination about TCP in wired 
>>networks.
>>
>>   I want to know the reason for my mysterious simulation results. Is it 
>>because of my wrong simulation method or because of TCP inherent 
>>characteristics? Thank you very much.
>>
>>Best Regards.
>>
>>--
>>Yumei Wang
>_________________________________________________________________
>Add photos to your e-mail with MSN 8. Get 2 months FREE*. 
>http://join.msn.com/?page=features/featuredemail

Best Regards.            
--
Wang, Yumei

---

From: WANG Yu-mei <[email-masked]>
Date: Thu, 12 Dec 2002 21:23:15 +0800

Best Regards.