Subject: [manet] fixed address for MANET?

From: "Qi Fan" <[email-masked]>
Date: Fri, 6 Dec 2002 16:41:36 -0000

BlankHello

Recently, I have read some papers about the address configuration for MANET. Here I have some questions:

1. Why do we dynamic assign the address instead of fix (IPV6 have enough address) a unique address for each MANET terminal? This ways should be very similar with the MAC addresses for Ethernet NIC. By this we can save more energy and latency.

2.Nearly all the paper use the IP address as the MANET address. IP address is become the standerd, isn't it?

Any comments? I would be very appricate for your infomation.

All the best.

------------------------------------
Qi Fan
 
Center for Telecommunications Research
King's College London

---

From: "A A" <[email-masked]>
Date: Sat, 07 Dec 2002 22:56:33 +0000

>1. Why do we dynamic assign the address instead of
>fix (IPV6 have enough address) a unique address for
>each MANET terminal? This ways should be very
>similar with the MAC addresses for Ethernet NIC. By
>this we can save more energy and latency.

Fix IPv6 address will sure save some energy, but latency will most probably 
remain the same, because of the fact that to configure an IPv6 properly you 
still have to rely on an router advertisement. How early you get that 
information depends on multicasting protocols used in the ad-hoc network. In 
this way it is very similar to DHCP (gateway )server working in IPv4 
environment. Therefore there will always be some delay factor present.

>2.Nearly all the paper use the IP address as the
>MANET address. IP address is become the standerd,
>isn't it?

There is nothing in ad-hoc network protocol which dictate IP address usage. 
Most probably for ad-hoc network logical names like A, B, C, or D will work 
fine, as everything boils to (selective) multicasting. But for internet 
conectivity the node would be requring a topological correct address. This 
address may be configured in the node, or ad-hoc network can continue using 
the logical address space and the gateway providing connectivity to outside 
world may implement some mechanism for address translation

Hope that helped,
Abdul

>From: Xuming Fang <[email-masked]>
>To: MANET Mailing List <[email-masked]>
>Subject: Re: [manet] fixed address for MANET?
>Date: Sat, 7 Dec 2002 02:05:31 -0800 (PST)
>
>I have the same question.
>
>X. Fang
>
>--- Qi Fan <[email-masked]> wrote:
> > BlankHello
> >
> > Recently, I have read some papers about the address
> > configuration for MANET. Here I have some questions:
> >
> > 1. Why do we dynamic assign the address instead of
> > fix (IPV6 have enough address) a unique address for
> > each MANET terminal? This ways should be very
> > similar with the MAC addresses for Ethernet NIC. By
> > this we can save more energy and latency.
> >
> > 2.Nearly all the paper use the IP address as the
> > MANET address. IP address is become the standerd,
> > isn't it?
> >
>__________________________________________________
>Do you Yahoo!?
>Yahoo! Mail Plus - Powerful. Affordable. Sign up now.
>http://mailplus.yahoo.com
>_______________________________________________
>manet mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/manet

_________________________________________________________________
Add photos to your e-mail with MSN 8. Get 2 months FREE*. 
http://join.msn.com/?page=features/featuredemail

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Qi Fan" <[email-masked]>
Date: Mon, 9 Dec 2002 18:22:51 -0000

Warm regards, and have a nice day!

Boris

----- Original Message -----
From: "Nils Agne Nordbotten" <[email-masked]>
To: "Qi Fan" <[email-masked]>
Sent: Monday, December 09, 2002 5:20 PM
Subject: Re: [manet] fixed address for MANET?

> Hi,
>
> I think maybe this email was intended for the mailinglist, and not only
for
> me.
>
> ----- Original Message -----
> From: "Qi Fan" <[email-masked]>
> To: "Nils Agne Nordbotten" <[email-masked]>
> Sent: Monday, December 09, 2002 4:52 PM
> > If we assign a fixed IPv6 prefix for MANET nodes, will that destory the
> > hierarchy of the IPv6? Because the IP address is a hierarchical address
> > system, however, the MANET can move to wherever they want. Can we use
the
> > mobile IP to solve it?
>
> Because an address generated from a fixed MANET IPv6 prefix would only be
> used within the MANET itself, I don`t think it destroys the IPv6 address
> hirearchy. For the same reason it should not matter if the MANET moves.
>
> > I am quite agree with Ryuj's comments: The node may not start MIP6
> operation
> > (sending BU, etc) unless it communicates with the global Internet. Also
i
> > think the permanent address will be assigned to MANET should be 'MANET
> > Address' but IP address. Is that right?
>
> I don`t think I understand this question completely, so if it was meant
for
> me please explain.
> Regards
> Nils

---

From: "Qi Fan" <[email-masked]>
Date: Mon, 9 Dec 2002 18:22:51 -0000

Boris

----- Original Message -----
From: "Nils Agne Nordbotten" <[email-masked]>
To: "Qi Fan" <[email-masked]>
Sent: Monday, December 09, 2002 5:20 PM
Subject: Re: [manet] fixed address for MANET?

for
the
i
for

---

From: [email-masked]
Date: Tue, 10 Dec 2002 10:14:00 +0800 (HKT)

Hi,
>> >each MANET terminal? 

first  ad hoc network can use as a tool to access internet.the dynamic address can provide a convenient way.
Second manet's address configuration become more quick.
that my opinion.

This ways should be very
>This is not true, depending on other assumptions.  For instance,
>a mobile device may already have an IP address configured before it
>enters the ad hoc network.  If there is no infrastructure, or even if
>there is, the device can keep its already configured address.
>
>That's true, but if it's not IP, it may or may not belong in the IETF.
>IP-addressible devices seem very naturally suited for consideration
>within the IETF.
>
>> fine, as everything boils to (selective) multicasting.
>
>Sure, any naming scheme can be made to work, but NOT everything
>boils down to multicasting.   It depends on your assumptions.
>
>Regards,
>Charlie P.
>

---

From: [email-masked]
Date: Tue, 10 Dec 2002 10:14:00 +0800 (HKT)

Hi,

This ways should be very