Subject: RE: [manet] is info on link capacity available to a manet protocol

From: "Martin Layley" <[email-masked]>
Date: Wed, 4 Dec 2002 10:54:21 -0000

Battery life/performance currently fits in the ISO model at layer 7 (application).  Historically, because most network components have been powered by mains supplies, (often with UPS and generator backup), lifetime of power has had nothing to do with communication.  The big systems will run a power monitoring application which will update routing tables, DNS servers etc of other machines, before the computer is shut down.  With the growth of small, battery powered devices, this is effectively a new problem.
 
I don't know the 802.11 layer 2, but I am very familiar with Bluetooth (BT), having used chips from 5 different silicon vendors.  Most of these devices don't even have the ability to measure the battery voltage.  Battery life estimation requires an intelligent charger with the ability to measure the battery capacity and report it.  To read the battery charger, a BT device needs an I2C or SPI bus.  Most devices do have these, for reading external E2PROMs.  Some cannot extend this use, others allow the user to write a C program to bit-bash the I/O pins.  The BT spec gives a minimal set of functions and allows the silicon vendor to provide extra manufacturer specific commands. The system designer can then create an application which monitors the system health.  What is done with this information is then outside the BT spec.
 
Laptops & PDAs may have the ability to guess their remaining battery life.  This will be part of the operating system & will be present regardless of networking components.  This information may be able to be read remotely.  If it is available, a reading application will be required (such as IE, netscape, mosaic).  This again is layer 7.

I agree that altering network routing to avoid battery powered devices with marginal capacity is extremely desirable.  To achieve this, you will need to look at using a system management protocol.  I am not very familiar with it, but SMTP may provide you with the desired features.

        Martin

-----Original Message-----
From: Jigar Doshi [mailto:[email-masked]]
Sent: 03 December 2002 11:19
To: [email-masked]
Subject: [manet] is info on link capacity available to a manet protocol

Hello,

Does the network layer report information such as link capacity ( i.e bandwidth ) and/or expected remaining battery life . We are currently developing a protocol which uses this information to calculate optimum paths .A way out of the bandwidth calculation would be indirectly measuring the performance of the link by sending packets across. Is there a more efficient way? Can it be assumed tht such information is available , while designing the protocol like the conventional protocols.

Jigar Doshi & K Prahlad

  _____  

Tired of spam? Get advanced junk mail  <http://g.msn.com/8HMSEN/2017> protection with MSN 8. _______________________________________________ manet mailing list [email-masked] https://www1.ietf.org/mailman/listinfo/manet 

The mail message has been scanned by MAILsweeper
for content analysis.

---

From: Joe Macker <[email-masked]>
Date: Wed, 04 Dec 2002 10:18:06 -0500

>I agree that altering network routing to avoid battery powered devices with marginal capacity is extremely desirable.  To achieve this, you will need to look at using a system management protocol.…

In the MANET sesne, this can be supported through simple router preference features (e.g., in OLSR and TBRPF updates)..

>----------
>Tired of spam? Get <http://g.msn.com/8HMSEN/2017>advanced junk mail protection with MSN 8. _______________________________________________ manet mailing list [email-masked] https://www1.ietf.org/mailman/listinfo/manet 
>
>
>

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Joe Macker <[email-masked]>
Date: Wed, 04 Dec 2002 10:18:06 -0500