Subject: AW: [manet] Sequence Number for Gateway Nodes in AODV

From: Bahr Michael <[email-masked]>
Date: Mon, 12 May 2003 17:42:15 +0200

Sudha,

Thank you for your reply.

I realized my question was a little bit misleading. Since an external
network has to be handled as any other MANET node in the routing tables,
there has to be a sequence number for it. My actual question was, whether it
is necessary to maintain two separate sequence number _counters_ at the
gateway node - one for the gateway node as MANET node, and one for the
external network. This can not be seen from the the Internet draft. I think,
only one sequence number counter is needed, which is used for both the
gateway node and the external network.

Best regards,
Michael Bahr

> -----Ursprüngliche Nachricht-----
> Von: Sudanthi, Sudha (Sudha) [mailto:[email-masked]]
> Gesendet am: Montag, 12. Mai 2003 16:51
> An: Bahr Michael
> Betreff: RE: [manet] Sequence Number for Gateway Nodes in AODV
> 
> Michael,
> 
> The external network would be treated as one node and it 
> would maintain a sequence number for it as it would for any 
> other node.  (A destination sequence number is maintained for 
> all destinations in its cache.)  Therefore, this sentence you 
> quoted just restates that a destination sequence number must 
> be maintained for that external subnet...similar to if the 
> external subnet was just another node...
> 
> Hope that helped...sorry if it didn't...
> 
> -----Original Message-----
> From: Bahr Michael [mailto:[email-masked]]
> Sent: Monday, May 12, 2003 5:01 AM
> To: [email-masked]
> Subject: [manet] Sequence Number for Gateway Nodes in AODV
> 
> 
> 
> 
> Hello,
> 
> I'm refering to draft-ietf-manet-aodv-13, section 8. This 
> section is about
> using AODV with other networks (usually called AODV with 
> gateway node). The
> draft says, that "This includes the need for maintaining a destination
> sequence number for that external subnet."
> 
> Since the only necessary property of the destination sequence 
> number is the
> monotonous increase of its value, it is not necessary to have 
> more than one
> destination sequence number at the AODV gateway node. This means, the
> external subnet uses the same destination sequence number 
> variable as the
> AODV gateway node uses for its own paths.
> 
> Maybe, I've missed something.
> 
> 
> Best regards,
> 
> Michael Bahr
> 
> Siemens AG
> Corporate Technology
> Munich, Germany
> 
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/manet
> 
_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Luke Klein-Berndt" <[email-masked]>
Date: Mon, 12 May 2003 14:33:47 -0400

I have just finished a long delayed update of Kernel AODV, v2.1

Version 2.1 includes:
 - Better internet gatewaying, fixes problems people were having with it
only working for one hop
 - Basic Multicasting, all multicast packets are now broadcast flooded
to everyone
 - Improved stability, locks have been added around shared areas of code

The updated version can be found at:

http://w3.antd.nist.gov/wctg/aodv_kernel/kaodv_download.htm

Thanks!

Luke Klein-Berndt

---

From: "Luke Klein-Berndt" <[email-masked]>
Date: Mon, 12 May 2003 15:23:52 -0400

Hi Michael,
	This should work in practice, but it might cause some trouble
later on down the road. While the most important property of the AODV
Dst Seq Num is that it is monotonously increases, I think another
important property it that it only increases when the route has been
changed. This might mess up some latter enchantment which depends on
this. 

	Also if you have two Gateway nodes for the same external
networks, some instability might develop. That being said, only having
one seq number might make it easier to sync between gateways that have
the same external network. 

-Luke Klein-Berndt

> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Bahr Michael
> Sent: Monday, May 12, 2003 11:42 AM
> To: Sudanthi, Sudha (Sudha)
> Cc: [email-masked]
> Subject: AW: [manet] Sequence Number for Gateway Nodes in AODV
> 
> 
> 
> Sudha,
> 
> I realized my question was a little bit misleading. Since an 
> external network has to be handled as any other MANET node in 
> the routing tables, there has to be a sequence number for it. 
> My actual question was, whether it is necessary to maintain 
> two separate sequence number _counters_ at the gateway node - 
> one for the gateway node as MANET node, and one for the 
> external network. This can not be seen from the the Internet 
> draft. I think, only one sequence number counter is needed, 
> which is used for both the gateway node and the external network.
> 
> Best regards,
> Michael Bahr
>