Subject: [manet] AODV - Sequence Number

From: Kashif Sharif <[email-masked]>
Date: Tue, 13 May 2003 12:34:17 +0100 (BST)

The following para is from draft-ietf-manet-aodv-13, page 16, article 6.6.1 Route Reply Generation by the Destination.

"If the generating node is the destination itself, it MUST increment its own sequence number by one if the sequence number in the RREQ packet is equal to that incremented value. Otherwise, the destination does not change its sequence number before generating the RREP message. The destination node places its  perhaps newly incremented) sequence number into the Destination Sequence Number field of the RREP, and enters the value zero in the Hop Count field of the RREP."

the text in bold implies that the sequence number in RREQ message is greater than the sequence number of the destination. 

How is that possible?

Please any one comment one it!!!

---------------------------------
Yahoo! Plus - For a better Internet experience

---

From: "Nicola Alagia" <[email-masked]>
Date: Tue, 13 May 2003 14:51:30 +0200

Hi Kashif, it is possible and here is an example.
 
Suppose that node S has a route towards node D with a sequence number (X). 
If S reports a link breakage between it and the next hop toward D (say A the next hop),
the node S itself increases the sequence number at (X+1) and sends a RERR message 
to its neighbor nodes that are in the precursors lists for the destinations that use A as next hop.
 
Now, if S attemps a new route discovery for the destination node D, it broadcasts a new 
RREQ message and puts (X+1) in the Destination Sequence Number field. So the RREQ has
a Destination Sequence Number greater than the sequence number known by the destination D.
 
A more detailed description of the RERR message is in the section 6.11 of the draft-13.
 
Bye, Nicola

 -----Original Message-----
From: Kashif Sharif [mailto:[email-masked]]
Sent: Tuesday, May 13, 2003 13:34
To: AODV MailingList; Manet MailingList
Subject: [manet] AODV - Sequence Number

How is that possible?

  _____  

 <http://uk.rd.yahoo.com/evt=8613/*http://uk.yahoo.com/mail/tagline_plus/?http://uk.promotions.yahoo.com/yplus/btoffer.html> Yahoo! Plus - For a better Internet experience

---

From: "Sudanthi, Sudha (Sudha)" <[email-masked]>
Date: Tue, 13 May 2003 09:38:42 -0400

The generating node increments the destination sequence number it is requesting in the RREQ packet before sending, so if it previously received a RREP from this destination with a sequence number X, it is going to ask for X+1 next time and the destination will increment its own sequence number from X to X+1 before sending a RREP.  
 
Therefore, receiving a RREQ with a sequence number greater than what the destination has for itself does not mean that the requesting node has a more fresh route for the destination--just that a more fresh route is being asked for than what it previously received.
 
I hope that makes some sense and helps...

-----Original Message-----
From: Kashif Sharif [mailto:[email-masked]]
Sent: Tuesday, May 13, 2003 7:34 AM
To: AODV MailingList; Manet MailingList
Subject: [manet] AODV - Sequence Number

How is that possible?

  _____

---

From: "Nicola Alagia" <[email-masked]>
Date: Tue, 13 May 2003 16:56:55 +0200

Hi Sudha, I don't agree with you and here is my motivation:
 
according to the draft 13, the Originator node increments its own sequence number 
and copies (without modification) the Destination sequence number from its routing table 
(if the Destination sequence number is not known, the U bit in the RREQ is set). 
 
You can read this in the first paragraphs of the sections 6.1 and 6.3 of the draft.
 
Am I right? Is there something that I'm missing? 
 
Bye, Nicola.

 

-----Original Message-----
From: Kashif Sharif [mailto:[email-masked]]
Sent: Tuesday, May 13, 2003 7:34 AM
To: AODV MailingList; Manet MailingList
Subject: [manet] AODV - Sequence Number

How is that possible?

  _____

---

From: "Sudanthi, Sudha (Sudha)" <[email-masked]>
Date: Tue, 13 May 2003 11:03:05 -0400

oops.  You are completely right in that it does not increment its own sequence number before sending a RREQ, sorry about that.   And yes, as you said, after a RERR is sent for a destination D, a RREQ sent with a destination sequence number greater than what the destination D has for itself is likely...
 
my apologies!

-----Original Message-----
From: Nicola Alagia [mailto:[email-masked]]
Sent: Tuesday, May 13, 2003 10:57 AM
To: Sudanthi, Sudha (Sudha); Kashif Sharif; AODV MailingList; Manet MailingList
Subject: RE: [manet] AODV - Sequence Number

 

Bye, Nicola.

 

-----Original Message-----
From: Kashif Sharif [mailto:[email-masked]]
Sent: Tuesday, May 13, 2003 7:34 AM
To: AODV MailingList; Manet MailingList
Subject: [manet] AODV - Sequence Number

How is that possible?

  _____

---

From: snagaraj <[email-masked]>
Date: Tue, 13 May 2003 09:22:00 -0600

I guess what Sudha mentioned is OK if the node is performing a LOCAL_REPAIR?
 
Best Regards,
Sumeeth

>===== Original Message From "Nicola Alagia" <[email-masked]> =====
>The generating node increments the destination sequence number it is 
requesting in the RREQ packet before sending, so if it previously received a 
RREP from this destination with a sequence number X, it is going to ask for 
X+1 next time and the destination will increment its own sequence number from 
X to X+1 before sending a RREP.
>
>Therefore, receiving a RREQ with a sequence number greater than what the 
destination has for itself does not mean that the requesting node has a more 
fresh route for the destination--just that a more fresh route is being asked 
for than what it previously received.
>The following para is from draft-ietf-manet-aodv-13, page 16, article 6.6.1 
Route Reply Generation by the Destination.
>
>"If the generating node is the destination itself, it MUST increment its own 
sequence number by one if the sequence number in the RREQ packet is equal to 
that incremented value. Otherwise, the destination does not change its 
sequence number before generating the RREP message. The destination node 
places its  perhaps newly incremented) sequence number into the Destination 
Sequence Number field of the RREP, and enters the value zero in the Hop Count 
field of the RREP."
>
>
>
>the text in bold implies that the sequence number in RREQ message is greater 
than the sequence number of the destination.
>Please any one comment one it!!!
<http://uk.rd.yahoo.com/evt=8613/*http://uk.yahoo.com/mail/tagline_plus/?http:
//uk.promotions.yahoo.com/yplus/btoffer.html> Yahoo! Plus - For a better 
Internet experience

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet