Subject: [manet] Basic question about MANET protocols

From: Young-Jun Lee <[email-masked]>
Date: Mon, 5 May 2003 17:44:09 -0400 (EDT)

Hi all,

I think MANET protocols belong to the application layer in the sense that
they utilize L3 (IP) or L4 (udp broadcast) functions.
But I guess that when the IP layer receives a control packet
(like RREQ in AODV) and passes it up to a higher layer (AODV),
the information in the IP header is not available to the higher layer any
more.
If this is correct, how can the higher layer like AODV still use that
information in the IP header like TTL?

Young

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Ryuji Wakikawa <[email-masked]>
Date: Tue, 06 May 2003 16:14:24 +0900

Hi Young.

I use advanced socket API (RFC2292) to retrieve HOPLIMIT(TTL) at
application layer. 
If you are working on IPv4, you can use IP_TTL socket option to retrieve
TTL.

Try "%man ip", you could get more information.

regards,
ryuji