Subject: [manet] Local route repair

From: Maher Kaddoura <[email-masked]>
Date: Fri, 16 May 2003 10:11:32 -0500

Hi,

I am trying to develop a method to reconnect a route when it breaks, by trying to connect 
the node where there break took place to a node downstream from it along the route.
However, all the method that I developed so far causes loops. I was wondering if anyone 
was able to solve this problem.

Thank you,

Maher 

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Sonny Rajagopalan <[email-masked]>
Date: Fri, 16 May 2003 12:00:22 -0400 (EDT)

Two methods that will guarantee loop freedom

(a) use source routing!
(b) use sequence numbers for routing information updates.

Cheers,
Sonny.
----
>From the desk of Sonny Rajagopalan @ http://www.cis.udel.edu/~rajagopa
                                                                  ----

On Fri, 16 May 2003, Maher Kaddoura wrote:

> 7bit
> MIME-Version: 1.0
> Content-Type: text/plain; charset="us-ascii"
> Content-Transfer-Encoding: 7bit
> 7bit
>
> Hi,
>

---

From: "Charles E. Perkins" <[email-masked]>
Date: Fri, 16 May 2003 09:10:38 -0700

Hello Maher,

AODV specifies a loop-free route repair mechanism
that does what you request.

Regards,
Charlie P.