Subject: [manet] APIs for implementing routing protocols

From: Abhinav Gupta <[email-masked]>
Date: Tue, 06 May 2003 18:28:23 -0600

I am looking for APIs for implementing routing in manets. Can someone 
provide me with the  information on the APIs available for implementing 
the routing protocols?

Thanks,
Abhinav.

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Carlos Miguel Calafate <[email-masked]>
Date: Wed, 07 May 2003 10:02:29 +0200

Hi,

I have implemented a simple library that allows the implementation of 
routing protocols and also achieves inter-platform compatibility for 
WinNT, Linux and WinCE.

It's available at:

http://pica-api.sourceforge.net/

For an example you can check the OLSR implementation at my home page:

http://reptar.grc.upv.es/~calafate/

Best regards,

Carlos

-- 
_________________________________________________
Carlos Miguel Tavares de Araújo Cesariny Calafate
Becário de la Universidad Politécnica de Valencia
e-mail: [email-masked]
http://reptar.grc.upv.es/~calafate/
_________________________________________________
\"In an open world without walls and fences who
needs Windows and Gates?\"

---

From: Matt Miller <[email-masked]>
Date: Wed, 7 May 2003 09:02:47 -0500 (CDT)

You should also check out the Ad-hoc Support Library by Vikas Kawadia, 
Yongguang Zhang and Binita Gupta.  It's at:

http://aslib.sourceforge.net/

-Matt

---

From: "Eugenio Magistretti" <[email-masked]>
Date: Wed, 7 May 2003 16:48:25 +0200

Hi Abhinav,
 An API to develop on-demand protocols under Linux operating system is
discussed in
   V. Kawadia, Y. Zhang, B. Gupta, "System Services for Implementing Ad-Hoc
Routing Protocols"
Best regards,
Eugenio