Subject: [manet] Re: Ad Hoc IP Address Autoconfiguration

From: "Jaehoon Jeong" <[email-masked]>
Date: Tue, 24 Jun 2003 16:27:23 +0900

Hi, Ali.

----- Original Message ----- 
From: "Ali Hamidian" <[email-masked]>
To: <[email-masked]>
Sent: Tuesday, June 24, 2003 12:32 AM
Subject: Ad Hoc IP Address Autoconfiguration

> 
> Hi!
> 
> I started to read your draft today. A question arised when I came to 
> Section 5.1.1, step (c):
> * What is the TTL value used when the mobile node broadcasts the AREQ 
> message?
   TTL value is a system parameter. I think that 10 is appropriate.
   This value should be tuned appropriately, 
   considering the characteristics of the corresponding MANET.

> It seems the TTL value must be "big enough" so that all mobile nodes in 
> the MANET can receive the AREQ message - which resluts in a lot of 
> traffic created in the MANET.
   
   Not at all. Because my scheme adopts the weak or delayed DAD
   for checking the duplication of IP address, it need not big TTL value.
   
   /Jaehoon
   
> 
> Thanks in advance
> Ali Hamidian
> &jw™¨¥Šx%ŠËfjw‰ë_¢¸!¶Úlÿü0ÃXžµú+ƒùšŠYšŸùb²Ø§~æjw

---

From: Ali Hamidian <[email-masked]>
Date: Tue, 24 Jun 2003 12:20:32 +0200

Thanks for your reply Jaehoon!

Now I've also read draft-ietf-manet-autoconf-01.txt. It seems your 
proposal is better than the "autoconf" draft mainly because address 
duplication is detected not only once "at the beginning", but 
continuously thanks to weak DAD, step (f). Is this correct?

Thanks
Ali

---

From: "Jaehoon Jeong" <[email-masked]>
Date: Sat, 26 Jul 2003 19:01:17 +0900

Hi, Ali.

  ----- Original Message ----- 
  From: Ali Hamidian 
  To: Jaehoon Jeong ; [email-masked] 
  Sent: Tuesday, June 24, 2003 7:20 PM
  Subject: Re: Ad Hoc IP Address Autoconfiguration

  Now I've also read draft-ietf-manet-autoconf-01.txt. It seems your proposal is better than the "autoconf" draft mainly because address duplication is detected not only once "at the beginning", but continuously thanks to weak DAD, step (f). Is this correct?

    -> Yes, it is.
         Also, my draft considered the maintenance or survivability of upper layer sessions after the address change.
         I think my suggestion is useful in MANET autoconfiguration.
    
         /Jaehoon

  Thanks
  Ali

  Jaehoon Jeong wrote:

Hi, Ali.----- Original Message ----- From: "Ali Hamidian" <[email-masked]>To: <[email-masked]>Sent: Tuesday, June 24, 2003 12:32 AMSubject: Ad Hoc IP Address AutoconfigurationHi!I started to read your draft today. A question arised when I came to Section 5.1.1, step (c):* What is the TTL value used when the mobile node broadcasts the AREQ message?   TTL value is a system parameter. I think that 10 is appropriate.   This value should be tuned appropriately,    considering the characteristics of the corresponding MANET.It seems the TTL value must be "big enough" so that all mobile nodes in the MANET can receive the AREQ message - which resluts in a lot of traffic created in the MANET.      Not at all. Because my scheme adopts the weak or delayed DAD   for checking the duplication of IP address, it need not big TTL value.      /Jaehoon   Thanks in advanceAli Hamidian