Subject: Re: [manet] Basic question about MANET protocols

From: Young-Jun Lee <[email-masked]>
Date: Tue, 3 Jun 2003 18:57:50 -0400 (EDT)

Hi all,

Is it also possible to retrieve the information in L2 header?

Young

On Tue, 6 May 2003, Ryuji Wakikawa wrote:

> Hi Young.
>
> I use advanced socket API (RFC2292) to retrieve HOPLIMIT(TTL) at
> application layer.
> If you are working on IPv4, you can use IP_TTL socket option to retrieve
> TTL.
>
> Try "%man ip", you could get more information.
>
> regards,
> ryuji
>
> > Hi all,
> >
> > I think MANET protocols belong to the application layer in the sense that
> > they utilize L3 (IP) or L4 (udp broadcast) functions.
> > But I guess that when the IP layer receives a control packet
> > (like RREQ in AODV) and passes it up to a higher layer (AODV),
> > the information in the IP header is not available to the higher layer any
> > more.
> > If this is correct, how can the higher layer like AODV still use that
> > information in the IP header like TTL?
> >
> > Young
> >
> > _______________________________________________
> > manet mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/manet
>
>
>

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Fred Templin <[email-masked]>
Date: Tue, 03 Jun 2003 16:21:04 -0700

>Is it also possible to retrieve the information in L2 header?
On linux, try the packet socket (man 7 packet).

Fred
[email-masked]

---

From: Young-Jun Lee <[email-masked]>
Date: Wed, 4 Jun 2003 12:24:19 -0400 (EDT)

Hi,

Is it possible for MANET protocols to access L2 info?
The linux manual says the packet socket is used at L2.

Young