Subject: [manet] Ad hoc IP address autoconfiguration

From: "Jaehoon Jeong" <[email-masked]>
Date: Mon, 2 Jun 2003 15:14:19 +0900

Hello, manet guys!
I would like to request your comments on my new draft,
"Ad Hoc IP Address Autoconfiguration ".
http://www.ietf.org/internet-drafts/draft-jeong-adhoc-ip-addr-autoconf-00.txt

After four basic ad hoc routing protocols (AODV, DSR, OLSR and TBRPF)
become experimental RFCs, I think, it is time for us to discuss
ad hoc IP address autoconfiguration again.
In my draft, I considered the manet partition and mergence for detecting duplicate address.
Also, I included the mechanism for supporting the survivability of upper-layer sessions
in the case that the duplicate address should be replaced with a new address.
In this 57th ietf meeting, I hope manet wg will discuss the topic related to
ad hoc IP address autoconfiguration.
I'll wait for your comments.
Thanks.

Regards,
Jaehoon
_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Jaehoon Jeong" <[email-masked]>
Date: Tue, 3 Jun 2003 17:01:46 +0900

First of all, thanks for your good comments.
There are my responses inlines.

----- Original Message ----- 
From: "Zhong Fan" <[email-masked]>
To: "'Jaehoon Jeong'" <[email-masked]>
Sent: Tuesday, June 03, 2003 12:42 AM
Subject: RE: [manet] Ad hoc IP address autoconfiguration

> Hi
> 
> I have read your draft and here are my comments:
> 
> 1 As I understand, in IPv6, the originator's address should be part of IPv6
> header instead of in the message itself. Maybe I'm wrong. 
> 

 Yes, you're right. I agree with you. 
 In the next version, I'am going to exclude the originator's IPv6 address field
 from ad hoc IPv6 address autoconf messages.
 But, how about IPv4?
 I think it is the same as IPv6.

> 2 Is weak DAD in your draft the same as Vaidya's method?

 Yes, Prof. Vaidya agreed to give comments on my drafting.
 His method takes an important place in my draft.

> 
> 3 As for upper-layer sessions, the concept of "preferred" and "deprecated"
> addresses for graceful site-renumbering in RFC 2462 is very useful. I am not
> sure how exactly your tunnelling method works -- perhaps you need to put in
> more detail.

  Good comments! 
  In the current draft, I didn't descibe the mechanism of supporting the survivability 
  of upper-layer sessions in detail and just suggested a key idea. 
  In the next version, I'll explain the mechanism more in details, including your comments.

  Thanks a lot.

  Jaehoon

> 
> Cheers, 
> 
> Dr Z Fan
> Toshiba
> 
> -----Original Message-----
> From: Jaehoon Jeong [mailto:[email-masked]] 
> Sent: 02 June 2003 07:14
> To: MANET WG
> Subject: [manet] Ad hoc IP address autoconfiguration
> 
> Hello, manet guys!
> _________________________________________________________________
> The information contained in this message is intended for the addressee only and may contain confidential and/or privileged information.  If you are not the addressee, please delete this message and notify the sender; you should not copy or distribute this message or disclose its contents to anyone. Any views or opinions expressed in this message are those of the author and do not necessarily represent those of Toshiba Research Europe limited or any of its affiliates.  No reliance may be placed on this message without written confirmation from an authorised representative of its contents. Registered in England No.2519556 @ 260 Cambridge Science Park, Milton Road, Cambridge, CB4 0WE
> 
> This message has been scanned for email content security threats
> by MAILsweeper, one of Content Technologies MIMEsweeper family of products. 
> _________________________________________________________________
>