Subject: [manet] (no subject)

From: "reham elmayet" <[email-masked]>
Date: Wed, 18 Jun 2003 12:13:45 +0000

Hello,

I want to ask about  what are the adaptive routing protocols for MANETs and If there are any links can help me to understand them.

Also, can I get the ns-2 to work under windows for free ?

regards,

Reham

MSN 8 with e-mail virus protection service: 2 months FREE*

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Andrew Thiessen" <[email-masked]>
Date: Wed, 18 Jun 2003 10:57:47 -0600

Reham,

Below are two articles that will provide a good introduction into
routing protocols for MANETs.

Scalable routing protocols for mobile ad hoc networks 
Xiaoyan Hong; Kaixin Xu; Gerla, M.; 
Network, IEEE , Volume: 16 Issue: 4 , July-Aug. 2002 
Page(s): 11 -21

A review of current routing protocols for ad hoc mobile wireless
networks 
Royer, E.M.; Chai-Keong Toh; 
Personal Communications, IEEE [see also IEEE Wireless Communications] ,
Volume: 6 Issue: 2 , April 1999 
Page(s): 46 -55

In addition, the following is a link to getting NS-2 working under
Windows.

http://www.isi.edu/nsnam/ns/ns-build.html

Andrew Thiessen

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
reham elmayet
Sent: Wednesday, June 18, 2003 6:14 AM
To: [email-masked]
Subject: [manet] (no subject)

Hello,

I want to ask about  what are the adaptive routing protocols for MANETs
and If there are any links can help me to understand them.

regards,

Reham

  _____  

MSN 8 with e-mail <http://g.msn.com/8HMTEN/2740??PS=>  virus protection
service: 2 months FREE*

_______________________________________________ manet mailing list
[email-masked] https://www1.ietf.org/mailman/listinfo/manet

---

From: "George Hadjichristofi" <[email-masked]>
Date: Thu, 19 Jun 2003 11:34:40 -0400

Hi,

How do new nodes coming into a manet get their ip address?
Is it usually pre-assigned or assigned dynamically?

How can a node in a Manet be uniquely identified, if the IP and MAC address
can be spoofed?

I would appreciate any help on these questions.

Thank you
George Hadjichristofi

***********************************************************
George C. Hadjichristofi
Graduate Student
Bradley Department of Electrical and Computer Engineering
Virginia Tech,Blacksburg,VA 24061,U.S.A
TEL:(540)-951-8936
***********************************************************

---

From: "Jaehoon Jeong" <[email-masked]>
Date: Fri, 20 Jun 2003 18:08:28 +0900

inlines :-)
  ----- Original Message ----- 
  From: George Hadjichristofi 
  To: [email-masked] 
  Cc: George Hadjichristofi 
  Sent: Friday, June 20, 2003 12:34 AM
  Subject: [manet] IP address --unique ID

  Hi,

   -> Actually, most of manet nodes get their address through manual configuration.
        There are many schemes for addressing manet node automatically.
        Among them, I suggested one recently as manet internet-draft entitled
        "Ad Hoc IP Address Autoconfiguration".
        You can find the draft in the following site;
         http://www.ietf.org/internet-drafts/draft-jeong-adhoc-ip-addr-autoconf-00.txt

  How can a node in a Manet be uniquely identified, if the IP and MAC address can be spoofed?

    -> In my scheme, a manet node that finds an IP address duplicate with its own address,
         the node selects another address and tries to autoconfigure the new one.
         For MAC address, there is no consideration.

         /Jaehoon

  Thank you
  George Hadjichristofi