Subject: [manet] reg: AODV route req

From: panneer pandi <[email-masked]>
Date: Sun, 1 Jun 2003 23:40:16 -0700 (PDT)

hai
 
I need a help,
 
in glomosim , they use the function

RoutingAodvHandleProtocolPacket

it is said that it is called from, mac layer.

Can anyone say me where do they call this function.

Another problem, in AODV route request if i give specific address , i am not getting route reply for it(because route request is a packet which should be broadcasted). 

Cannt, we use a specific address for route req, what are changes we need to do.

Please help me.

---------------------------------
Do you Yahoo!?
Free online calendar with sync to Outlook(TM).

---

From: l s <[email-masked]>
Date: Mon, 2 Jun 2003 23:37:22 +0100 (BST)

Hi

RoutingAodvHandleProtocolPacket() is called from:
ProcessPacketForMeFromMac() in network/nwip.pc,
which is called from:
ProcessPacketFromMac() in network/nwip.pc,
which is called from:
NetworkIpReceivePacketFromMacLayer() in
network/nwip.pc,
which is called from the appropriate protocol function
(802.11 / CSMA / ...) in the mac/ directory

When you do a RREQ you request a route to a specific
address, and this address is contained within the
packet but the RREQ packet itself is broadcast.  Does
this answer the question?

Lee -S-
CCSR, University of Surrey, UK

 --- panneer pandi <[email-masked]> wrote:
> Another problem, in AODV route request if i give
> specific address , i am not getting route reply for
> it(because route request is a packet which should be
> broadcasted). 
> 

__________________________________________________
Yahoo! Plus - For a better Internet experience
http://uk.promotions.yahoo.com/yplus/yoffer.html
_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet