Subject: [manet] Internet-MANET gateways?

From: [email-masked] (Ralph Preston)
Date: Thu, 12 Jun 2003 09:39:43 -0400

Hello,

An easy question, has it been defined how a MANET-Internet gateway will 
work?  If it has, please point me to it and don't bother to read the 
rest of this message.  :)

I've been trying to figure out how a MANET gateway will interface with 
the Internet and enable nodes outside the MANET to initiate 
communication with nodes in the MANET.  The way I see it there are 
three possibilities:

1) The gateway advertises routes to each node in the MANET to the 
entire Internet.

2) The gateway runs NAT.

3) Any node who wants to be reachable from outside the MANET must be 
running MobileIP and in IPv4 the gateway must be its Foreign Agent, or 
Home Agent.

Number 1 isn't a good solution since nodes in the MANET wont 
necessarily be route aggregated.  Solution 2 doesn't allow nodes 
outside the MANET to contact nodes within the MANET.  Which leaves 
solution 3, but solution 3 wont work except for nodes that have a 
direct connection with the gateway.  So, is there currently no way for 
outside nodes to contact MANET nodes?

Ralph A. Preston
The MITRE Corporation
202 Burlington Road  MS E095
Bedford, MA 01730-1420
http://www.mitre.org

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Fred Templin <[email-masked]>
Date: Thu, 12 Jun 2003 09:47:01 -0700

Let's not forget also that IPv6 is coming online soon as a possible
solution 4 alternative.

Fred
[email-masked]

Ralph Preston wrote:

> Hello,
>
> An easy question, has it been defined how a MANET-Internet gateway 
> will work?  If it has, please point me to it and don't bother to read 
> the rest of this message.  :)
>

---

From: Joe Macker <[email-masked]>
Date: Thu, 12 Jun 2003 12:47:28 -0400

At 09:39 AM 6/12/2003 -0400, Ralph Preston wrote:
>Hello,
>
>An easy question, has it been defined how a MANET-Internet gateway will work?  If it has, please point me to it and don't bother to read the rest of this message.  :)
>
>I've been trying to figure out how a MANET gateway will interface with the Internet and enable nodes outside the MANET to initiate communication with nodes in the MANET.  The way I see it there are three possibilities:
>
>1) The gateway advertises routes to each node in the MANET to the entire Internet.
>
>2) The gateway runs NAT.
>
>3) Any node who wants to be reachable from outside the MANET must be running MobileIP and in IPv4 the gateway must be its Foreign Agent, or Home Agent.
>
>Number 1 isn't a good solution since nodes in the MANET wont necessarily be route aggregated.  Solution 2 doesn't allow nodes outside the MANET to contact nodes within the 

Why not? In many applications area aggregation is a quite natural address management approach and a prefix or set of prefixes takes care of things.  In many cases, we also autoconfig locally and this is already working for both IPv4 and IPv6.

---

From: Jon Zeeff <[email-masked]>
Date: Thu, 12 Jun 2003 15:40:47 -0400

>
> >Some (most?) of the mesh routing protocols do not have a default route 
> concept.

>If so, I disagree with your general observations.

If I remember correctly, AODV and DSR don't.  I didn't say all and OLSR is 
a good example
of why not.

---

From: Jon Zeeff <[email-masked]>
Date: Thu, 12 Jun 2003 14:06:25 -0400

Some (most?) of the mesh routing protocols do not have a default route 
concept.  This is unfortunate since it means that if you are using a mesh 
network to access another network (say the Internet), you have to do route 
discovery for every single ip address you connect to.
Would be more efficient if one could supply a mask with a route (and more 
specific routes
override less specific ones).

In general, mesh routing protocols are deficient in:

1) security
2) use of metrics other than hop count
3) multipath support
4) communicating routes for more than a single ip address
5) address assignment mechanisms

---

From: [email-masked] (Ralph Preston)
Date: Thu, 12 Jun 2003 15:20:32 -0400

Thank you all very much for your replies, you've been very helpful.  
These two drafts are exactly what I was looking for:

http://www.cs.ucsb.edu/~ebelding/txt/globalv4.txt
http://www.ietf.org/internet-drafts/draft-wakikawa-manet-globalv6-02.txt

Charlie Perkins wrote:
>
> Hello Ralph,
>
> Did you look at our IPv6 gateways draft?
>    http://people.nokia.net/charliep/txt/aodvid/globalv6.txt
>
> There is also an IPv4 gateways draft, authored by a group of
> people including Elizabeth Belding-Royer and Yuan Sun.
>
> These drafts are very similar. The manet nodes treat the Internet
> Gateway as a "default router", even if it is multiple hops away.
>
> Regards.
> Charlie P.

Ralph A. Preston
The MITRE Corporation

---

From: Erik Nordström <[email-masked]>
Date: 12 Jun 2003 18:00:07 +0200

Here are some pointers to drafts:

http://www.ietf.org/internet-drafts/draft-royer-manet-globalv4-00.txt

Erik

---

From: Joe Macker <[email-masked]>
Date: Thu, 12 Jun 2003 16:46:02 -0400

At 03:40 PM 6/12/2003 -0400, Jon Zeeff wrote:

>>>Some (most?) of the mesh routing protocols do not have a default route concept.
>
>If I remember correctly, AODV and DSR don't.  I didn't say all and OLSR is a good example
>of why not.

Right, in my last message I asked if you meant reactive..it was not implied.
Taxonomy helps discussion. Also, the first caveat later devolved into 
implied general observations.

(as an example)
>4) communicating routes for more than a single ip address

Present WG specifications support prefix advertisements and attached networks
in one way or another. This was not always true but has been for awhile.

>5) address assignment mechanisms

For some common Internet-connected deployment cases this is quite simple engineering.
As I have mentioned in the past,  moderate scale operation can be done and has been demonstrated with manet routing and bootstrapping dhcp relay agents involving no specification modifications. This is just an example of one approach working. There are many scenarios that people may deploy routing protocols in requiring different considerations.

Other very esoteric ad hoc methods are possible and there are papers on those.  I believe the INTERNET connected case is the most interesting from the IETF engineering perspective.

----------------------------
In general, all routing protocols have problems and will need to go through evolutionary steps.
This includes wired protocols relating to security,etc.

---

From: Charlie Perkins <[email-masked]>
Date: Thu, 12 Jun 2003 11:45:58 -0700

Hello Ralph,

Regards.
Charlie P.

---

From: Joe Macker <[email-masked]>
Date: Thu, 12 Jun 2003 15:02:32 -0400

At 02:06 PM 6/12/2003 -0400, Jon Zeeff wrote:

>Some (most?) of the mesh routing protocols do not have a default route concept.  This is unfortunate since it means that if you are using a mesh network to access another network (say the Internet), you have to do route discovery for every single ip address you connect to.

Are you using mesh and manet synonymously here? If so, I disagree with your general observations.

This is quite easily supported with OLSR or other proactive appraoches (TBRPF I assume also)...
But what do you mean?  Similar to OSPF ABR functionality default routes can easily be injected for stub mobile routing areas.  We have been doing this with working code for some time now (multiple addresses and connected networks are advertisable at each node).  Aggregate prefixes can be discovered dynamically and appropriate route entries maintained..do you need instructions? Normal address assignment approaches (e.g., DHCP) are also supportable as I have previously posted.  Transit networks of course need additional policy and management approaches to address such issues. All routing protocols tend to have extensions and specific conditions.

We also have working mutiple path and other metric support code extensions working but are keeping that in the research realm for now.

Or are you speaking specifically about reactive? Please be very specific. There is some support for prefix advertisement there as well. Someone else could address whether its been done in practice and how.

>Would be more efficient if one could supply a mask with a route (and more specific routes

---

From: Denis Cobos <[email-masked]>
Date: Fri, 13 Jun 2003 13:23:17 -0400 (VET)

Hello everybody,

I'm interested in using a movement model in my
simulation, but I'm interested in having a tool such
as Setdest already implemented for generating others 
movement models in NS2. I would also like to know if there
exist some improvements on the waypoint model that
were already defined, used or tested for NS2, or if
there are new models to ensure the quality and
validity of the simulation.

Thanks

Best regards
-- 
     *****************************************************
     *                                                   *
     *               Denis Alfonzo Cobos                 *
     *              Escuela de Computacio                *
     *               Facultad de Ciencias                *
     *            Universidad Central de Venezuela       *
     *               Caracas-Venezuela                   *
     *****************************************************

..... Saludos

---

From: "Tao Lin" <[email-masked]>
Date: Fri, 13 Jun 2003 13:08:21 -0400

Search Bonnmotion on google.  It is a good one.

 Tao Lin
 PhD Candidate
 ECE Dept. 
 Virginia Tech

---

From: Carlos Alberto Vieira Campos <[email-masked]>
Date: Fri, 13 Jun 2003 16:24:25 -0300 (BRT)

Denis,
 
I recommend you to look the ScenGen Simulator, a tool to generate
MANET mobility scenarios for NS-2. It support individual and group
mobility models. It can be found in 
http://www.comp.nus.edu.sg/~liqm/scengen/
 
Good luck,
 
Carlos Alberto.

---

From: Carlos Alberto Vieira Campos <[email-masked]>
Date: Fri, 13 Jun 2003 14:58:48 -0300 (BRT)

Denis,

I recommend to look the ScenGen Simulator, a tool for to generate
MANET mobility scenarios for NS-2. It support individual and group
mobility models. It can be meeted in 
http://www.comp.nus.edu.sg/~liqm/scengen/

Good luck,

Carlos Alberto.