Subject: FW: [manet] Comment on draft-spagnolo-manet-ospf-wireless-interface-00

From: "Spagnolo, Phillip A" <[email-masked]>
Date: Wed, 17 Dec 2003 09:38:54 -0800

Comments included.

> -----Original Message-----
> From: Richard Ogier [mailto:[email-masked]]
> Sent: Tuesday, December 16, 2003 10:32 PM
> To: [email-masked]
> Subject: [manet] Comment on
> draft-spagnolo-manet-ospf-wireless-interface-00
> 
> 
> I have a comment regarding
> draft-spagnolo-manet-ospf-wireless-interface-00
> 
> Suppose router A is an edge router (with both a wireless interface
> and a wired interface) that is configured as a stub, and router B
> is a neighbor of A with only a wireless interface.
> Also suppose that router A has received "outside" LSAs originated
> from outside the wireless subnet, which it does not forward to
> router B (since it is a stub).  Further suppose that *all* routers in
> the network (including non-wireless routers) are in the same area.
> 
> There appears to be a problem, because OSPF assumes that all routers
> in the same area have the same link-state information for the area,
> but routers A and B have different information.
> To reach a destination outside the wireless subnet, router B will
> use the default route and thus forward the packet to router A.
> Since router A has more information than router B, router A will
> compute the shortest path to the destination, which might happen
> to go through router B, thus forming a routing loop.
> (The draft states that the routing table is calculated as in OSPF.)

I don't seem to see the problem here. 
 
If router B sends a packet outside the wireless stub through router A, how will A ever think to send back to router B?  The shortest path cannot be through the wireless network because the only way out of the wireless network is through A.  Any path back into the network would add the additional cost of the loop.  

Router A has a full view of the network, but router B only has a view of the wireless stub and a default to A.  

Maybe the problem is textual in that we are assuming there is only one edge router in a wireless stub.  Otherwise, the network would not be a stub but a transit wireless network.

We do agree the mechanism is functionally equivalent to a totally stubby area, but this is not specified in 2328.

> 
> If instead, an OSPF stub area is configured which includes only the
> wireless routers, with router A as an area border router, this problem
> is avoided, because in OSPF, router A would use only backbone summary
> LSAs to compute routes to destinations outside the area, and thus
> would not send the packet back into the wireless area.
> 
> Am I missing something?  Why don't you simply use an OSPF stub area
> to avoid flooding outside LSAs within the wireless subnet
> (as per Section 12.4.3.1 of RFC 2328)?
> 
> Also, I should point out that there has been some discussion on
> the OSPF list regarding how to approach the problem of extending
> OSPF to support MANETs.
> 
> http://peach.ease.lsoft.com/scripts/wa.exe?A1=ind0312&L=ospf
> 
> Regards,
> Richard
> 
> 
> 
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/manet
> 

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Richard Ogier <[email-masked]>
Date: Wed, 17 Dec 2003 10:51:18 -0800

Phillip,

>If router B sends a packet outside the wireless stub through router A, how will A ever think to send back to router B?  The shortest path cannot be through the wireless network because the only way…
You are assuming that there is only one edge router.  But your draft 
defines an edge router as
"A router that has more than one interface and at least one of these 
interfaces is a wireless interface."
So the draft does not preclude multiple edge routers.   I wouldn't want 
to preclude this anyway.

>Maybe the problem is textual in that we are assuming there is only one edge router in a wireless stub.  Otherwise, the network would not be a stub but a transit wireless network.
A stub network can have multiple edge routers.   In OSPF terms, a stub 
area can have multiple
area border routers.

>We do agree the mechanism is functionally equivalent to a totally stubby area, but this is not specified in 2328.
Indeed it is provided in Section 12.4.3.1 of RFC 2328, as I discussed 
with Vishwas.
A stub area is not *required* to be "totally stubby", but the RFC allows 
suppressing all summary LSAs,
for exactly the reason we have in mind.

In general, as I discussed on the OSPF list, my view is that it is 
possible to extend OSPF to support
MANET interfaces using something that is much closer to OSPF than what 
your draft proposes.
I think the OSPF WG would like to minimize the changes/additions to OSPF.

Richard