Subject: [manet] Re: How to do the simulation with ns2 for hybrid wireless network?

From: "HyunWook Cha" <[email-masked]>
Date: Sat, 13 Dec 2003 17:26:12 +0900

Hello, minh tam.

Actually I have never simulated this kind of scenario where AODV provides internet connectivity for a mobile node with MIP. I have only AODV internet connectivity simulations. 
Right. The example in ns2 does not provide what you want. As I mentioned before, I am also interested in this scenario and could check existing facility (mainly mobilenode architecture in tcl side) for this task. That is, base station with AODV plus HA(or FA) and mobile node with AODV plus MN can be provided in NS2 without your effort. 

Since I have not looked though MIPv4 implementation in ns2, I can help you much. But , what I am going to do are as follow.

1. When MIPMH agent want to discover available agents(HA or FA), it sends broadcast agent solicitation. If no agents are available within one hop range(some timer expires), MIPMH agent gets information(hop count, per_hop_time etc..) about reachable GWs from AODV and send agent solicitation msg to selected one or multiple GWs. It can set timeout value using information from AODV. Then, MIPMH agent try MIP registration through FA(s) which sent the agent advertisement received firstly or within some period.        

2. If AODV does not have available GW info, AODV send GW solicitation. When AODV finds available GWs, above 1 can be done succesfully. 

3. Embedding MIP adv solication message to broadcast GW solicitation message(modified RREQ) by defining new flag(MIP adv) can reduce delay for Agent discovery. 

As you can see, I consider MIPMH agent as a client of AODV and AODV provides only route discovery and GW infos for MIP agent. Different approaches can be possible. 

I hope that this suggestion can be helpful. 

Have a nice weekend.

HyunWook Cha.
  ----- Original Message ----- 
  From: minh tam 
  To: [email-masked] 
  Sent: Saturday, December 13, 2003 1:08 PM
  Subject: How to do the simulation with ns2 for hybrid wireless network?

  Hi,

  Please see my attachment .
  Thanks so much for your help!

------------------------------------------------------------------------------
  Yahoo! Personals
  - New people, new possibilities. FREE for a limited time!

---

From: [email-masked]
Date: Sat, 13 Dec 2003 11:20:40 +0100 (CET)

Hello,

Why don't you have a look at any of the existing publications that solves
exactly what you are trying to do? The below are just a few, there is more
of them out there. Check google.

For example:
"AODV and IPv6 Internet Access for Ad hoc Networks",
Nilsson et al. ACM SIGMOBILE Mobile Computing and Communications Review 
archive Volume 6 ,  Issue 3  (July 2002).

"Providing internet access to mobile ad hoc networks".
George Andreadis, University College London.

Global connectivity for IPv6 mobile ad hoc networks, " Internet Draft
(Work in Progress) draft-wakikawa-manet-globalv6-03.txt, Internet
Engineering Task Force.

 "Internet connectivity for ad hoc mobile networks," International Journal
of Wireless Information Networks, Special Issue on Mobile Ad hoc
Networks, 2002. Yuan Sun, Elizabeth M. Belding-Royer, and Charles E.
Perkins.

Internet connectivity for mobile ad hoc networks
WIRELESS COMMUNICATIONS AND MOBILE COMPUTING
Wirel. Commun. Mob. Comput. 2002; 2:465– 482 (DOI: 10.1002/wcm.71)
Perkins et.al.

 "Global Connectivity for IPv4 Mobile Ad hoc Networks."IETF Internet
Draft, draft-royer-manet-globalv4-00.txt, November 2001 (Work in
Progress).
Elizabeth M. Belding-Royer, Yuan Sun, and Charles E. Perkins.

I also strongly recomend MIPMANET, that also builds on AODV like you
describe:

"MIPMANET-Mobile IP for Mobile Ad Hoc Networks." in Proceedings of
IEEE/ACM Workshop on Mobile and Ad Hoc Networking and Computing, Boston,
MA USA, August 1999.

There is also a NS-2 package that do this for you: AODV+
You can find it on the NS-2 webpage:
http://www.isi.edu/nsnam/ns/ns-contributed.

regards,

Anders

> Hello, minh tam.
>
> Actually I have never simulated this kind of scenario where AODV provides
> internet connectivity for a mobile node with MIP. I have only AODV
> internet connectivity simulations.
> Right. The example in ns2 does not provide what you want. As I mentioned
> before, I am also interested in this scenario and could check existing
> facility (mainly mobilenode architecture in tcl side) for this task. That
> is, base station with AODV plus HA(or FA) and mobile node with AODV plus
> MN can be provided in NS2 without your effort.
>
> Since I have not looked though MIPv4 implementation in ns2, I can help you
> much. But , what I am going to do are as follow.
>
> 1. When MIPMH agent want to discover available agents(HA or FA), it sends
> broadcast agent solicitation. If no agents are available within one hop
> range(some timer expires), MIPMH agent gets information(hop count,
> per_hop_time etc..) about reachable GWs from AODV and send agent
> solicitation msg to selected one or multiple GWs. It can set timeout value
> using information from AODV. Then, MIPMH agent try MIP registration
> through FA(s) which sent the agent advertisement received firstly or
> within some period.
>
> 2. If AODV does not have available GW info, AODV send GW solicitation.
> When AODV finds available GWs, above 1 can be done succesfully.
>
> 3. Embedding MIP adv solication message to broadcast GW solicitation
> message(modified RREQ) by defining new flag(MIP adv) can reduce delay for
> Agent discovery.
>
> As you can see, I consider MIPMH agent as a client of AODV and AODV
> provides only route discovery and GW infos for MIP agent. Different
> approaches can be possible.
>

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "HyunWook Cha" <[email-masked]>
Date: Mon, 15 Dec 2003 09:01:59 +0900

Hello, Anders.

Thanks for many references. I already refered most of them. Do not
misunderstand that I am trying to do this job overlooking existing good
research results. As I already mentioned, I just want to compare my I-D
with the integration of AODV and MIPv6 through NS-2 simulation. I also
finished implementing my extended support for AODV internet
connectivity. So, I am trying to integrate AODV and MIPv6. As far as I
know, there exist no pulbic NS2 implementations for this. If you know,
please correct me. 

MIP-MANET fits for minh Tam who are discussing about this with me, but
does not for me since I want MIPv6 plus AODV. 

I just mentioned my idea for integrating existing AODV with existing
MIPv6 with minimal modification in NS2. And I do not insist that my list
of implementation consideration(or rough design) is absolutely new and
correct. 

Anyway, thank you for listing nice papers related to this subject. 

HyunWook Cha

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> Sent: Saturday, December 13, 2003 7:21 PM
> To: HyunWook Cha
> Cc: [email-masked]
> Subject: Re: [manet] Re: How to do the simulation with ns2 
> for hybrid wireless network?
> 
> 
> 
> Hello,
> 
> Why don't you have a look at any of the existing publications 
> that solves exactly what you are trying to do? The below are 
> just a few, there is more of them out there. Check google.
> 
> For example:
> Global connectivity for IPv6 mobile ad hoc networks, " 
> Internet Draft (Work in Progress) 
> draft-wakikawa-manet-globalv6-03.txt, Internet Engineering Task Force.
> 
>  "Internet connectivity for ad hoc mobile networks," 
> International Journal of Wireless Information Networks, 
> Special Issue on Mobile Ad hoc Networks, 2002. Yuan Sun, 
> Elizabeth M. Belding-Royer, and Charles E. Perkins.
> 
> Wirel. Commun. Mob. Comput. 2002; 2:465- 482 (DOI: 
> 10.1002/wcm.71) Perkins et.al.
> 
>  "Global Connectivity for IPv4 Mobile Ad hoc Networks."IETF 
> Internet Draft, draft-royer-manet-globalv4-00.txt, November 
> 2001 (Work in Progress). Elizabeth M. Belding-Royer, Yuan 
> Sun, and Charles E. Perkins.
> 
> "MIPMANET-Mobile IP for Mobile Ad Hoc Networks." in 
> Proceedings of IEEE/ACM Workshop on Mobile and Ad Hoc 
> Networking and Computing, Boston, MA USA, August 1999.
> 
> > Actually I have never simulated this kind of scenario where AODV 
> > provides internet connectivity for a mobile node with MIP. 
> I have only 
> > AODV internet connectivity simulations. Right. The example 
> in ns2 does 
> > not provide what you want. As I mentioned before, I am also 
> interested 
> > in this scenario and could check existing facility (mainly 
> mobilenode 
> > architecture in tcl side) for this task. That is, base station with 
> > AODV plus HA(or FA) and mobile node with AODV plus MN can 
> be provided 
> > in NS2 without your effort.
> >
> > Since I have not looked though MIPv4 implementation in ns2, 
> I can help 
> > you much. But , what I am going to do are as follow.
> >
> > 1. When MIPMH agent want to discover available agents(HA or FA), it 
> > sends broadcast agent solicitation. If no agents are 
> available within 
> > one hop range(some timer expires), MIPMH agent gets information(hop 
> > count, per_hop_time etc..) about reachable GWs from AODV and send 
> > agent solicitation msg to selected one or multiple GWs. It can set 
> > timeout value using information from AODV. Then, MIPMH 
> agent try MIP 
> > registration through FA(s) which sent the agent 
> advertisement received 
> > firstly or within some period.
> >
> > message(modified RREQ) by defining new flag(MIP adv) can 
> reduce delay 
> > for Agent discovery.
> >

---

From: "HyunWook Cha" <[email-masked]>
Date: Mon, 15 Dec 2003 09:32:02 +0900

Hello.

I should correct my previous response. Actually, my list is related to
the integration of MIPv4 and AODV, and it is not exactly what I am going
to do.   

Regards,

HyunWook Cha

> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of HyunWook Cha
> Sent: Monday, December 15, 2003 9:02 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: RE: [manet] Re: How to do the simulation with ns2 
> Thanks for many references. I already refered most of them. 
> Do not misunderstand that I am trying to do this job 
> overlooking existing good research results. As I already 
> mentioned, I just want to compare my I-D with the integration 
> of AODV and MIPv6 through NS-2 simulation. I also finished 
> implementing my extended support for AODV internet 
> connectivity. So, I am trying to integrate AODV and MIPv6. As 
> far as I know, there exist no pulbic NS2 implementations for 
> this. If you know, please correct me. 
> 
> MIP-MANET fits for minh Tam who are discussing about this 
> with me, but does not for me since I want MIPv6 plus AODV. 
> 
> I just mentioned my idea for integrating existing AODV with 
> existing MIPv6 with minimal modification in NS2. And I do not 
> insist that my list of implementation consideration(or rough 
> design) is absolutely new and correct. 
>

---

From: Manish Karir <[email-masked]>
Date: Mon, 15 Dec 2003 14:20:09 -0500 (EST)

I would also like to point out:
    - J. McGee, M. Karir, et. al., Implementing Ad Hoc to Terrestrial
      Network Gateways, in Proceedings of 2nd International Conference
      on Wired/Wireless Internet Communications (WWIC 2004), Frankfurt,
      Germany, Feb 2004.

in which we take a different approach.  Instead of using MIP we integrate
a terrestrial routing protocol with an adhoc routing
protocol(OSPF<->AODV, or MOSPF<->MAODV)
The gateway is implemented in Linux....

please let me know if you would like a copy of this paper...or the
modified AODV code...no modifications were necessary to OSPF(/MOSPF)

-manish

---

From: "Charles E. Perkins" <[email-masked]>
Date: Tue, 16 Dec 2003 09:48:26 -0800

Hello Manish,

Thanks for forwarding the paper to me.  It is
interesting work, and leads me to believe that
the Internet Gateway drafts should be reissued
to handle multicast also, using some of your
ideas about multicast operation of the gateway.

However, I have a few quibbles with some of
the claims of the paper.

You make the assumption that the nodes in the
ad hoc network are all addressable from a
subnet prefix advertised by the gateway.
I am sure you do not intend to claim this as
novel, but the paper presents the idea as an
insightful solution to previous complexity.
The overall presentation in this regard
should (instead) point out the following
ideas:

- The publications for Internet Gateway operation
  with Mobile IP can _only_ work if the gateway
  advertises reachability to such a prefix.  The
  idea of address aggregation is fundamental to
  the work, and thus must be regarded as implicit

- Eliminating the possibility of routing within the
  ad hoc network to non-aggregable addresses is not
  only a simplifying assumption, it is almost a
  disablement.  One of the prime motivating factors
  for research into ad hoc networks is to allow nodes
  to communicate without infrastructure (e.g., no
  gateways or default routers).  If a gateway happens
  to become reachable, so much the better!

- As a minor point, I don't think that using
  address aggregation provides very much simplification
  for duplicate address detection within the ad hoc
  network.  Of course, with strict address assignment
  rules, you can enforce that ad hoc node addresses
  do not duplicate addresses found within the Internet,
  which isn't feasible otherwise.  As long as you
  have a connection to the Internet, that is...
  Are you assuming that Internet connectivity is
  stable for the life of the ad hoc network?

I agree with you that the gateway should shield
the Internet from knowledge of the topology
changes within the ad hoc network, and that the
"wired-side" (<-- soon to be an anachronism)
protocols should not be required to change.
That was also a design goal for the protocols
specified in the Internet Gateways publications
that you cited in your paper.

Thanks again for the interesting paper and ideas
about multicast routing.

Kind Regards,
Charlie P.

Manish Karir wrote:
> > Wirel. Commun. Mob. Comput. 2002; 2:465- 482 (DOI: 10.1002/wcm.71)
> > Perkins et.al.
> >

---

From: "Pedro M. Ruiz" <[email-masked]>
Date: Tue, 16 Dec 2003 19:09:21 +0100

Dear Manish,

Thank you for sending the paper to me as well. I found it very interesting,
although I still have to look at it at a greater detail. I agree with
Charlie that the multicast interworking is an interesting issue to deal
with. We worked out some solution but I did not comment on the list because
I saw not much discussion regarding this topic. In fact, we wrote an I-D on
this, but finally did not send it. May be we submit it as an individual
submission. We'd be open to comment with people interested on this trying to
agree on a nice standard solution for this, even if it differs from our
proposal. I'd be very happy to hear your comments.

Keeping the requirent of introducing no changes in the "wired-side"
protocolos most commonly used (i.e. MSDP, MBGP and PIM) we proposed the idea
of MIGs (Multicast Internet Gateways). The basic assumption is that the
access routers remain the same, and ad hoc nodes being just one hop away
from them, are in charge of generating IGMP reports accordingly.

For a detailed discussion on this topic, you can check these papers. Should
you be interested in having a look at them, please drop me an e-mail and
I'll provide you with a copy of the paper. We also have some implementations
of the proposed approach which we may share if you're interested:

Pedro M. Ruiz, Antonio Gomez-Skarmeta and Ian Groves, "The MMARP Protocol
for Efficient Support of Standard IP Multicast Communications in Mobile Ad
hoc Access Networks". In proc. of the IST Mobile & Wireless Communications
Summit 2003. Aveiro, Portugal, 15-18 June 2003. pp. 478-482

Pedro M. Ruiz, Antonio Gomez-Skarmeta, Pedro Martinez and David Larrabeiti.
"Extending Seamless IP Multicast Edge-Coverage Through Mobile Ad Hoc Access
Networks". Ad Hoc, Mobile and Wireless Networks. Lecture Notes in Computer
Science, Vol. 2865 (LCNS-2865). Ed: Springer-Verlag, ISSN:0302-9743. pp.
84-95. October 2003.

Best wishes,

Pedrom

> -----Mensaje original-----
> De: [email-masked] [mailto:[email-masked]]En nombre de
> Charles E. Perkins
> Enviado el: 16 December 2003 18:48
> Para: Manish Karir
> CC: [email-masked]
> Asunto: Re: [manet] Re: How to do the simulation with ns2 for hybrid
> wireless network?
>
>
>
> Hello Manish,
>
> that solves
> International Journal

---

From: Manish Karir <[email-masked]>
Date: Tue, 16 Dec 2003 17:45:23 -0500 (EST)

Hello,

I agree the unicast gateway work is fairly obvious but was included
for two reasons....the first for completeness and the second reason
was that I did want to emphasis that I do believe that the *only*
practical way to deploy a MANET is via an aggregatable address space.
Relaxing this requirement is just not feasible. In particular this was
aimed at recent discussion on the mailing list regarding routing loops
being formed when nodes from the terrestrial network move to the ad hoc
side etc.......basically allowing for that to happen only creates more
problems than it solves.

We need to do this because then the problem of assigning globally unique
address to adhoc nodes becomes much more manageable.  Otherwise we have
to deal with the problem of having to perform duplicate address detection
across all the nodes in the internet!.  Furthermore, if you look at how
networks are deployed these days....they are pretty much a collection
of subnet.....and the IANA has control over who uses what address space,
so if an entity was to commercially deploy an ad hoc network that *could*
possible connect to the internet, the first thing they would have to do is
to get an address space from IANA.  This would make them the responsible
party for that address space(which is very important in these days of DDoS
attacks, atleast you would have someone you could hold accountable).

its either this or NAT...and nobody wants that right? ;)

on a more philosophical perspective....in my opinion though the concept of
a "pure" adhoc network is nice, in practice it is actually quite limiting.
The content resides in the terrestrial networks.  Sooner or later if
adhoc networks want to get useful work done they will need to connect back
to the terrestrial network(maybe transient).  Hence gateways of some form
are essential.  The lack of gateway development till such a late stage,
has in my opinion severely restricted actual useful deployments of adhoc
networks in real life.

-manish

---

From: "Charles E. Perkins" <[email-masked]>
Date: Tue, 16 Dec 2003 15:51:46 -0800

Hello Manish,

I wonder if you'd be willing to provide your
justification for the following statement:

Manish Karir wrote:
>            I did want to emphasis that I do believe that the *only*
> Relaxing this requirement is just not feasible.

If routing loops are formed, then I think it has to
be regarded as a bug in some routing protocol, not a
reason to restrict addressability.  It is true, on
the other hand, that I am writing this before I go
find the messages you refer to, otherwise I might not
ever write again (if I have to find sufficiently many
old messages, that is).

> move to the ad hoc side etc  ...      basically
> allowing for that to happen only creates more
> problems than it solves.

Then you are speaking about a particular case, with
particular assumptions.  If you have an "ad-hoc" side,
and another side, and the routing protocols are not
compatible (perhaps because of bugs on the "other side"),
then O.K. you can't do it.  But to say that the movement
itself causes the problems, is manifestly incorrect.
And if a routing protocol is correct, but stimulates
bugs in another routing protocol, then ... you have
to evaluate what's worth it to you -- or else fix
the bugs.  On the other hand, in your paper, it is an
axiom that one mustn't mess with the protocol on the
"other side".

Notably, manet was created because some of those
protocols on the "other side" did not work.  If the
point is to insert their presence, bugs and all,
and then to characterize the ad hoc protocols as
"broken", then I would not agree.

> address to adhoc nodes becomes much more manageable.

Well, I disagree, because I think that you are
putting the cart before the horse.  If you start
from a population of nodes where the addresses are
_already_ assigned, then you may not have the luxury
of aggregating their addresses.  If you can assign
addresses, then it would be silly not to do as you
suggest, of course!  If you wish to state that you
just don't want to serve the former node populations,
then I will understand that you have that luxury.

>                            Otherwise we have
> across all the nodes in the internet!.

This isn't correct, as we showed by the use of
Mobile IP.  The important thing is to avoid
injecting ad hoc host routes into the Internet.

  Furthermore, if you look at how
> of subnet.....and the IANA has control over who uses what address space,

That sounds like infrastructure to me.  You may take
my remarks as a suggestion that ad hoc networking is
useful even when infrastructure isn't available.

> to get an address space from IANA.

I interpret this to mean that a router needs an allocated
prefix.  Check!

Even if the router is a gateway to an ad hoc network.
Check!

Even if the ad hoc network has nodes that have preassigned
addresses that are topologically incorrect.
Check!

What am I missing...?

>                         This would make them the responsible

This is a totally irrelevant red herring!

> its either this or NAT...and nobody wants that right? ;)

Likewise.

> a "pure" adhoc network is nice, in practice it is actually quite limiting.

In my opinion the idea of pure "X" is quite nice, but in practice
it is quite limiting.  If you want me to say that I think the
Internet is irrelevant and since we don't need it, we can all
go off and play "ad hoc" games, then surprise I don't think that.
If you want me to say that my peer-to-peer applications should
work _whether or not_ there is a default router, as long as I
am in wireless range of my peer, then I'll happily say that!

> has in my opinion severely restricted actual useful deployments of adhoc

I still say you are putting the cart before the horse,
and furthermore now seem to be imputing wrong motives to
the researchers involved with ad hoc networks.

Regards,
Charlie P.