Subject: [manet] How to create a new protocol based on AODV??

From: [email-masked]
Date: Thu, 11 Dec 2003 19:09:04 -0500

Dear all,

If i want to create a new protocol (with load balancing feature for example) 
based on AODV. Do i have to modify the aodv.cc and recompile it all over again.
OR, there is any way to develop then new protocol in NS-2.  

I would really appreciate any hints.

Thanks.

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "HyunWook Cha" <[email-masked]>
Date: Fri, 12 Dec 2003 10:07:25 +0900

Hi,

I suggest that your new routing protocol be inherit from AODV agent in
c++ side and be called Agent/Your_Agent_Name in tcl space if your design
allows. Of course, new packet structures include existing AODV packets.
However, it is not bad to write little bit dirty codes by modifying
existing files for AODV and test it before you create new routing agent
separted from AODV agent. 
 
Cheers

HyunWook Cha

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of [email-masked]
> Sent: Friday, December 12, 2003 9:09 AM
> To: [email-masked]
> Subject: [manet] How to create a new protocol based on AODV??
> 
> 
> 
> 
> 
> Dear all,
> 
> based on AODV. Do i have to modify the aodv.cc and recompile 
> it all over again. OR, there is any way to develop then new 
> protocol in NS-2.  
>