Subject: [manet] DSR unidirectional links

From: "Michael Voorhaen" <[email-masked]>
Date: Thu, 18 Dec 2003 10:56:26 +0100

Hi, 

Recently I've been looking into the use of unidirectional links in MANETs,
and am trying to figure if they can be used as an advantage. Naturally I
turned myself to DSR, since the draft says it supports unidirectional links
and there is already a lot of code available that I can work with.
Implementing the RREP being piggybacked on a RREQ was not that difficult.
But implementing Route Maintenance is trickier, and I am starting to think
that this is the reason why very little effort is being made about research
into unidirectional links. As the draft describes you can use link layer,
passive and network layer acks. The first two are not feasible in this case.
So we would have to use network layer acks. However these acks might need to
return over an entirely different route to the previous hop and that route
needs to be found and maintained. It seems to me that there are many
disadvantages to this approach, and that it will be difficult to quickly
notice a link failure.

Does anybody know of any other work directed at these problems?

Regards,
Michael Voorhaen

========================================================
Michael Voorhaen
========================================================
Phd Student
Dept. of Mathematics and Computer Sciences
PATS (Performance Analysis of Telecommunication Systems)
University of Antwerp
Middelheimlaan 1
2020 Antwerpen, Belgium
G1.11
Phone: 03/2653905
Mail: [email-masked]
========================================================

---

From: "Richard Draves" <[email-masked]>
Date: Thu, 18 Dec 2003 09:52:04 -0800

> Recently I've been looking into the use of unidirectional 
> links in MANETs, and am trying to figure if they can be used 
> as an advantage. Naturally I turned myself to DSR, since the 
> draft says it supports unidirectional links and there is 
> already a lot of code available that I can work with. 
> Implementing the RREP being piggybacked on a RREQ was not 
> that difficult. But implementing Route Maintenance is 
> trickier, and I am starting to think that this is the reason 
> why very little effort is being made about research into 
> unidirectional links. As the draft describes you can use link 
> layer, passive and network layer acks. The first two are not 
> feasible in this case. So we would have to use network layer 
> acks. However these acks might need to return over an 
> entirely different route to the previous hop and that route 
> needs to be found and maintained. It seems to me that there 
> are many disadvantages to this approach, and that it will be 
> difficult to quickly notice a link failure.

The Microsoft Research implementation of DSR supports unidirectional
links using network layer acks for route maintenance. Works great.

Rich

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet