Subject: Re: [MANET] How to emulate encryption time

From: [email-masked]
Date: Thu, 18 Dec 2003 20:26:35 -0600

Question
-------------

From: "Leiyuan Li" <[email-masked]>
To: <[email-masked]>
Subject: [MANET] How to emulate encryption time
Date: Thu, 18 Dec 2003 13:58:52 -0500

I'm making a simulator for testing the performance of SAODV.  Since the =
encryption/decryption algorithm constitutes a significant time in packet =
processing, I want to include this time into the simulation.  I wonder, =
when estimating the time for encryption/decryption, is it a common =
practice to run a seperate encryption/decryption program to test the =
time for cryptographic algorithms on a machine with certain =
computational power, and manually set this delay as a parameter to the =
simulator?  Or, did people actually run the encryption/decryption inside =
the simulator to test the time?

Response
---------------

I assume that "to test the time" means "to test the latency performance
through a node or through a network."

In that case, we just set the delay to be a parameter provided to the
simulator to speed up the simulation if all we want to do is run the
simulation to test latency performance.

Jim

P.S.  some other random, but somewhat related thoughts are:

Don't forget to include other non-obvious moderately large delays that can
arise from things like OS scheduling or interrupt processing or hardware
power up times from sleep modes.

It should be possible to build encryption accelerators to either reduce
power consumption and/or speed up the encryption/decryption for many
hardware implementations.

Are you considering the different latency performances of the various MAC
protocols which can vary widely over a range of conditions (such as nodal
densities from just two nodes to tens or even hundreds of nodes) or
congestion (from very lightly loaded to heavily congested)?

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "HyunWook Cha" <[email-masked]>
Date: Fri, 19 Dec 2003 15:20:15 +0900

Hello.

I am also ineterested in this issue. I know that a lot of papers are
related in the security mechanism in MANET area and authors of most of
them conducted simulation works with NS2 or whatever. So, more accurate
answers including assumption about encryption/decryption processing
delay and implementation delails can be given from them.(I want to hear
that.) Although I do not have experiences in this, I think that we do
not have to perform actual processing as most parts of simulation do, so
we need some constant value for delay and next thing we have to do is to
pass over new event for notifying the termination of enc/dec work with
current time plus given delay to scheduler. For event hanlder to make
next correct procedure start, the event also should have some parameter
which can tell the context in which this event was generated. Since I am
not sure, anyone who has experience with this issue can overwrite my
thought. ^^

Regards,

HyunWook  

+++++++++++++++++++++++++++++++++++++++++++++ 

-    0               HyunWook Cha                         
-    |                                 
0 - 0 - 0          Researcher 
-    |               NGI Standards Research Team 
-    0               PEC/ETRI, KOREA
-    |               (Tel) +82-42-860-1076
-    0  
    The truth will set you free.              - John 8:32 -
++++++++++++++++++++++++++++++++++++++++++++++

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of [email-masked]
> Sent: Friday, December 19, 2003 11:27 AM
> To: [email-masked]
> Subject: Re: [MANET] How to emulate encryption time
> 
> 
> 
> 
> 
> 
> 
> Question
> -------------
> 
> I'm making a simulator for testing the performance of SAODV.  
> Since the = encryption/decryption algorithm constitutes a 
> significant time in packet = processing, I want to include 
> this time into the simulation.  I wonder, = when estimating 
> the time for encryption/decryption, is it a common = practice 
> to run a seperate encryption/decryption program to test the = 
> computational power, and manually set this delay as a 
> parameter to the = simulator?  Or, did people actually run 
> the encryption/decryption inside = the simulator to test the time?
> 
> Response
> ---------------
> 
> I assume that "to test the time" means "to test the latency 
> performance through a node or through a network."
> 
> In that case, we just set the delay to be a parameter 
> provided to the simulator to speed up the simulation if all 
> we want to do is run the simulation to test latency performance.
> 
> Jim
> 
> Don't forget to include other non-obvious moderately large 
> delays that can arise from things like OS scheduling or 
> interrupt processing or hardware power up times from sleep modes.
> 
> It should be possible to build encryption accelerators to 
> either reduce power consumption and/or speed up the 
> encryption/decryption for many hardware implementations.
> 
> Are you considering the different latency performances of the 
> various MAC protocols which can vary widely over a range of 
> conditions (such as nodal densities from just two nodes to 
> tens or even hundreds of nodes) or congestion (from very 
> lightly loaded to heavily congested)?
> 
> 
> 
> 
> 
> 
> 
>