Subject: [manet] about the good path model in MANET

From: [email-masked]
Date: Tue, 23 Dec 2003 15:52:01 +0800 (HKT)

Hi all,
I am doing some work on the selfishness of nodes in ad 
hoc network.
I need to model a good path which includes only non-
selfish node.
if the packet delivery behavior of a path pcan be 
modeled through a random variable R(p),we define
R(p) = 1; if p correctly de;ivers the data pkt to dest;
R(p) = 0; otherwise

we know that there many reasons causing the failure of 
pkt delivery.such as wireless random loss, content loss 
or congestoin loss.
My question is ,can we say that in lightly loaded 
network scenario ,where wireless random loss dominates 
the pkt loss,the above random varialbe R(p) follows the 
Bernoulli distribution?
How about the model in heavily loaded scenario?

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: [email-masked]
Date: Tue, 23 Dec 2003 07:37:33 -0700

Hi,

The Bernoulli distribution requires that 1) there be exactly two possible 
outcomes, 2) successive values be independent, and 3) the probability of 
success be constant.  Clearly, condition 1) is satisfied.  Whether or not 2) 
is satisfied depends on the assumptions you are willing to make about the RF
environment.  For example, some types of interference and noise events can 
disrupt more than one packet in succession.  However, independence is often 
assumed.  The real problem is 3).  

Because we are talking of a mobile network, it can safely be assumed that the 
probability of success will not be constant.  

I think, instead, what you want to do is model the probability of reception as 
a random process which is indexed on, at least, distance.  This would give you 
more realistic results.

John Mullen