Subject: [manet] Regarding Simulatiuon of AODV and TORA

From: "Karun Verma" <[email-masked]>
Date: Fri, 09 Jan 2004 11:47:33 +0530

When i want to simulate protocols aodv and tora using the script 
wireless1.tcl in ~ns/tc/ex directory
i get thye following errors

invalid command name "tora-create-mobile-node"
    while executing
"tora-create-mobile-node $i"
    invoked from within
"if { [string compare $opt(rp) "dsr"] == 0} {
        for {set i 0} {$i < $opt(nn) } {incr i} {
                dsr-create-mobile-node $i
        }
} elseif { [string compare $opt..."
    (file "wireless_tora.tcl" line 209)

i have modified the script.
What else modifications i have to do for both these protocols.
Help me. with this mail i am attaching the script "wireless_tora.tcl"

thanx in advance

############################################

#                              Karun Verma                                   
      #

###########################################

_________________________________________________________________
Games, MMS cards, ringtones. Operator logos, picture messages & more. 
http://server1.msn.co.in/sp03/mobilesms/ Jazz up your mobile!

---

From: "HyunWook Cha" <[email-masked]>
Date: Fri, 9 Jan 2004 16:16:35 +0900

As for tora and aodv, you can refer test-suite-wirless-lan-aodv(or
tora).tcl. (Both files seems to be almost same.) NS-2 provides a common
framework to generate(instantiate) mobile nodes irrespective ad hoc
routing protocols. What to do is as follows.

set ns_  [new Simulator]
set god_ [create-god $opt(nn) ] // opt(nn) = number of nodes
$ns_ node-config -adhocRouting AODV [or DSR or TORA or DSDV]  ....   ;
refer the example file.
for {set i 0} {$i < $opt(nn) } {incr i} {
	set node_($i) [$ns_ node]   
	...
}

For more details, you can refer the ns-2 manual.

HyunWook Cha

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Karun Verma
> Sent: Friday, January 09, 2004 3:18 PM
> To: [email-masked]
> Subject: [manet] Regarding Simulatiuon of AODV and TORA
> 
> 
> What else modifications i have to do for both these 
> protocols. Help me. with this mail i am attaching the script 
> "wireless_tora.tcl"
> 
> thanx in advance
> 

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Poornananda G R" <[email-masked]>
Date: Fri, 9 Jan 2004 13:10:20 +0530

Hi,
I have another related question- can we simulate one or more of these
routing protocols simultaneously? 
For example, can we simulate a set of 100 nodes and say 50 of them
running aodv, 25 running dsr and the rest running tora?
Thanks,
-Poorna

% -----Original Message-----
% From: [email-masked] [mailto:[email-masked]] On 
% Behalf Of HyunWook Cha
% Sent: Friday, January 09, 2004 12:47 PM
% To: 'Karun Verma'; [email-masked]
% Subject: RE: [manet] Regarding Simulatiuon of AODV and TORA
% 
% 
% 
% As for tora and aodv, you can refer 
% test-suite-wirless-lan-aodv(or tora).tcl. (Both files seems 
% to be almost same.) NS-2 provides a common framework to 
% generate(instantiate) mobile nodes irrespective ad hoc 
% routing protocols. What to do is as follows.
% 
% set ns_  [new Simulator]
% set god_ [create-god $opt(nn) ] // opt(nn) = number of nodes
% $ns_ node-config -adhocRouting AODV [or DSR or TORA or DSDV]  ....   ;
% refer the example file.
% for {set i 0} {$i < $opt(nn) } {incr i} {
% 	set node_($i) [$ns_ node]   
% 	...
% }
% 
% For more details, you can refer the ns-2 manual.
% 
% HyunWook Cha
% 
% > -----Original Message-----
% > From: [email-masked] [mailto:[email-masked]] On
% > Behalf Of Karun Verma
% > Sent: Friday, January 09, 2004 3:18 PM
% > To: [email-masked]
% > Subject: [manet] Regarding Simulatiuon of AODV and TORA
% > 
% > 
% > When i want to simulate protocols aodv and tora using the script
% > wireless1.tcl in ~ns/tc/ex directory
% > i get thye following errors
% > 
% > invalid command name "tora-create-mobile-node"
% >     while executing
% > "tora-create-mobile-node $i"
% >     invoked from within
% > "if { [string compare $opt(rp) "dsr"] == 0} {
% >         for {set i 0} {$i < $opt(nn) } {incr i} {
% >                 dsr-create-mobile-node $i
% >         }
% > } elseif { [string compare $opt..."
% >     (file "wireless_tora.tcl" line 209)
% > 
% > i have modified the script.
% > What else modifications i have to do for both these
% > protocols. Help me. with this mail i am attaching the script 
% > "wireless_tora.tcl"
% > 
% > thanx in advance
% > 
% > ############################################
% > 
% > #                              Karun Verma                    
% >                
% >       #
% > 
% > ###########################################
% > 
% > _________________________________________________________________
% > Games, MMS cards, ringtones. Operator logos, picture 
% messages & more.
% > http://server1.msn.co.in/sp03/mobilesms/ Jazz up your mobile!
% > 
% > 
% 
% 
% _______________________________________________
% manet mailing list
% [email-masked]
% https://www1.ietf.org/mailman/listinfo/manet
%