Subject: [manet] precursor list for AODV operation

From: taka <[email-masked]>
Date: Wed, 14 Jan 2004 10:05:29 +0900

Hi all.

I have questions about RFC 3561 (AODV).

>    6.7. Receiving and Forwarding Route Replies
>    .....
>
>    When any node transmits a RREP, the precursor list for the
>    corresponding destination node is updated by adding to it the next
>    hop node to which the RREP is forwarded.  Also, at each node the
>    (reverse) route used to forward a RREP has its lifetime changed to be
>    the maximum of (existing-lifetime, (current time +
>    ACTIVE_ROUTE_TIMEOUT).  Finally, the precursor list for the next hop
>    towards the destination is updated to contain the next hop towards
>    the source.

I don't understand the real intention of the third sentence.

- Does the sentence means that when a node B receives a RREP from a node C
in the next figure, it adds a node A to the precursor list for the node C?

S-------A---------B---------C---------D
  RREQ->   RREQ->    RREQ->    RREQ->
                     <-RREP    <-RREP

- If so, why the operation is needed?
If the node A is communicating with the node C, the node B must have the
precursor list for either the node A or the node C.

Thanks in advance.
Taka

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Koojana Kuladinithi" <[email-masked]>
Date: Wed, 14 Jan 2004 12:07:14 +0100

Hi Taka
 
>   RREQ->   RREQ->    RREQ->    RREQ->

Third sentence means (as I understood) that it updates the precursor list
for the reverse route entry.

Destination next-hop Precursor-List
S            A        C   - (As explained in third sentence)
D            C        A   - (As explained in First sentence)

> precursor list for either the node A or the node C.

I guess, in your example A is communicating with C through B and B should
detects the link connectivity to both A and C. If link to C fails, B will
send RERR to A, telling that D is unreachable. In the same manner, if link
to A fails, it sends RERR to C, telling S is unreachable.
That's why B should maintain Precursor list for both directions.
 
Regards,

Koojana