Subject: [manet] Help needed!!

From: "Karun Verma" <[email-masked]>
Date: Thu, 15 Jan 2004 12:34:17 +0530

Hello ALL,

While doing simulation of aodv and tora protcol under ns-2 in linux 7.2, i 
found these errors. please suggest
a wayout of the problem.

#=======================for wireless_aodv.tcl=====================
[root@localhost ex]# ns wireless_aodv.tcl
num_nodes is set 50
Loading connection pattern...
Loading scenario file...
Load complete...
Starting Simulation...
Segmentation fault

#=========================for wireless_tora.tcl=====================

[root@localhost ex]# ns wireless_tora.tcl
num_nodes is set 50
can't read "imep_(0)": no such variable
    while executing
"subst $[subst $var"
    (procedure "_o15" line 5)
    (SplitObject set line 5)
    invoked from within
"$self set imep_(0)"
    (procedure "_o15" line 17)
    (Node/MobileNode add-target line 17)
    invoked from within
"$self add-target $agent $port"
    (procedure "_o15" line 15)
    (Node attach line 15)
    invoked from within
"$node attach $ragent [Node set rtagent_port_]"
    (procedure "create-routing-agent" line 9)
    invoked from within
"create-routing-agent $node $id"
    (procedure "create-mobile-node" line 36)
    invoked from within
"create-mobile-node $i"
    invoked from within
"if { [string compare $opt(rp) "dsr"] == 0} {
        for {set i 0} {$i < $opt(nn) } {incr i} {
                dsr-create-mobile-node $i
        }
} elseif { [string compare $opt..."
    (file "wireless_tora.tcl" line 210)
================================================================

While the files tora.tcl and aodv.tcl under the ~ns/tcl/mobility folder are 
compiling successfully.

the files attached with the mail are

wireless_aodv.tcl
wireless_tora.tcl
aodv.tcl
tora.tcl

Please help me urgently.

thanx in advance.

############################################

#                              Karun Verma                                   
      #

###########################################

_________________________________________________________________
Send DD, pay no commission. 
http://server1.msn.co.in/msnleads/suvidha/dec03.asp?type=hottag Click here.

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Einar Vollset <[email-masked]>
Date: Thu, 15 Jan 2004 12:00:20 +0000

Can I suggest that questions like this gets put to the appropriate 
simulation
specific mailing lists, rather than to the IETF MANET mailing list, as 
this is
wildly off topic for this forum.

Cheers,

Einar