Subject: Re: [manet] Selective Acknowledgement

From: Justin Lipman <[email-masked]>
Date: Tue, 27 Jan 2004 19:39:34 +1100

Hi Joan,

I have a paper currently under review which addresses just this issue when 
performing flooding in ad hoc networks. I can send you the tech-report, if 
you are interested.

regards,
Justin

-- 
Research Associate
Smart Internet Technology Cooperative Research Centre
http://www.titr.uow.edu.au/~justin

On Tue, 27 Jan 2004 07:19 pm, [email-masked] wrote:
> Hi,
>
> Does anybody know any literature about selective acknowledgement applied
> to manet (802.11). Concretely, selective acknowledge in response to a
> broadcast transmission.
>
> The IEEE 802.11 MAC specification does not allow acknowledging on
> receiving a broadcast transmission. Therefore how could I design a
> mechanism which ensures me that at least one neighboring node has received
> the broadcast message (imagine a critical application, e.g. car accident
> warning, in which you cannot permit a broadcast message "to be lost on the
> air")
>
> Best regards,
> Joan

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Justin Lipman <[email-masked]>
Date: Tue, 27 Jan 2004 20:30:40 +1100

Hi,

Sorry I should clarify. My approach is related to more reliable flooding, not 
to modifications to IEEE 802.11 for reliable broadcasts.

kind regards,
Justin

---

From: "Philippe Jacquet" <[email-masked]>
Date: Tue, 27 Jan 2004 10:59:35 +0100

The problem differs if you want to check that all neighbor receives the broadcast or check that at least one neighbor receives it. 

For the first problem, in HIPERLAN 1, long time ago, we proposed a collision signal after each transmission. When a node receives a corrupted packet it emits a collision signal burst just after the packet. The signal is just energy and can aggregate with other signals. When the broadcaster senses signal after its packet transmission, it inferes collision and retransmits.  

In IEEE 802.11 you can use the RTS CTS mechanism with broadcast. Of course there are no CTS. Therefore if the broadcaster senses signal after its RTS, then it just backoff transmission. 

Philippe
  ----- Original Message ----- 
  From: [email-masked] 
  To: [email-masked] 
  Sent: Tuesday, January 27, 2004 9:19 AM
  Subject: [manet] Selective Acknowledgement

  Hi, 

  Does anybody know any literature about selective acknowledgement applied to manet (802.11). Concretely, selective acknowledge in response to a broadcast transmission. 

  The IEEE 802.11 MAC specification does not allow acknowledging on receiving a broadcast transmission. Therefore how could I design a mechanism which ensures me that at least one neighboring node has received the broadcast message (imagine a critical application, e.g. car accident warning, in which you cannot permit a broadcast message "to be lost on the air") 

  Best regards, 
  Joan

---

From: David Young <[email-masked]>
Date: Wed, 28 Jan 2004 02:34:02 -0600

> warning, in which you cannot permit a broadcast message "to be lost on the 

Do you have your choice of 802.11 radio, or do you have to use a
particular chip?  How timely must the acknowledgements be?  Presumably
some of the broadcast's receivers could be hidden from each other?

Dave

-- 
David Young             OJC Technologies
[email-masked]      Urbana, IL * (217) 278-3933