Subject: [manet] MANET Address Autoconf Issues

From: Jaehoon Jeong <[email-masked]>
Date: Mon, 1 Mar 2004 08:44:24 -0800 (PST)

Hi Maneters,

I send my presentation material in order to discuss
"MANET IP Address Autoconfiguration Issues" today
afternoon as follows;
 - PPT file:
  
http://www.adhoc.6ants.net/~paul/ietf/manet/manet-addr-autoconf-issues-jaehoon.ppt
 - PDF file:
  
http://www.adhoc.6ants.net/~paul/ietf/manet/manet-addr-autoconf-issues-jaehoon.pdf

If participants read this material, you can prepare
the discussion well. Also, those who cannot take part
in this Seoul meeting can comment on my drafts by
email.

Thanks.

Regards,
Jaehoon Paul Jeong

__________________________________
Do you Yahoo!?
Get better spam protection with Yahoo! Mail.
http://antispam.yahoo.com/tools

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Joe Macker <[email-masked]>
Date: Mon, 01 Mar 2004 14:36:30 -0500

>"MANET IP Address Autoconfiguration Issues" today

I, for one, will not be there so here are a few comments.
In summary, I do not agree with your requirements.
They are too strict.

We should support multiple way of configuring MANETs
just as a real network supports this in multiple ways.

The use of MUSTs MUST be carefully considered.

There are a few common problem areas I think we can define
and potentially work on. (e.g., flooding service,etc)

-Joe

---

From: Jaehoon Jeong <[email-masked]>
Date: Mon, 1 Mar 2004 17:25:59 -0800 (PST)

Dear Macker,

> just as a real network supports this in multiple

You are right in the aspect of address selection.
I agree with you that MANET can allow several
configuration methods;
  - DHCPv4 or DHCPv6
  - IPv6 Stateless Address Autoconf
  - Dynamic Configuration of Link-Local IPv4 Addresses
  - Manual Configuration
  - etc.

As you know, MANET address autoconf seems to consist
of the following four steps;

 Step 1: Address selection
         How to select one of IP addresses in the
         address space. 

 Step 2: Duplicate address detection
         How to detect a duplicate address

 Step 3: Address change negotiation
         Which node should perform a reallocation
         procedure

 Step 4: Maintenance of upper-layer sessions
         How to let an upper-layer session avoid
         a connection breakage 

Especially, it seems that you talk about address
selection problem of Step 1.
Whichever address selection mechanism a mobile node
uses, a unified DAD mechanism is required.

> The use of MUSTs MUST be carefully considered.

Sure, I will carefully replace MUSTs with another
through the discussion with MANET members including
authors.

> and potentially work on. (e.g., flooding

Do you mean that we can use a general flooding service
for DAD operation?
If so, is it not so general a requirement?
Anyway, I agree with you that there are other problem
areas. 
We authors need your feedback and will reflect your
comments and suggestions to a revised requirements
draft.

Thanks.

Regards,
Paul