Subject: [manet] ZRP simulation

From: "#ZHOU XIAOFENG#" <[email-masked]>
Date: Thu, 4 Mar 2004 10:22:42 +0800

Hi,all
I have download the source code of ZRP in Glomosim from http://wnl.ece.cornell.edu/wnlprojects.html 
and I untar the compressed package release the zrp.h and zrp.pc
then copy these two files into the /glomosim-2.03/glomosim/network to overwrite the existed files with same name. then delete the files zrp.o and zrp.pi
the next step is compile zrp.pc to produce .pi and .o files, but when I compile the zrp.pc, there are some errors:
such as all of the include files in the source code of zrp.pc.
 
Could anybody tell me the reason? and how to tackle it.
or could you tell me how to perform the simulation of zrp
Thank you very much!

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Justin Lipman <[email-masked]>
Date: Thu, 4 Mar 2004 14:42:26 +1100

Hi Zhou,

Sounds like you have a problem with the version of gcc that is being used.
I havent tried compiling ZRP in GlomoSim, but your description of the errors 
sounds familiar to the problem I had when using the incorrect version of gcc.

at your unix prompt type gcc -v 
if you have any other version of gcc other than gcc-2.95 then you will have 
this problem. 

You might also want to limit these types of questions to the GlomoSim mailing 
lists... if they still exist...

hope this helps,
Justin

On Thu, 4 Mar 2004 01:22 pm, #ZHOU XIAOFENG# wrote:
> Hi,all
> I have download the source code of ZRP in Glomosim from
> http://wnl.ece.cornell.edu/wnlprojects.html and I untar the compressed
> package release the zrp.h and zrp.pc
> then copy these two files into the /glomosim-2.03/glomosim/network to
> overwrite the existed files with same name. then delete the files zrp.o and
> zrp.pi the next step is compile zrp.pc to produce .pi and .o files, but
> when I compile the zrp.pc, there are some errors: such as all of the
> include files in the source code of zrp.pc.
>

-- 
Research Associate
Smart Internet Technology Cooperative Research Centre
http://www.titr.uow.edu.au/~justin