Subject: Re: [manet] Request of Comments on the i-d ietf-cha-manet-aodv-internet-00.txt

From: "Pete Sholander" <[email-masked]>
Date: Wed, 03 Mar 2004 09:15:50 -0500

If the charter doesn't include "internet connectivity" then it should be, IMHO :)  

Standardizing that feature would be most useful to my customer set.  Futhermore having a simple method that scaled to 50-100 node sized MANETs (with a reasonably-planned set of address blocks) might suffice for now.  A general solution might be a ANS problem.

--Pete Sholander
Atlanta, GA

>>> Ryuji Wakikawa <[email-masked]> 03/03/04 01:58AM >>>

I think the first step is MANET WG should make decision whether the WG
includes internet connectivity stuff in manet charter or
not. Otherwise, many similar drafts are submitted without any progress
at IETF. 

<snip>

ryuji

At Tue, 2 Mar 2004 16:07:17 +0900,
HyunWook Cha wrote:
> 
> Hello, all.
> 
> After my presentation is finished, I got two comments. Although Paal's
> comments which are more technical seem to be resolved(I guess. If wrong,
> please correct me, Paal), I think that I must tell what is different
> with existing solutions for MANET Internet connectivity in my draft. 
> 
> As I mentioned at my presentation, my draft consists of two component.
> Route determination algorithm and Forwarding algorithm. As you know,
> these are critical parts in this area(Int. Connectivity) and all
> existing solutions address with their own way. 
> 
> Firstly, route optimization is not mentioned at existing drafts
> referenced by mine (If wrong, please correct me.) 
> 
> As for proposed forwarding algorithm, forwarding using default route can
> be done for packets without routing header. I.E, after look up of
> routing table with destination address fails, forwarding decision is
> based on source global address of the packet. That is, gw_info list is
> searched with source prefix. If matched gw_info is found, the packet is
> forwarded through host route entry for the gw advertising the prefix.
> Thus, multiple addresses from multiple gateways can be configured in a
> node and intermediate nodes can forward packets without routing header
> only if gateway info list is maintained in the node.
> 
> I request valuable comments on my draft from authors of previous drafts
> including C. Perkins, Wakikawa, C. Jelger, Pekka. Personally I also
> believe that this area is very important and it is time to make
> progress. How about requirement document or merged solution document?
> Please let me know what is in your mind. Whoever is interested in this
> topic may be welcomed in this thread.
> 
> Kindly Regards,
> 
> HyunWook Cha
>    
> 
> 
> 
> _______________________________________________
> manet mailing list
> [email-masked] 
> https://www1.ietf.org/mailman/listinfo/manet 

_______________________________________________
manet mailing list
[email-masked] 
https://www1.ietf.org/mailman/listinfo/manet

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Sukanta K. Hazra" <[email-masked]>
Date: Fri, 05 Mar 2004 00:41:11 +0800

Hi!

Comments inline.

----- Original Message -----
From: "Pete Sholander <[email-masked]>"
Date: Wed, 03 Mar, 2004 22:15 SGT
Subject: Re: [manet] Request of Comments on the i-d ietf-cha-manet-aodv-internet-00.txt

> If the charter doesn't include "internet connectivity" then it should be, IMHO :)  

I strongly agree.

> Standardizing that feature would be most useful to my customer set.  Futhermore having a simple method that scaled to 50-100 node sized MANETs (with a reasonably-planned set of address blocks) migh…

I don't quite feel comfortable with restricting the scope of the
solution to 50-100 nodes (at least not in so many words). 
Pushing the problem to ANS is not a solution.  Networks do and will
grow, and we will face the same problem again in near future. Any
solution which is proposed should keep scalability in mind, which means
be wary of flooding (even something which is as seemingly harmless as broadcast
every 2 seconds may come back and haunt you in large dense networks).

- Sukanta

-- 
Sukanta K. Hazra (Mr.)	<[email-masked]>
Institute for Infocomm Research
Tel: +65 6874-1953 Fax: +65 6776-8109
Homepage: http://www1.i2r.a-star.edu.sg/~sukanta/