Subject: [manet] OLSR attack

From: "Wala Turki Latrous" <[email-masked]>
Date: Mon, 22 Mar 2004 12:19:28 +0100

Hello,

In the OLSR protocol :  if a node X wants to send HELLO messages, pretending to have the identity of another node A ; knowing the main address of A and then use it as his originator address is sufficient for this attack ? or X must also know the sequence numbers recently used by A for the packets and/or the HELLO messages ? 

In the same way, X wants to send TC messages, pretending to have the identity of A. Must X know the packet sequence number and the ANSN recently used by A?

Is there any works on attacks on OLSR or securing OLSR ?

---

From: Andreas Tønnesen <[email-masked]>
Date: Mon, 22 Mar 2004 13:17:07 +0100

You could check out:
*"Securing the OLSR protocol"*
Thomas Heide Clausen, Cedric Adjih, Philippe Jacquet, Anis Laouiti, Paul 
Muhltahler, Daniele Raffo

http://voop.free.fr/Publications/2003/medhoc03.shtml

- Andreas

Wala Turki Latrous wrote:

> Hello,
>
>  
>
> In the OLSR protocol :  if a node X wants to send HELLO messages, 
> pretending to have the identity of another node A ; knowing the main 
> address of A and then use it as his originator address is sufficient 
> for this attack ? or X must also know the sequence numbers recently 
> used by A for the packets and/or the HELLO messages ?
>
>  
>
> In the same way, X wants to send TC messages, pretending to have the 
> identity of A. Must X know the packet sequence number and the ANSN 
> recently used by A?
>
>  
>

-- 

-- 
Andreas Tønnesen([email-masked])
UniK University Graduation Center
University of Oslo
http://www.olsr.org

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Wala Turki Latrous" <[email-masked]>
Date: Mon, 22 Mar 2004 14:59:47 +0100

Thank you for your indication. But i had already checked out this document
and there is no clarification about the sequence number utilisation in such
type of attacks so i need to clarify this point.