Subject: [manet] Local recovery of AODV

From: "genping liu" <[email-masked]>
Date: Sun, 21 Mar 2004 12:46:05 +0800

hi,

I was using ns2.1b8a to simulate of the peformance of AODV with and
without
local recovery. it is expected that AODV with local recovery should
outperform AODV without. however, our simulation results shows that the
local recovery decreased the performance of AODV. our simulation scenario
is
map of 2000mx1600m, node number=100, transmission range of 350, random way
point with medium mobility.

anyone know that reason that local recovery decreased the performance of
AODV?

Thanks

Regards
Genping

_________________________________________________________________
Get 10mb of inbox space with MSN Hotmail Extra Storage 
http://join.msn.com/?pgmarket=en-sg

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Ali Hamidian <[email-masked]>
Date: Mon, 22 Mar 2004 10:30:31 +0100

Hi,

> anyone know that reason that local recovery decreased the performance of

I don't think that local recovery is implemented correctly in the aodv 
code of ns-2.1b8(a). I also think there is some comment in aodv.h which 
says that local recovery shouldn't be used and that it doesn't show any 
significant performance improvements.

Regards
Ali Hamidian

---

From: Alvin Valera <[email-masked]>
Date: Wed, 24 Mar 2004 00:14:55 -0800 (PST)

Hi All,

I discussed this behavior in my master's thesis. My
observations are:

(1) Additional routing overhead is generated for local
repair. Supposedly, this overhead should be less than
the overhead of performing a new route discovery.

(2) In a congested and highly mobile environment, many
local repairs fail. The penalty for such failures is a
significant increase in the routing overhead. (Why?
because routing overhead = local repair overhead +
route discovery overhead) Such additional overhead
then worsens congestion and increases packet loss.

(3) In light load environments, I observed that local
repair is advantageous, that is, it improves packet
delivery.

Best regards,
Alvin

--- Ali Hamidian <[email-masked]> wrote:
> > map of 2000mx1600m, node number=100, transmission
> range of 350, random 
> > way
> > http://join.msn.com/?pgmarket=en-sg

__________________________________
Do you Yahoo!?
Yahoo! Finance Tax Center - File online. File on time.
http://taxes.yahoo.com/filing.html