Subject: SV: Re: [manet] ACTIVE_ROUTE_TIMEOUT in AODV (RFC 3561) (Intern)

From: [email-masked]
Date: 26 Feb 2004 21:12:48 +0100

Hi Erik,

Thanks for your comments.

> Just wanted to add that ACTIVE_ROUTE_TIMEOUT probably just works as a
> garbage collection timer, making sure that there is no stale information
> in the network.

It's a good point. The question is if the stale information can cause consierable damage to the routing functionality.

> > Isn't it the case that routes are often preempted by other events, such
> > as link break (link layer feedback or HELLO messages), with the result
> > that ACTIVE_ROUTE_TIMEOUT doesn't really matter that much?

Yes, I am about to convince myself of the same. So, if what you say is right, you may choose very high ACTIVE_ROUTE_TIMEOUT values (e.g 100-200 sec) without big consequences. 

Paal

---

From: [email-masked]
Date: 26 Feb 2004 21:28:02 +0100

Hi Vinod,

> I also think that your traffic model plays a part.If
> you send packets continously from a starting point in
> time, ACTIVE_ROUTE_TIMEOUT never gets a chance to come
> into play.It should come into play only if that route
> has been unused for that period of time.

Actually, this point is what triggered my interest in the ACTIVE_ROUTE_TIMEOUT value in the first place. For normal bursty traffic (e.g. a ftp or http file download) it does not make much difference. However, in our AODV testbed with limited mobility/dynamics I tested communication that requires user interaction i.e. Telnet. Then a route may time out between each transmitted packet, which naturally is not a very desirable. At another instance, we also implemented event-based middleware on top of AODV and both periodic polling and unsolicited events may be sent on intervals exceeding normal settings of the ACTIVE_ROUTE_TIMEOUT.

> many
> simulations done on ns-2 are based on cbr traffic
> starting at a certain time and going on till end of
> simulation which isnt a good way to study the effect
> of  ACTIVE_ROUTE_TIMEOUT.

Agreed. Well, I steered around that pithole, at least.

Thanks for your comments, anyway.
Paal

> Regards,
> Vinod
>  
> --- [email-masked] wrote:
> > Hi,
> > 
> > I did some GloMoSim simulations with AODV and
> > experimented with the setting of the
> > ACTIVE_ROUTE_TIMEOUT value. For the scenarios that I
> > tested, I was surprised to see how little the
> > performance degraded when I chose very large timeout
> > values. I have obviously done something wrong -
> > either not selected the right simulation scenarios
> > or not measured the right things.
> > 
> > To help me on the way, could someone please tell me
> > the most important networking aspects that prohibits
> > the choice of a large ACTIVE_ROUTE_TIMEOUT. What are
> > the main trade-offs when setting this value? Or
> > could someone give me a pointer to relevant
> > publications.
> > 
> > Thanks,
> > Paal
> > 
> > _______________________________________________
> > manet mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/manet
> 
> 
> =====
> Vinod Namboodiri
> 
> Graduate Student
> Department of Electrical and Computer Engineering
> University of Massachusetts, Amherst
> 
> __________________________________
> Do you Yahoo!?
> Yahoo! Mail SpamGuard - Read only the mail you want.
> http://antispam.yahoo.com/tools