Subject: Re: [manet] Simulating 802.11b and g

From: Claude Chaudet <[email-masked]>
Date: Tue, 18 Nov 2003 10:59:04 +0100

Hello,

That's true, NS (at least version 2.26) simulates 2Mbps 802.11.

Nevertheless, you can change this by simply putting in your script the 
following lines :
	Mac/802_11 set bandwidth_   11e6
	Mac/802_11 set dataRate_      11e6
	Mac/802_11 set basicRate_     2e6

This only changes the rate at which data is sent. This can be useful 
for simulating
802.11b protocol, for which only the physical layer changes. But 
simulating 802.11a
will need at least some timings modifications in the mac/mac-802_11.* 
files.

Concerning the physical layer parameters, I tried to update some 
parameters based on the
specification of an Avaya card. Nevertheless, being no expert in 
physical layers, I cannot
guarantee this will be the exact parameters.
Here they are :
	Phy/WirelessPhy set CPThresh_ 10.0
	Phy/WirelessPhy set CSThresh_ 5.011872e-12
	Phy/WirelessPhy set RXThresh_ 1.15209e-10
	Phy/WirelessPhy set Rb_ 11e6
	Phy/WirelessPhy set bandwidth_ 11e6
	Phy/WirelessPhy set Pt_ 0.031622777
	Phy/WirelessPhy set freq_ 2457e+6
	Phy/WirelessPhy set L_ 1.0

Concerning this, I wondered if anyone on this list could provide good 
values once
and for all, so that we can use ns, opnet and any other simulator on 
the same basis.
I am especially interested in the CPThresh parameter, i.e. the signal 
over noise
ratio (in dB) required to understand a frame. I found no value in any 
NIC specification.
I suppose it depends on the physical layer. 10 dB was used for early 
802.11, is it still
the good value for newer ones ?

Claude Chaudet.

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Frank Li" <[email-masked]>
Date: Tue, 25 Nov 2003 10:54:10 +0100

Hi Zhifei,

>However, for the standard itself, the condition PMD_CS < PMD_ED should be true, at least 
>for IEEE 802.11a where the PMD_ED is 20 DB greater than PMD_CS.

Are you sure that PMD_ED is 20 dB greater than PMD_CS? Is the difference between PMD_CS and  PMD_ED the same for all datarates? In the paper posted to the same discussion by Mineo Takai last week, the two thresholds are set as CST = - 78 dBm and RXT = - 64 dBm for WaveLan card. But maybe they don't correspond to PMD_CS and PMD_ED? Any further comments here, Mineo?

>I think the receiver-sensitivity is used to calculate the transmission range, while the CCA >sensitivity (or CS threshold) is used to calculate the sensing range.

No, I think receiver-sensivity (or CS threshold in ns2) should be used to calculate the sensing range, another threshold (PMD_ED?) which  is greater than receiver-sensivity, should  be used to calculate the tansmission range. 

List below are the sensing ranges for outdoor environment I calculated based on Agere Wireless LAN World PC Card (Extended) specification. Here Pt=15 dBm , receiver-sensitivity and transmission ranges are directly from the specification, and I used two-ray model 
with Gt=Gr=1, ht=hr=1.5, L=1 to obtain the sensing ranges. 

Datarate                11 Mbps          5.5 Mbps            2 Mbps         1 Mbps

Transmission range      160 m              270 m              400 m           550 m

Receiver sensitivity    -82 dBm           -87 dBm            -91 dBm         -94 dBm

sensing range           399 m               532 m             670 m           796 m

Any comments are welcome. 

Frank