Subject: Re: [manet] Draft MANET Problem Statement and Direction

From: "Pete Sholander" <[email-masked]>
Date: Wed, 12 May 2004 13:48:34 -0400

Joe,

Looks good!!!  

Q1: Does the WG intend to focus on unicast routing protocols only?  Or are simple multicast protocols in scope?  (I would guess unicast only, since you're aiming at Proposed Standards.)

Q2: Do you a notional schedule in mind for completing this work?   (The last round of RFCs took a while for various reasons.  Hopefully, this effort can be faster.)

--Pete Sholander
Atlanta, GA

>>> Joe Macker <[email-masked]> 05/12/04 11:30AM >>>
ALL:

This discussion is a little overdue but we have run this draft outline past the Routing ADs and are posting it here for the WG to kick around. Within the next 2 weeks we would like to have a reasonable WG framework to proceed with. I don't think there are many surprises here as the WG has been openly discussing the next steps for awhile.

-----------------------------------------------------------------------------------------------------
DRAFT MANET PROBLEM STATEMENT AND DIRECTION 
(REALLY A CHARTER UPDATE)

The purpose of the MANET working group is to standardize IP routing protocol functionality suitable for wireless routing application within both static and dynamic topologies. The fundamental problem issues are that wireless link interfaces have some unique routing interface characteristics and that node topologies within a wireless routing region may experience increased dynamics, due to motion or other factors. The continued proliferation of a wide variety of wireless device technologies and embedded network devices is opening up new wireless networking challenges.  MANET specifications fundamentally provide improved operational IP routing performance for dynamic, wireless routing regions.  Approaches are intended to be relatively lightweight in nature and suitable for heterogeneous adaptation across multiple hardware and wireless environments.

While MANET routing areas may operate in isolation from a larger connected Internet, a primary focus of the MANET WG is to address use as a routing technology extension at the edges of an IP infrastructure. The deployment of hybrid infrastructures (e.g., a mixture of preferred fixed grid and mobile routers) should also be supported by MANET specifications and management features. In the past, this WG has focused on exploring a broad range of MANET problems, performance issues, and related candidate protocols and has developed several EXPERIMENTAL RFCs with associated working prototypes along with an INFORMATIONAL RFC (2501) discussing performance and design considerations.  The present protocol frameworks provide Experimental MANET specifications covering both reactive and proactive design spaces and many of the concepts have reached a significant level of engineering maturity. Building off this work, the MANET WG will now concentrate its scope on developing several Proposed Standard specification efforts. Two central routing protocol approaches will be developed.

- MANET Reactive Routing Protocol (MRRP)
- MANET Proactive Routing Protocol (MPRP)

For this goal, it is expected that MRRP will become a convergence of mature reactive design components.  Likewise, it is expected that MPRP would be a convergence of mature proactive design components.  At this point, the WG has rough consensus that a split between proactive and reactive taxonomies appears sensible from a design complexity and application space perspective. The WG will begin its work with development of protocols along these tracks.  If the WG sees significant commonality among the design spaces common building blocks may be developed.  The WG will develop both IPv4 and IPv6 support within these protocols.  Routing security requirements and issues will also be addressed.

Within the MANET WG, the development of a common ALL_MANET_NODES forwarding protocol building block for use withing a MANET routing area has also been identified as a useful work item.  The potential for the "broadcast storm problem" to arise is exacerbated in a MANET wireless interface scenario, where each node may have a different set of single hop neighbors.  Present MANET routing protocol work has developed a number of flooding optimizations suitable for MANET environments that can reduce significantly the number of redundant transmissions when forwarding packets to ALL_MANET_NODES.  A generic MANET flooding building block can be adapted to a routing protocol instantiation and may also be useful in designing service discovery and autoconfiguration mechanisms within MANET areas.  The MANET WG will develop a generic flooding building block and related instantiations that will be useful for the intended wireless network environments.  

Additional WG items that are to be covered by a small set of INFORMATIONAL documents and possible PROPOSED STANDARD specifications relate to issues of address autoconfiguration, MANET gateway discovery and operation, and network service discovery.  The MANET WG will work with other IETF WGs to determine and support the working of related issues within the appropriate working groups.

Some related work the MANET WG will pay particular attention to will be the OSPF-MANET protocol work within the OSPF WG and the ANS IRTF work that is addressing research topics related to MANET environments.

_______________________________________________
manet mailing list
[email-masked] 
https://www1.ietf.org/mailman/listinfo/manet

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Rex Buddenberg <[email-masked]>
Date: 12 May 2004 11:25:30 -0700

> Looks good!!!  
I'll second that.
> Q1: Does the WG intend to focus on unicast routing protocols only?  Or are simple multicast protocols in scope?  (I would guess unicast only, since you're aiming at Proposed Standards.)

Astute question, Pete.  Let me contribute some information.

I can think of lots of situations where the character of the data is
multicast.  The military has a lot.  And every time I envision the kind
of volatile topology that MANET is trying to cope with, there is present
a ton of data that is multicast in nature.  In opposition, I can think
of no situations where the volatile topology would be present but not
multicast data.

The current illustration (only the latest) is Blue Force Tracker which
is a system that relays nav positions of nodes which are then put into
the common tactical picture database.  The database is displayed at all
echelons of command from the 4-star in Qatar down to the truck driver on
the road from Kuwait to Baghdad.  

If you look at public safety (fire, police departments) you get much the
same logic.  

But the operational take needs to be leavened with Joe's entirely
necessary attitude that we need to get something out the door.

If we can get some standards-track MANET RFCs out that ignore, but do
not do violence to multicast, then OK.  We don't have to take a step
back on MANET in order to take a step forward with multicast routing
info protocols later.  If this is not the case, then the answer to your
question should be yes -- we don't get much if we don't include
multicast.  
-- 
b

---

From: "Marshall Eubanks" <[email-masked]>
Date: Wed, 12 May 2004 22:25:21 -0400

On 12 May 2004 11:25:30 -0700
 Rex Buddenberg <[email-masked]> wrote:
> > Q1: Does the WG intend to focus on unicast routing protocols only?  Or are simple multicast
> protocols in scope?  (I would guess unicast only, since you're aiming at Proposed Standards.)
> 

I, at least, am very interested in multicast routing on ad hoc networks, but have just begun to dig
into the manet archives. Can you provide me some pointers to list discussion or other
resources as to why Single Source Multicast at least would be problematic in this context ? 

Regards
Marshall Eubanks