Subject: Re: [manet] Draft MANET Problem Statement and Direction

From: Joe Macker <[email-masked]>
Date: Thu, 13 May 2004 09:47:44 -0400

At 01:48 PM 5/12/2004, Pete Sholander wrote:
>Joe,
>
>Looks good!!!  
>
>Q1: Does the WG intend to focus on unicast routing protocols only?  Or are simple multicast protocols in scope?  (I would guess unicast only, since you're aiming at Proposed Standards.)

Yes, I believe simple multicast forwarding is in scope.  Paragraph 4 could be seen as a possibility.
We have a running prototype similar to MPR-F along these lines..

Common building block needs (e.g., duplicate packet detection) are certainly different than typical wired approaches and can be engineered.  

>Q2: Do you a notional schedule in mind for completing this work?   (The last round of RFCs took a while for various reasons.  Hopefully, this effort can be faster.)

Let's get consensus on the problem and the work items first.
I certainly think we can speed up the process once we scope in on the items

>--Pete Sholander
>Atlanta, GA
>
>>>> Joe Macker <[email-masked]> 05/12/04 11:30AM >>>
>ALL:
>
>This discussion is a little overdue but we have run this draft outline past the Routing ADs and are posting it here for the WG to kick around. Within the next 2 weeks we would like to have a reasonable WG framework to proceed with. I don't think there are many surprises here as the WG has been openly discussing the next steps for awhile.
>
>-----------------------------------------------------------------------------------------------------
>DRAFT MANET PROBLEM STATEMENT AND DIRECTION 
>(REALLY A CHARTER UPDATE)
>
>The purpose of the MANET working group is to standardize IP routing protocol functionality suitable for wireless routing application within both static and dynamic topologies. The fundamental problem issues are that wireless link interfaces have some unique routing interface characteristics and that node topologies within a wireless routing region may experience increased dynamics, due to motion or other factors. The continued proliferation of a wide variety of wireless device technologies and embedded network devices is opening up new wireless networking challenges.  MANET specifications fundamentally provide improved operational IP routing performance for dynamic, wireless routing regions.  Approaches are intended to be relatively lightweight in nature and suitable for heterogeneous adaptation across multiple hardware and wireless environments.
>
>While MANET routing areas may operate in isolation from a larger connected Internet, a primary focus of the MANET WG is to address use as a routing technology extension at the edges of an IP infrastructure. The deployment of hybrid infrastructures (e.g., a mixture of preferred fixed grid and mobile routers) should also be supported by MANET specifications and management features. In the past, this WG has focused on exploring a broad range of MANET problems, performance issues, and related candidate protocols and has developed several EXPERIMENTAL RFCs with associated working prototypes along with an INFORMATIONAL RFC (2501) discussing performance and design considerations.  The present protocol frameworks provide Experimental MANET specifications covering both reactive and proactive design spaces and many of the concepts have reached a significant level of engineering maturity. Building off this work, the MANET WG will now concentrate its scope on developing several Proposed Standard specification efforts. Two central routing protocol approaches will be developed.
>
>- MANET Reactive Routing Protocol (MRRP)
>- MANET Proactive Routing Protocol (MPRP)
>
>For this goal, it is expected that MRRP will become a convergence of mature reactive design components.  Likewise, it is expected that MPRP would be a convergence of mature proactive design components.  At this point, the WG has rough consensus that a split between proactive and reactive taxonomies appears sensible from a design complexity and application space perspective. The WG will begin its work with development of protocols along these tracks.  If the WG sees significant commonality among the design spaces common building blocks may be developed.  The WG will develop both IPv4 and IPv6 support within these protocols.  Routing security requirements and issues will also be addressed.
>
>Within the MANET WG, the development of a common ALL_MANET_NODES forwarding protocol building block for use withing a MANET routing area has also been identified as a useful work item.  The potential for the "broadcast storm problem" to arise is exacerbated in a MANET wireless interface scenario, where each node may have a different set of single hop neighbors.  Present MANET routing protocol work has developed a number of flooding optimizations suitable for MANET environments that can reduce significantly the number of redundant transmissions when forwarding packets to ALL_MANET_NODES.  A generic MANET flooding building block can be adapted to a routing protocol instantiation and may also be useful in designing service discovery and autoconfiguration mechanisms within MANET areas.  The MANET WG will develop a generic flooding building block and related instantiations that will be useful for the intended wireless network environments.  
>
>Additional WG items that are to be covered by a small set of INFORMATIONAL documents and possible PROPOSED STANDARD specifications relate to issues of address autoconfiguration, MANET gateway discovery and operation, and network service discovery.  The MANET WG will work with other IETF WGs to determine and support the working of related issues within the appropriate working groups.
>
>Some related work the MANET WG will pay particular attention to will be the OSPF-MANET protocol work within the OSPF WG and the ANS IRTF work that is addressing research topics related to MANET environments.
>
>
>_______________________________________________
>manet mailing list
>[email-masked] 
>https://www1.ietf.org/mailman/listinfo/manet

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Pete Sholander" <[email-masked]>
Date: Wed, 19 May 2004 16:42:35 -0400

Thanks Joe!  As my last round of comments ...

My group has an "optimized flooding" approach to multicast that we've been field demoing lately.  ODMRP seems popular for larger networks with a few multicast sources.  Multicast based on MPR-F approaches that leverage underlying topology info from a proactive unicast routing protocol also seem reasonable.  So, there are indeed working, multi-OS code-bases that the WG can draw real-life experience from :)   The academic folks can help us with simulations. etc. 

So, I humbly suggest that we consider both proactive and reactive solutions for multicast routing.  As you mention, the multicast approach might leverage technology concepts from the unicast MPRP and MRRP.  As in unicast routing, a proactive approach and a reactive approach should well cover the application space between large/dense/static networks vs. other networks where robustness against mobility and RF effects is paramount.

Consideration of multicast routing should *not* (IMHO) be allowed to delay the next versions of the unicast MANET routing standards though.

>>> Joe Macker <[email-masked]> 05/13/04 09:47AM >>>