Subject: [manet] Question about AODV

From: "Jihoon Lee" <[email-masked]>
Date: Thu, 6 May 2004 16:12:17 +0900

Hi all,

In AODV, A node MAY offer connectivity information by broadcasting local Hello messages.

In the spec., the following sentence is presented. 
"A node SHOULD only use hello messages if it is part of an active route."

I think the sentence can have the one meaning of the followings:
1. Even if the node does not have any active route information, the node should periodically send Hello message to the neighbors. That is, every node can send Hello messages.
2. Only nodes with active routes can send Hello message to the neighbors.

Which one is correct?

Thanks,

Jihoon Lee

---

From: Mehran Abolhasan <[email-masked]>
Date: Thu, 6 May 2004 18:23:28 +1000

Hi,

I think the second one is correct. This is done to reduce the amount of 
overhead introduced by hello messages and reduce redundancy. It can also be 
used to detect if a node in an active route has become inactive. 

-- 
Mehran Abolhasan
B.E Computer, PhD
Smart Internet Technology CRC (SITCRC) Research Fellow
Telecommunications and IT Research Institute (TITR)
University of Wollongong
Northfields Avenue, NSW, 2522, Australia
Phone: +61 2 4221 5491
Fax: +61 2 4221 3277
Email 1: [email-masked]
Email 2: [email-masked] 

On Thu, 6 May 2004 05:12 pm, Jihoon Lee wrote:
> 1. Even if the node does not have any active route information, the node
> should periodically send Hello message to the neighbors. That is, every
> node can send Hello messages. 2. Only nodes with active routes can send
> Hello message to the neighbors.
>
> Which one is correct?
>
> Thanks,
>
> Jihoon Lee

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet