Subject: Re: [manet] Question about NS2 simulation of Ad Hoc netowrk

From: Nilesh Bansal <[email-masked]>
Date: Mon, 17 May 2004 11:03:54 +0530 (IST)

Interesting question Jack, But i got a doubt in the earlier solution 
itself. If u change the mobility file as u said, or add some fix nodes 
in the tcl file as suggested by mona, then won't it be required to provide 
this (n other coz of this) information to "god"? If yes, then how to do 
it?

Actually the doubt arises bcoz of mysterious working/significance of 
god... Any i/ps why exactly it's needed?

regards,
--nilesh  

------------------------------------------------------------------
Thanks a lot. That is a good idea. I will try it.
Another question is, if I want to limit the movement of some nodes within 
a  small part of the whole simulation region, what should I do? One method 
is to modify the output of setdest. But it is complex. 
Any better approaches?

Jack

 --- On Thu 05/13, Mona < [email-masked] > wrote:
From: Mona [mailto: [email-masked]]
To: [email-masked]
     Cc: [email-masked]
Date: Thu, 13 May 2004 11:12:21 +0100
Subject: RE: [manet] Question about NS2 simulation of Ad Hoc netowrk.

 Hi 
Jack,
 
If you want to create a mobility file with some fixed specific nodes, the 
easiest way is to create your mobility file for number of mobile nodes. 
Then set the position of the fix nodes in the tcl file.
 
For example you want to generate a scenario with 10 mobile nodes and 4 
fixed nodes. Simply create a mobility file for 10 nodes, set you number of 
mobile nodes in your tcl file as 14 and define the position of fixed nodes 
in the tcl file.
 
If you want to change the speed or the destination of an specific mobile 
node, then you need to change parameters of setdest as you have mentioned 
yourself.
 
Kind Regards,
Mona
-----------------------------------------------------------
Mona Ghassemian, PhD student
Centre for Telecommunications Research
King's College London
Drury Lane, London WC2R 5RL
T: +44 20 7848 2889
F: +44 20 7848 2664
E: [email-masked]
-----------------------------------------------------------

To: [email-masked]
Reply-To: [email-masked]
From: "Jack Wang" <[email-masked]>
Date: Tue, 11 May 2004 12:49:42 -0400 (EDT)
Subject: [manet] Question about NS2 simulation of Ad Hoc netowrk.

Hi all:

For Ad Hoc network simulation in NS2, I can use setdest to genenate a 
mobility pattern.
After I get the output from setdest, can I modify the output?
For example, if want a node to be stationary during the whole simulation, 
I only keep the original coordinates of the node and delete all other 
lines, like:
$ns_ at 9.000000000000 "$node_(11) setdest 952.680251940036 
841.668771362655 6.978688752644" 
If I want to change the destination and speed of a node, I can also modify 
the lines containing these information, like the above line.
Am I right? Will it cause any error?

Thanks.

Jack

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Pedro M. Ruiz" <[email-masked]>
Date: Mon, 17 May 2004 19:40:55 +0200

AFAIK, God is an object with a perfect knowledge about the topology. It 
was used by CMU to assess the performance of ad hoc routing protocols 
compared to the optimal routes. I think that if you are not interested 
in making the same comparisons, then you can change those files without 
the need to update God with those changes.

Regards, Pedro