Subject: Re: [manet] Question about NS2 simulation of Ad Hoc netowrk

From: Shshank Sharma <[email-masked]>
Date: Wed, 12 May 2004 10:28:23 -0700 (PDT)

> Message: 1
> To: [email-masked]
> Reply-To: [email-masked]
> From: "Jack Wang" <[email-masked]>
> Date: Tue, 11 May 2004 12:49:42 -0400 (EDT)
> Subject: [manet] Question about NS2 simulation of Ad Hoc netowrk.
>
> Hi all:
>
> For Ad Hoc network simulation in NS2, I can use setdest to genenate a mobility pattern.
> After I get the output from setdest, can I modify the output?
> For example, if want a node to be stationary during the whole simulation, I only keep the original coordinates of the node and delete all other lines, like:
> $ns_ at 9.000000000000 "$node_(11) setdest 952.680251940036 841.668771362655 6.978688752644"
> If I want to change the destination and speed of a node, I can also modify the lines containing these information, like the above line.
> Am I right? Will it cause any error?
>
> Thanks.
>
> Jack

You sure can modify the output to enforce the desired behavior. However,
you will need to define the state of the node for the entire length of the
simulation.

-Shshank
http://www.shshank.org

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Jack Wang" <[email-masked]>
Date: Thu, 20 May 2004 11:17:07 -0400 (EDT)

I think so, too.

Jack

 --- On Mon 05/17, Pedro M. Ruiz < [email-masked] > wrote:
From: Pedro M. Ruiz [mailto: [email-masked]]
To: [email-masked]
     Cc: [email-masked], [email-masked], [email-masked]
Date: Mon, 17 May 2004 19:40:55 +0200
Subject: Re: [manet] Question about NS2 simulation of Ad Hoc netowrk

<br>AFAIK, God is an object with a perfect knowledge about the topology. It <br>was used by CMU to assess the performance of ad hoc routing protocols <br>compared to the optimal routes. I think that if you are not interested <br>in making the same comparisons, then you can change those files without <br>the need to update God with those changes.<br><br>Regards, Pedro<br><br>Nilesh Bansal wrote:<br><br>>Interesting question Jack, But i got a doubt in the earlier solution <br>>itself. If u change the mobility file as u said, or add some fix nodes <br>>in the tcl file as suggested by mona, then won't it be required to provide <br>>this (n other coz of this) information to "god"? If yes, then how to do <br>>it?<br>><br>>Actually the doubt arises bcoz of mysterious working/significance of <br>>god... Any i/ps why exactly it's needed?<br>><br>>regards,<br>>--nilesh  <br>><br>>------------------------------------------------------------------<br>>Thanks a lot. That is a good idea. !
 I will try it.<br>>Another question is, if I want to limit the movement of some nodes within <br>>a  small part of the whole simulation region, what should I do? One method <br>>is to modify the output of setdest. But it is complex. <br>>Any better approaches?<br>><br>>Jack<br>><br>><br>> --- On Thu 05/13, Mona < [email-masked] > wrote:<br>>From: Mona [mailto: [email-masked]]<br>>To: [email-masked]<br>>     Cc: [email-masked]<br>>Date: Thu, 13 May 2004 11:12:21 +0100<br>>Subject: RE: [manet] Question about NS2 simulation of Ad Hoc netowrk.<br>><br>> Hi <br>>Jack,<br>> <br>>If you want to create a mobility file with some fixed specific nodes, the <br>>easiest way is to create your mobility file for number of mobile nodes. <br>>Then set the position of the fix nodes in the tcl file.<br>> <br>>For example you want to generate a scenario with 10 mobile nodes and 4 <br>>fixed nodes. Simply create a mobility file for 10 nodes, set you number of <br>>mobil!
 e nodes in your tcl file as 14 and define the position of fixed nodes 
<br>>in the tcl file.<br>> <br>>If you want to change the speed or the destination of an specific mobile <br>>node, then you need to change parameters of setdest as you have mentioned <br>>yourself.<br>> <br>>Kind Regards,<br>>Mona<br>>-----------------------------------------------------------<br>>Mona Ghassemian, PhD student<br>>Centre for Telecommunications Research<br>>King's College London<br>>Drury Lane, London WC2R 5RL<br>>T: +44 20 7848 2889<br>>F: +44 20 7848 2664<br>>E: [email-masked]<br>>-----------------------------------------------------------<br>><br>>To: [email-masked]<br>>Reply-To: [email-masked]<br>>From: "Jack Wang" <[email-masked]><br>>Date: Tue, 11 May 2004 12:49:42 -0400 (EDT)<br>>Subject: [manet] Question about NS2 simulation of Ad Hoc netowrk.<br>><br>><br>>Hi all:<br>><br>>For Ad Hoc network simulation in NS2, I can use setdest to genenate a <br>>mobility pattern.<br>>After I get the output from setdest, can I modify the output?<br>>!
 For example, if want a node to be stationary during the whole simulation, <br>>I only keep the original coordinates of the node and delete all other <br>>lines, like:<br>>$ns_ at 9.000000000000 "$node_(11) setdest 952.680251940036 <br>>841.668771362655 6.978688752644" <br>>If I want to change the destination and speed of a node, I can also modify <br>>the lines containing these information, like the above line.<br>>Am I right? Will it cause any error?<br>><br>>Thanks.<br>><br>>Jack<br>><br>><br>>_______________________________________________<br>>manet mailing list<br>>[email-masked]<br>>https://www1.ietf.org/mailman/listinfo/manet<br>><br>>  <br>><br><br><br>

_______________________________________________
Join Excite! - http://www.excite.com
The most personalized portal on the Web!