Subject: [manet] Re: manet digest, Vol 1 #834 - 3 msgs

From: "C.Rama Krishna" <[email-masked]>
Date: Fri, 7 May 2004 09:18:31 +0400 (RET)

***********************************************
This Mail is Certified to be Virus Free.

CIC Network Security Group, IIT Kharagpur
***********************************************

****************************************************
This Mail is certifiled to be Virus Free

CIC Network Security Group
****************************************************

Hi,

I am using GloMoSim 2.03 for my work. can anyone tell me about how given
node say X is in the range of another node say Y,Z,and so on... ? I mean
where exactly (which file should I like into) the range of nodes is
calculated during simulation time? In fact, radio_range.exe gives me the
Tx range of all nodes, but it does not say how the range of a node is
calculated during simulation. Any help on this is appreciated.

Thanks.

****************************************************************************
C.Rama Krishna,
R/S,E & ECE Department,
Indian Institute of Technology,
KHARAGPUR - 721 302
India.

Phone: 91-3222-281500
****************************************************************************

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Sukanta K. Hazra" <[email-masked]>
Date: Fri, 07 May 2004 15:21:29 +0800

> calculated during simulation. Any help on this is appreciated.

Depends on the pathloss model used, the transmission power, and the 
threshold SNR of the receiver. Look into the radio subdirectory for
pathloss models.

Try posting to the glomosim list for more information.

- Sukanta

---

From: Manoj K Pandey <[email-masked]>
Date: Mon, 10 May 2004 13:15:00 -0700 (PDT)

hi Rama,

Distance is estimated in radio/propagation.pc file,
upon which depending upon the model ones uses,
path_loss for that distance is estimated.

Estimated path_loss is then substraced from the
tranmission power to estimate the signal
at the receiver. If this signal level
is less than the propagation limit
(specified in the config.in input file)
then the receiver is presumed to be
non_reachable.

hope I wasn't too late in replying!
-manoj

******************************
Manoj Pandey, PhD student,
#207C, Network Research Lab,
Deschutes, Computer and Information Science,
University of Oregon, Phone# 541-346-0892 [Office],
www.cs.uoregon.edu/~manoj
******************************