Subject: [manet] Question about NS2 simulation of Ad Hoc netowrk.

From: "Jack Wang" <[email-masked]>
Date: Tue, 11 May 2004 12:49:42 -0400 (EDT)

Hi all:

For Ad Hoc network simulation in NS2, I can use setdest to genenate a mobility pattern.
After I get the output from setdest, can I modify the output?
For example, if want a node to be stationary during the whole simulation, I only keep the original coordinates of the node and delete all other lines, like:
$ns_ at 9.000000000000 "$node_(11) setdest 952.680251940036 841.668771362655 6.978688752644"  
If I want to change the destination and speed of a node, I can also modify the lines containing these information, like the above line.
Am I right? Will it cause any error?

Thanks.

Jack

_______________________________________________
Join Excite! - http://www.excite.com
The most personalized portal on the Web!

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Jack Wang" <[email-masked]>
Date: Thu, 13 May 2004 01:29:24 -0400 (EDT)

Thanks a lot.
When I modify the output of setdest, I should ensure that it is reasonable, right?
For example, assume pause time is 10 seconds. The following two lines are impossible case.
$ns_ at 1.00 "$node_(11) setdest 1.0 10.0 2.0
$ns_ at 5.00 "$node_(11) setdest 1.0 100.0 2.0  

Am I right?

Jack

 --- On Tue 05/11, Kimaya M. Sanzgiri < [email-masked] > wrote:
From: Kimaya M. Sanzgiri [mailto: [email-masked]]
To: [email-masked]
Date: Tue, 11 May 2004 11:39:58 -0700 (PDT)
Subject: Re: [manet] Question about NS2 simulation of Ad Hoc netowrk.

<br>Yes, you can do this. It won't cause any error.<br><br>Kimaya<br><br><br>On Tue, 11 May 2004, Jack Wang wrote:<br><br>> <br>> Hi all:<br>> <br>> For Ad Hoc network simulation in NS2, I can use setdest to genenate a mobility pattern.<br>> After I get the output from setdest, can I modify the output?<br>> For example, if want a node to be stationary during the whole simulation, I only keep the original coordinates of the node and delete all other lines, like:<br>> $ns_ at 9.000000000000 "$node_(11) setdest 952.680251940036 841.668771362655 6.978688752644"  <br>> If I want to change the destination and speed of a node, I can also modify the lines containing these information, like the above line.<br>> Am I right? Will it cause any error?<br>> <br>> Thanks.<br>> <br>> Jack<br>> <br>> _______________________________________________<br>> Join Excite! - http://www.excite.com<br>> The most personalized portal on the Web!<br>> <br>> _______________________________________________!
 <br>> manet mailing list<br>> [email-masked]<br>> https://www1.ietf.org/mailman/listinfo/manet<br>> <br><br>

---

From: "Mona" <[email-masked]>
Date: Thu, 13 May 2004 11:12:21 +0100

Hi Jack,

If you want to create a mobility file with some fixed specific nodes, the easiest way is to create your mobility file for number of mobile nodes. Then set the position of the fix nodes in the tcl file.

For example you want to generate a scenario with 10 mobile nodes and 4 fixed nodes. Simply create a mobility file for 10 nodes, set you number of mobile nodes in your tcl file as 14 and define the position of fixed nodes in the tcl file.

If you want to change the speed or the destination of an specific mobile node, then you need to change parameters of setdest as you have mentioned yourself.

Kind Regards,
Mona
-----------------------------------------------------------
Mona Ghassemian, PhD student
Centre for Telecommunications Research
King's College London
Drury Lane, London WC2R 5RL
T: +44 20 7848 2889
F: +44 20 7848 2664
E: [email-masked]
-----------------------------------------------------------

To: [email-masked]
Reply-To: [email-masked]
From: "Jack Wang" <[email-masked]>
Date: Tue, 11 May 2004 12:49:42 -0400 (EDT)
Subject: [manet] Question about NS2 simulation of Ad Hoc netowrk.

Hi all:

Thanks.

Jack

---

From: "Jack Wang" <[email-masked]>
Date: Thu, 13 May 2004 11:27:34 -0400 (EDT)

Thanks a lot.
That is a good idea. I will try it.
Another question is, if I want to limit the movement of some nodes within a  small part of the whole simulation region, what should I do? One method is to modify the output of setdest. But it is complex. 
Any better approaches?

Jack

 --- On Thu 05/13, Mona < [email-masked] > wrote:
From: Mona [mailto: [email-masked]]
To: [email-masked]
     Cc: [email-masked]
Date: Thu, 13 May 2004 11:12:21 +0100
Subject: RE: [manet] Question about NS2 simulation of Ad Hoc netowrk.

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META http-equiv=Content-Type content="text/html; charset=windows-1252">
<META content="MSHTML 6.00.2800.1400" name=GENERATOR>
<STYLE></STYLE>
</HEAD>
<BODY bgColor=#ffffff>
<DIV>
<DIV><FONT size=2>Hi Jack,</FONT></DIV>
<DIV><FONT size=2></FONT> </DIV>
<DIV><FONT size=2>If you want to create a mobility file with some fixed specific 
nodes, the easiest way is to create your mobility file for number of mobile 
nodes. Then set the position of the fix nodes in the tcl file.</FONT></DIV>
<DIV><FONT size=2></FONT> </DIV>
<DIV><FONT size=2>For example you want to generate a scenario with 10 mobile 
nodes and 4 fixed nodes. Simply create a mobility file for 10 nodes, set you 
number of mobile nodes in your tcl file as 14 and define the position of fixed 
nodes in the tcl file.</FONT></DIV>
<DIV><FONT size=2></FONT> </DIV>
<DIV><FONT size=2>If you want to change the speed or the destination of an 
specific mobile node, then you need to change parameters of setdest as you have 
mentioned yourself.</FONT></DIV>
<DIV><FONT size=2></FONT> </DIV>
<DIV><FONT size=2>Kind Regards,</FONT></DIV>
<DIV><FONT size=2>Mona</FONT></DIV>
<DIV><FONT 
size=2>-----------------------------------------------------------<BR>Mona 
Ghassemian, PhD student<BR>Centre for Telecommunications Research<BR>King's 
College London<BR>Drury Lane, London WC2R 5RL<BR>T: +44 20 7848 2889<BR>F: +44 
20 7848 2664<BR>E: <A 
href="mailto:[email-masked]">[email-masked]</A><BR>-----------------------------------------------------------<BR></DIV></FONT></DIV>
<DIV>To: <A href="mailto:[email-masked]">[email-masked]</A><BR>Reply-To: <A 
href="mailto:[email-masked]">[email-masked]</A><BR>From: "Jack Wang" 
<<A href="mailto:[email-masked]">[email-masked]</A>><BR>Date: Tue, 
11 May 2004 12:49:42 -0400 (EDT)<BR>Subject: [manet] Question about NS2 
simulation of Ad Hoc netowrk.<BR><BR><BR>Hi all:<BR><BR>For Ad Hoc network 
simulation in NS2, I can use setdest to genenate a mobility pattern.<BR>After I 
get the output from setdest, can I modify the output?<BR>For example, if want a 
node to be stationary during the whole simulation, I only keep the original 
coordinates of the node and delete all other lines, like:<BR>$ns_ at 
9.000000000000 "$node_(11) setdest 952.680251940036 841.668771362655 
6.978688752644"  <BR>If I want to change the destination and speed of a 
node, I can also modify the lines containing these information, like the above 
line.<BR>Am I right? Will it cause any 
error?<BR><BR>Thanks.<BR><BR>Jack<BR><BR>_______________________________________________<BR>Join 
Excite! - <A href="http://www.excite.com">http://www.excite.com</A><BR>The most 
personalized portal on the Web!<BR></DIV></BODY></HTML>
<p>