Subject: RE: [manet] any techniques on velocity estimation/prediction in M ANET?

From: Edward Hua <[email-masked]>
Date: Fri, 24 Sep 2004 00:43:23 -0400 (EDT)

Rex,

  you're right, I was talking about the velocity of the node as measured 
in the physical layer.

  The reason I'm asking is I'm curious if there's any papers in the 
literature that talk about using velocity information to help improve 
performance (by any performance metric) by the network-layer routing 
protocol. Specifically, I'm wondering if any realistic method of 
velocity estimation/prediction is developed for MANET in implementation, 
not in simulation where you assume the knowledge of node velocity a 
priori. This could be, for example, as an appendix of a published paper. 

     So, if anyone has any reference like that, I appreciate a pointer.

-Ed

 On Thu, 23 Sep 2004, 
Rex Buddenberg wrote:

> Ed,
> 
> You ought to then be specific: layer 1 velocity.
> 
> Which makes the question irrelevant to the MANET list since MANET deals
> with layer 3 protocols where velocity is measured in terms of network
> volatility -- router-to-router connections coming and going.  MANET is
> expressly targeted at reconverging the network in the face of this
> volatility.
> 
> Just to complete the list, you can measure 'velocity' in layer 2 by
> shifting from one cellphone pylon to the next.  There are also layer 4
> issues -- keeping your connections open in the face of this volatility. 
> 
> 
> Now, to physical layer velocity.  Comparison of Lat/Long positions and
> their change over time is indeed one way to measure.  Many radio
> networks contain some kind of internal (in-band) measurements.  Link 11
> has a doppler shift field in it's frame format.  802.16 has a layer 2
> (MAC) ranging message which has several values that get exchanged.  .16
> has a harder problem since it is a slotted system -- SSs need to stay
> within their timeslots.  .16 also has signal strengh values in the
> ranging message which allows the BS to pick an appropriate modulation
> scheme.  Exactly how these values are determined by a station is a local
> matter (station design) and are not in the standard.  
> 
> Help?
> 
> 
> 
> 
> On Thu, 2004-09-23 at 13:57, Edward Hua wrote:
> > I am looking at velocity that's distance/time. I know some proposals
> > use GPS to estimate the speed and direction at which each node moves. I'm 
> > wondering how others might have done the velocity estimation without the 
> > aid of GPS.
> > 
> > Is there a paper, Daniel, on the FIR technique that you suggested that is 
> > tailored for MANETs? Thanks.
> > 
> > -Ed
> > 
> > On Thu, 23 Sep 2004, DANIEL BYRNE wrote:
> > 
> > > I'm wondering how do you define node velocity?    Is it in hops/time, distance/time.  The speed at which a message propagates through an adhoc network is related to node processing speed, overhead, congestion, collision, interference, node volatility, node motion, and numerous other factors.  Any number you come up with wouldn't be useful for more than a few minutes in a highly volatile mesh.  The measuire would make more sense and would be more reliable would be in a mesh composed of static, immobile base stations.  I think that in a generic moderately volatile mesh network the only accurate method of node velocity would be a FIR filter applied to a tapped delay line of packet propagation times.  The weights can be adjusted as you see fit, or it could be just a simple average.
> > > 
> > > t1*w1 t2*w2 t3*w3 t4*w4 t5*w5 t6*w6 t7*w7 t8*w8 t9*w9 t10*w10
> > > 
> > > -----Original Message-----
> > > From: [email-masked] [mailto:[email-masked]]On Behalf Of
> > > Edward Hua
> > > Sent: Thursday, September 23, 2004 1:16 PM
> > > To: [email-masked]
> > > Subject: [manet] any techniques on velocity estimation/prediction in
> > > MANET? 
> > > 
> > > 
> > > Hello,
> > > 
> > >    I'm wondering if anybody could point me to some references that deal 
> > > with methods on velocity estimation/prediction (either individual node 
> > > velocity or relative velocity between two nodes) in mobile ad hoc networks. 
> > > Actual methods that are implementable (not just in simulation) are preferred. 
> > > Thanks in advance.
> > > 
> > > -Ed
> > > 
> > > 
> > > 
> > > _______________________________________________
> > > manet mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/manet
> > > 
> > > _______________________________________________
> > > manet mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/manet
> > > 
> > > 
> > 
> > 
> > _______________________________________________
> > manet mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/manet
> 

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: David Young <[email-masked]>
Date: Fri, 24 Sep 2004 11:30:22 -0500

> priori. This could be, for example, as an appendix of a published paper. 

Edward,

If I understand you correctly, you don't want to use velocity to
estimate future location so much as you want to estimate future network
connectivity, so that you can optimize the routing/forwarding function?

If that is about right, and you can make certain assumptions---"fixed"
nodes abound (on lampposts, say), or else many nodes move in a fixed
relationship (a "caravan")---maybe you can estimate future adjacencies
from past and present adjacencies using a probabilistic model---no
velocity information being necessary.  My hazy recollection is that
Microsoft Research did something like that to optimize their software
for locating roving 802.11 clients based on RSSI at the APs.

There are beam-forming antenna technologies for 802.11 coming from
Motia and Atheros.  A rep from Motia told me that you can download the
phase-shifter settings from their part, and I bet Atheros is the same.
These phase settings might be valuable inputs to an algorithm for
estimating a node's velocity.

I should ask whether by implementable you mean "using 802.11 radios,"
or "using a device I will build in the lab" ?

Dave

-- 
David Young             OJC Technologies
[email-masked]      Urbana, IL * (217) 278-3933