Subject: Re: [manet] Mackill for newer kernels?

From: Roar Bjørgum Rotvik <[email-masked]>
Date: Wed, 22 Sep 2004 08:09:34 +0200

Marcin Michalak wrote:
> On 21 Sep 2004 at 17:12, Marcin Michalak wrote:
> 
>>Hello,
>> I'm trying to check multihop behaviour and need to filter packets on 
>>the MAC level. I'm trying Mackill, but what I found works only with 
>>kernels up to 2.4.18, later structures are changed and patch can't be 
>>applied.
>> Is there any other similar tools? Does anybody have mackill working 
>>with kernel 2.4.22 or 2.6.x? Any similar solutions available?
>> Regards,
>>  Marcin
> 
> I would like to thank everybody for a quick response. The command is 
> simple, I didn't realize it can be done with iptables:
> iptables -A INPUT -m mac --mac-source $MAC_ADDR -j DROP
>  Have a good day,
>   Marcin

Just a small notice on the command you are quoting. I suggested 
"iptables -I INPUT 1 ..." instead of "iptables -A INPUT".

The difference is that "-I" means "input rule at position after rule 
name", i.e. in my example insert rule first in INPUT checking.
Option "-A" appends the rule _last_ in INPUT checking.

If you don't use any other iptables rules in INPUT this is probably not 
a problem, but if you have many iptables rules and you don't have full 
control over them there may be an earlier rule in INPUT that so happens 
to accept the packet before it reaches the mac-filter check (when a 
iptables rule is matched, it normally doesn't check the rest of the 
rules). The packet is then allowed in to the machine even though you 
have the mac-filter.

Just to inform you about a possible problem..

-- 
Roar Bjørgum Rotvik

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Kilian Weniger <[email-masked]>
Date: Wed, 22 Sep 2004 10:02:41 +0200

Hi Marcin,

the Wireless Network Topology Emulator (WNTE) is a similar tool. It is based 
on iptables MAC filters and features a Qt-based GUI to visualize and modify 
the network topology to be emulated.

WNTE is available for download at

http://sourceforge.net/projects/wnte/

Regards,

Kilian

Am Dienstag, 21. September 2004 17:12 schrieb Marcin Michalak:
> ----------------------------------------------------------
> Marcin Michalak		Research Engineer
> Mobile: +41 79 330 83 51	Telscom AG
>
>

-- 
Dr.-Ing. Kilian Weniger	
Institute of Telematics, Universitaet Karlsruhe (TH)
Zirkel 2, 76128 Karlsruhe, Germany
Phone: +49 721 608 6415, Fax: +49 721 388097
Email: [email-masked], HP: http://www.tm.uka.de/~weniger