Subject: RE: [manet] any techniques on velocity estimation/prediction in M ANET?

From: DANIEL BYRNE <[email-masked]>
Date: Thu, 23 Sep 2004 16:06:23 -0500

I guess I misunderstood then.  I assumed you were looking to track a
packet's velocity, but you are wanting to track a node's velocity, right?  I
haven't researched that topic, and the filter technquie I described came off
the top of my head, but I would use it to track the velocity of packets
through the network to a specific node.  I would assume node velocity would
fall under a probability distribution problem.  I don't follow those topics,
sorry.

-----Original Message-----
From: Edward Hua [mailto:[email-masked]]
Sent: Thursday, September 23, 2004 3:58 PM
To: DANIEL BYRNE
Cc: [email-masked]
Subject: RE: [manet] any techniques on velocity estimation/prediction in
M ANET?

I am looking at velocity that's distance/time. I know some proposals
use GPS to estimate the speed and direction at which each node moves. I'm 
wondering how others might have done the velocity estimation without the 
aid of GPS.

Is there a paper, Daniel, on the FIR technique that you suggested that is 
tailored for MANETs? Thanks.

-Ed

On Thu, 23 Sep 2004, DANIEL BYRNE wrote:

> I'm wondering how do you define node velocity?    Is it in hops/time,
distance/time.  The speed at which a message propagates through an adhoc
network is related to node processing speed, overhead, congestion,
collision, interference, node volatility, node motion, and numerous other
factors.  Any number you come up with wouldn't be useful for more than a few
minutes in a highly volatile mesh.  The measuire would make more sense and
would be more reliable would be in a mesh composed of static, immobile base
stations.  I think that in a generic moderately volatile mesh network the
only accurate method of node velocity would be a FIR filter applied to a
tapped delay line of packet propagation times.  The weights can be adjusted
as you see fit, or it could be just a simple average.
> 
> t1*w1 t2*w2 t3*w3 t4*w4 t5*w5 t6*w6 t7*w7 t8*w8 t9*w9 t10*w10
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Edward Hua
> Sent: Thursday, September 23, 2004 1:16 PM
> To: [email-masked]
> Subject: [manet] any techniques on velocity estimation/prediction in
> MANET? 
> 
> 
> Hello,
> 
>    I'm wondering if anybody could point me to some references that deal 
> with methods on velocity estimation/prediction (either individual node 
> velocity or relative velocity between two nodes) in mobile ad hoc
networks. 
> Actual methods that are implementable (not just in simulation) are
preferred. 
> Thanks in advance.
> 
> -Ed
> 
> 
> 
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/manet
> 
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/manet
> 
> 

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Bush, Stephen F (Research)" <[email-masked]>
Date: Sat, 25 Sep 2004 10:46:25 -0400

We have a paper under review for an upcoming conference on 
motion entropy and it's impact on predicting network topology 
and routing performance.

Predictive network gain is examined in detail for several cases,
namely: 

(a) delaying transmission to achieve faster throughput because 
	a better route is likely to form
(b) predictive routing around mobile noise sources
(c) temporally discontinuous routing 
(d) the likelihood of detecting flash routes. We define flash routes as
routes whose duration would be too short to be detectable via traditional
routing mechanisms without prediction. 

As part of this work we derive, and compare against, a theoretical 
optimum ad hoc routing update time and overhead for a wireless ad 
hoc network using traditional routing update mechanisms.

(This work was funded thru Lockheed Martin Shared Vision in collaboration
with Lockheed Martin Advanced Technology Laboratories.)

Stephen F Bush (http://www.research.ge.com/~bushsf)

> From: Huneycutt, Doug [mailto:[email-masked]]
> Sent: Thursday, September 23, 2004 4:53 PM
> To: [email-masked]
> I too would be very interested in any work being done to incorporate
> geospatial awareness into MANET routing algorithms.  Items such as
> predictive steering, augmented precompensation, predetermined
> next-several-hops calculations, etc.
> 
> Thanks,
> Doug
> 
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of DANIEL BYRNE
> Sent: Thursday, September 23, 2004 5:06 PM
> To: 'Edward Hua'
> Cc: [email-masked]
> haven't researched that topic, and the filter technquie I 
> described came
> off
> factors.  Any number you come up with wouldn't be useful for 
> more than a
> few
> > From: [email-masked] 
> [mailto:[email-masked]]On Behalf
> Of
> > Edward Hua