Subject: [manet] Which Simulator can do per-packet power control?

From: Vinod <[email-masked]>
Date: Wed, 6 Oct 2004 17:59:18 -0700 (PDT)

Hi All. I was hoping to do some simulation work on
topology control in manet's. could anyone advise me
what simulator is able to do per-packet power control?
I had a look at ns-2 and it seems the power for nodes
are set at the beginning and can't be changed later
(correct me if i am wrong.would be very helpful if
'how' can also be explained). I haven't looked at
glomosim or opnet. I would prefer NS2, but if i have
to, i am willing to put the effort in for the other
two. 
p.s: I was under the impression that lot of power
control work that has been published was done on
ns2.however, i see no contributed code or extensions
for power control in ns2. Any pointers to
implementations on ns2 are most welcome
Thanks,
Vinod

__________________________________
Do you Yahoo!?
Take Yahoo! Mail with you! Get it on your mobile phone.
http://mobile.yahoo.com/maildemo 

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Christian de Waal <[email-masked]>
Date: Thu, 07 Oct 2004 08:53:02 +0200

Hi Vinod,

indeed it is possible to control the tx power of a mobile node in ns-2. 
You can get the WirelessPhy of a node at runtime with the following 
expression:

(WirelessPhy*)(Node::get_node_by_address(here_.addr_))->ifhead().lh_first;

This is what we use in our ns-2 implementation of the "Cooperative 
Nearest Neighbours Topology Control" (which is not "per packet", put 
"per node"). Unfortunately, the code is not yet in state to be publicly 
released, but we might do so soon.

Best regards,
Christian de Waal

-- 
____________________________________________________________________
Christian de Waal

University of Bonn                            Phone: +49 228 73-4548
Institute of Computer Science IV                Fax: +49 228 73-4571
Roemerstr. 164                         E-mail: [email-masked]
53117 Bonn, Germany                    http://www.cs.uni-bonn.de/IV/