Subject: [manet] few questions about MAC protocol

From: Parag Goswami <[email-masked]>
Date: Wed, 27 Oct 2004 12:29:55 -0700 (PDT)

Dear all,
Could anybody please tell me the anwere to these questions ?
Why does the complexity in MAC protocol design for wireless ad hoc networks arises due to  :
1.  node mobility
2. radio link vulnerability and 
3. the lack of central coordination
 
Thanks for the consideration.
 
Regards,
Parag Goswami
http://www.geocities.com/paragboom2k

---------------------------------
Do you Yahoo!?
Yahoo! Mail - Helps protect you from nasty viruses.

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Brijesh Kumar" <[email-masked]>
Date: Wed, 27 Oct 2004 18:01:20 -0400

Parag:

It is a big area to explain. Here are some
short answers, and pointers for you to explore
further.

>> Why does the complexity in MAC protocol design for wireless ad hoc
networks arises due to  :

Node mobility affects how time slots get allocated to
existing nodes in the network/ or how often the contention
will occur for the control of the channel. This directly
affects throughput and energy efficiency of MAC protocols.

>> 2. radio link vulnerability and

Radio link vulnerability needs to be dealt with additional
security mechanisms. The more information you put in
a control channel, less you are left for data transmission.
It has direct impact on efficiency of the MAC protocols.

>>3. the lack of central coordination

It is hard to obtain energy efficiency without
central co-ordination. If no node
tells you when to sleep and wake up to
listen for incoming transmission, then
you may have to listen to every frame from
every one. That's not you want for large ad-hoc
networks.

Cheers,

--bk