Subject: [manet] Which simulator is better to use?

From: Maximiliano Eschoyez <[email-masked]>
Date: Wed, 13 Oct 2004 19:17:25 -0300 (ART)

Dear all,

I'm starting my Ph.D studies in ad hoc routing and I'm wondering which network 
simulator is good enough to test and develop protocols.

I've started to use NS2 because is widely known and used as reference. But, 
those bugs related with the 802.11 MAC code (thread of August) disapponted me a 
litle bit.

Also, I've been using GloMoSim 2.03, but this release is a little bit older 
(2000) and not so well documented.

As I have seen, there is a lot of contributed routing code made for OPNet, but 
I didn't tried it yet.

So, my question is which of these (or other) simulator could you recommend me? 
I want to hear experiencies, pros and cons, etc.

Thanks in advance!

Regards,

         Maximiliano Eschoyez
      Ing. en Telecomunicaciones

              +-------------------------------------------+
              |  Laboratorio de Comunicaciones Digitales  |
              |         http://lcd.efn.uncor.edu/         |
              |                                           |
              |      Universidad Nacional de Córdoba      |
              |            Córdoba - Argentina            |
              +-------------------------------------------+

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Einar Vollset <[email-masked]>
Date: Thu, 14 Oct 2004 10:52:01 +0100

Hello Maximiliano,

I would strongly recommend taking a look at SWANS developed by Rimon  
Barr at
Cornell. Impressive performance in terms of possible simulation sizes,  
and also
allows you to develop in Java (a bonus to me at least) and harness  
"real" java
applications to simulate.
The one downside is that it's not widely used (yet), and thus has a  
limited amount
of "standard" protocols available (particularly w.r.t multicast).

http://jist.ece.cornell.edu/index.html

Cheers,

Einar

On 13 Oct 2004, at 23:17, Maximiliano Eschoyez wrote:

> Dear all,
>
> I'm starting my Ph.D studies in ad hoc routing and I'm wondering which  
> network simulator is good enough to test and develop protocols.
>
> I've started to use NS2 because is widely known and used as reference.  
> But, those bugs related with the 802.11 MAC code (thread of August)  
> disapponted me a litle bit.
>
> Also, I've been using GloMoSim 2.03, but this release is a little bit  
> older (2000) and not so well documented.
>
> As I have seen, there is a lot of contributed routing code made for  
> OPNet, but I didn't tried it yet.
>
> So, my question is which of these (or other) simulator could you  
> recommend me? I want to hear experiencies, pros and cons, etc.
>
> Thanks in advance!
>
> Regards,
>
>         Maximiliano Eschoyez
> +------------------------------------------- 
> +_______________________________________________
> manet mailing list
> [email-masked]

---

From: "Charles E. Perkins" <[email-masked]>
Date: Thu, 14 Oct 2004 08:03:23 -0700

Hello folks,

 I would recommend looking at SNS-2, also from Cornell.
It is NS-2 souped up with some performance enhancements
that allow large-scale simulations in much reduced time.
We use it and like it.

Is anyone working on improving the previously noted
deficiencies of the NS-2 802.11 models (sorry I don't
remember the specifics)?

Regards,
Charlie P.

Einar Vollset wrote:

> Cornell. Impressive performance in terms of possible simulation 
> sizes,  and also
>> I'm starting my Ph.D studies in ad hoc routing and I'm wondering 
>> which  network simulator is good enough to test and develop protocols.
>>
>> I've started to use NS2 because is widely known and used as 
>> reference.  But, those bugs related with the 802.11 MAC code (thread 
>> of August)  disapponted me a litle bit.
>>
>> Also, I've been using GloMoSim 2.03, but this release is a little 
>> bit  older (2000) and not so well documented.
>>
>>              |      Universidad Nacional de Csrdoba      |
>>              |            Csrdoba - Argentina            |