Subject: RE: [manet] TCP for MANETs

From: [email-masked]
Date: Fri, 1 Oct 2004 09:18:48 +0200

Hi,

You can read "A Comparison of TCP Performance aver Three Routing Protocols
for Mobile Ad Hoc Networks", from Thomas D. Dyer  Rajendra V. Boppana.
In this document  a heuristique is used on the TCP sender to avoid doubling
more than once the TCP RTO when route is considered broken.

	Raphael

-----Message d'origine-----
De : B. Venkata Ramana [mailto:[email-masked]]
Envoye : vendredi 1 octobre 2004 05:37
A : [email-masked]
Objet : [manet] TCP for MANETs

hi all

Are there any proposals on TCP for ad hoc networks that do NOT require 
(obtain) any explicit feedback from the network. I had come across to see 
such proposals some time back. But i am unable to trace them back now. can 
you please give me some info on this.

regards
ramana,
HPCN Lab,
Dept. of CSE
IIT-Madras
India

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Manoj K Pandey <[email-masked]>
Date: Fri, 1 Oct 2004 13:57:37 -0700 (PDT)

hi Ramana,

There is a paper, which focuses on identifying congestion
based losses from "random" wireless losses. Here is the reference:
  @inproceedings{tcp-adhoc-door,
  author = "Feng Wang and Yongguang Zhang",
  title = "Improving TCP Performance over Mobile Ad-Hoc Networks with Out-of-Order Detection and Response",
  booktitle = "Mobihoc",
  year = "2002"}

There is some work done in the area of differentiating congestion
losses from wireless losses in TCP for an infrastructured wireless
network [wired + base station] (but this is not ad hoc network). You can
find comparision of some of these in this:
  @misc{tcp-wireless-differentiating-losses-comparison,
  author = "S. Cen and P. Cosman and G. Voelker",
  title = "End-to-end differentiation of congestion and wireless Losses",
  text = "S. Cen,P. Cosman, G.M. Voelker,End-to-end differentiation of congestion and wireless Losses, Proceedings of ACM Mul
  year = "2002",
  url = "citeseer.ist.psu.edu/cen02endtoend.html" }

thnx,
Manoj

---

From: Andrea Passarella <[email-masked]>
Date: Mon, 4 Oct 2004 13:09:49 +0200

Hi,

you can take a look at "G. Anastasi and A. Passarella, Towards a Novel 
Transport Protocol for Ad hoc Networks, Proceedings of the Eighth 
International Conference on Personal Wireless Communications (PWC 2003) - 
LNCS Series, Venice (I), September 23-25, 2003." (if you wish, you can 
download it from my home, the address is in the signature).
Our protocol benefits from explicit feedbacks from the network, but is 
designed to work also when such support is very very limited (we just assume 
some routing-layer feedback that is quite common).

Hope this may help,

	Andrea

-- 
Andrea Passarella
=======================================
Ph.D. Student
Pervasive Computing & Networking Lab. (PerLab)
University of Pisa
Dept. of Information Engineering
Via Diotisalvi, 2
56122 Pisa, Italy
=======================================
voice: +39 050 2217 554
fax: +39 050 2217 600
web: http://www.ing.unipi.it/~o783499/research/index.html
email: [email-masked]
=======================================