Subject: [manet] Average Node Speed

From: Hasan K <[email-masked]>
Date: Fri, 22 Oct 2004 04:36:05 -0700 (PDT)

Hello,
 
Consider this simple mobility model: A node chooses a random coordinate (x, y) within a grid then move to it a speed uniformly selected on (0,V]. Then every T seconds, this process is repeated.
 
The question is, what is the average nodal speed? It is not V/2 since we have the T factor. 
 
What do you think?
 
HK

---------------------------------
Do you Yahoo!?
vote.yahoo.com - Register online to vote today!

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Alessandro La Piana <[email-masked]>
Date: Fri, 22 Oct 2004 14:40:20 +0200

Hi,
the average speed should always be V/2.

Let's suppose we take N speed samples. The space traveled in N T seconds 
time will be

Sum[V_i T] = T Sum[V_i] for i  going from 1 to N.
So the average speed will be

Sum[V_i T]              Sum[V_i]                                      V_max
---------------- = ----------------- = (in the limit N->\infinity) 
------------
      N T                  N                                            2

Bye.
       Alessandro La Piana

Hasan K wrote:

> Hello,
>  
> Consider this simple mobility model: A node chooses a random 
> coordinate (x, y) within a grid then move to it a speed uniformly 
> selected on (0,V]. Then every T seconds, this process is repeated.
>  
> ------------------------------------------------------------------------
> Do you Yahoo!?
> vote.yahoo.com <http://vote.yahoo.com> - Register online to vote today!
>
>
>------------------------------------------------------------------------
>

---

From: Hasan K <[email-masked]>
Date: Fri, 22 Oct 2004 06:21:48 -0700 (PDT)

Thanks! That was fast!
 
I agree with you if nodes continue to move till the next time they change speed. But in the model I am describing a node may may stop well before the expiry of T seconds because it reached its random coordinate. I am not sure whether the average (total distance travelled / total time) then will be V/2?!
 
Thanks again!

Alessandro La Piana <[email-masked]> wrote:
Hi,
the average speed should always be V/2.

Bye.
Alessandro La Piana

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com

---

From: "John Mullen" <[email-masked]>
Date: Fri, 22 Oct 2004 10:30:52 -0600

Hi Hasan,
 
The mean speed for nodes in motion will be V/2, but the mean speed over
all nodes will be less.
 
For nodes in motion, the speed is a random variable with an average of
V/2.  As long as a node has not reached its destination, it is moving at
a speed randomly selected from a U(0,T) distribution.
 
However, nodes that reach their destination before traveling T time
units will stop and wait for the start of the next time interval.
Therefore, the average speed is
        (V/2)Pr(Travel time is greater than or equal to T).
 
The distribution of the distances between nodes uniformly distributed in
a rectangular region is approximately bivariate Normal with a mean of
(0,0), assuming your origin is in the center, and a standard deviation
along each axis of W/12, where W is the width of the rectangle along
that axis.  Thus, depending on the ratio of V to Wx and Wy, you can
calculate the probability that the selected travel distance is less than
TV and from that, get your overall average.
 
John Mullen

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Hasan K
Sent: Friday, October 22, 2004 4:36 AM
To: [email-masked]
Subject: [manet] Average Node Speed

Hello,
 
Consider this simple mobility model: A node chooses a random coordinate
(x, y) within a grid then move to it a speed uniformly selected on
(0,V]. Then every T seconds, this process is repeated.
 
The question is, what is the average nodal speed? It is not V/2 since we
have the T factor. 
 
What do you think?
 
HK

  _____  

Do you Yahoo!?

---

From: Hasan K <[email-masked]>
Date: Sun, 24 Oct 2004 00:25:10 -0700 (PDT)

Thank you all.

HK