Subject: [manet] Routing in manets

From: ADHOC <[email-masked]>
Date: Thu, 3 Feb 2005 02:32:14 -0800 (PST)

Hello!!!

I've got few queries regarding routing in MANETs....

1. How to find the lifetime of the nodes dynamically
during simulation using GloMoSim?
 
2. How to send multiple multimedia packets from
different sources to different destinations without
dropping them? Is there any specific traffic generator
for multimedia traffic?
 
3. How to preemptively discard lower precedence
traffic?

Your suggestions are welcome....Any links or reference
to any web material would be appreciated too..
 
Thanks in advance.

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Mehran Abolhasan <[email-masked]>
Date: Fri, 4 Feb 2005 10:28:44 +1100

> during simulation using GloMoSim?

Not sure what you mean exactly by lifetime? if you mean battery power, 
then you have to set a limit yourself in glomosim, by default there is no 
limit. If you mean how long a node has been turned on, then you would have to 
create a lifetime (on and off time) yourself.

> dropping them? Is there any specific traffic generator

There is a number of example files in the scenario directory in glomosim, they 
show you how to set different types of traffic, such as CBR in the app.config 
file. If you want any specific types of traffic you have to create a traffic 
generating file youself. Go to the applications folder and implement it 
there.

> 3. How to preemptively discard lower precedence

Again you have to implement a strategy yourself in glomosim. you could do this 
at the networking layer or MAC layer, depending on what you want to do.

Hope that helped.

Regards,

-- 
Mehran Abolhasan
B.E Computer, PhD
Research Fellow
Telecommunications and IT Research Institute (TITR)
University of Wollongong
Northfields Avenue, NSW, 2522, Australia
Phone: +61 2 4221 3347
Fax: +61 2 4221 3277
http://www.titr.uow.edu.au/~mehran
Email 1: [email-masked]
Email 2: [email-masked]