Subject: RE: [manet] the beacon mechanism in network layer

From: "Giorgio Mulas" <[email-masked]>
Date: Mon, 7 Feb 2005 09:31:39 +0100

Hi,
hereunder some considerations about your questions.
- beaconing mechanisms are needed in order to discover network topology, especially when topology may change in an unpredictable way.
- of course beacons are sent on a regular basis. A rule of thumb should be: the higher the topology change rate (due e.g. to nodes' mobility) the higher the beaconing rate.
- the simplest information in the beacon packet is "here I am!" => you can translate it, for example, in an IP address.
- In theory wireless links are bi-directional, in practice no. An acknowledgment mechanism could be a solution.
 
hope this helps
 
    Giorgio

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of pakorn kulsirimongkol
Sent: lunedì 7 febbraio 2005 8.47
To: [email-masked]
Subject: [manet] the beacon mechanism in network layer

Dear, sir
      pls tell me the beacon mechanism in network layer. 
      Is beacon regularly sent every time?
      nodes in the network must have a time out for waiting beacon right?
      what is time out of beacon?
      what is the information in beacon packet?
      node, how to know a connectivity of other nodes which it receive beacon is bidirectional link.
 
best regard,
add

  _____  

Do you Yahoo!?
Yahoo!  <http://us.rd.yahoo.com/mail_us/taglines/security/*http://promotions.yahoo.com/new_mail/static/protection.html> Mail - You care about security. So do we.

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: pakorn kulsirimongkol <[email-masked]>
Date: Mon, 7 Feb 2005 02:04:31 -0800 (PST)

Thank you for your helping
            However,  I am confused a little bit. From you answer, nodes will broadcast a beacon and then wait for its neighbor ack right.   
            How long node which haven't received its neighbor beacon decide its neighbor disconneted. In some my simulation, there is less time out than it should be because that simulation is much traffic. 
Giorgio Mulas <[email-masked]> wrote:
Hi,
hereunder some considerations about your questions.
- beaconing mechanisms are needed in order to discover network topology, especially when topology may change in an unpredictable way.
- of course beacons are sent on a regular basis. A rule of thumb should be: the higher the topology change rate (due e.g. to nodes' mobility) the higher the beaconing rate.
- the simplest information in the beacon packet is "here I am!" => you can translate it, for example, in an IP address.
- In theory wireless links are bi-directional, in practice no. An acknowledgment mechanism could be a solution.
 
hope this helps
 
    Giorgio

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of pakorn kulsirimongkol
Sent: lunedì 7 febbraio 2005 8.47
To: [email-masked]
Subject: [manet] the beacon mechanism in network layer

Dear, sir
 
best regard,
add

---------------------------------
Do you Yahoo!?
Yahoo! Mail - You care about security. So do we.
		
---------------------------------
Do you Yahoo!?
 Yahoo! Search presents - Jib Jab's 'Second Term'