Subject: RE : [manet] Where is forwarding done in ns2?

From: "Yann ." <[email-masked]>
Date: Mon, 21 Feb 2005 16:41:32 +0100

>From what I've seen, both routing decision and forwarding seem to be done in 
the routing agent.

-----Message d'origine-----
De : Leon Martin [mailto:[email-masked]]
Envoyé : vendredi 18 février 2005 22:07
À : [email-masked]
Objet : [manet] Where is forwarding done in ns2?

Hi all,

I am trying to do static routing for MANET in ns-2. To
do this, I need to know where _forwarding_, instead of _routing_, is 
implemented in ns2 (2.27).

Does anyone know whether the forwarding decision is
made by AODV or by IP?

Thanks.

- Leon

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around
http://mail.yahoo.com

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

_________________________________________________________________
Nouveau MSN Hotmail : 250 Mo d'espace de stockage gratuit ! 
http://www.msn.fr/newmsnhotmail

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Ali Hamidian <[email-masked]>
Date: Mon, 21 Feb 2005 19:58:08 +0100

Hi,

I agree with Yann; in aodv.cc you can find
void
AODV::forward(aodv_rt_entry *rt, Packet *p, double delay) {

which I think is what you're looking for.

Kind regards
Ali