Subject: [manet] 802.11, infrastructure and ad-hoc modes

From: Claudio Lavecchia <[email-masked]>
Date: Wed, 09 Feb 2005 17:52:43 +0100

Hello you MANET people,

I have a short but in my opinion interesting question:

Let's consider a 802.11 network made of an access point and  several stations that generate a "normal" rate of traffic. Let's focus on 2 stations and the 
access point (every equipment "see" each other):

S1 --- AP --- S2

If S1 wants to send a message to S2, is there any motivation (performances? Media Access Control?), other than the security/encryption issues, to use 
infrastructure mode instead of ad-hoc mode?

Thx 

Claudio

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Herbert Rubens" <[email-masked]>
Date: Wed, 9 Feb 2005 12:10:26 -0500

This is an interesting question. Most 802.11 devices operate at multiple
rates, so the answer to your question will depend on the link speeds and
the network configuration.

    11      11 Mbps
S1 ---- AP ---- S2
 |-------------- |
       1 Mbps
 
I've added possible link speeds to the example you mentioned. In the
above configuration it would be 2-3 times faster for S1 to send packets
to S2 through the access point.
 
Another possible network configuration could be:
 
          1 Mbps
   S1----------------AP
    |                 |
11  |                 | 
    |                 |   
   S2-----------------| 
                   1 Mbps

In this second configuration it would be much faster for S1 to send
packets directly to S2 and not relay them through the access point. So
if S1 and S2 were in ad hoc mode, they would achieve higher performance
in this case.
 
So it really depends on the network configuration and the current link
speeds. We have a paper that talks about these issues which you might
find interesting:
 
http://www.cnds.jhu.edu/research/networks/archipelago/publications/AHR-M
ediumTimeMetric-TechnicalReport.pdf

Regards,
 
Herb

------------------------
Johns Hopkins University
Dept. of Computer Science
[email-masked]
http://www.cnds.jhu.edu/archipelago/

 
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Claudio Lavecchia
Sent: Wednesday, February 09, 2005 11:53 AM
To: [email-masked]
Subject: [manet] 802.11, infrastructure and ad-hoc modes
 
Hello you MANET people,

Let's consider a 802.11 network made of an access point and  several
stations that generate a "normal" rate of traffic. Let's focus on 2
stations and the 
access point (every equipment "see" each other):

S1 --- AP --- S2
 
If S1 wants to send a message to S2, is there any motivation
(performances? Media Access Control?), other than the
security/encryption issues, to use 
infrastructure mode instead of ad-hoc mode?
 
Thx 
 
Claudio

---

From: Miguel Sanchez <[email-masked]>
Date: Wed, 09 Feb 2005 20:09:41 +0100

Absolutely Herbert.

I think the main point of infrastructure mode is to include station 
authorization, which is missing if you use ad-hoc mode.

So you get something and you may lose something by using ad-hoc mode as 
your second example shows.

@Claudio,

The way nodes are laid out on your example the AP could help nodes S1 & 
S2 to talk to each other when they are not in range of each other.

You may switch your card operating mode at will, so you can try to to 
use ad-hoc mode first then give up to infrastructure mode ... or the 
opposite.

Cheers,

Miguel Sánchez

Herbert Rubens wrote:
>
> This is an interesting question. Most 802.11 devices operate at 
> multiple rates, so the answer to your question will depend on the link 
> speeds and the network configuration.
>
>  
>
>  
>
>     11      11 Mbps
>
> S1 ---- AP ---- S2
>
>  |-------------- |
>
>        1 Mbps
>
>  
>
> above configuration it would be 2-3 times faster for S1 to send 
> packets to S2 through the access point.
>
>  
>
> if S1 and S2 were in ad hoc mode, they would achieve higher 
> performance in this case.
>
>  
>
> http://www.cnds.jhu.edu/research/networks/archipelago/publications/AHR-MediumTimeMetric-TechnicalReport.pdf
>
>  
>
>  
>
> Regards,
>
>  
>
> Herb
>
>  
>
>  
>
>  
>
> ------------------------
>
> Johns Hopkins University
>
> [email-masked] <mailto:[email-masked]>
>
>------------------------------------------------------------------------
>

---

From: Fethi Filali <[email-masked]>
Date: Thu, 10 Feb 2005 09:05:11 +0100

Direct communication between S1 and S2 is possible in 802.11e using the 
DLP (Direct Link Protocol). Using DLP signaling messages S1 asks direct 
link authorisation to AP and the AP sends back to S1 the MAC address of S2.

FF.