Subject: [manet] Re: manet Digest, Vol 15, Issue 25

From: Torsha Banerjee <[email-masked]>
Date: Sun, 31 Jul 2005 22:12:39 -0400 (EDT)

Hello,
when I did the forced compilation I got the error
ip.dispatch file missing. I guess this is causing the problem. Now, how do
I fix this?
thanx,
Torsha
+----------------------------------------------------------------------+
| Torsha Banerjee                                                      |
| Ph.D Student                         Email:[email-masked]     |
| University of Cincinnati             Lab Phone: (513) 556-3437       |
| CDMC Laboratory                                                      |
| ECECS Dept, PO Box 210030                                            |
| Cincinnati, OH 45221-0030                                            |
+----------------------------------------------------------------------+

On Fri, 29 Jul 2005 [email-masked] wrote:

> Send manet mailing list submissions to
> 	[email-masked]
>
> To subscribe or unsubscribe via the World Wide Web, visit
> 	https://www1.ietf.org/mailman/listinfo/manet
> or, via email, send a message with subject or body 'help' to
> 	[email-masked]
>
> You can reach the person managing the list at
> 	[email-masked]
>
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of manet digest..."
>
>
> Today's Topics:
>
>    1. RE: Question about LAR (location aided routing protocol)
>       (Mullen, John)
>    2. RE: error (manet user)
>    3. RE: error (Mullen, John)
>
>
> ----------------------------------------------------------------------
>
> Message: 1
> Date: Fri, 29 Jul 2005 07:31:42 -0600
> From: "Mullen, John" <[email-masked]>
> Subject: RE: [manet] Question about LAR (location aided routing
> 	protocol)
> To: <[email-masked]>
> Cc: [email-masked]
> Message-ID:
> 	<[email-masked]>
> Content-Type: text/plain;	charset="us-ascii"
>
> Hi Jack,
>
> It sounds to me like you have a bottleneck.  Does the simulation place
> the nodes or are you starting with the same initial node positions and
> and have movement along the same routes each time?  If the distribution
> of nodes is not changing, the topology could be the cause.  If that is
> the case, I suggest you check the mean queue length and/or utilization
> of each node to see if some are very high.  The channel could also be
> heavily used somewhere, but I'm not sure if you can isolate that.
> However, if the channel is heavily utilized, local queues should get
> long.
>
> I'm assuming, of course, this is not a Glomosim bug.
>
> Also, I'm not sure of your physical layer model.  If your model includes
> fine grain variation effects, such as multipath fading, the problem
> could be that the system is getting clogged up with retransmissions.  If
> that is the case, you might want to check the limit on the number of
> re-transmissions attempted at the MAC level.  Here, we've found that if
> the cap is more than three, the MANET tends to retain poor paths too
> long, leading to a significant increase in the average number of
> retransmissions.  With fewer, the MANET tends to drop poor paths and
> look for better ones sooner.  However, this behavior is only apparent in
> simulations if you simulate these fine grain variations in signal
> strength.  If this feature is not being used, this would not be a
> problem.
>
> Best of luck!
>
> John P. Mullen, Ph.D.
> (505) 646-2958
> [email-masked]
>
> -----Original Message-----
> From: [mailto:[email-masked]]
> Sent: Tuesday, July 26, 2005 10:45 AM
> To: Mullen, John; [email-masked]
> Subject: RE: [manet] Question about LAR (location aided routing
> protocol)
>
>
> Hi Dr. Mullen:
>
> Thank you for your reply.
> I simulated the same configuration with different seeds. For each seed
> there are always some nodes whose end-to-end delay is very high.
> The average of end-to-end delay of all forty source/destination pairs is
> about 5-30 seconds depending on the seed. The packet delivery ratio is
> about 70-80 percent.
>
> I also tried the same configuration with AODV. AODV has much better
> performance with about 90 percent packet delivery ratio and 0.05
> end-to-end delay.
>
> In AODV, if a node can not find a path, it puts the data packet into a
> queue and stores for a short time. For LAR, if the end-to-end delay is
> several hundred seconds, the data packets must be stored in a queue for
> several hundred seconds, which is too long.
>
> I do not know if it is LAR's problem or glomosim's problem.
>
> Regards,
>
> Jack
>
>
>  --- On Mon 07/25, Mullen, John < [email-masked] > wrote:
> From: Mullen, John [mailto: [email-masked]]
> To: [email-masked], [email-masked]
> Date: Mon, 25 Jul 2005 14:10:45 -0600
> Subject: RE: [manet] Question about LAR (location aided routing
> protocol)
>
> Hi,<br><br>You might want to look at the routes on those high-delay
> paths.  You<br>might have a bottleneck. For example, if your net is
> nearly partitioned<br>into two regions; A and B, then any messages from
> A to B or vice versa<br>would go through a constrained path while
> exchanges within A or within B<br>would be unaffected.  This might also
> happen if there are a few links<br>that are very heavily
> utilized.<br><br>You also don't mention the distribution of message
> initiations.  It is<br>possible that some senders consistently start
> their messages after<br>another user of common elements of the path and,
> as a result, have to<br>wait for the channel.<br><br>Also, is this the
> result of a single run?  If so, you may want to run<br>some more
> replicates to get a better picture of the situation.  This<br>might
> indicate that what you are looking at is an outlier or give
> you<br>further insight into the cause.<br><br>Maybe one of these
> suggestions is the cause, but if not, hopefully,
>
> they<br>will help you find the problem.<br><br><br>John P. Mullen,
> Ph.D.<br>(505) 646-2958<br>[email-masked]<br> <br>-----Original
> Message-----<br>From: [email-masked]
> [mailto:[email-masked]] <br>Sent: Saturday, July 23, 2005 10:50
> PM<br>To: [email-masked]<br>Subject: [manet] Question about LAR
> (location aided routing protocol)<br><br><br>Hi:<br><br><br><br>I am
> simulating an ad hoc network with LAR (location aided
> routing<br>protocol) as the routing protocl. I use Glomosim. The
> configuration of<br>my simulation is 600 nodes in (5000 X 2000) region,
> random way point<br>model, four 512B packets per second, CBR, 40
> source/destinatin pairs. <br><br>The strange thing is that, the average
> end-to-end delay of some nodes is<br>very large, about 100-200 seconds.
> The average end-to-end delay of most<br>of the nodes are normal, about
> 0.5-3 seconds. <br><br>What is the problem? Is the result correct? I use
> the original code of<br>LAR in Glomosim. I do not modify
> anything.<br><br><br><br>Thanks.
> <br><br><br><br><br><br><br><br>________________________________________
> _______<br>Join Excite! - http://www.excite.com<br>The most personalized
> portal on the
> Web!<br><br><br><br>_______________________________________________<br>m
> anet mailing
> list<br>[email-masked]<br>https://www1.ietf.org/mailman/listinfo/manet<b
> r>
>
> _______________________________________________
> Join Excite! - http://www.excite.com
> The most personalized portal on the Web!
>
>
>
>
>
> ------------------------------
>
> Message: 2
> Date: Fri, 29 Jul 2005 07:21:01 -0700 (PDT)
> From: manet user <[email-masked]>
> Subject: RE: [manet] error
> To: Torsha Banerjee <[email-masked]>
> Cc: [email-masked]
> Message-ID: <[email-masked]>
> Content-Type: text/plain; charset="iso-8859-1"
>
> Hello,
> Have you made changes to the standard models? If yes, please first try to comiple customized files individually. After successful compilation of all files, run without repositories and perform force compile. (When you click on running man to run the simualtion, in Configure/Run DES window, expand Execution->Advanced->Compilation. Check the box against Force model recompilation and hit Run). Make sure you are using development kernel. This will compile all files related to this scenario.
>
> If you haven't made any changes to the standard models, then you might be referencing some old .obj files in some other directories. You can solve this problem by making new env_dd. Open OPNET console, and type modeler -new_env_db. This will create new env_db and put the old one as backup. If your project is in folder other than op_models, you need to add that directory. Make sure this directory does not have custom process models or ex.c files.
>
> Hope this helps. If you have Tech Support with OPNET, please write to them, and they will help you troubleshoot problems within hours.
>
>
> Torsha Banerjee <[email-masked]> wrote:
> Hello,
> thanks so much for your reply. I tried doing that but that gives me a
> this new error:
> <<< Recoverable Error >>>
> Unable to register global stat (IP.Background Traffic Delay (sec)).
> Please check spelling of group and statistic name.
> T (0), EV (10), MOD (top.Office Network.node_0.ip), KP (op_stat_reg)
> -----
> <<< Recoverable Error >>>
> Unable to register global stat (IP.Background Traffic Delay (sec)).
> Please check spelling of group and statistic name.
> T (0), EV (22), MOD (top.Office Network.node_1.ip), KP (op_stat_reg)
> -----
> <<< Recoverable Error >>>
> Field (2) of packet (8) is of type (OPC_FIELD_TYPE_INTEGER);
> can't set its value as OpT_Packet_Id.
> T (16.1852), EV (98), MOD (top.Office Network.node_0.wireless_lan_mac), KP
> (op_pk_nfd_set_pkid)
> -----
> <<< Recoverable Error >>>
> No field named (PHY Info) in packet (8).
> T (16.1852), EV (98), MOD (top.Office Network.node_0.wireless_lan_mac), KP
> (op_pk_nfd_set_int32)
> -----
> <<< Recoverable Error >>>
> No field named (Tx Data Rate) in packet (8).
> T (16.1852), EV (98), MOD (top.Office Network.node_0.wireless_lan_mac), KP
> (op_pk_nfd_set_dbl)
> -----
> <<< Recoverable Error >>>
> No field named (Tx Data Rate) in packet (8).
> T (16.1852), EV (99), MOD (top.Office Network.node_0.wlan_port_tx_0_0), KP
> (op_pk_nfd_get_dbl)
> -----
> Torsha
>
>
>
>
> +----------------------------------------------------------------------+
> | Torsha Banerjee |
> | Ph.D Student Email:[email-masked] |
> | University of Cincinnati Lab Phone: (513) 556-3437 |
> | CDMC Laboratory |
> | ECECS Dept, PO Box 210030 |
> | Cincinnati, OH 45221-0030 |
> +----------------------------------------------------------------------+
>
>
> On Mon, 25 Jul 2005, Mullen, John wrote:
>
>
>
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/manet
>
> __________________________________________________
> Do You Yahoo!?
> Tired of spam?  Yahoo! Mail has the best spam protection around
> http://mail.yahoo.com
> -------------- next part --------------
> An HTML attachment was scrubbed...
> URL: http://www1.ietf.org/pipermail/manet/attachments/20050729/0b23390d/attachment.htm
>
> ------------------------------
>
> Message: 3
> Date: Fri, 29 Jul 2005 09:00:53 -0600
> From: "Mullen, John" <[email-masked]>
> Subject: RE: [manet] error
> To: "Torsha Banerjee" <[email-masked]>
> Cc: [email-masked]
> Message-ID:
> 	<[email-masked]>
> Content-Type: text/plain;	charset="us-ascii"
>
> Hi Torsha,
>
> I got similar errors some time ago.  The problem was I was using the
> wrong modules.  If you are using the OPNET MANET model, use only the
> modules that are included in that model.  Some of the other wireless
> modules are incompatable.
>
> John Mullen
>
>
> John P. Mullen, Ph.D.
> (505) 646-2958
> [email-masked]
>
> -----Original Message-----
> From: Torsha Banerjee [mailto:[email-masked]]
> Sent: Monday, July 25, 2005 1:59 PM
> To: Mullen, John
> Cc: [email-masked]
> Subject: RE: [manet] error
>
> Hello,
>  thanks so much for your reply. I tried doing that but that gives me a
> this new error:
> <<< Recoverable Error >>>
> Unable to register global stat (IP.Background Traffic Delay (sec)).
> Please check spelling of group and statistic name.
> T (0), EV (10), MOD (top.Office Network.node_0.ip), KP (op_stat_reg)
> -----
> <<< Recoverable Error >>>
> Unable to register global stat (IP.Background Traffic Delay (sec)).
> Please check spelling of group and statistic name.
> T (0), EV (22), MOD (top.Office Network.node_1.ip), KP (op_stat_reg)
> -----
> <<< Recoverable Error >>>
> Field (2) of packet (8) is of type (OPC_FIELD_TYPE_INTEGER); can't set
> its value as OpT_Packet_Id.
> T (16.1852), EV (98), MOD (top.Office Network.node_0.wireless_lan_mac),
> KP
> (op_pk_nfd_set_pkid)
> -----
> <<< Recoverable Error >>>
> No field named (PHY Info) in packet (8).
> T (16.1852), EV (98), MOD (top.Office Network.node_0.wireless_lan_mac),
> KP
> (op_pk_nfd_set_int32)
> -----
> <<< Recoverable Error >>>
> No field named (Tx Data Rate) in packet (8).
> T (16.1852), EV (98), MOD (top.Office Network.node_0.wireless_lan_mac),
> KP
> (op_pk_nfd_set_dbl)
> -----
> <<< Recoverable Error >>>
> No field named (Tx Data Rate) in packet (8).
> T (16.1852), EV (99), MOD (top.Office Network.node_0.wlan_port_tx_0_0),
> KP
> (op_pk_nfd_get_dbl)
> -----
> Torsha
>
>
>
>
> +----------------------------------------------------------------------+
> | Torsha Banerjee                                                      |
> | Ph.D Student                         Email:[email-masked]     |
> | University of Cincinnati             Lab Phone: (513) 556-3437       |
> | CDMC Laboratory                                                      |
> | ECECS Dept, PO Box 210030                                            |
> | Cincinnati, OH 45221-0030                                            |
> +----------------------------------------------------------------------+
>
>
> On Mon, 25 Jul 2005, Mullen, John wrote:
>
>
>
>
>
> ------------------------------
>
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/manet
>
>
> End of manet Digest, Vol 15, Issue 25
> *************************************
>

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Torsha Banerjee <[email-masked]>
Date: Sun, 31 Jul 2005 22:18:31 -0400 (EDT)

How do I got to OPNET console and create new new_env_db. Also, I request
you to tell me how to ensure that my directory does not have custom
process models or ex.c files.
Thanks,
Torsha