Subject: RE: [manet] error

From: "Mullen, John" <[email-masked]>
Date: Mon, 25 Jul 2005 13:38:27 -0600

Hi Torsha,

The message indicates that OPNET was unable to construct a repository
file.  This can be rather involved to correct, but I suggest you try
something simple first.  Because you are using standard models in OPNET
11,  you should specify stdmod under Edit > Preferences > repositories.
This is covered in the "Small Internets" tutorial for OPNET 11 on page
27 ff.

Hope this helps.

John P. Mullen, Ph.D.
(505) 646-2958
[email-masked]
 
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Torsha Banerjee
Sent: Monday, July 25, 2005 1:06 PM
To: [email-masked]
Subject: [manet] error

Hello,
when I am running a simple opnet model (vs 11.0) I am getting the
following error:
<<< Recoverable Error >>>
Process model (ip_dispatch) compilation failed due to error on source
line (533) Errors given in file (Z:\op_admin\tmp\cc_err_1392)
-----
<<< Recoverable Error >>>
Object repository construction failed
Process model (C:\PROGRA~1\OPNET\11.0.A\models\std\ip\ip_dispatch.pr.c)
compilation failed, see error messages in (Z:\op_admin\tmp\cc_err_1392)
T (0), EV (-), MOD (NONE), PROC (sim_load_repos_rebuild)
-----
My repositories list  is empty ..So I am being unable to figure what
might be causing this problem.
I request you to let me know how to solve this problem.
Thanks,
Torsha
+----------------------------------------------------------------------+
| Torsha Banerjee                                                      |
| Ph.D Student                         Email:[email-masked]     |
| University of Cincinnati             Lab Phone: (513) 556-3437       |
| CDMC Laboratory                                                      |
| ECECS Dept, PO Box 210030                                            |
| Cincinnati, OH 45221-0030                                            |
+----------------------------------------------------------------------+

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Torsha Banerjee <[email-masked]>
Date: Mon, 25 Jul 2005 15:58:43 -0400 (EDT)

Hello,
 thanks so much for your reply. I tried doing that but that gives me a
this new error:
<<< Recoverable Error >>>
Unable to register global stat (IP.Background Traffic Delay (sec)).
Please check spelling of group and statistic name.
T (0), EV (10), MOD (top.Office Network.node_0.ip), KP (op_stat_reg)
-----
<<< Recoverable Error >>>
Unable to register global stat (IP.Background Traffic Delay (sec)).
Please check spelling of group and statistic name.
T (0), EV (22), MOD (top.Office Network.node_1.ip), KP (op_stat_reg)
-----
<<< Recoverable Error >>>
Field (2) of packet (8) is of type (OPC_FIELD_TYPE_INTEGER);
can't set its value as OpT_Packet_Id.
T (16.1852), EV (98), MOD (top.Office Network.node_0.wireless_lan_mac), KP
(op_pk_nfd_set_pkid)
-----
<<< Recoverable Error >>>
No field named (PHY Info) in packet (8).
T (16.1852), EV (98), MOD (top.Office Network.node_0.wireless_lan_mac), KP
(op_pk_nfd_set_int32)
-----
<<< Recoverable Error >>>
No field named (Tx Data Rate) in packet (8).
T (16.1852), EV (98), MOD (top.Office Network.node_0.wireless_lan_mac), KP
(op_pk_nfd_set_dbl)
-----
<<< Recoverable Error >>>
No field named (Tx Data Rate) in packet (8).
T (16.1852), EV (99), MOD (top.Office Network.node_0.wlan_port_tx_0_0), KP
(op_pk_nfd_get_dbl)
-----
Torsha

On Mon, 25 Jul 2005, Mullen, John wrote:

---

From: manet user <[email-masked]>
Date: Fri, 29 Jul 2005 07:21:01 -0700 (PDT)

Hello,
Have you made changes to the standard models? If yes, please first try to comiple customized files individually. After successful compilation of all files, run without repositories and perform force compile. (When you click on running man to run the simualtion, in Configure/Run DES window, expand Execution->Advanced->Compilation. Check the box against Force model recompilation and hit Run). Make sure you are using development kernel. This will compile all files related to this scenario.
 
If you haven't made any changes to the standard models, then you might be referencing some old .obj files in some other directories. You can solve this problem by making new env_dd. Open OPNET console, and type modeler -new_env_db. This will create new env_db and put the old one as backup. If your project is in folder other than op_models, you need to add that directory. Make sure this directory does not have custom process models or ex.c files.
 
Hope this helps. If you have Tech Support with OPNET, please write to them, and they will help you troubleshoot problems within hours.

Torsha Banerjee <[email-masked]> wrote:
Hello,

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com