Subject: [manet] Opnet packet streams

From: "Leonardo A. Martucci" <[email-masked]>
Date: Tue, 4 Oct 2005 14:46:08 +0200

Hi,

I am modifying a Opnet wkstn model a bit (wlan_wkstn_adv model to be 
precise).
Just added a new processor (new_proc) in between Tpal and the Appl 
processors and defined new packet streams to connect them, as shown:

 ->    appl    -
|                     |
 -               <-
     new_proc
 ->               -
|                     |
 -      tpal    <-

But I am having some trouble to find out how to hijack the original packet 
streams between appl and tpal layers. Does anyone have any clue where to 
find it in the gna_clsrv_mgr and tpal process models (I have a strong belief 
that they are there somewhere)? Any help will be really appreciated!

Thanks!
Leonardo 

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: manet user <[email-masked]>
Date: Tue, 4 Oct 2005 14:49:14 -0700 (PDT)

Leonardo,
 
To add a module between Application layer and TPAL, there are two things that you have to take care:
 
(1) Stream indexes for the Application and TPAL should not change. The new module addition should be transparent to both app and tpal if you maintain the original stream index going out & coming in of these two modules.
 
(2) Your module should be able to handle all the interrupts generated by tpal for application and vice-versa. Also, if application layer is expecting some ICIs from tpal, your module should generate these ICIs to send to app. Similarly ICIs expected by tpal should be given by your module. This is to make module addition transparent.
 
For case (1), the original stream configugration for application module is: outgoing stream index = 0 (i.e. src strm[0]), incoming stream index = 0 (i.e. dst strm[0]). For tpal: outgoing stream index=1 (i.e. src strm[1]) and incoming stream index=1 (i.e. dst strm[1]). When you draw streams through new module, right click and Edit Attributes. Edit src stream and dst stream attributes to capture the above original indexes.
 
Hope this helps.

"Leonardo A. Martucci" <[email-masked]> wrote:
Hi,

-> appl -
| |
- <-
new_proc
-> -
| |
- tpal <-

Thanks!
Leonardo 

		
---------------------------------
Yahoo! for Good
 Click here to donate to the Hurricane Katrina relief effort.