Subject: [manet] custom statistic in opnet

From: "Andrea Robba" <[email-masked]>
Date: Tue, 13 Jun 2006 13:34:51 +0200

hi!

I need to add a custom statistics to a custom protocol based on
original ADOV model of OPNET MODELER 11.0 .

Any suggsetion ?

Best Regards,

Andrea Robba

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: LD <[email-masked]>
Date: Tue, 13 Jun 2006 14:01:55 +0200

Hi Andrea

> original ADOV model of OPNET MODELER 11.0 .
You have to code it.

Maybe the two tutorials called "Basic Processes" and "CSMA/CD" from
Modeler could help you as a fist start.

HTH

Laurent

---

From: manet user <[email-masked]>
Date: Thu, 15 Jun 2006 13:20:37 -0700 (PDT)

You can get help on custom statistic in Modeler
tutorial as well as OPNET support website's FAQ.

Below is the the excerpt from the FAQ:
There are basically four steps to creating statistics
within process models. (Note order does not matter):

1. Declare a new variable of type Stathandle in the
State Variable block of your custom process model.

2. Register the Stathandle using the kernel procedure
op_stat_reg (). This is usually done in an
initialization state of the process model.

3. Write to the statistic using the Kernel Procedure
op_stat_write () and the registered Stathandle. The
op_stat_write () and op_stat_reg () kernel procedures
are explained in the documentation "Simulation Kernel
-> Statistic Package"

4. Declare the statistic either in the Global or Local
Statistic block in the process editor under the
"Interfaces" menu. Fill in the information for each
statistic you wish to create. This will then allow you
to choose the statistic later in the Project Editor.
Note that the column "Stat Name" must match the string
passed into the op_stat_reg () kp as that is how they
are matched up during the simulation. With modern
product releases, you can also use the "Group" field
to position related statistics together for ease of
use. Please refer to the online documentation (Editor
Reference Menu -> Process Editor -> Pr. 4 Interfaces
Menu Operations) for more details on creating
statistics.

Note that this will only make the statistic appear as
a "Module Statistic" in the Project Editor. In other
words, when you right-click on an individual node and
select "Choose Individual Statistics", you will see
the new statistic under the "Module Statistics"
portion of the tree.

To make the statistic appear as a Node Statistic, do
the following: In the node model, Go to "Interfaces >
Node Statistics". Click on "Orig. Name" and choose the
module statistic you created. You may then change its
name or group as it will appear in the Project editor.

Examples of creating statistics are also available in
the Modeler tutorials. 

> original ADOV model of OPNET MODELER 11.0 .

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com