Subject: [manet] How to get or set the transmission range in JiST/SWANS?

From: Longjiang Li <[email-masked]>
Date: Sun, 21 Jan 2007 14:19:15 +0800 (CST)

Dear everyone,

I used JiST/SWANS to implement simulations about MANETs, but I have no idea about how to get or set the transmission range of a node. It is said that JiST/SWANS uses a radio model identical to the one used by ns-2.

According to the default setting as below, I estimated that the transmission range was about 500m, since the free space radio model was used. However，a reviewer said that it was not practical to set the transmission range to be 500m. 

Are the default settings reasonable? or Does I miss anything? 

Best Regards,
Longjiang Li

P.S.
1. The simulator can be found in http://jist.ece.cornell.edu/. A snapshot of the simulation debug output is like follows.

JiST Project: Node discovery protocol macro-benchmark v0.1
Rimon Barr <[email-masked]>, Cornell University.

nodes   = 300
size    = 6000 x 6000
time    = 0 seconds
spatial = hier:6
Creating simulation nodes... done.
Average density  = 8.333333333333334/km^2
Average sensing  = 78.57333333333334
Average receive  = 7.32
Average node/bin = 0.0732421875

2. A slice copied from Constants.java is given as followed.

  /** Default radio frequency (units: Hz). */
  public static final double FREQUENCY_DEFAULT = 2.4e9; // 2.4 GHz
  /** Default radio bandwidth (units: bits/second). */
  public static final int BANDWIDTH_DEFAULT = (int)1e6; // 1Mb/s
  /** Default transmission strength (units: dBm). */
  public static final double TRANSMIT_DEFAULT = 15.0;
  /** Default antenna gain (units: dB). */
  public static final double GAIN_DEFAULT = 0.0;
  /** Default radio reception sensitivity (units: dBm). */
  public static final double SENSITIVITY_DEFAULT = -91.0;
  /** Default radio reception threshold (units: dBm). */
  public static final double THRESHOLD_DEFAULT = -81.0;
  /** Default temperature (units: degrees Kelvin). */
  public static final double TEMPERATURE_DEFAULT = 290.0;
  /** Default temperature noise factor. */
  public static final double TEMPERATURE_FACTOR_DEFAULT = 10.0;
  /** Default ambient noise (units: mW). */
  public static final double AMBIENT_NOISE_DEFAULT = 0.0;
  /** Default minimum propagated signal (units: dBm). */
  //public static final double PROPAGATION_LIMIT_DEFAULT = -111.0;
  public static final double PROPAGATION_LIMIT_DEFAULT = SENSITIVITY_DEFAULT; 
  /** Default radio height (units: sim distance units, usually meters). */
  public static final double HEIGHT_DEFAULT = 1.5;
  /** Default threshold signal-to-noise ratio. */
  public static final double SNR_THRESHOLD_DEFAULT = 10.0;

___________________________________________________________ 
抢注雅虎免费邮箱-3.5G容量，20M附件！ 
http://cn.mail.yahoo.com

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Gabi Kliot" <[email-masked]>
Date: Sun, 21 Jan 2007 10:54:15 +0200

Hello

In order to determine the exact transmission range in JiST/SWANS you have to run a short calibration simulation, in which you place to two nodes at a certain distance from each other and then move one of tem away, until it stops receiving packets.

In order to change the range you can play with either TRANSMIT_DEFAULT or THRESHOLD_DEFAULT (and then also SENSITIVITY_DEFAULT)

For example, THRESHOLD_DEFAULT=-72 gave me a transmit range of 220m, SENSITIVITY_DEFAULT=-75 gave sensing range of 310m (keeping  TRANSMIT_DEFAULT at 15.0)

But I really suggest you do not use those number as is without checking them first and run the range simulation yourself.

Best regards,

Gabriel Kliot

  _____  

From: Longjiang Li [mailto:[email-masked]] 
Sent: Sunday, January 21, 2007 8:19 AM
To: [email-masked]
Subject: [manet] How to get or set the transmission range in JiST/SWANS?

Dear everyone,

Best Regards,
Longjiang Li

P.S.

nodes   = 300
size    = 6000 x 6000
time    = 0 seconds
spatial = hier:6

 

  _____  

 <http://cn.mail.yahoo.com> 抢注雅虎免费邮箱-3.5G容量，20M附件！