Subject: [manet] CBR

From: "shilpa sharma" <[email-masked]>
Date: Sun, 15 Apr 2007 15:57:14 +0530

hello everyone,
I was going through CBR.java.. I want to know is it actually using any
protocol for sending message between client and server?? As far as i could
see there is a switch case for the choice of protocols zrp, aodv, dsr... but
after that client and server are being initialized to send messages.. but
nowhere i could see the role of any protocol to send message between them..
if i give -p dsr or -p aodv, both are giving the same output.. does choosing
a protocol make any difference to the code??
_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "gabik" <[email-masked]>
Date: Sun, 15 Apr 2007 14:20:53 +0300

Hello 
 
Client and server use UDP transport to send message to each other.
At the IP/routing level they use the routing protocol according to what you
have picked (dsr/aodv/...)
 
You can see it very clearly at the lines:
NetIp net = new NetIp(address, protMap, loss, loss);
RouteInterface route = ...
........
net.setRouting(route);
....
udp.setNetEntity(net.getProxy());

Gabi

  _____  

From: shilpa sharma [mailto:[email-masked]] 
Sent: Sunday, April 15, 2007 1:27 PM
To: [email-masked]
Subject: [manet] CBR

hello everyone,