Subject: Re: [manet] MANET Port Name

From: Roger <[email-masked]>
Date: Sat, 21 Apr 2007 12:53:16 -0400

There are, and will continue to be, other MANET protocols outside the
standards, so we should at least specify that we are talking about
standard MANET protocols.  As you have said, the experimental RFCs
will remain experimental for now.

What we should be asking is whether all future MANET standards can be
expected to use PacketBB.  Given the recent discussions on this list,
I do not believe that we can safely say that 10-20 years out.

On 4/20/07, Ian Chakeres <[email-masked]> wrote:
>All the MANET protocols that generate control messages (NHDP, DYMO,
>OLSRv2) use PacketBB (Packet Building Block) for their packets &
>messages.
>
>Ian
>
>On 4/20/07, Alexandru Petrescu <[email-masked]> wrote:
>> Ian Chakeres wrote:
>> > I'd like to ask people whether they would like the port in the IANA
>> > document  named "MANET" or "PacketBB".
>> >
>> > If you have a preference, please reply.
>>
>> Yes, I have some thoughts on this, thanks for asking.
>>
>> _If_ PacketBB is something used by most (all?) MANET protocols, then
>> indeed the port should be named PacketBB.
>>
>> _If_ PacketBB is something that works only over UDP and/or TCP then
>> again I prefer PacketBB for port name.
>>
>> If some existing MANET protocols have already ports assigned then a new
>> one can't be so called MANET.
>>
>> But let me say something else.  _If_ (only a big _if_) this WG defined
>> only one protocol that they called "GRABNET" for example then it could
>> have been easier to just have one port called "GRABNET" instead of
>> PacketBB which seems to be only a TLV, not a protocol per se.
>>
>> Because, for example DYMO doesn't necessarily run at network layer (it
>> may run at link-layer) so at that point DYMO using PacketBB and PacketBB
>> port number wouldn't make much sense; it should have been "DYMO port
>> number".
>>
>> Alex

-- 
Roger

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: <[email-masked]>
Date: Mon, 23 Apr 2007 13:12:04 +0530

I too feel the same. I would prefer PacketBB to MANET.

Regards,
Ratul Mukhopadhyay

-----Original Message-----
From: Roger [mailto:[email-masked]] 
Sent: Saturday, April 21, 2007 10:23 PM
To: manet
Subject: Re: [manet] MANET Port Name

-- 
Roger