Subject: [manet] draft-ietf-manet-packetbb-11

From: Thomas Clausen <[email-masked]>
Date: Wed, 14 Nov 2007 22:59:26 +0100

All,

While we are disappointed that the points we have been making  
regarding the constraints obviously have been misunderstood, the  
authors have over the past days conferred to produce an updated  
version of draft-ietf-manet-packetbb -- which has been submitted.

The authors have been listening to the objections raised, and tried  
hard to come up with a solution that everyone can live with -- and we  
hope that this will allow the working group to move the I-D forward.

Thomas

-- 
Thomas Clausen
[email-masked]
http://www.thomasclausen.org/
http://hipercom.thomasclausen.org/

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Teco Boot" <[email-masked]>
Date: Thu, 15 Nov 2007 11:34:34 +0100

Dear authors,

Thanks for updating the document.
I checked corrections and additions, I think the document is OK now.
I agree on moving the I-D forward, as I think this is more important than
discussing minor issues.
Just for the record: I listed some minor issues below. To be discussed when
there is a need for a new version.

Cheers, Teco

Minor issues, not to be discussed right now:
1) I suggest using term Prefix instead of Network Address (see
autoconf-manetarch)
2) I suggest reserving semantics bit 7 as xhassemext (x=p,m,a), and prepare
for <xxx-semantics-ext> fields
3) I suggest using bitstrings for address / prefix encoding instead of
octets

> -----Oorspronkelijk bericht-----
> Van: Thomas Clausen [mailto:[email-masked]]
> Verzonden: woensdag 14 november 2007 22:59
> Aan: manet
> Onderwerp: [manet] draft-ietf-manet-packetbb-11
> 
> All,
>

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Thu, 15 Nov 2007 10:43:23 -0000

I note your not discuss right now, but note that IPv6
prefix lengths need 7 or 8 bits (depending on the need
to encode 0 and 128) and hence there is no real saving.
(And irregular bit fields are very messy.)

As for semantics bit 7, there's no point in reserving
it with a function. If it has a function, we do it. If
not it's simply reserved for whatever we do want. I'm
also very wary about using up the last semantics bit, as
it makes future extensions less compatible. (If you want
multiple new semantics bit - and they keep growing -
you can do it by making bit 7 an "extended semantics
octet bit" giving you a backwardly compatible
extension. It's an option worth keeping open.)

Incidentally did you check the acknowledgements section?

-----Original Message-----
From: Teco Boot [mailto:[email-masked]] 
Sent: 15 November 2007 10:35
To: 'Thomas Clausen'; [email-masked]; Dearlove, Christopher
(UK); [email-masked]
Cc: 'manet'
Subject: RE: [manet] draft-ietf-manet-packetbb-11

               *** WARNING ***

This mail has originated outside your organization,
either from an external partner or the Global Internet. 
     Keep this in mind if you answer this message. 

Dear authors,

Thanks for updating the document.
I checked corrections and additions, I think the document is OK now.
I agree on moving the I-D forward, as I think this is more important
than
discussing minor issues.
Just for the record: I listed some minor issues below. To be discussed
when
there is a need for a new version.

Cheers, Teco

2) I suggest reserving semantics bit 7 as xhassemext (x=p,m,a), and
prepare

> hope that this will allow the working group to move the I-D forward.

********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************