Subject: [manet] New Version Notification for draft-ietf-manet-timetlv-03

From: IETF I-D Submission Tool <[email-masked]>
Date: Thu, 15 Nov 2007 11:20:11 -0500

A new version of I-D, draft-ietf-manet-timetlv-03.txt has been successfuly submitted by Thomas Clausen and posted to the IETF repository.

Filename:	 draft-ietf-manet-timetlv
Revision:	 03
Title:		 Representing multi-value time in MANETs
Creation_date:	 2007-11-15
WG ID:		 manet
Number_of_pages: 18

Abstract:
This document describes a general and flexible TLV (type-length-value
structure) for representing time using the generalized MANET packet/
message format.  It defines two message and two address block TLVs
for representing validity and interval times for MANET routing
protocols.

The IETF Secretariat.

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Teco Boot" <[email-masked]>
Date: Fri, 16 Nov 2007 09:35:12 +0100

Hi, here some comment.

Typos:
======
Page 7: 
4.  if 0 <= a <= 7, and 0 lt;= b <= 31, then the required time-value
                          ^^^

Page 12: typo: 9.1.  Message TLV tyepes
                                   ^             
Page 13: typo: 9.2.  Address Block TLV tyepes
                                         ^             

Terminology used:
=================
Page 8: 
If t_n is 255, t_default is not used. So this algorithm saves one octet. OK for me.
But t_default doesn't look default at all. Pick another name? 
t_other
t_larger
t_dis255  <= this is meant

That's all;-)

Teco.

> -----Oorspronkelijk bericht-----
> Van: IETF I-D Submission Tool [mailto:[email-masked]]
> Verzonden: donderdag 15 november 2007 17:20
> Aan: [email-masked]
> CC: [email-masked]; [email-masked]
> Onderwerp: [manet] New Version Notification for draft-ietf-manet-
> timetlv-03
> 
> 
> A new version of I-D, draft-ietf-manet-timetlv-03.txt has been
> successfuly submitted by Thomas Clausen and posted to the IETF
> repository.
>

---

From: Thomas Heide Clausen <[email-masked]>
Date: Fri, 16 Nov 2007 11:42:38 +0100

Teco,

Thanks for your review. For the typo's, I agree and will update  
according to those.

For t_default, I note that we are OK with the mechanism, but that you  
prefer a name other than t_default, yes?

I am of the opinion that this is a minor point, but I note that the  
term was chosen in line with the usual dictionary definition of  
default: "a selection made usually automatically or without active  
consideration due to lack of a viable alternative" -- which in a  
sense corresponds to the last bullet point on page 9:

	o  <t_default> otherwise, i.e. if n == 0 or distance > <d_n>.

Cheers,

Thomas

-- 
Thomas Clausen
[email-masked]
http://www.thomasclausen.org/
http://hipercom.thomasclausen.org/

---

From: "Teco Boot" <[email-masked]>
Date: Fri, 16 Nov 2007 12:28:22 +0100

> prefer a name other than t_default, yes?
YES

> I am of the opinion that this is a minor point,
Me too;-)

> but I note that the
I would say when the node distance is larger than <d_n>, that only in that
case <t_default> is to be used. I do not see a difference with other
distances not explicitly listed in the list.
There are three cases:
1: distance is smaller than or equal to <d_1>
2: distance is between <d_1> and <d_n>, including <d_n> only
3: distance is larger than <d_n>
Would you say case 3 is default?
It is bloody minor. But I certainly would not use _default_ for it.

I would use _default_ for values not listed, used in some other mechanism.
E.g. default prefix length is /128, except the prefix length of a specific
entry (the 100th), for that one the prefix length is /64. The /128 (or /32
for IPv4) could be hard coded, it does not require any signaling.
_default_ may have signaling, e.g. default value in message tlv, and
specific values in address tlv.

Teco.