Subject: Re: [manet] manet Digest, Vol 53, Issue 13

From: "Kavitha Ammayappan" <[email-masked]>
Date: Wed, 24 Sep 2008 09:52:44 +0530

Dear All,

Kindly clarify the following doubts.

In the case of wireless scenario , when we transmit an information, which is
destined to specific destination, can be received by all others nodes of the
mobile ad hoc networks

In the case of MANET is there any difference between broadcast and unicast
communication? if it is, which one is superior?

Thanks in advance
Regards
Kavitha Ammayappan

-- 
"Every one is the architect of his own fortune." Mathurin Regnier
_______________________________________________
manet mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/manet

---

From: Rex Buddenberg <[email-masked]>
Date: Wed, 24 Sep 2008 08:56:20 -0700

On Wed, 2008-09-24 at 09:52 +0530, Kavitha Ammayappan wrote:
> In the case of wireless scenario , when we transmit an information,
> which is destined to specific destination, can be received by all
> others nodes of the mobile ad hoc networks

It depends on precisely what you mean by 'destined to a specific
destination'.  In emergency services and the military a great deal of
data is multicast in nature.  Asset tracking data (blue force track in
military lingo), for instance, originates from one physically mobile
node and, to be useful, has to go to lots of places.  
	Turned around the other way, we can easily rovision the fixed network
at G sizes (the backbones in the internet today are mostly OC192 at
10.6G) and we can provision a LAN within a platform at G sizes
(ethernet).  But the radio-WAN that interconnects them is about four
orders of magnitude less capacious.  Multicast is really the only gouge
against that bandwidth constriction.

'received by all others nodes'.  This is not a MANET (layer 3) question
but rather a question specific to the layer 2 technology chosen.  Radio
is, by nature, a shared medium.  But not all radio-based links exploit
that.  For example, all the cellphone technologies of the 2G, 2.5G, 3G
flavors do not.  
	(This problem is sometimes masked in data networks by the fact that TCP
is an unalterably unicast protocol).  

Help?

> 
> In the case of MANET is there any difference between broadcast and
> unicast communication? if it is, which one is superior?
> 
> Thanks in advance 
> Regards 
> Kavitha Ammayappan
> 
> 
> 
> 
> --

---

From: "Mullen, John" <[email-masked]>
Date: Wed, 24 Sep 2008 11:37:41 -0600

Hi Kavitha,

When a transmitter sends a message, any receiver within range will be affected.  If the receiver can interpret the message, it will do so and if it is not something intended for it, the receiver will discard it.  If the message is encrypted or otherwise in a form the receiver cannot interpret, it appears as interference to the receiver.  Receivers that are too far away to interpret the message, but close enough to be affected will experience interference. This distance is generally about twice the reliable reception range. Finally, nodes that are far enough away will not be significantly affected.

Broadcast means that the transmitter intends to send the message to all nodes which can interpret it.  Unicast means that the transmitter intends the message for a specific receiver and that any others that can interpret the message should discard it. Both are used in a MANET.  For example, in the case of flooding, the transmitter is looking for any node that can supply a path to the destination, so broadcast is used.  On the other hand, when replying to a flooded request, I think unicast is better to use, because it reduces the risk of the sender selecting an unreliable path. Opinions on this differ. At any rate, when sending a message, the norm is unicast along the chosen path.

John Mullen

From: [email-masked] [mailto:[email-masked]] On Behalf Of Kavitha Ammayappan
Sent: Tuesday, September 23, 2008 10:23 PM
To: [email-masked]
Subject: Re: [manet] manet Digest, Vol 53, Issue 13

Dear All,

In the case of wireless scenario , when we transmit an information, which is destined to specific destination, can be received by all others nodes of the mobile ad hoc networks

In the case of MANET is there any difference between broadcast and unicast communication? if it is, which one is superior?

Thanks in advance
Regards
Kavitha Ammayappan