Subject: [manet] The "M" in "MANET"

From: "Buraiky, Salah M." <[email-masked]>
Date: Tue, 16 Sep 2008 11:26:39 +0300

Dear All,

Why does the "M" in "MANET" stand for "Mobile" rather than "Multihop"?

Technologies such as 802.11b and Bluetooth do support both mobility and ad-hoc connectivity. A fundamental distinction between those and MANET protocols (and the protocols based on them such as 802.11s) is that they are "multihop": to communicate, a node doesn't need to be within range of a target node nor within range of a central element (such as an access point) as long as it can reach the target through intermediate relay nodes. The multihop nature is an intrinsic property that is always present regardless of the deployment scenario. Mobility is not. A MANET could consist of an un-engineered network of *static* nodes arbitrarily situated within an area. This network is multihop but isn't mobile. I understand that both are appropriate qualifiers for such ad hoc networks, I am just arguing that multihop is more descriptive. Just I thought I wanted to share. What do you think?

Best regards,

Salah M.  S.  Al-Buraiky
Engineering Network Management Group
Data Network Engineering Division/CE&TSD/IT
Saudi Aramco - Energy for Generations -
Business Phone: +966 3 872 9880

"The network should be invisible; the traffic should be granularly visible"

_______________________________________________
manet mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/manet

---

From: Rex Buddenberg <[email-masked]>
Date: Tue, 16 Sep 2008 09:48:00 -0700

Salah,

De-acronymizing MANET as multihop rather than mobile would not yield any
improvement.  The fixed internet is multihop -- that's the whole point.

But you are right, 'mobile' is a cause of a great deal of confusion (I
have to disentangle students all the time):
	- layer 1 mobility is usually measured in things like doppler shift.  
	- layer 2 mobility has a couple parts.  One is handoffs where a
subscriber station joins a new network segment and leaves an initial
one.  WiFi, WiMAX and circuit-switch cellphone all do this.  At least as
long as the two segments are in the same subnet (no change in routing
tables).
	- layer 2 mobility also properly encompasses 'meshing' or 'daisy
chaining'.  Which is what 802.11s is about.  There have been a number of
proprietary attempts to fill this space over the past few years (along
with my students' stubbed toes).  While the meshing algorithms may be
identical to layer 3 algorithms (e.g. OLSR), the implementation is
clearly at layer 2 (and therefore outside of scope of MANET WG).
	- layer 3 mobility is dealing with routing tables.  (The MANET WG has
had to fend off the three bullets above on a periodic basis on order to
maintain focus.)

Splitting hairs over the naming won't get us much value.  I can't think
of a term to replace the M with that would avoid having to make the
above disentangle.  Besides, almost any change would wreck the proper
pronunciation of the term;-)

On Tue, 2008-09-16 at 11:26 +0300, Buraiky, Salah M. wrote:
> Dear All, 
> 
>  
> 
> Why does the “M” in “MANET” stand for “Mobile” rather than
> “Multihop”? 
> 
>  
> 
> Technologies such as 802.11b and Bluetooth do support both mobility
> and ad-hoc connectivity. A fundamental distinction between those and
> MANET protocols (and the protocols based on them such as 802.11s) is
> that they are “multihop”: to communicate, a node doesn’t need to be
> within range of a target node nor within range of a central element
> (such as an access point) as long as it can reach the target through
> intermediate relay nodes. The multihop nature is an intrinsic property
> that is always present regardless of the deployment scenario. Mobility
> is not. A MANET could consist of an un-engineered network of *static*
> nodes arbitrarily situated within an area. This network is multihop
> but isn’t mobile. I understand that both are appropriate qualifiers
> for such ad hoc networks, I am just arguing that multihop is more
> descriptive. Just I thought I wanted to share. What do you think? 
> 
>  
> 
>  
> 
> Best regards, 
> 
>  
> 
> Salah M.  S.  Al-Buraiky
> 
> Saudi Aramco- Energy for Generations -
> 
> “The network should be invisible; the traffic should be granularly
> visible”
> 
>  
> 
>

---

From: "Mullen, John" <[email-masked]>
Date: Tue, 16 Sep 2008 10:50:30 -0600

Hi Salah,

At this point, the change would create more confusion than clarity.  To find papers, people would have to search for "mobile ad hoc", "multihop ad hoc" and maybe "multi-hop ad hoc."  (MS Outlook tells me "multihop" is wrong, but "multi-hop" is right).   No naming is perfect.  For example, some queueing systems have no queues, but we still call them queueing (or queuing) systems.

John Mullen

From: [email-masked] [mailto:[email-masked]] On Behalf Of Buraiky, Salah M.
Sent: Tuesday, September 16, 2008 2:27 AM
To: [email-masked]
Subject: [manet] The "M" in "MANET"

Dear All,

Best regards,

Salah M.  S.  Al-Buraiky

---

From: Lawrence MacIntyre <[email-masked]>
Date: Tue, 16 Sep 2008 11:02:01 -0400

Salah:

The term for static networks is "Mesh".   This is used to describe
sensor network protocols such as Zigbee.  It is much easier to create a
mesh network protocol than it is to create a MANET protocol, because,
especially as the network scales up in size, mobility adds greatly to
the bandwidth required for route maintenance.

> “The network should be invisible; the traffic should be granularly

Lawrence MacIntyre  [email-masked]  Oak Ridge National Laboratory
 865.574.8696  Cyber Space and Information Intelligence Research Group
   SIPRNet: [email-masked]  ICMail: [email-masked]

---

From: "Buraiky, Salah M." <[email-masked]>
Date: Sat, 27 Sep 2008 10:46:41 +0300

Dear Rex,

Thank you for your insightful replies. I've enjoyed reading them. I also got a broader perspective on mobility in data networks.

I am not suggesting de-acronymization. I was just wondering why the mobility aspect of MANET was deemed more fundamental than the multihop aspect. MANET networks are certainly both multihop and mobile.

The name could refer to both. Why not? GPS could be Global Positioning System or Geographic Positioning System. NIS could stand for Network Information System or Network Information Service. M could be for either Mobile or Multihop. The elegant name MANET remains with both ;-).

It is true that the fixed Internet is multihop, but not in the MANET sense. In the MANET sense, the classical Internet is actually single-hop. The host in the traditional Internet always communicates single-hop. To communicate, it has to be a single hop away from the peer host it wishes to communicate with or a single hop away from the infrastructure (the closest router). A node that is two hops away from a node it wishes to communicate with or two hops away from the nearest router is out of luck as hosts in between can't relay traffic. With MANET, the situation is different. Any host within range has embedded routing capability and can be used to hop towards other hosts or towards the fixed infrastructure.

That's why MANET is very frequently described as multihop in journal papers and RFC documents. To cite just one example, I quote Charles Perkins:
"We discuss only proposals that offer solutions to the case in which some of the wireless nodes are not within range of each other. Combined with the lack of infrastructure routers, the restricted range of wireless transmission indicates the need for *multihop* routing." (Page 4 of AD HOC NETWORKING, published by Addison-Wesley).

I'd like to also add to your list another shade of meaning to the word "mobility". In NEMO a mobile network is a network that experiences mobility as a whole as a single unit. In MANET a mobile network is a network that experiences mobility within between its components.

Regards,

Salah

-----Original Message-----
From: Rex Buddenberg [mailto:[email-masked]]
Sent: Tuesday, September 16, 2008 7:48 PM
To: Buraiky, Salah M.
Cc: [email-masked]
Subject: Re: [manet] The "M" in "MANET"

Salah,

On Tue, 2008-09-16 at 11:26 +0300, Buraiky, Salah M. wrote:
> that they are "multihop": to communicate, a node doesn't need to be
> but isn't mobile. I understand that both are appropriate qualifiers