Subject: Re: [manet] [Technical Errata Reported] RFC5497 (1722)

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Mon, 16 Mar 2009 10:17:35 -0000

I believe this erratum is correct, and should be made. 

Christopher Dearlove (co-author of RFC 5497)

-- 
Christopher Dearlove
Technology Leader, Communications Group
Networks, Security and Information Systems Department
BAE Systems Advanced Technology Centre
West Hanningfield Road, Great Baddow, Chelmsford, CM2 8HN, UK
Tel: +44 1245 242194  Fax: +44 1245 242124

BAE Systems (Operations) Limited
Registered Office: Warwick House, PO Box 87,
Farnborough Aerospace Centre, Farnborough, Hants, GU14 6YU, UK
Registered in England & Wales No: 1996687

-----Original Message-----
From: RFC Errata System [mailto:[email-masked]] 
Sent: 16 March 2009 10:06
To: [email-masked]; Dearlove, Christopher (UK);
[email-masked]; [email-masked]; [email-masked];
[email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: [Technical Errata Reported] RFC5497 (1722)

               *** WARNING ***

This mail has originated outside your organization,
either from an external partner or the Global Internet. 
     Keep this in mind if you answer this message. 

The following errata report has been submitted for RFC5497,
"Representing Multi-Value Time in Mobile Ad Hoc Networks (MANETs)".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=5497&eid=1722

--------------------------------------
Type: Technical
Reported by: Alfred Hoenes <[email-masked]>

Section: 6.2, pg.9

Original Text
-------------
[ first bullet: ]

   o  The <length> field in the TLV MUST contain the value m * (2n+1),
|     with n being the number of (time-value, hop count) pairs in the
|     Time TLV, and m being number-values as defined in [RFC5444].

Corrected Text
--------------
   o  The <length> field in the TLV MUST contain the value m * (2n+1),
|     with n being the number of (time-value, hop count) pairs per
|     associated address in the Time TLV, and m being number-values as
      defined in [RFC5444].

Notes
-----
Rationale:
The original text is contradictory in itself, and it opposes the
subsequent bullets and prose in the same section.
The proposed correction (inserting "per associated adddress")
is derived from the text in the first paragraph of the section.

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC5497 (draft-ietf-manet-timetlv-08)
--------------------------------------
Title               : Representing Multi-Value Time in Mobile Ad Hoc
Networks (MANETs)
Publication Date    : March 2009
Author(s)           : T. Clausen, C. Dearlove
Category            : PROPOSED STANDARD
Source              : Mobile Ad-hoc Networks
Area                : Routing
Stream              : IETF
Verifying Party     : IESG

********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************

---

From: RFC Errata System <[email-masked]>
Date: Mon, 16 Mar 2009 03:06:22 -0700 (PDT)

Section: 6.2, pg.9

Original Text
-------------
[ first bullet: ]

Corrected Text
--------------

Notes
-----
Rationale:

Instructions:
-------------

Title               : Representing Multi-Value Time in Mobile Ad Hoc Networks (MANETs)