Subject: Re: [manet] IETF mailing List - draft-ramrekha-manet-chameleon-00.txt (manet routing)

From: Konstantinos Birkos <[email-masked]>
Date: Wed, 10 Mar 2010 15:38:00 +0200

In general, different routing schemes perform differently in varying 
network conditions such as mobility or time-varying number of nodes. 
Therefore, adaptive approaches that make use of the appropriate routing 
scheme depending on the conditions can indeed lead in enhanced routing 
performance.
 From what I assume, only transition from p-phase to r-phase is defined 
(with o-phase preventing unnecessary transitions). I would suggest 
considering also transition from r-phase to p-phase as a future amendment.

Konstantinos Birkos
University of Patras

---

From: "Ramrekha, Arvind" <[email-masked]>
Date: Wed, 10 Mar 2010 17:22:34 +0000

The CML draft actually describes both transitions i.e. the transition from p-phase to r-phase and from r-phase to the p-phase. 

In the p- to r- transition, the actual number of nodes in the network can be found using the proactive routing table.

In the r- to p- transition, reactive routing tables do not store network information. We use the number of hops as received by Reply packets to estimate the network size using a mathematical relationship between the two. This will be revised in the future with suggestions by Henning about the problems of using hop count as a metric for route selection. 

Also, the transition from r-phase to p-phase is based on the lower value for network size threshold as described in the CML draft.           
 
Regards,

Arvind.
________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Konstantinos Birkos [[email-masked]]
Sent: 10 March 2010 13:38
To: [email-masked]
Cc: [email-masked]
Subject: Re: [manet] IETF mailing List - draft-ramrekha-manet-chameleon-00.txt (manet routing)

Konstantinos Birkos
University of Patras

_______________________________________________
manet mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/manet

This email has been scanned for all viruses by the MessageLabs Email
Security System.

This email has been scanned for all viruses by the MessageLabs Email
Security System.