Subject: [manet] OLSR.org preliminary NHDP interop result

From: Henning Rogge <[email-masked]>
Date: Tue, 23 Nov 2010 08:12:18 +0100

Hello,

I did a first interop test yesterday, together with the NRL NHDP 
implementation on some virtual machines.

The result is that the two implementations are NOT inter operable at the 
moment.

The reason is that I designed the OLSR.org NHDP implementation with OLSRv2 in 
mind, so my implementation use the originator address as a unique identifier 
for the one-hop neighbors. Pure NHDP does not do this, but relies on a list of 
interface addresses as the key to the neighbors identity.

Henning Rogge
-- 
Diplom-Informatiker Henning Rogge , Fraunhofer-Institut für
Kommunikation, Informationsverarbeitung und Ergonomie FKIE
Kommunikationssysteme (KOM)
Neuenahrer Straße 20, 53343 Wachtberg, Germany
Telefon +49 228 9435-961,   Fax +49 228 9435 685
mailto:[email-masked] http://www.fkie.fraunhofer.de
GPG: E1C6 0914 490B 3909 D944 F80D 4487 C67C 55EC CFE0

---

From: "Justin Dean" <[email-masked]>
Date: Tue, 23 Nov 2010 09:48:09 -0500

So would it possibly work if there was an option in NRL NHDP to include an
originator address?

Justin

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Henning Rogge
> Sent: Tuesday, November 23, 2010 2:12 AM
> To: [email-masked]
> Subject: [manet] OLSR.org preliminary NHDP interop result
> 
> Hello,
> 
> The result is that the two implementations are NOT inter operable at
> the moment.
> 
> The reason is that I designed the OLSR.org NHDP implementation with
> OLSRv2 in mind, so my implementation use the originator address as a
> unique identifier for the one-hop neighbors. Pure NHDP does not do
> this, but relies on a list of interface addresses as the key to the
> neighbors identity.
> 
> Henning Rogge
> --
> Kommunikationssysteme (KOM) Neuenahrer Straße 20, 53343 Wachtberg,
> Germany

---

From: Henning Rogge <[email-masked]>
Date: Tue, 23 Nov 2010 17:01:59 +0100

> So would it possibly work if there was an option in NRL NHDP to include an
Yes, but I am still thinking about ideas how to resolv the problem... my 
problem is that pure NHDP does not contain an identifier for each "neighbor", 
so it's not easy to handle efficiently with linked lists and avl trees as the 
basic datastructure.

Henning Rogge
-- 
1) You can't win.
2) You can't break even.
3) You can't leave the game.
— The Laws of Thermodynamics, summarized