Subject: [manet] Deployment Experience?

From: Hannes Tschofenig <[email-masked]>
Date: Wed, 26 Jan 2011 11:31:16 +0200

Hi all,

some of you might have missed the announcement on the IETF announcement list. The workshop on "Interconnecting Smart Objects with the Internet" will take place on the Friday before the IETF#80 meeting in Prague. Here is the link to the workshop page:
http://www.iab.org/about/workshops/smartobjects

There is also a tutorial day attached to the workshop (on Saturday):
http://www.iab.org/about/workshops/smartobjects/tutorial.html

I am writing to you because the MANET group has done a lot of work on routing in constrained environments. The questions I have are: 

a) Has the deployment experience given you some insight on what functionality is of common interest for a large range of application scenarios. A random example of a technology is multicast.

b) What is the deployment experience with mobile adhoc networks in general? Did the technology you guys develop turn out to be useful in the real world? If not, where did things go wrong or what assumptions were incorrect?

In essence I am asking for sharing your experience with us and whether there are open questions that still remain to be solved (from a standardization as well as research point of view).

Ciao
Hannes

---

From: Joe Macker <[email-masked]>
Date: Wed, 26 Jan 2011 15:27:33 -0500

For me I think multicast is a key issue. 
That becomes important at the dynamic edge and there is experience with early deployments and lessons learned across layers.

Working to integrate upper layers simple things such as more flexible timing apparatus and event driven interfaces can sometimes make a big difference.
For myself, I was hoping to be there but I just had surgery which is limited my travel options.

-Joe

On Jan 26, 2011, at 4:31 AM, Hannes Tschofenig wrote:

> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet
>

---

From: Rex Buddenberg <[email-masked]>
Date: Wed, 26 Jan 2011 13:30:13 -0800

Hannes,

I agree with Joe; let me tell you why.

If you look at the commercial world and whisper 'mobile', what you get
back is all about cellphones and WiFi.  'Mobile' equates to a LAN
problem at the fringe of the internet.  

But that's not the military's problem and it's not emergency services'
problem.  The topology is different: we want to reach to a router in the
ambulance (with all the medical diagnostic sensors attached to a LAN on
other side of that router).  In other words its a radio-WAN problem, not
a LAN one.

In addition to topology, there are two other differences here:
	10e-4.  We can easily provision both the terrestrial-WAN and LANs at
Gbit capacities and better.  But the radio-WAN tops out in the Mbit
territory and we're up on the engineering limits (bits/hertz).  About
the only remaining engineering rabbit in the hat is multicast.  The
radio-WAN is the part of the internet where we get the benefit.
	Shared medium.  Most of the internet is made up of point-point
infrastructure.  This has two edges:  point-point means that there's no
evident payoff to multicast (part of the reason multicast has had such a
slow uptake in the commercial internet to date).  And point-point
plumbing means that you don't need a MAC.  Since a radio-WAN is in the
interior of an internet and is four orders of magnitude less capacious
than the network segments on all sides, we can safely assume that it
will be saturated so we must have a contention-free MAC.  

My comments about multicast are independent of whether or not there's
MANET routing in the infrastructure.