Subject: [manet] Some general comments on SMF-11

From: Jiazi YI <[email-masked]>
Date: Fri, 22 Apr 2011 10:55:40 +0200

Hi,

After reading through the SMF-11, I still have some general comments (or
I would rather call them questions) on it.  Because I'm relatively new
to the SMF, I'm sorry if those are too "naive" :-P

1. In the specification of the protocol, the multicast address or the
multicast groups are not mentioned. What SMF does is mainly forwards the
packets to all the nodes in the SMF domain.
So SMF can also be regarded as a "broadcast" protocol ?

2. For the Relay Set Selection section, if I was trying to implement
SMF,  I'll have difficulties in choosing the three methods in the
appendixes. What's the difference in those solutions and which one is
recommended in difference scenarios?
Concerning the E-CDS, the choice is based on (Router priority, Router
ID). However, there is no recommendation made for defining the
"priority". How can we set the values for "priority"? If we only choose
the node based on the ID, it seems that it's not convincing enough.

best regards

-- 
Jiazi YI

www.jiaziyi.com
Postdoctoral researcher
Hipercom@LIX, Ecole Polytechnique
91128 Palaiseau Cedex France

---

From: "Justin Dean" <[email-masked]>
Date: Fri, 22 Apr 2011 09:31:05 -0400

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Jiazi YI
> Sent: Friday, April 22, 2011 4:56 AM
> To: [email-masked]
> Subject: [manet] Some general comments on SMF-11
> 
> Hi,
> 

Correct to an extent.  Future extensions and modifications to the election
algorithm could possibly provide group based forwarding.  Currently it is
for "broadcast"ing within the MANET.  Simply setting a low TTL can provide
localized scoping.

> recommended in difference scenarios?

We really did try to include information related to algorithm requirements,
and some general attributes of the algorithms.  There is no one size fits
all algorithm and debating which is "best" leads to never ending rabbit
hole. In danger of stepping into the rabbit hole.

S-MPR: source based flooding with shortest hop paths.  Generally the most
efficient in terms of #routers forwarding vs others provided.  Good with
sharp cutoff radio/link characteristics.

E-CDS: single shared CDS.  Shortest hops paths NOT guaranteed.

MPR-CDS: single shared CDS. Shortest hop paths guaranteed.  Generally most
#of forwarders vs other two.

All that being said the algorithms provided are only a sample of what is
actually possible.  The efficiencies are relatively speaking "close" and the
greatest gains are to be had in selecting/sensing quality neighbor
information.
This paper presents some tests related to the various algorithms.
http://cs.itd.nrl.navy.mil/pubs/docs/acm2007-macker.pdf

> the node based on the ID, it seems that it's not convincing enough.
"priority" can be anything from preconfigured (for example a mixture of
heterogeneous routers with differing power constraints), to an aggregate
value of power/neighbors/MAC utilization/queue size or any number of things
relevant to the deployment. Power and #neighbors are simple dynamic ones to
implement.

> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet

---

From: Joe Macker <[email-masked]>
Date: Fri, 22 Apr 2011 13:05:17 -0400

> to the SMF, I'm sorry if those are too "naive" :-P

No problem.

> So SMF can also be regarded as a "broadcast" protocol ?

This is partially true and most of that is explained right up front in the applicability part of the document.
SMF is also about forwarding site-scoped multicast and any additional multicast global addresses determined by the FIB.
There is some discussion the forwarding rules for various multicast groups.
Link local is disallowed, site (admin)-scoped addresses are discussed, and the role of global multicast addresses if forwarding is allowed in by the FIB is defined.  See processing rules an sections on forwarding, multicast group scoping sections.

It is intended for limited use in deployments where this may make sense.

There is past and present discussion on applying more detailed group-based forwarding decision.
The control for that would live in another protocol layer but could be support by the SMF mesh forwarding approach.
So one can layer group specifics on top of something like SMF as a more sophisticated control plane.

SMF is fundamentally about a simplified core specification addressing duplicate detection and optional cover set-based forwarding in limited multi-hop wireless edge networks (e.g., MANETs)
 
There is also past and present work on more specific group-based multicast forwarding in highly dynamic environments.

> the node based on the ID, it seems that it's not convincing enough.

There has been work done here in practice.  The priority tuple value can be based upon density or on some other admin knowledge (most advantaged relay link).

For example, there is paper showing the comparison of ID-alone vs. 2-hop density-based priority election for E-CDS in various topological cases. So I agree with you above although the ID approach works for maintaining a dynamic CDS it is not as optimized.

Priority is basically there as a protocol hook to provide additional control (possible management control or more optimized election).

Best practices are not established and we are not trying to limit people here, one reason the WG has consensus on EXPERIMENTAL not STD TRACK submission status.

Some additional info: In practice, SMF implementation are often deployed alongside something like MANET OSPF extensions or OLSR and these unicast protocols can provide related relay set election information. There are working implementations. I discuss this but implementation details are not provided.  NHDP and SMF interaction is specified but at present there is not working implementation.