Subject: [manet] [DLEP] CDR

From: "Kang, Jaewon" <[email-masked]>
Date: Thu, 6 Oct 2011 10:00:26 -0400

Hi,

I want to discuss how DLEP reports the CDR in the shared medium. From the draft, it is unclear to me whether the CDR conveyed by the "Link Characteristics ACK" message is a per-neighbor or an aggregate CDR when requested by a "Link Characteristics Request" message without the CDR field.
Depending on the radio type, the modem can support either of them or both. For example, in TDMA, the modem can calculate the per-neighbor CDR based on the number of time slots assigned for the neighbor. Or in CSMA, the modem might not calculate the per-neighbor CDR and therefore, it simply reports the aggregate CDR. Then it is up to the router (or any application running on the router) to infer the per-neighbor CDR based on the aggregate CDR & (maybe) number of neighbors in the shared medium. (The routing daemon might assign different link weights depending on the available CDR).

So, if we agree that this differentiation is helpful, then I want to discuss how to specify the type of CDR (per-neighbor or aggregate) in the Link Characteristics messages. If the modem does not support the per-neighbor CDR, then it can signal that to the router. What I understand is that most of the current modems report a certain CDR value, but I am not sure whether this is a per-neighbor or an aggregate CDR. (Sure, there is no confusion if the link is a point-to-point link).

Thanks for reading.

Jae from Telcordia.

---

From: Vikram KAUL <[email-masked]>
Date: Thu, 6 Oct 2011 10:27:22 -0400 (Eastern Daylight Time)

> 
> So, if we agree that this differentiation is helpful, then I want to discuss how
> to specify the type of CDR (per-neighbor or aggregate) in the Link
> Characteristics messages. If the modem does not support the per-neighbor CDR,

My thinking is that we could again use the MAC Address sub-TLV to identify 
whether per-neighbor information is being requested (or even configured) 
or whether it is aggregate

My email from yesterday talked about the MAC Address sub-TLV to have the 
following uses

  1) The MAC address of the far-end (neighbor) router
  2) An all-broadcast address 0xffffffffffff (6 bytes all 0xFF)
  3) An IPv4 multicast address, the most significant two bytes being 0x0100
     and the next 4 octets being the IPv4 multicast address octets

Perhaps, we can add a 4)

  4) An all-zero address 0x00000000000 (6 bytes all 0x00)

which would specify this as a request for 'aggregate'

  1) would always be used for per-neighbor

Vikram

> then it can signal that to the router. What I understand is that most of the
> current modems report a certain CDR value, but I am not sure whether this is a
> per-neighbor or an aggregate CDR. (Sure, there is no confusion if the link is a
> point-to-point link).
>
> 
> 
> Thanks for reading.
>
> 
> 
> Jae from Telcordia.
>
> 
>
> 
> 
> 
>