Subject: [manet] Fwd: New Version Notification fordraft-baccelli-manet-multihop-communication-00.txt

From: "Charles E. Perkins" <[email-masked]>
Date: Wed, 23 Nov 2011 14:08:30 -0800

Hello folks,

As promised, we have resubmitted the draft for
describing the characteristics of communication
between nodes in a multihop network, which was
originally submitted for consideration in the
[autoconf] working group.

The document is basically finished, and has completed
extensive review within [autoconf], and should be published.
If there is interest to adopt the document as a working
group draft within [manet], we would be happy to make
any further additional changes which might be needed.

Regards,
Charlie P.

-------- Original Message --------
Subject: New Version Notification 
fordraft-baccelli-manet-multihop-communication-00.txt
Date: Wed, 23 Nov 2011 15:46:28 -0600
From: <[email-masked]>
To: Perkins, Charles <[email-masked]>
CC: Perkins, Charles <[email-masked]>, <[email-masked]>

A new version of I-D, draft-baccelli-manet-multihop-communication-00.txt 
has been successfully submitted by Charles Perkins and posted to the 
IETF repository.

Filename:	 draft-baccelli-manet-multihop-communication
Revision:	 00
Title:		 Multi-hop Ad Hoc Wireless Communication
Creation date:	 2011-11-23
WG ID:		 Individual Submission
Number of pages: 10

Abstract:
    This document describes some characteristics of communication between
    nodes in a multi-hop ad hoc wireless network.  These are not
    requirements in the sense usually understood as applying to
    formulation of a requirements document.  Nevertheless, protocol
    engineers and system analysts involved with designing solutions for
    ad hoc networks must maintain awareness of these characteristics.

The IETF Secretariat

---

From: Carlos Jesús Bernardos Cano <[email-masked]>
Date: Wed, 23 Nov 2011 23:40:15 +0100

Hi Charlie,

Although I cannot be considered as a MANET WG member, as a former
AUTOCONF WG participant, I support the adoption/publication of your
document. I think it is a very useful document.

Kind Regards,

Carlos

On Wed, 2011-11-23 at 14:08 -0800, Charles E. Perkins wrote:
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet

-- 
Carlos Jesús Bernardos Cano  http://www.netcom.it.uc3m.es/
GPG FP: D29B 0A6A 639A A561 93CA  4D55 35DC BA4D D170 4F67

---

From: Emmanuel Baccelli <[email-masked]>
Date: Thu, 24 Nov 2011 09:52:05 +0100

Hi Carlos,
I wonder what is the specification for a "real" MANET wg member ;)
I don't know if I am one myself, but of course I also support taking on
this document in MANET.
Regards,
Emmanuel

2011/11/23 Carlos Jesús Bernardos Cano <[email-masked]>

> > CC: Perkins, Charles <[email-masked]>, <[email-masked]
> >
> >

---

From: Ulrich Herberg <[email-masked]>
Date: Thu, 24 Nov 2011 11:06:52 +0100

Hi all,

I don't think we should adopt this draft in the WG (at least not currently), for two reasons:

1) We are not chartered to do so. We are still chartered to produce a proactive and a reactive routing protocol. None of them have been published yet, even though we are 4.5 years behind schedule. 

2) I am scared to create similar discussions as we had in AUTOCONF. We all know where that led to. Can the authors explain what the purose of having the draft standardized is? I think we should have a very good answer to that question if we are willing to bring in the AUTOCONF discussions into MANET (and I fear that that may happen).

Regards
Ulrich

On Nov 24, 2011, at 9:52, Emmanuel Baccelli <[email-masked]> wrote:

> I don't know if I am one myself, but of course I also support taking on this document in MANET.
> Regards,
> Emmanuel
> 
>

---

From: Teco Boot <[email-masked]>
Date: Thu, 24 Nov 2011 11:28:21 +0100

This ID has value for what we are chartered for. The suggestion 
made by AD in Autoconf was to publish the doc as independent 
submission. Adoption in MANET is a good alternative.

I used this doc while discussing DLEP. Referring an RFC helps.

Teco

---

From: Emmanuel Baccelli <[email-masked]>
Date: Thu, 24 Nov 2011 11:33:58 +0100

Hi Ulrich,

I see your points. However:

1) the use of standardizing such a document is obvious: the subject keeps
popping up (latest occurrence MANET meeting in Taipei), so having a pointer
to an RFC would be useful.

2) the wireless-comm draft is already mature and could be sent very soon to
the IESG.

3) I don't see how this doing would impact work on reactive/proactive
protocol work, quite the contrary in fact!

Best Regards,

Emmanuel

On Thu, Nov 24, 2011 at 11:06 AM, Ulrich Herberg <[email-masked]>wrote:

> 1) We are not chartered to do so. We are still chartered to produce a
> proactive and a reactive routing protocol. None of them have been published
> yet, even though we are 4.5 years behind schedule.
>
> 2) I am scared to create similar discussions as we had in AUTOCONF. We all
> know where that led to. Can the authors explain what the purose of having
> the draft standardized is? I think we should have a very good answer to
> that question if we are willing to bring in the AUTOCONF discussions into
> MANET (and I fear that that may happen).
>
> Regards
> Ulrich
>

---

From: Thomas Heide Clausen <[email-masked]>
Date: Thu, 24 Nov 2011 12:06:04 +0100

Dear Emmanuel,

I do agree with Ulrich's position here, but want to add something to your points below….sorry if I am being discouraging…..

I suggest it to be prudent to be putting this whole topic on hold, finish the task(s) that the WG is chartered to do as well as the auxiliary tasks (MIBs, security) in progress -- then, and only then, consider taking on new work (which may or may not involve these link/subnet/* discussions).

Further below….

On Nov 24, 2011, at 11:33 , Emmanuel Baccelli wrote:

> 1) the use of standardizing such a document is obvious: the subject keeps popping up (latest occurrence MANET meeting in Taipei), so having a pointer to an RFC would be useful.
> 
> 2) the wireless-comm draft is already mature and could be sent very soon to the IESG.

I believe that there is a lot of things that can be said on the subject of this "link-type" or "subnet model". I also believe that there is no wide consensus (as we saw in [AUTOCONF]) as to what can and should be said - none of the various architecture/model document attained anything close to consensus.

This wireless-comm I-D describes some basic and well known properties (hidden/exposed terminals, transitivity, asymmetry, …) -- basic text-book material on wireless networks, and with which I can't disagree, technically (as they say: it's hard to argue against apple pie ….).

However the I-D  does not position these in the context which is interesting in and for the IETF: how they relate to a link or subnet, how they impact protocol design, etc. For me to consider such a document to be sufficiently mature and ready for the IESG, I would want to see these issues discussed in detail. 

In its present form, I actually question what publication would accomplish for the IETF or the WG: as a protocol designer, it doesn't address the topics that are important (link/subnet model/assumptions) to know about and take into account. As a deployer of protocols, it doesn't provide any guidelines that should be applied.

> 3) I don't see how this doing would impact work on reactive/proactive protocol work, quite the contrary in fact!

Have you forgotten [autoconf] already? That WG got so bogged down in metaphysical discussions on "what is a link" and the like that it didn't get any protocol design done. I really really would want to not see that happen in [MANET]. We have - as Ulrich points out - protocols to finish. Taking on this as new work would distract from that goal of getting these protocols through. I do not see how taking on this work could help (as you seem to imply)? -- experience goes contrary to this,

I'll repeat myself: I suggest it to be prudent to be putting this whole topic on hold, finish the task(s) that the WG is chartered to do as well as the auxiliary tasks (MIBs, security) in progress -- then, and only then, consider taking on new work (which may or may not involve these link/subnet/* discussions).

As I said, sorry for being discouraging. I am sure that you know from where I am coming here, though.

Respectfully yours,

Thomas

> Best Regards,
> 
> Emmanuel
> 
> 
> On Thu, Nov 24, 2011 at 11:06 AM, Ulrich Herberg <[email-masked]> wrote:
> Hi all,
>

---

From: Emmanuel Baccelli <[email-masked]>
Date: Thu, 24 Nov 2011 14:00:34 +0100

Hi Thomas,

indeed, the wireless-comm I-D describes some observed properties of
multi-hop wireless communications. Apparently these properties are not so
well known in the broad IETF community, but on the other hand, as you say
yourself, these properties are well known in a smaller community (including
MANET), and captured well enough in the wireless-comm I-D.

>From these facts I conclude that (i) an informational RFC based on the
wireless-comm I-D would be useful for the IETF community at large, and (ii)
our smaller community is ready to judge the wireless-comm I-D as mature
enough, useful enough, and non-controversial, so why not do it?

Now, concerning a subnet/link model that would fit these properties, that's
another debate which we don't necessarily have to address at the same time.

It might however make sense to point to RFC5889? RFC 5889 tackles links
with undetermined connectivity properties - a type of link which indeed
fits the characteristics described in the wireless-comm I-D ;)

Cheers

Emmanuel

On Thu, Nov 24, 2011 at 12:06 PM, Thomas Heide Clausen <
[email-masked]> wrote:

> Dear Emmanuel,
>
> I do agree with Ulrich's position here, but want to add something to your
> points below….sorry if I am being discouraging…..
>
> I suggest it to be prudent to be putting this whole topic on hold, finish
> the task(s) that the WG is chartered to do as well as the auxiliary tasks
> (MIBs, security) in progress -- then, and only then, consider taking on new
> work (which may or may not involve these link/subnet/* discussions).
>
> Further below….
>
> I believe that there is a lot of things that can be said on the subject of
> this "link-type" or "subnet model". I also believe that there is no wide
> consensus (as we saw in [AUTOCONF]) as to what can and should be said -
> none of the various architecture/model document attained anything close to
> consensus.
>
> This wireless-comm I-D describes some basic and well known properties
> (hidden/exposed terminals, transitivity, asymmetry, …) -- basic text-book
> material on wireless networks, and with which I can't disagree, technically
> (as they say: it's hard to argue against apple pie ….).
>
> However the I-D  does not position these in the context which is
> interesting in and for the IETF: how they relate to a link or subnet, how
> they impact protocol design, etc. For me to consider such a document to be
> sufficiently mature and ready for the IESG, I would want to see these
> issues discussed in detail.
>
> In its present form, I actually question what publication would accomplish
> for the IETF or the WG: as a protocol designer, it doesn't address the
> topics that are important (link/subnet model/assumptions) to know about and
> take into account. As a deployer of protocols, it doesn't provide any
> guidelines that should be applied.
>
> Have you forgotten [autoconf] already? That WG got so bogged down in
> metaphysical discussions on "what is a link" and the like that it didn't
> get any protocol design done. I really really would want to not see that
> happen in [MANET]. We have - as Ulrich points out - protocols to finish.
> Taking on this as new work would distract from that goal of getting these
> protocols through. I do not see how taking on this work could help (as you
> seem to imply)? -- experience goes contrary to this,
>
> I'll repeat myself: I suggest it to be prudent to be putting this whole
> topic on hold, finish the task(s) that the WG is chartered to do as well as
> the auxiliary tasks (MIBs, security) in progress -- then, and only then,
> consider taking on new work (which may or may not involve these
> link/subnet/* discussions).
>
>> 2) I am scared to create similar discussions as we had in AUTOCONF. We
>> all know where that led to. Can the authors explain what the purose of
>> having the draft standardized is? I think we should have a very good answer
>> to that question if we are willing to bring in the AUTOCONF discussions
>> into MANET (and I fear that that may happen).
>>
>> Regards
>> Ulrich
>>
>>> > A new version of I-D,
>>> draft-baccelli-manet-multihop-communication-00.txt

---

From: Thomas Heide Clausen <[email-masked]>
Date: Thu, 24 Nov 2011 14:16:57 +0100

Hi Emmanuel,

On Nov 24, 2011, at 14:00 , Emmanuel Baccelli wrote:

> Hi Thomas,
> 
> indeed, the wireless-comm I-D describes some observed properties of multi-hop wireless communications. Apparently these properties are not so well known in the broad IETF community, but on the other hand, as you say yourself, these properties are well known in a smaller community (including MANET), and captured well enough in the wireless-comm I-D. 

Not sure that I agree with your evaluation of community size here; I would guess (and, hope) that the growing interest in LLNs have made more people more aware - but this is conjecture anyways.

> From these facts I conclude that (i) an informational RFC based on the wireless-comm I-D would be useful for the IETF community at large, and (ii) our smaller community is ready to judge the wireless-comm I-D as mature enough, useful enough, and non-controversial, so why not do it?
> 
> Now, concerning a subnet/link model that would fit these properties, that's another debate which we don't necessarily have to address at the same time. 

To me, these two things are inextricably related, and one can't legitimately be discussed without also discussing the other -- and, I do think that both [eventually] would need to be discussed.

But, I still think that those discussions might be relevant in [MANET] only after current charter items have been properly addressed in and by the WG.

Thomas

> It might however make sense to point to RFC5889? RFC 5889 tackles links with undetermined connectivity properties - a type of link which indeed fits the characteristics described in the wireless-comm I-D ;)
> 
> Cheers
> 
> Emmanuel
> 
> 
> On Thu, Nov 24, 2011 at 12:06 PM, Thomas Heide Clausen <[email-masked]> wrote:
> Dear Emmanuel,
>

---

From: Emmanuel Baccelli <[email-masked]>
Date: Thu, 24 Nov 2011 14:28:14 +0100

On Thu, Nov 24, 2011 at 2:16 PM, Thomas Heide Clausen <
[email-masked]> wrote:

> Not sure that I agree with your evaluation of community size here; I would
> guess (and, hope) that the growing interest in LLNs have made more people
> more aware - but this is conjecture anyways.
>
> Now, concerning a subnet/link model that would fit these properties,
> that's another debate which we don't necessarily have to address at the
> same time.
>
>
> To me, these two things are inextricably related, and one can't
> legitimately be discussed without also discussing the other -- and, I do
> think that both [eventually] would need to be discussed.
>
> But, I still think that those discussions might be relevant in [MANET]
> only after current charter items have been properly addressed in and by the
> WG.
>

I understand your personal opinion. However, it does not seem like MANET
lacks available bandwidth to take on other opinions, and/or an additional
item as useful, mature and non-controversial as the wireless-comm I-D?

Regards,

Emmanuel

>> I believe that there is a lot of things that can be said on the subject
>> of this "link-type" or "subnet model". I also believe that there is no wide
>> In its present form, I actually question what publication would
>> accomplish for the IETF or the WG: as a protocol designer, it doesn't
>> address the topics that are important (link/subnet model/assumptions) to
>> know about and take into account. As a deployer of protocols, it doesn't
>> provide any guidelines that should be applied.
>>

---

From: Thomas Heide Clausen <[email-masked]>
Date: Thu, 24 Nov 2011 14:39:54 +0100

Dear Emmanuel,

On Nov 24, 2011, at 14:28 , Emmanuel Baccelli wrote:

> 
> 
> On Thu, Nov 24, 2011 at 2:16 PM, Thomas Heide Clausen <[email-masked]> wrote:
> Hi Emmanuel,
> 
> I understand your personal opinion. However, it does not seem like MANET lacks available bandwidth to take on other opinions, and/or an additional item as useful, mature and non-controversial as the wireless-comm I-D?
> 

That's the thing:

	o	I don't think it's "useful, mature and non-controvercial", for the reasons previously cited, and that substantial
		(but, interesting) work would be required. 

	o	I don't think that [MANET] has bandwidth to import the old [AUTOCONF] discussions.

	o	I don't think that a WG which is 4.5 years behind on its milestones can be said to have a lot of available bandwidth.

	o	I do think that [MANET] should finish its current charter items first, then consider picking up new items (which may or may not include this work).

I'll leave this discussion here, I've made my opinions known and I trust that the chairs will take them (as well as the opinions of you and others) into consideration when making a call on this issue.

Respectfully yours,

Thomas

---

From: Teco Boot <[email-masked]>
Date: Thu, 24 Nov 2011 16:30:10 +0100

Op 24 nov. 2011, om 14:39 heeft Thomas Heide Clausen het volgende geschreven:

> the chairs will take them (as well as the opinions of you and others) into consideration when making a call on this issue.

+1. 

It is up to the WG to adopt something. I think the charter is a nice guideline, not a mandate. Who objected because procedures when we adopted DLEP? Packetbb-sec? We shall decide on what is important and in line with the charter.

Teco