Subject: [manet] I-D Action: draft-ietf-manet-nhdp-mib-19.txt

From: [email-masked]
Date: Sun, 09 Sep 2012 09:54:21 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Mobile Ad-hoc Networks Working Group of the IETF.

	Title           : Definition of Managed Objects for the Neighborhood Discovery Protocol
	Author(s)       : Ulrich Herberg
                          Robert G. Cole
                          Ian D Chakeres
	Filename        : draft-ietf-manet-nhdp-mib-19.txt
	Pages           : 67
	Date            : 2012-09-09

Abstract:
   This document defines a portion of the Management Information Base
   (MIB) for use with network management protocols in the Internet
   community.  In particular, it describes objects for configuring
   parameters of the Neighborhood Discovery Protocol (NHDP) process on a
   router.  The MIB module defined in this document, denoted NHDP-MIB,
   also reports state, performance information and notifications about
   NHDP.  This additional state and performance information is useful to
   troubleshoot problems and performance issues during neighbor
   discovery.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-manet-nhdp-mib

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-manet-nhdp-mib-19

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-manet-nhdp-mib-19

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Abdussalam Baryun <[email-masked]>
Date: Sun, 9 Sep 2012 22:58:59 +0200

Could we know as a WG, why this WG draft is changing many times while
submitted? Please advise,

AB

On 9/9/12, [email-masked] <[email-masked]> wrote:
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet
>

---

From: Thomas Heide Clausen <[email-masked]>
Date: Mon, 10 Sep 2012 01:37:10 +0200

See:
	http://tools.ietf.org/rfcdiff?difftype=--hwdiff&url2=draft-ietf-manet-nhdp-mib-19.txt

-- 
Thomas Heide Clausen
http://www.thomasclausen.org/

"Any simple problem can be made insoluble if enough meetings are held to
 discuss it."
   -- Mitchell's Law of Committees

---

From: Ulrich Herberg <[email-masked]>
Date: Sun, 9 Sep 2012 19:25:14 -0700

Abdussalam,

the reason for the latest revision was a simple glitch in our
versioning, where we un-did some changes we already submitted in an
earlier version. The last three revisions were addressing the DISCUSS
from Benoit (and in particular some of the requests of Thomas Nadeau,
the MIB doctor). As you can see in the diff, the changes were minimal
and mostly editorial.

Best regards
Ulrich

---

From: Abdussalam Baryun <[email-masked]>
Date: Mon, 10 Sep 2012 11:59:14 +0200

Hi Ulrich,

I just wanted to know why the DISCUSS is still there from July until
now? I think you done well in the versions as adding [*], and why we
still are making changes after -17 in many versions why not one only.
I am interested that it goes through with known progress or known
delay reasons. Furthermore, I will hope the draft will not stay in
DISCUSS for more than 28 days, if it does I think the WG should know
why. Thanking you,

[*] http://www.ietf.org/mail-archive/web/manet/current/msg13168.html

AB
+++
On 9/10/12, Ulrich Herberg <[email-masked]> wrote:
>>>> This draft is a work item of the Mobile Ad-hoc Networks Working Group
>>>> of
>>>> the IETF.
>>>>

---

From: Thomas Heide Clausen <[email-masked]>
Date: Mon, 10 Sep 2012 12:18:50 +0200

Abdussalam,

1) 	A DISCUSS is held on a document, for as long as is needed for an AD to verify that the 
    	subject of his/her discuss is resolved. Note that this includes (often) exchanging emails 
	between the AD and the authors (often, with these being in different time-zones) so as 
	to understand how to resolve the discuss, for the authors to implement whatever
	necessary changes, for the AD to review the changes (and possibly iterations over this for 
	as long as is needed). Occasionally, a DISCUSS is held for only hours, at other times for
	years - commonly, a DISCUSS lasts somewhere in between, depending on the issue.

2)	Often, but not always, authors work on one issue, resolve that one issue in a revised version 
	of the document, then proceed to work on resolving the next issue (etc.) - depending on
	their available time, work-practices, when they manage to corner an AD, etc.

3)	ADs are not paid by the IETF either (just like everybody else aren't), and have day-jobs to 
	attend to also. Rather than stress them, you should encourage them and express 
	appreciation for their efforts.

4)	I suggest taking a good long look at http://www.ietf.org/edu/tutorials.html especially
	(but not exclusively) at http://www.ietf.org/edu/process-oriented-tutorials.html

Best,

Thomas

---

From: Abdussalam Baryun <[email-masked]>
Date: Mon, 10 Sep 2012 14:35:42 +0200

Hi Thomas,

I don't think it is efficient to have a draft in IESG for years, I
don't accept that, however, comments below:

> 	years - commonly, a DISCUSS lasts somewhere in between, depending on the

A DISCUSS position should not be more that 90 days or maximum two ietf
meeting periods. I recommend they create a new position named HOLD.

> 	their available time, work-practices, when they manage to corner an AD,
That is fine and I think authors done well for NHDP-MIB, but I see the
delay from IESG, that was the reason of my reply to the new version 19
post.

> 	appreciation for their efforts.

I always appreciate any effort we are equal in IETF, we all have full
responsibilities and we all have taken our choice to participate and
volunteer. If we cannot continue to volunteer more than 90 days then
we should mention that and help to progress the work force not delay
the work force more than 90 days (period of meetings) or maximum 180
days (the maximum is the period for expired drafts). I encourage all
to respond as soon as possible so we don't forget issues or change our
mind, I encourage both sides submitters and reviewers.

>
> 4)	I suggest taking a good long look at
> http://www.ietf.org/edu/tutorials.html especially
> 	(but not exclusively) at
> http://www.ietf.org/edu/process-oriented-tutorials.html

I already done that before, I joined this organisation. Now I am
trying to participate to make things go forward not just watch things
happen without comments,

-AB
+++

---

From: Thomas Heide Clausen <[email-masked]>
Date: Mon, 10 Sep 2012 16:17:28 +0200

Abdussalam,

I think that this mailing-list is the wrong forum for discussing IETF/IESG procedural matters.

Thomas

---

From: Ulrich Herberg <[email-masked]>
Date: Mon, 10 Sep 2012 08:33:51 -0700

Hi Abdussalam,

as Thomas explained to you, there was some back and forth between and
Benoit and us. Plus, we have clicked the "submit" button too early, so
there could have been fewer versions, but well, that's life. The
document has improved with the help of Benoit, Thomas Nadeau and
Adrian, and so I think the time was well spent. As soon as we
submitted a new revision that addressed the DISCUSS, Benoit has lifted
his DISCUSS, so I think the process was smooth. I appreciate their
help, and I am glad that the document is approved now.

Best regards
Ulrich

---

From: Ulrich Herberg <[email-masked]>
Date: Mon, 10 Sep 2012 08:35:56 -0700

+1

These discussions that concern the IETF process or the IESG really do
not belong here.

Best regards
Ulrich

---

From: Abdussalam Baryun <[email-masked]>
Date: Tue, 11 Sep 2012 12:09:25 +0200

Happy to know that the DISCUSS position was changed now after my
comments/reminder. Please note that I can comment on the draft process
as long as you posted it to the list or as long as it has a DISCUSS
position to follow up with the authors maybe they need
help/volunteers.

 My comment was on the progress of the NHDP-MIB draft process which it
is a WG draft, so I am involved and following up with the draft, if
there is a mistake in that I advise the chair to inform me of such
mistake not any participant.

AB

---

From: "Stan Ratliff (sratliff)" <[email-masked]>
Date: Tue, 11 Sep 2012 13:51:43 +0000

> mistake not any participant.

OK, from a co-chair: This is the wrong list for issues on the IESG process. 

Stan