Subject: [manet] Progressing on draft-ietf-manet-olsrv2-metrics-rationale

From: Thomas Heide Clausen <[email-masked]>
Date: Wed, 5 Sep 2012 11:04:44 -0400

Dear all,

As you know,  http://tools.ietf.org/html/draft-dearlove-olsrv2-metrics-06 was presented at the IETF'84 [MANET] meeting, and has been adopted by the WG as http://tools.ietf.org/html/draft-ietf-manet-olsrv2-metrics-rationale-00. The slides of the presentation from IETF'84 are, starting from page 9, here: http://www.ietf.org/proceedings/84/slides/slides-84-manet-2.pdf

As a reminder, this document is derived from the document (already discussed by the WG since 2007, as draft-dearlove-olsrv2-metrics) which originally described how to integrate metrics into OLSRv2, and for which consensus was established resulting in the metrics design of OLSRv2.
 
While OLSRv2 describes *how* metrics were integrated, draft-ietf-manet-olsrv2-metrics-rationale presents the *why* - the design rationale, and is intended as publication as an Informational RFC.
 
The authors would like to see a WGLC of this document some time between now and the next IETF. 

We'd therefore like to ask the WG to review and give feedback so that we may spin a new version soon.

Respectfully,

Thomas, Chris and Philippe

-- 
Thomas Heide Clausen
http://www.thomasclausen.org/

"Any simple problem can be made insoluble if enough meetings are held to
 discuss it."
   -- Mitchell's Law of Committees

---

From: "Stan Ratliff (sratliff)" <[email-masked]>
Date: Wed, 5 Sep 2012 16:31:38 +0000

Folks,

Please find some time to review and comment on this doc, so that we may move it along the path.

Regards,
Stan

On Sep 5, 2012, at 11:04 AM, Thomas Heide Clausen wrote:

Dear all,

Respectfully,

"Any simple problem can be made insoluble if enough meetings are held to
 discuss it."
   -- Mitchell's Law of Committees
_______________________________________________
manet mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/manet

---

From: Ulrich Herberg <[email-masked]>
Date: Wed, 5 Sep 2012 10:57:28 -0700

Hi,

I have read the draft and think it is of high quality and value, and
therefore I support to move forward.

Some nits:
  - terminology: MANET *I*nterface vs. OLSRv2 *i*nterface (lower case)
  - section 4: "When the network topology is changing, and with
possibly lossy messages"; rather "lossy channel"  or "in cases where
messages can be lost (frequently)"
  - section 5.2: "This does not directly take into account delays due to
      routers, rather than links, but these can be divided among
      incoming and outgoing links."
Maybe it could be helpful to add an example what is meant by "delays
due to routers". I assume that this could be internal processing of
messages, handing over packets from one layer to the next etc.
  - bandwidth section: "high", "medium" and low"  ; missing " before low
   The end of that section is a little hard to read (with the question
in the parentheses "(and at times maybe better,...", and missing full
stop after the sentence).
  - Section 5.5: there seems to be some redundancy between the first
paragraph: "When a router reports a 1-hop neighbor in a HELLO message
it may do  so for the first time with link status HEARD.  The
receiving router
   will then immediately consider the link to be symmetric and thus will
   use it."
 and the beginning of the third paragraph:
  "Thus a router must be able to immediately decide on an incoming link
   metric once it has heard a 1-hop neighbor on an OLSRv2 interface for
   the first time.  This is because, on receiving a HELLO message from
   this router, that 1-hop neighbor will (unless link quality indicates
   otherwise) immediately consider the link to be symmetric and use it."

Also the latter paragraph, it is not quite clear to me that it will
only add the neighbor as SYMMETRIC, if it finds one of its addresses
advertised in the HELLO (with status other than LOST). Also, it is
unclear what "and *use* it" means. Use it for what?

- In that same section: "It will probably be best to...". Is that an
implementation advice?

- section 5.6: "this produced a 2"; produced or produces?
- same section: "using normal network octet ordering (high first)". I
think there was a better description in NHDP or OLSRv2 than "high
first" ("most significant bits first" or something like like).
- I will do a more thorough review of the rest during WGLC, but in
general I like the proposed text, and believe it is useful for the
community.

Best
Ulrich

On Wed, Sep 5, 2012 at 9:31 AM, Stan Ratliff (sratliff)
<[email-masked]> wrote:
> As you know,  http://tools.ietf.org/html/draft-dearlove-olsrv2-metrics-06
> was presented at the IETF'84 [MANET] meeting, and has been adopted by the WG
> as http://tools.ietf.org/html/draft-ietf-manet-olsrv2-metrics-rationale-00.
> The slides of the presentation from IETF'84 are, starting from page 9, here:
> http://www.ietf.org/proceedings/84/slides/slides-84-manet-2.pdf
>
> As a reminder, this document is derived from the document (already discussed
> by the WG since 2007, as draft-dearlove-olsrv2-metrics) which originally
> described how to integrate metrics into OLSRv2, and for which consensus was
> established resulting in the metrics design of OLSRv2.
>
> While OLSRv2 describes *how* metrics were integrated,
> draft-ietf-manet-olsrv2-metrics-rationale presents the *why* - the design
> rationale, and is intended as publication as an Informational RFC.
>
> [email-masked]
> [email-masked]

---

From: Thomas Heide Clausen <[email-masked]>
Date: Wed, 5 Sep 2012 14:06:22 -0400

Dear Ulrich,

Thank you for your prompt review.

We will consider your feedback, most of which seems easy enough to address, in a coming revision. This email just to acknowledge receipt of your comments.

Thomas

---

From: Abdussalam Baryun <[email-masked]>
Date: Thu, 6 Sep 2012 20:19:30 +0100

Hi Thomas,

I commented before on the work metric-06 [*], with no reply on the list,
even in the meeting 84 there was no comment on what was in the list (which
I recommend to be done in future) related to such document.

My comment on the new WG draft (rationale-00) is that the draft is
excellent, and I support to WGLC, I will try to find time to overview and
comment (minor suggestion),

[*] http://www.ietf.org/mail-archive/web/manet/current/msg13204.html
 AB
===

On Wed, Sep 5, 2012 at 4:04 PM, Thomas Heide Clausen <[email-masked]
> wrote:

>    Dear all,
>
> As you know,  http://tools.ietf.org/html/draft-dearlove-olsrv2-metrics-06 was
> presented at the IETF'84 [MANET] meeting, and has been adopted by the WG as
> http://tools.ietf.org/html/draft-ietf-manet-olsrv2-metrics-rationale-00.
> The slides of the presentation from IETF'84 are, starting from page 9,
> here: http://www.ietf.org/proceedings/84/slides/slides-84-manet-2.pdf****
>
>
> As a reminder, this document is derived from the document (already
> discussed by the WG since 2007, as draft-dearlove-olsrv2-metrics) which
> originally described how to integrate metrics into OLSRv2, and for which
> consensus was established resulting in the metrics design of OLSRv2.****
>
>
> ****
> ** **
> The authors would like to see a WGLC of this document some time between
> now and the next IETF. ****
>
>
> ****
>
> We'd therefore like to ask the WG to review and give feedback so that we
> may spin a new version soon.****
>
>
>
> ****
>
> Respectfully,
>
>
> ****
>

---

From: Abdussalam Baryun <[email-masked]>
Date: Thu, 6 Sep 2012 20:41:38 +0100

Hi Stan,

I agree with you that we need to comment on this document for *progress*,
but I also recommend that any comment related to be replied to by authors
in both the list and abstracted at the next meeting 85. Furthermore, I
recommend that authors should reply to comments/discussions related to
their document not later than 90 days.

There were many comments/suggestions on the list but were not even
mentioned in the meeting which I felt no progress.

AB

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Fri, 7 Sep 2012 08:55:40 +0000

Those comments misunderstood the nature of the document. They suggested that it should introduce rules for this and that. This is an informative draft that describes rationale, not a protocol specification.

--
Christopher Dearlove
Senior Principal Engineer, Communications Group
Communications, Networks and Image Analysis Capability
BAE Systems Advanced Technology Centre
West Hanningfield Road, Great Baddow, Chelmsford, CM2 8HN, UK
Tel: +44 1245 242194 |  Fax: +44 1245 242124
[email-masked]<mailto:[email-masked]> | http://www.baesystems.com

BAE Systems (Operations) Limited
Registered Office: Warwick House, PO Box 87, Farnborough Aerospace Centre, Farnborough, Hants, GU14 6YU, UK
Registered in England & Wales No: 1996687

From: [email-masked] [mailto:[email-masked]] On Behalf Of Abdussalam Baryun
Sent: 06 September 2012 20:20
To: Thomas Heide Clausen
Cc: manet
Subject: Re: [manet] Progressing on draft-ietf-manet-olsrv2-metrics-rationale

*** WARNING ***
This message originates from outside our organisation, either from an external partner or the internet.
Keep this in mind if you answer this message.
Please see this process<http://intranet.ent.baesystems.com/howwework/security/spotlights/Documents/Dealing%20With%20Suspicious%20Emails.pdf> on how to deal with suspicious emails.
Hi Thomas,

I commented before on the work metric-06 [*], with no reply on the list, even in the meeting 84 there was no comment on what was in the list (which I recommend to be done in future) related to such document.

My comment on the new WG draft (rationale-00) is that the draft is excellent, and I support to WGLC, I will try to find time to overview and comment (minor suggestion),

On Wed, Sep 5, 2012 at 4:04 PM, Thomas Heide Clausen <[email-masked]<mailto:[email-masked]>> wrote:
Dear all,

Respectfully,

********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************

---

From: Abdussalam Baryun <[email-masked]>
Date: Sun, 9 Sep 2012 23:14:52 +0200

I don't think it was misunderstood and I think it was related to the
subject and was in title for getting a reply from authors at least for
progress in two direction not only one.

Progress for drafts needs equal discussion by the WG and authors, I
recommend all authors of any draft (individual or wg) to reply to
related comments/suggestions.

I will reply in details to the below message in another place,
thanking you for your reply.

AB

On 9/7/12, Dearlove, Christopher (UK) <[email-masked]> wrote:
> Those comments misunderstood the nature of the document. They suggested that
> it should introduce rules for this and that. This is an informative draft
> that describes rationale, not a protocol specification.
>
> --
> Christopher Dearlove
> Subject: Re: [manet] Progressing on
> draft-ietf-manet-olsrv2-metrics-rationale
>
>
> *** WARNING ***
> Please see this
> process<http://intranet.ent.baesystems.com/howwework/security/spotlights/Documents/Dealing%20With%20Suspicious%20Emails.pdf>
> on how to deal with suspicious emails.
> Hi Thomas,
>
> even in the meeting 84 there was no comment on what was in the list (which I
> recommend to be done in future) related to such document.
>
> On Wed, Sep 5, 2012 at 4:04 PM, Thomas Heide Clausen
> <[email-masked]<mailto:[email-masked]>> wrote:
> Dear all,
>