Subject: [manet] Fwd: New Version Notification for draft-clausen-lln-loadng-08.txt

From: Jiazi Yi <[email-masked]>
Date: Fri, 11 Jan 2013 18:52:50 +0100

Dear all, 

We have released the -08 revision of LOADng. The main update is that a new section named "Implementation Status" has been added. 

This is based on the suggestions from draft-sheffer-running-code-01, Improving "Rough Consensus" with Running Code ( http://tools.ietf.org/html/draft-sheffer-running-code-01 ). 
According to draft-sheffer-running-code-01:

"there are many examples of Internet-Drafts  containing protocol specification that have gone through to  publication as Proposed Standard RFCs without implementation. Some of them may never get implemented."

and 

"this (Implementation Status) will allow reviewers and working groups to assign due consideration to documents that have the benefit of running code and potentially reward the documented protocols by treating the documents with implementations preferentially"

In the new section, we described four implementations of LOADng, and we will try to release more details in the future. 

Comments are welcome. 

best

Jiazi

Begin forwarded message:

> From: [email-masked]
> Subject: New Version Notification for draft-clausen-lln-loadng-08.txt
> Date: January 11, 2013 6:48:08 PM GMT+01:00
> To: [email-masked]
> Cc: [email-masked], [email-masked], [email-masked], [email-masked], [email-masked], [email-masked], [email-masked], [email-masked], [email-masked], [email-masked]
> 
> 
> A new version of I-D, draft-clausen-lln-loadng-08.txt
> has been successfully submitted by Jiazi Yi and posted to the
> IETF repository.
> 
> Filename:	 draft-clausen-lln-loadng
> Revision:	 08
> Title:		 The Lightweight On-demand Ad hoc Distance-vector Routing Protocol - Next Generation (LOADng)
> Creation date:	 2013-01-11
> WG ID:		 Individual Submission
> Number of pages: 69
> URL:             http://www.ietf.org/internet-drafts/draft-clausen-lln-loadng-08.txt
> Status:          http://datatracker.ietf.org/doc/draft-clausen-lln-loadng
> Htmlized:        http://tools.ietf.org/html/draft-clausen-lln-loadng-08
> Diff:            http://www.ietf.org/rfcdiff?url2=draft-clausen-lln-loadng-08
> 
> Abstract:
>   This document describes the Lightweight Ad hoc On-Demand - Next
>   Generation (LOADng) distance vector routing protocol, a reactive
>   routing protocol intended for use in Mobile Ad hoc NETworks (MANETs).
> 
> 
> 
> 
> The IETF Secretariat
>

---

From: Abdussalam Baryun <[email-masked]>
Date: Fri, 11 Jan 2013 19:33:11 +0100

Hi Jiazi,

Thanks, it is good to add this section, I have no objection as long it
does not confuses doc aim, I prefer to separate implementation from
standard, but maybe there is always other reasons I may not know.
However, I like to learn about this thanks,

AB

On 1/11/13, Jiazi Yi <[email-masked]> wrote:
> Dear all,
>
> We have released the -08 revision of LOADng. The main update is that a new
> section named "Implementation Status" has been added.
>
> This is based on the suggestions from draft-sheffer-running-code-01,
> Improving "Rough Consensus" with Running Code (
> http://tools.ietf.org/html/draft-sheffer-running-code-01 ).
> "there are many examples of Internet-Drafts  containing protocol
> specification that have gone through to  publication as Proposed Standard
> RFCs without implementation. Some of them may never get implemented."
>
> and
>
> "this (Implementation Status) will allow reviewers and working groups to
> assign due consideration to documents that have the benefit of running code
> and potentially reward the documented protocols by treating the documents
> with implementations preferentially"
>
> In the new section, we described four implementations of LOADng, and we will
> try to release more details in the future.
>
> Comments are welcome.
>
> best
>
> Jiazi
>
>
>
> Begin forwarded message:
>
>> Cc: [email-masked], [email-masked], [email-masked],
>> [email-masked], [email-masked], [email-masked],
>> [email-masked], [email-masked],
>> [email-masked], [email-masked]
>>
>>
>> URL:
>> http://www.ietf.org/internet-drafts/draft-clausen-lln-loadng-08.txt
>> Diff:
>> http://www.ietf.org/rfcdiff?url2=draft-clausen-lln-loadng-08
>>
>> Abstract:
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet
>

---

From: Abdussalam Baryun <[email-masked]>
Date: Fri, 11 Jan 2013 19:42:11 +0100

Hi Jiazi,

ok, I got that wrong, you mean *informational section* about
implementations in labs, that will be excellent. I actually asked
questions many times about the LOADng implementation and no answer
from the authors, and now this section have answered, after a long
time of reminders. However, seems that the authors realized its
importance after all,

AB

On 1/11/13, Abdussalam Baryun <[email-masked]> wrote:
>>> Title:		 The Lightweight On-demand Ad hoc Distance-vector Routing
>>> Protocol
>>> - Next Generation (LOADng)
>>> Status:
>>> http://datatracker.ietf.org/doc/draft-clausen-lln-loadng