Subject: [manet] Address Order in RFC5444 messages

From: Abdussalam Baryun <[email-masked]>
Date: Wed, 23 Jan 2013 00:15:31 +0100

Hi Ulrich,

I have some questions in line;

On 1/22/13, Ulrich Herberg <[email-masked]> wrote:
> I was not saying that positional information within address blocks would
> not be possible, just that I think it is a bad idea. Also, it is possible
> to have multiple address blocks, but I don't think that a protocol should
> mandate how to use address blocks (e.g. how many address blocks, in which
> order, which addresses in which address block etc); this is the
> responsibility of the RFC5444 generator (for the reasons Henning and others
> mentioned).

- In the rfc5444; Who specifies how to use an address or block? is it
protocol or generator?
- Who is responsible for the address order if needed?
- Why rfc5444 was designed to make non-position and ignores the
position format? do you think order format is bad idea?

AB

---

From: Abdussalam Baryun <[email-masked]>
Date: Wed, 23 Jan 2013 00:18:02 +0100

>> not be possible, just that I think it is a bad idea. Also, it is possible

Why is the information should be within the Addblock, I want the info
non-position and the address positioned, I think this is better idea,

AB

---

From: Ulrich Herberg <[email-masked]>
Date: Tue, 22 Jan 2013 21:37:51 -0800

Hi AB,

> - In the rfc5444; Who specifies how to use an address or block? is it

Essentially, the protocol should just say "here is an address, add that to the message. oh, and associate it what that TLV." The generator then does the rest. As I mentioned before, this should be written down in a BCP (best current practice).

> - Who is responsible for the address order if needed?

I think it should be the RFC5444 generator. As Henning mentioned, intelligent compression algorithms like the one he implemented can than be applied from the RFC5444 generator.

> position format? do you think order format is bad idea?

I think this would be a longer (but important) answer. Some of it has already been mentioned in emails from Chris, Henning and I before, but I want to provide some more detailed text soon that explains the rationale.

Best regards
Ulrich

> AB
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet

---

From: Abdussalam Baryun <[email-masked]>
Date: Wed, 23 Jan 2013 09:09:22 +0100

Thanks Ulrich,

will wait your text on that last question,

AB

On 1/23/13, Ulrich Herberg <[email-masked]> wrote:
> Essentially, the protocol should just say "here is an address, add that to
> the message. oh, and associate it what that TLV." The generator then does
> the rest. As I mentioned before, this should be written down in a BCP (best
> current practice).
>
>
> I think it should be the RFC5444 generator. As Henning mentioned,
> intelligent compression algorithms like the one he implemented can than be
> applied from the RFC5444 generator.
>
>
> I think this would be a longer (but important) answer. Some of it has
> already been mentioned in emails from Chris, Henning and I before, but I
> want to provide some more detailed text soon that explains the rationale.
>
> Best regards
> Ulrich
>
>
>> AB