Subject: [manet] Defining a transparent compression/decompression scheme for RFC5444

From: Abdussalam Baryun <[email-masked]>
Date: Thu, 17 Jan 2013 09:05:01 +0100

Hi Henning,

I agree that defining a scheme will be helpful for the use of RFC5444,
but I think it should be an informational draft,

Also maybe we can look through compression/decompression schemes for
RFC5444, not only one scheme,

AB

Sub: Re: [manet] Notifications from the IETF tools Issue Tracker
On 1/17/13, Henning Rogge <[email-masked]> wrote:
> On 01/17/2013 12:07 AM, Abdussalam Baryun wrote:
>> Hi Henning,
>>
>> I am not sure I understand the example you made, could you give a
>> suggestion of better design of RREQ and RREP for AODVv2 so we can
>> reasonably go through the protocol functionality.
>>
>> Giving general exmples will not produce protocols for our WG, even the
>> RFC5444 is flexibile but let us go through the reactive protocol
>> messaging and its reflection on the function, not just giving
>> interesting things outside the function, as compressing,
>
> I was talking about a potential new Draft for this working group which
> defines a transparent compression/decompression scheme for RFC5444
> messages.
>
> I think this is "in scope" of this WG.
>
> Henning Rogge
>
> --
> Diplom-Informatiker Henning Rogge , Fraunhofer-Institut für
> Kommunikation, Informationsverarbeitung und Ergonomie FKIE
> Kommunikationssysteme (KOM)
> Fraunhofer Straße 20, 53343 Wachtberg, Germany
> Telefon +49 228 9435-961,   Fax +49 228 9435 685
> mailto:[email-masked] http://www.fkie.fraunhofer.de
>
>

---

From: Abdussalam Baryun <[email-masked]>
Date: Thu, 17 Jan 2013 09:10:15 +0100

Any compression/decompression scheme for RFC5444 SHOULD not affect the
generality of the RFC5444 standard, otherwise it will not be general.
Another way to avoid confusion we may update the RFC5444 with a
section explaining thoes schemes as optional schemes that make
advantages for protocols,

AB