Subject: Re: [manet] IDs presemted in Berlin

From: "Stan Ratliff (sratliff)" <[email-masked]>
Date: Tue, 3 Sep 2013 15:34:08 +0000

Abdussalam, 

On Aug 31, 2013, at 4:55 AM, Abdussalam Baryun <[email-masked]> wrote:

> On 8/16/13, Teco Boot <[email-masked]> wrote:
>> Did I say I'm against? I just want to know the issues / problems. At least
>> they should be documented.
> 
>> questions before the above>
>> Does draft-dearlove-manet-nhdp-olsrv2-tlv-extension introduce problems in a network with and without routers that implement this?
> If so, I think we need some discussion first.
> 
>> May I read that there are problems?
> If so, we cannot bring out a std track RFC followed up with something
> that can not interoperate with it. Or we mark the to_be RFC as
> obsolete. That's how it works.
> +++++++++++++++++++++++++++++++++++++
> 
> I agree, that problems/questions that made MANET WG to update such
> RFC, SHOULD be documented/listed or discussed into IETF, we SHOULD not
> hide any information related to OLSRv2 problems.
> 
> I still not foud answers from the new draft authors of the document
> requested to adopt, I agree with Teco's questions and approach to
> update MANET documents.
> 
> AB

I'm confused by your email. The question before the WG is whether to accept these documents as working group docs, and to then work on getting consensus. Are you expressing a desire to do that (e.g. take the work on as a WG document), or are you saying these IDs are out-of-scope, or is there some other issue that, in your opinion, precludes the WG from taking this work on?

As to your statement "I still not foud [sic] answers from the new draft authors…", I personally believe the emails from Thomas Clausen and Henning Rogge of Aug 30 address the interoperability issue that Teco raised quite well.  

Regards,
Stan

---

From: Abdussalam Baryun <[email-masked]>
Date: Thu, 5 Sep 2013 00:15:48 +0200

Hi Stan,

I mean IMHO, we can only update after answering all questions, I have
no objections, but still we need to answer WG questions I think.
Questions are key discussions that give chance to community to decide
better.

 From Thomas and Henning, there is no problem with the
interoperability, but still the authors did not answer fully to Teco
questions, as saying: there is no problems and that thoes I-Ds just
giving additional features. The questions were clear, why not document
the problems or what are the problems that these I-Ds are solving.

AB

On 9/3/13, Stan Ratliff (sratliff) <[email-masked]> wrote:
>>> Does draft-dearlove-manet-nhdp-olsrv2-tlv-extension introduce problems in
>>> a network with and without routers that implement this?
> I'm confused by your email. The question before the WG is whether to accept
> these documents as working group docs, and to then work on getting
> consensus. Are you expressing a desire to do that (e.g. take the work on as
> a WG document), or are you saying these IDs are out-of-scope, or is there
> some other issue that, in your opinion, precludes the WG from taking this
> work on?
>
> As to your statement "I still not foud [sic] answers from the new draft
> authors…", I personally believe the emails from Thomas Clausen and Henning
> Rogge of Aug 30 address the interoperability issue that Teco raised quite
> well.
>
> Regards,
> Stan
>
>

---

From: Christopher Dearlove <[email-masked]>
Date: Wed, 4 Sep 2013 23:25:00 +0100

If you want to know what problems these I-D are solving then read them. Then read the MT-OLSRv2 draft for an example of their use.

---

From: "Stan Ratliff (sratliff)" <[email-masked]>
Date: Thu, 5 Sep 2013 14:00:24 +0000

Abdussalam, 

> the problems or what are the problems that these I-Ds are solving.

I disagree. In fact, I don't know how I could be *more* in disagreement. Perhaps there is something I'm not understanding, however. As I mentioned in the earlier email, the question before the WG is whether these 3 documents *should be working group documents*. In other words, does the WG think this work is worthwhile, in-scope, etc etc. No one - including yourself - has raised *any* objections in that vein. Instead, there have been (IMO) relatively low-level issues about interoperability, which HAVE been answered. I know of NO outstanding "questions" or issues that preclude adoption of al three of the drafts.

At this point, it appears to me that rough consensus has been reached.

Stan

> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet

---

From: "Stan Ratliff (sratliff)" <[email-masked]>
Date: Thu, 5 Sep 2013 14:02:47 +0000

Chris, 

My reading of the WG, based on the mailing list, is that rough consensus has been reached to accept all three drafts as WG documents.

Regards,
Stan

On Aug 16, 2013, at 8:59 AM, "Dearlove, Christopher (UK)" <[email-masked]> wrote:

> I don't believe that the chairs have raised the WG adoption of the IDs I presented at Berlin.
> 
> Two of these, draft-dearlove-manet-olsrv2-rmpr-optimization and draft-dearlove-manet-nhdp-olsrv2-tlv-extension are intended for Standards Track, and as minor updates to NHDP and OLSRv2, which we would like to progress as fast as possible.
> 
> The third, draft-dearlove-manet-olsrv2-multitopology, we'd obvious have no problem with being adopted as a WG document, but it needs at least one more revision, which we intend to do as an author draft, so there isn't the same time pressure there. However of course we would like discussion any time from now.
> 
> -- 
> Christopher Dearlove
> Senior Principal Engineer, Communications Group
> Communications, Networks and Image Analysis Capability
> BAE Systems Advanced Technology Centre
> West Hanningfield Road, Great Baddow, Chelmsford, CM2 8HN, UK
> Tel: +44 1245 242194 |  Fax: +44 1245 242124
> [email-masked] | http://www.baesystems.com
> 
> BAE Systems (Operations) Limited
> Registered Office: Warwick House, PO Box 87, Farnborough Aerospace Centre, Farnborough, Hants, GU14 6YU, UK
> Registered in England & Wales No: 1996687
> 
> 
> ********************************************************************
> This email and any attachments are confidential to the intended
> recipient and may also be privileged. If you are not the intended
> recipient please delete it from your system and notify the sender.
> You should not copy it or use it for any purpose nor disclose or
> distribute its contents to any other person.
> ********************************************************************
>

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Thu, 5 Sep 2013 14:46:28 +0000

Obviously no disagreement here. I'll discuss with Thomas about re-issuing those two as draft-ietf-manet-whatever. (I'm away next week, and have several things to do before then.)

-----Original Message-----
From: Stan Ratliff (sratliff) [mailto:[email-masked]] 
Sent: 05 September 2013 15:03
To: Dearlove, Christopher (UK)
Cc: [email-masked]; Joe Macker ([email-masked]); Thomas Heide Clausen ([email-masked])
Subject: Re: IDs presemted in Berlin

----------------------! WARNING ! ----------------------
This message originates from outside our organisation,
either from an external partner or from the internet.
Keep this in mind if you answer this message.
Follow the 'Report Suspicious Emails' link on IT matters
for instructions on reporting suspicious email messages.
--------------------------------------------------------

Chris, 

Regards,
Stan