Subject: [manet] review of draft-dearlove-manet-olsrv2-rmpr-optimization-00

From: Jiazi Yi <[email-masked]>
Date: Mon, 11 Nov 2013 12:12:14 +0100

Hi,

I had a review of draft-dearlove-manet-olsrv2-rmpr-optimization-00. Here 
are some comments (or some of them, I would rather call questions :)

1. In Section 4: Routing MPR Selection
...
then x_1 to x_n may be removed from the set of routing MPRs, if selected.
...

The first note: I think we should use RFC2119 term "MAY" here?
In fact, this is the part that confuses me most. As the only "action" 
described in the draft, the use of "may" without further explanation 
when this action should be taken or not is too vague. In the end of the 
section, another "RECOMMENDED" is used. Therefore, if I put them 
together, it is something like "It is RECOMMENDED that one MAY do foo, 
bar..."

2.  If x_1, x_2 ... x_n are the largest set with corresponding y_1, y_2, 
... y_n. Should we check all the subsets {x_i} of x_1, ... x_n with the 
criteria

d1(x_0) + d2(x_0,y_1) + ... + d2(x_m-1,y_m) < d1(x_m) for m belong to 
subset of x_1, ... x_n?

If so, we probably will have a lot combinations to check in a dense 
network. If not, the criteria seems to be too harsh to be actually 
"triggered"?

3. Should this be applied to all types of metrics? A potential affects 
of this draft is that, we can probably have more "hops" around the 
neighborhood of the original router, i.e., there is higher possibility 
of interference. In some of metrics, the interference is not much 
considered (because it is hard to measure). Will it be a problem if we 
introduce more transmission in some scenarios?

4. We have a "Willingness" value to "represents the router's willingness 
to be selected as an MPR." Should this need to be considered also? What 
about if x_0 has low willingness, while the others x_1, ... x_n have 
higher willingness?

5. In some scenarios, we probably want to have certain redundancy in MPR 
in some lossy scenarios?

sincerely

Jiazi

---

From: Jiazi Yi <[email-masked]>
Date: Mon, 11 Nov 2013 12:15:10 +0100

And one nit:

In the reference, we have

    [RFC6966-to-be]
               Clausen, T., Dearlove, C., and P. Jacquet, "Rationale for
               the Use of Link Metrics in the Optimized Link State
               Routing Protocol Version 2 (OLSRv2)", RFC 6966, TBD 2013.

I suppose the name of the draft is

   Link Metrics for the Mobile Ad Hoc Network (MANET) Routing Protocol 
OLSRv2 - Rationale

http://tools.ietf.org/html/draft-ietf-manet-olsrv2-metrics-rationale-04 ?

Jiazi

> Jiazi Yi <mailto:[email-masked]>
> 11 Nov 2013 12:12
> Hi,
>
> I had a review of draft-dearlove-manet-olsrv2-rmpr-optimization-00. 
> Here are some comments (or some of them, I would rather call questions :)
>
> when this action should be taken or not is too vague. In the end of 
> the section, another "RECOMMENDED" is used. Therefore, if I put them 
> 2.  If x_1, x_2 ... x_n are the largest set with corresponding y_1, 
> y_2, ... y_n. Should we check all the subsets {x_i} of x_1, ... x_n 
> with the criteria
>
> 4. We have a "Willingness" value to "represents the router's 
> willingness to be selected as an MPR." Should this need to be 
> considered also? What about if x_0 has low willingness, while the 
> others x_1, ... x_n have higher willingness?
>
> 5. In some scenarios, we probably want to have certain redundancy in 
> MPR in some lossy scenarios?
>
> sincerely
>
> Jiazi
>
>
>

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Mon, 11 Nov 2013 12:19:14 +0000

This is entirely optional, so MAY and RECOMMENDED are the right strength.

The removed MPRs do not add redundancy, as suggested, as they are useless. The whole point is to remove MPRs that will never be used. (They will never be used because there is always a shorter path than any using them directly.)

For discussion details, see the metrics rationale draft.

As to complexity, it's a tradeoff. If you don't like the complexity, don't do it. It won't make any difference to performance, it will just save a bit of message size and work at the other end of the link.

As noted, some of this is in the rationale document, and there's no point repeating that unnecessarily. But we should take a look at what may or may not be clear. Thanks for your comments on that.

Incidentally, top of my list is checking the specific definition of when MPRs can be dropped, for correctness and completeness (based on the rationale word explanation of when MPRs can be dropped). Anyone who does that and confirms they've done it (especially with something more than just "done it") would be definitely appreciated.

-- 
Christopher Dearlove
Senior Principal Engineer, Communications Group
Communications, Networks and Image Analysis Capability
BAE Systems Advanced Technology Centre
West Hanningfield Road, Great Baddow, Chelmsford, CM2 8HN, UK
Tel: +44 1245 242194 |  Fax: +44 1245 242124
[email-masked] | http://www.baesystems.com

BAE Systems (Operations) Limited
Registered Office: Warwick House, PO Box 87, Farnborough Aerospace Centre, Farnborough, Hants, GU14 6YU, UK
Registered in England & Wales No: 1996687

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Jiazi Yi
Sent: 11 November 2013 11:12
To: MANET IETF
Subject: [manet] review of draft-dearlove-manet-olsrv2-rmpr-optimization-00

----------------------! WARNING ! ----------------------
This message originates from outside our organisation,
either from an external partner or from the internet.
Keep this in mind if you answer this message.
Follow the 'Report Suspicious Emails' link on IT matters
for instructions on reporting suspicious email messages.
--------------------------------------------------------

Hi,

sincerely

Jiazi

_______________________________________________
manet mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/manet

********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Mon, 11 Nov 2013 12:24:59 +0000

Good catch, thanks. what's more that's never been the title, so don't know how that got there.

[email-masked]<mailto:[email-masked]> | http://www.baesystems.com

From: [email-masked] [mailto:[email-masked]] On Behalf Of Jiazi Yi
Sent: 11 November 2013 11:15
To: MANET IETF
Subject: Re: [manet] review of draft-dearlove-manet-olsrv2-rmpr-optimization-00

*** WARNING ***
This message originates from outside our organisation, either from an external partner or the internet.
Keep this in mind if you answer this message.
For information regarding Red Flags that you can look out for in emails you receive, click here<http://intranet.ent.baesystems.com/howwework/security/spotlights/Documents/Red%20Flags.pdf>.
If you feel the email is suspicious, please follow this process<http://intranet.ent.baesystems.com/howwework/security/spotlights/Documents/Dealing%20With%20Suspicious%20Emails.pdf>.
And one nit:

   [RFC6966-to-be]

  Link Metrics for the Mobile Ad Hoc Network (MANET) Routing Protocol OLSRv2 - Rationale

Jiazi

Jiazi Yi<mailto:[email-masked]>
11 Nov 2013 12:12
Hi,

I had a review of draft-dearlove-manet-olsrv2-rmpr-optimization-00. Here are some comments (or some of them, I would rather call questions :)

The first note: I think we should use RFC2119 term "MAY" here?
In fact, this is the part that confuses me most. As the only "action" described in the draft, the use of "may" without further explanation when this action should be taken or not is too vague. In the end of the section, another "RECOMMENDED" is used. Therefore, if I put them together, it is something like "It is RECOMMENDED that one MAY do foo, bar..."

2.  If x_1, x_2 ... x_n are the largest set with corresponding y_1, y_2, ... y_n. Should we check all the subsets {x_i} of x_1, ... x_n with the criteria

d1(x_0) + d2(x_0,y_1) + ... + d2(x_m-1,y_m) < d1(x_m) for m belong to subset of x_1, ... x_n?

If so, we probably will have a lot combinations to check in a dense network. If not, the criteria seems to be too harsh to be actually "triggered"?

3. Should this be applied to all types of metrics? A potential affects of this draft is that, we can probably have more "hops" around the neighborhood of the original router, i.e., there is higher possibility of interference. In some of metrics, the interference is not much considered (because it is hard to measure). Will it be a problem if we introduce more transmission in some scenarios?

4. We have a "Willingness" value to "represents the router's willingness to be selected as an MPR." Should this need to be considered also? What about if x_0 has low willingness, while the others x_1, ... x_n have higher willingness?

5. In some scenarios, we probably want to have certain redundancy in MPR in some lossy scenarios?

sincerely

Jiazi