Subject: Re: [manet] #20 (aodvv2): Idle routes must be marked as active after re-use

From: "Charles E. Perkins" <[email-masked]>
Date: Fri, 11 Apr 2014 18:21:36 -0700

Hello folks,

Here is some proposed text to resolve this issue:

On 3/28/2014 5:50 PM, manet issue tracker wrote:
> #20: Idle routes must be marked as active after re-use
>
>   The draft states how Idle routes should be treated and how a route becomes
>   Idle and when an Idle route expires. What's confusing to me is that it
>   states that an Idle route may still be used for packet forwarding, but it
>   doesn't say that a route becomes un-Idle (i.e. Active) when it is used
>   (for forwarding)– which would make sense to me.
>

Proposal: after the text:
> When a route is no longer Active, it
>         becomes an Idle route.

The proposed text:

>         If an Idle route is used to forward a packet, it becomes
>         an Active route once again.

However, there may be a better solution which requires more extensive 
changes.
While the distinction between an active route and an idle route is 
interesting
to consider, the main difference between them is that an idle route is 
preferred
for deletion whenever space needs to be reclaimed.  The same effect can be
had by specifying that route table memory space be reclaimed by deleting
the oldest routes first.  I think this will produce some simplification 
to the
text without any real loss of clarity.

I am O.K. going either way, and only offer this suggestion for 
consideration.

-- 
Regards,
Charlie P.

---

From: Martin Heusse <[email-masked]>
Date: Wed, 30 Apr 2014 11:44:46 +0200

Does this really belong to the protocol specification? To me, if a node runs out of memory space, it's a local decision to remove a route or the other. The protocol will still operate properly. Granted, it's more efficient if everyone follows pretty much the same policy :-)

Now, removing the oldest route may not be the best idea: it's not unlikely that the first route a "node" creates is the most important! 

Maybe a statement like: "routers should discard routes in order of least recent usage" could be enough? 
(And then, you don't have to care about idle/inactive/active route status. This information is not exchanged between nodes, anyway.)

Martin

Le 12 avr. 2014 à 03:21, Charles E. Perkins <[email-masked]> a écrit :

> However, there may be a better solution which requires more extensive changes.
> While the distinction between an active route and an idle route is interesting
> to consider, the main difference between them is that an idle route is preferred
> the oldest routes first.  I think this will produce some simplification to the
> I am O.K. going either way, and only offer this suggestion for consideration.