Subject: [manet] #23 (aodvv2): Format of processing algorithms

From: "manet issue tracker" <[email-masked]>
Date: Thu, 03 Apr 2014 21:05:38 -0000

#23: Format of processing algorithms

 (Thomas Clausen) .... I like bullet-point-pseudocode over "textual
 pseudocode". E.g something like this is more readable to me:

  Upon receiving an RREQ, a router:
  1.     Record X;
  2.     Record Y;
  3.     Test z then:
    a.   If z Do FOO;
    b.   otherwise: Do BAR;
  4.     Retransmit the RREQ

-- 
-------------------------+-------------------------------------------------
 Reporter:               |      Owner:  draft-ietf-manet-
  [email-masked]  |  [email-masked]
     Type:  defect       |     Status:  new
 Priority:  minor        |  Milestone:
Component:  aodvv2       |    Version:
 Severity:  Active WG    |   Keywords:
  Document               |
-------------------------+-------------------------------------------------

Ticket URL: <http://trac.tools.ietf.org/wg/manet/trac/ticket/23>
manet <http://tools.ietf.org/manet/>

---

From: Abdussalam Baryun <[email-masked]>
Date: Fri, 4 Apr 2014 01:00:36 +0100

That method of describing conditions are not similar way followed
in RFC3561. The below uses more lines in the draft, but not sure what is
problem with the current method used.

AB

On Thursday, April 3, 2014, manet issue tracker wrote:

>   [email-masked] <javascript:;>  |  [email-masked]<javascript:;>
> _______________________________________________
> manet mailing list
> [email-masked] <javascript:;>
> https://www.ietf.org/mailman/listinfo/manet
>

---

From: Henning Rogge <[email-masked]>
Date: Fri, 4 Apr 2014 08:13:07 +0200

> problem with the current method used. 

Algorithmic descriptions as large text blocks (instead of bullet lists
with short statements) are more easy to interpret in different ways,
which opens the door for incompatible implementations.

Henning Rogge

>     [email-masked]
> [email-masked]

-- 
Diplom-Informatiker Henning Rogge , Fraunhofer-Institut für
Kommunikation, Informationsverarbeitung und Ergonomie FKIE
Kommunikationssysteme (KOM)
Fraunhofer Straße 20, 53343 Wachtberg, Germany
Telefon +49 228 9435-961,   Fax +49 228 9435 685
mailto:[email-masked] http://www.fkie.fraunhofer.de

---

From: Jiazi YI <[email-masked]>
Date: Fri, 4 Apr 2014 15:13:25 +0200

As Henning said, using large text block for algorithms is hard to read and
understand. I don't see why it's necessary to follow RFC 3561.

Using more lines is not a problem, as long as the description is clear.

Jiazi

---

From: Abdussalam Baryun <[email-masked]>
Date: Sat, 5 Apr 2014 00:39:29 +0100

I went through this discussion before on the IETF list and the answer was
no, it is more better to use a simple text, and not use simple bullet
points.

AB

On Friday, April 4, 2014, Henning Rogge wrote:

> mailto:[email-masked] <javascript:;>
> http://www.fkie.fraunhofer.de
>
>

---

From: Christopher Dearlove <[email-masked]>
Date: Sat, 5 Apr 2014 02:09:32 +0100

Really? Reference please.

-- 
Christopher Dearlove
[email-masked] (iPhone)
[email-masked] (home)

> On 5 Apr 2014, at 00:39, Abdussalam Baryun <[email-masked]> wrote:
> 
> I went through this discussion before on the IETF list and the answer was no, it is more better to use a simple text, and not use simple bullet points.
> 
> AB
>

---

From: Abdussalam Baryun <[email-masked]>
Date: Mon, 7 Apr 2014 20:27:00 +0100

http://www.ietf.org/mail-archive/web/ietf/current/msg76625.html

That reference may not get the same understanding I got. But I understood
from that thread discussion and others the reason why specification drafts
go better for sentence text than go for sequence points.

AB

---

From: Christopher Dearlove <[email-masked]>
Date: Mon, 7 Apr 2014 20:39:09 +0100

That posting neither addresses the issue being discussed nor draws any definite conclusoins about the issue it does discuss.

On 7 Apr 2014, at 20:27, Abdussalam Baryun wrote:

> That reference may not get the same understanding I got. But I understood from that thread discussion and others the reason why specification drafts go better for sentence text than go for sequence points. 
> 
> AB
>

---

From: Thomas Heide Clausen <[email-masked]>
Date: Tue, 8 Apr 2014 00:05:26 +0200

Agree with Chris. I want to add just that a posting by an individual does not policy make.

-- 
Thomas Heide Clausen
http://www.thomasclausen.org

"Today's scientists have substituted mathematics for 
  experiments, and they wander off through equation 
  after equation, and eventually  build a structure 
  which has no relation to reality."
 - Nikola Tesla, 
    Modern Mechanics and Inventions, July, 1934

> On 7 avr. 2014, at 21:39, Christopher Dearlove <[email-masked]> wrote:
>

---

From: "Charles E. Perkins" <[email-masked]>
Date: Fri, 11 Apr 2014 16:23:00 -0700

Hello Henning and all,

The point of the specification is to enable interoperable implementations,.
Some people prefer a short stepwise description of the algorithm, and some
people prefer to read (unambiguous) text describing each step in more
detail.  I don't see why the specification cannot satisfy both groups.  
I will
develop the formulation with short statements as requested.

Regards,
Charlie P.

On 4/3/2014 11:13 PM, Henning Rogge wrote:
>>        [email-masked]   [email-masked]
>>      Ticket URL:<http://trac.tools.ietf.org/wg/manet/trac/ticket/23>
>>      manet<http://tools.ietf.org/manet/>
>>

-- 
Regards,
Charlie P.