Subject: [manet] Do you think RFC3561 defining node wrongly (was Re: #30 (aodvv2): Use of word "node"

From: Abdussalam Baryun <[email-masked]>
Date: Sat, 5 Apr 2014 10:31:24 +0100

Hi Joe,

I don't agree that RFC3561 is defining node wrongly and it seems the WG is
also because there was no update request received from any participant.
Thoughts without reason are mostly wrong but IETF WG documents are not
because they get updated.

So as you are author of RFC2501 do you agree that the RFC3561 (AODVv1) is
defining node wrongly. I see no one comment on the input of Thomas. ( If
all WG participants now thinks that their WG item RFC3561 is having
something defined wrong without updating, then I think all the WG RFCs may
be wrong issues as well).

I think RFC2501 and RFC3561 had same concept of the node definition and now
AODVv2 draft. It is very clear when you read them together while they were
produced both by same WG.

On Friday, April 4, 2014, Joe Macker wrote:

> RFC 2501 was not mandating terminology nor did it claim to.
>
> It was an informational document to raise issues and design considerations
> relating to a particular problem space.

Now we have a problem raised on the WG list of claim a wrong node
definition in RFC3561 where a participant saying  it clearly as
informational message.

> And certainly there are always more issues to consider than it raised at
> the time.

Yes I agree, but it should have explained clearly the node structure or
configuration.

>
> -joe
>
> "To everything there is a season. A time to weep, and a time to laugh; a
> time to model using a graph"

There is also time to fix and update old things and models. We don't always
need graphs.

>
> On Apr 3, 2014, at 7:42 PM, Thomas Heide Clausen <[email-masked]>
> wrote:
>
> > 3561 did it wrong.
> >
> > What is the definition of "node"?

Please define it, and suggest the update so we can go forward in
our discussion/work.

> >
> > Sent from my iPad
> >
> > On 4 avr. 2014, at 01:20, Abdussalam Baryun <[email-masked]>
> wrote:
> >
> >> I think draft uses node and router the same way it is used in the
> RFC3561 which is good.  The AODVv2 is protocol between nodes.
> >>

I agree with the definitions of the AODVv2 draft and the  RFC3561.

AB

---

From: Thomas Clausen <[email-masked]>
Date: Sat, 5 Apr 2014 11:36:21 +0200

On 05 Apr 2014, at 11:31, Abdussalam Baryun <[email-masked]> wrote:

> Hi Joe,
> 
> I don't agree that RFC3561 is defining node wrongly and it seems the WG is also because there was no update request received from any participant. Thoughts without reason are mostly wrong but IETF WG documents are not because they get updated. 
> 
> So as you are author of RFC2501 do you agree that the RFC3561 (AODVv1) is defining node wrongly. I see no one comment on the input of Thomas. ( If all WG participants now thinks that their WG item RFC3561 is having something defined wrong without updating, then I think all the WG RFCs may be wrong issues as well). 
> 
> I think RFC2501 and RFC3561 had same concept of the node definition and now AODVv2 draft. It is very clear when you read them together while they were produced both by same WG. 
> 
> 
> It was an informational document to raise issues and design considerations relating to a particular problem space.
> 
> Now we have a problem raised on the WG list of claim a wrong node definition in RFC3561 where a participant saying  it clearly as informational message. 
> 
> 
> And certainly there are always more issues to consider than it raised at the time.
> 
> Yes I agree, but it should have explained clearly the node structure or configuration. 
>  
> 
> -joe
> 
> "To everything there is a season. A time to weep, and a time to laugh; a time to model using a graph"
> 
> There is also time to fix and update old things and models. We don't always need graphs. 
>  
> 
> On Apr 3, 2014, at 7:42 PM, Thomas Heide Clausen <[email-masked]> wrote:
> 
> > 3561 did it wrong.
> >
> Please define it, and suggest the update so we can go forward in our discussion/work.  

No, you're getting it wrong.

There is no good reason for not using "host" and "router" in the appropriate places, for those terms are well defined and actually carry distinct meanings, as I explained previously.

The resolution to this issue is to use "host" and "router", consistently.

> >
> > Sent from my iPad
> >
> > On 4 avr. 2014, at 01:20, Abdussalam Baryun <[email-masked]> wrote:
> >
> >> I think draft uses node and router the same way it is used in the RFC3561 which is good.  The AODVv2 is protocol between nodes.
> >>
> 

You still haven't pointed to an useful  definition, though.

Thomas