Subject: [manet] #22 (aodvv2): Multiple terms for same concept

From: "manet issue tracker" <[email-masked]>
Date: Thu, 03 Apr 2014 21:00:52 -0000

#22: Multiple terms for same concept

 (Thomas Clausen) While we are on that, I notice that "active source" is
 used; I am not sure what that is vs a "source" and vs a !PktSource. A
 source is someone who generates data traffic, I would suspect ... so an
 active source is....what?  Or, is a source someone who can, but doesn't,
 generate data traffic? - if so, what is the significance of that wrt.
 routing protocol operation? And, wrt a /reactive/ routing protocol, which
 I would assume constructs routes only for active source-destination pairs?

-- 
-------------------------+-------------------------------------------------
 Reporter:               |      Owner:  draft-ietf-manet-
  [email-masked]  |  [email-masked]
     Type:  defect       |     Status:  new
 Priority:  minor        |  Milestone:
Component:  aodvv2       |    Version:
 Severity:  Active WG    |   Keywords:
  Document               |
-------------------------+-------------------------------------------------

Ticket URL: <http://trac.tools.ietf.org/wg/manet/trac/ticket/22>
manet <http://tools.ietf.org/manet/>

---

From: Abdussalam Baryun <[email-masked]>
Date: Fri, 4 Apr 2014 21:32:18 +0100

IMHO, MANET has more concepts depending on the network use and status.
Therefore it is good that this work considers many use cases.

On Thursday, April 3, 2014, manet issue tracker wrote:

>  used; I am not sure what that is vs a "source" and vs a !PktSource.

It is clear in MANET that active node means there is sleep period within
that node, so when the node is out of that period it is active.

A
>  generate data traffic?

The source is a node that generates data. The active node is a node that
generates data for some determined period of times, and does not
receive/generate within sleeping periods.

>  if so, what is the significance of that wrt.

I don't think that is correct. In MANET we say it MAY have LLN nodes so it
is good AODVv2 considers LLNs scenarios. The ROLL WG have done
a terminology RFC, I will try to continue the Manet terminology
draft. The routing in LLNs and MANETs does construct routes not only for
active source-destination pairs, but routes that have multihops with sleep
periods as well.

AB

---

From: Thomas Clausen <[email-masked]>
Date: Sat, 5 Apr 2014 14:46:10 +0200

On 04 Apr 2014, at 22:32, Abdussalam Baryun <[email-masked]> wrote:

> IMHO, MANET has more concepts depending on the network use and status. Therefore it is good that this work considers many use cases. 
> 
> It is clear in MANET that active node means there is sleep period within that node, so when the node is out of that period it is active. 

That is not clear to me. Where is that described in more details? How does it work in a reactive protocol, what if a router is "sleeping" when it receives a RREQ? Does it require global coordination of duty cycles in the network? If not, why not?

> The source is a node that generates data. The active node is a node that generates data for some determined period of times, and does not receive/generate within sleeping periods. 
>  
> I don't think that is correct.

You do not think that it is correct, that a reactive protocol constructs routes only for active source-destination pairs?

> In MANET we say it MAY have LLN nodes so it is good AODVv2 considers LLNs scenarios. The ROLL WG have done a terminology RFC, I will try to continue the Manet terminology draft. The routing in LLNs and MANETs does construct routes not only for active source-destination pairs, but routes that have multihops with sleep periods as well. 

I am at a loss, what does that mean?

> 
> AB
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet

---

From: "Charles E. Perkins" <[email-masked]>
Date: Fri, 11 Apr 2014 16:34:50 -0700

Hello folks,

PktSource means the source of the packet that triggered
the RERR.  It could be renamed to be "RERR_Dest", since the
RERR is being sent to the source of the packet that triggered
the RERR.

"active sources" are those actively sending data.  I will make
a new definition for this.

Regards,
Charlie P.

On 4/4/2014 1:32 PM, Abdussalam Baryun wrote:
> It is clear in MANET that active node means there is sleep period 
> within that node, so when the node is out of that period it is active.
>
>     A
> The source is a node that generates data. The active node is a node 
> that generates data for some determined period of times, and does not 
> I don't think that is correct. In MANET we say it MAY have LLN 
> nodes so it is good AODVv2 considers LLNs scenarios. The ROLL WG have 
> done a terminology RFC, I will try to continue the Manet terminology 
> draft. The routing in LLNs and MANETs does construct routes not only 
> for active source-destination pairs, but routes that have multihops 
> with sleep periods as well.
>
> AB

-- 
Regards,
Charlie P.