Subject: [manet] Definition of "upstream"

From: "Charles E. Perkins" <[email-masked]>
Date: Tue, 15 Apr 2014 15:10:56 -0700

Hello folks,

There was recently a message that suggested clarification was needed
on the meaning of "upstream".  Here is some proposed text for a
definition to be inserted in the Terminology section of the AODVv2 draft:

> For any routing path, source of traffic using that routing path,
> and router on that routing path, the other routers between the
> source and that router are called upstream routers.

Or, perhaps better...

> Given a particular routing path, source of traffic using that
> routing path, and router on that routing path, the other routers
> between the source and that router are called upstream routers.

Or, slightly more verbose:

> Given a particular routing path, source of traffic using that
> routing path, and router on that routing path, the other routers
> between the source and that router are called upstream routers
> in relation to that router.

I believe this conforms to standard usage in networking discussions.
Comments, please?

Regards,
Charlie P.

-- 
Regards,
Charlie P.

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Tue, 15 Apr 2014 22:48:18 +0000

> I believe this conforms to standard usage in networking discussions.

I have heard the term used in at least two different ways. One is pretty much as you defined it - traffic flows “downstream” from someplace “upstream”. The other is arguably a business context: an upstream network is the provider of a service to a downstream network. A residential user’s broadband network is “upstream” from him, a coffee shop’s WiFi might have a service upstream of it, an ISP that buys transit service from another ISP considers the transit ISP to be “upstream”, and so on. In that second context, the “upstream” network may well be referred to as an “upstream”, as opposed to an “upstream network”.

> Comments, please?
> 
> Regards,
> Charlie P.
> 
> 
> 
> 
> -- 
> Regards,
> Charlie P.
> 
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet

----------------------------------------------------
The ignorance of how to use new knowledge stockpiles exponentially. 
   - Marshall McLuhan

---

From: Thomas Heide Clausen <[email-masked]>
Date: Wed, 16 Apr 2014 01:05:06 +0200

Having carefully reviewed the document, I do not actually believe that it's a matter of defining "upstream" in one way or another (although it currently is undefined).

I find that the notion of "upstream" and "downstream" in a  routing protocol, intended for operating within a flat routing domain, is counter-intuitive in general -- and, specifically, that the use of the term in this document actually confuses the reader and the specification.

I would therefore strongly suggest than, rather than spending efforts at coming up with terminology, the efforts be spent on editing the document for clarity.

To put it in another way: I have (over the past many, many years, since Maastricht) pointed out several issues (including this issue, I think) as indicators that the document was/is extremely unclear and ambiguous. The solution here is not to "apply band-aids and address each individual issue in isolation" - I do not believe that this will result in an acceptable document -  but to look at the whole document and edit for overall clarity, including major restructuring and reengineering.

Sent from my iPad

> On 16 avr. 2014, at 00:10, "Charles E. Perkins" <[email-masked]> wrote:
> 
> 
> Hello folks,
>

---

From: Charlie Perkins <[email-masked]>
Date: Tue, 15 Apr 2014 17:08:38 -0700

Hello folks,

Fred Baker <fred at cisco.com> wrote:
> .........
> I have heard the term used in at least two different ways. One is pretty
> much as you defined it - traffic flows "downstream" from someplace
> "upstream". The other is arguably a business context: an upstream
> network is the provider of a service to a downstream network.
> A residential user’s broadband network is "upstream" from him,
> a coffee shop’s WiFi might have a service upstream of it, an ISP
> that buys transit service from another ISP considers the transit
> ISP to be "upstream", and so on. In that second context, the
> "upstream" network may well be referred to as an "upstream", as
> opposed to an "upstream network".

O.K. I will make sure that the definition is limited to upstream
routers since I don't think we need to introduce the concept of
upstream networks.

Regards,
Charlie P.

PS to Fred: I lost your original message and had to copy this from the
list archive. Darned computers.

---

From: "Ivancic, William D. (GRC-RHN0)" <[email-masked]>
Date: Wed, 16 Apr 2014 12:35:14 +0000

I have used the term upstream analogous to a river or stream.  Thus, I my
router is a edge router (last router in the network), it is upstream from
other routers.  My company router at the firewall is upstream from the ISP
and downstream from my internal company routers.  As traffic volume
increases, if flows downstream.  But, this may not apply very well for ad
hoc networks if traffic flow is truly random (which it never is).

Will

=======

On 4/15/14 6:48 PM, "Fred Baker (fred)" <[email-masked]> wrote:

>much as you defined it - traffic flows ³downstream² from someplace
>³upstream². The other is arguably a business context: an upstream network
>is the provider of a service to a downstream network. A residential
>user¹s broadband network is ³upstream² from him, a coffee shop¹s WiFi
>might have a service upstream of it, an ISP that buys transit service
>from another ISP considers the transit ISP to be ³upstream², and so on.
>In that second context, the ³upstream² network may well be referred to as
>an ³upstream², as opposed to an ³upstream network².
>
>
>> Comments, please?
>> 
>> Regards,
>> Charlie P.
>> 
>> 
>> 
>> 
>> -- 
>> Regards,
>> Charlie P.
>>

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 16 Apr 2014 16:44:28 +0100

PMFJI

If this problem has not yet been addressed a hundred times then it is only
because someone got tired!

"upstream" does not just apply to entities (routers in this case, networks in
Fred's example), it also depends on a context.

Thus "upstream router in this data flow" or "upstream router for this packet" or
"upstream router for this protocol message" or "upstream router for this
circuit/path".

Adrian