Subject: [manet] TLV naming draft

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Wed, 19 Nov 2014 13:53:09 +0000

We would, as was said in Honolulu, like to request that draft-dearlove-manet-tlv-naming be adopted as a WG draft, and for the chairs to start this process.

As also indicated, we will shortly thereafter be wanting to go to WGLC and onwards, but one step at a time.

For those who may have missed it, this draft just tidies up some details of TLV naming, it has no actual impact on any protocol. However our AD has indicated that multitopology OLSRv2 (with the IESG for experimental status) won't be able to proceed to RFC without this.

Of course comments welcome on any points arising.

--
Christopher Dearlove
Senior Principal Engineer, Information Assurance Group
Communications, Networks and Image Analysis Capability
BAE Systems Advanced Technology Centre
West Hanningfield Road, Great Baddow, Chelmsford, CM2 8HN, UK
Tel: +44 1245 242194 |  Fax: +44 1245 242124
[email-masked]<mailto:[email-masked]> | http://www.baesystems.com

BAE Systems (Operations) Limited
Registered Office: Warwick House, PO Box 87, Farnborough Aerospace Centre, Farnborough, Hants, GU14 6YU, UK
Registered in England & Wales No: 1996687

********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************

---

From: Abdussalam Baryun <[email-masked]>
Date: Thu, 20 Nov 2014 18:05:22 -0800

On 11/19/14, Dearlove, Christopher (UK) <[email-masked]> wrote:
>
> For those who may have missed it, this draft just tidies up some details of
> TLV naming, it has no actual impact on any protocol. However our AD has
> indicated that multitopology OLSRv2 (with the IESG for experimental status)
> won't be able to proceed to RFC without this.

I think that such indication of requesting a new draft and stoping one
should be clear on the list but I did not see it. However, I
understand from your message that this TLV naming draft is not
updating any of our standards, but it is updating RFC5444 so this
draft has impact on RFC5444.

AB

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Fri, 21 Nov 2014 09:46:18 +0000

The impact on 5444 is limited to adding advice to the designated experts who are responsible for TLV allocations to ensure naming of new TLVs follows this pattern. It has no impact on any actual protocol, as is noted. The authors have marked it as updating 5444 for that technical reason, but aren't wedding to that description.

[email-masked] | http://www.baesystems.com

-----Original Message-----
From: Abdussalam Baryun [mailto:[email-masked]] 
Sent: 21 November 2014 02:05
To: Dearlove, Christopher (UK)
Cc: Stan Ratliff ([email-masked]); Justin Dean ([email-masked]); [email-masked]
Subject: Re: [manet] TLV naming draft

----------------------! WARNING ! ---------------------- This message originates from outside our organisation, either from an external partner or from the internet.
Consider carefully whether you should click on any links, open any attachments or reply.
Follow the 'Report Suspicious Emails' link on IT matters for instructions on reporting suspicious email messages.
--------------------------------------------------------

On 11/19/14, Dearlove, Christopher (UK) <[email-masked]> wrote:
>
> For those who may have missed it, this draft just tidies up some 
> details of TLV naming, it has no actual impact on any protocol. 
> However our AD has indicated that multitopology OLSRv2 (with the IESG 
> for experimental status) won't be able to proceed to RFC without this.

I think that such indication of requesting a new draft and stoping one should be clear on the list but I did not see it. However, I understand from your message that this TLV naming draft is not updating any of our standards, but it is updating RFC5444 so this draft has impact on RFC5444.

AB