Subject: [manet] Fwd: New Version Notification for draft-gerla-manet-odmrp-asym-01.txt

From: Axel Colin de Verdière <[email-masked]>
Date: Sun, 16 Nov 2014 19:53:35 +0100

Dear WG,

As announced during this week's meeting, we updated the draft for ODMRP-ASYM (the extension to ODMRP which handles routing through unidirectional links).
The main changes in this draft are:
	- The spec now correctly accounts for routers with multiple interfaces and multiple addresses.
	- Since ODMRP no longer requires that Join Query messages carry a hop count field, the addition of this field is specified in ODMRP-ASYM. Having a hop-count field is necessary to be able to build Loops (as a reminder, the Loop is the main construct of this draft, which allows to find an alternative reverse path for Join Replies).
	- Moved the RFC5444 encoding part from an appendix to a section and clarified the separation between message content and encoding
	- Some clarifications and consistency fixes between the two drafts.

Best,

Axel

Début du message réexpédié :

> De: [email-masked]
> Objet: New Version Notification for draft-gerla-manet-odmrp-asym-01.txt
> Date: 16 novembre 2014 19:37:02 UTC+1
> À: "Soon Young Oh" <[email-masked]>, Soon Young Oh <[email-masked]>, "Axel Coli Verdiere" <[email-masked]>, Mario Gerla <[email-masked]>, "Professor Mario Gerla" <[email-masked]>, Axel Colin de Verdiere <[email-masked]>
> 
> 
> A new version of I-D, draft-gerla-manet-odmrp-asym-01.txt
> has been successfully submitted by Axel Colin de Verdiere and posted to the
> IETF repository.
> 
> Name:		draft-gerla-manet-odmrp-asym
> Revision:	01
> Title:		ODMRP-ASYM
> Document date:	2014-11-16
> Group:		Individual Submission
> Pages:		27
> URL:            http://www.ietf.org/internet-drafts/draft-gerla-manet-odmrp-asym-01.txt
> Status:         https://datatracker.ietf.org/doc/draft-gerla-manet-odmrp-asym/
> Htmlized:       http://tools.ietf.org/html/draft-gerla-manet-odmrp-asym-01
> Diff:           http://www.ietf.org/rfcdiff?url2=draft-gerla-manet-odmrp-asym-01
> 
> Abstract:
>   This document describes ODMRP-ASYM, an extension for the On Demand
>   Multicast Routing Protocol [ODMRP], which enables routers to use
>   unidirectional links to route multicast messages.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
>

---

From: Ulrich Herberg <[email-masked]>
Date: Sun, 16 Nov 2014 11:04:03 -0800

Thanks Axel for this new revision!

What are the intended next steps? You asked the chairs to call for WG
adoption of draft-gerla-manet-odmrp. What about
draft-gerla-manet-odmrp-asym?

Are there implementations of both drafts?

Regards
Ulrich

On Sun, Nov 16, 2014 at 10:53 AM, Axel Colin de Verdière
<[email-masked]> wrote:
> Dear WG,
>
> As announced during this week's meeting, we updated the draft for ODMRP-ASYM
> (the extension to ODMRP which handles routing through unidirectional links).
> - Since ODMRP no longer requires that Join Query messages carry a hop count
> field, the addition of this field is specified in ODMRP-ASYM. Having a
> hop-count field is necessary to be able to build Loops (as a reminder, the
> Loop is the main construct of this draft, which allows to find an
> alternative reverse path for Join Replies).
> - Moved the RFC5444 encoding part from an appendix to a section and
> clarified the separation between message content and encoding
> À: "Soon Young Oh" <[email-masked]>, Soon Young Oh
> <[email-masked]>, "Axel Coli Verdiere" <[email-masked]>, Mario
> Gerla <[email-masked]>, "Professor Mario Gerla" <[email-masked]>, Axel
> Colin de Verdiere <[email-masked]>
>
>
> URL:
> http://www.ietf.org/internet-drafts/draft-gerla-manet-odmrp-asym-01.txt
> Status:
> https://datatracker.ietf.org/doc/draft-gerla-manet-odmrp-asym/
> Diff:
> http://www.ietf.org/rfcdiff?url2=draft-gerla-manet-odmrp-asym-01
>
> Abstract:
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet
>

---

From: Axel Colin de Verdière <[email-masked]>
Date: Sun, 16 Nov 2014 21:12:00 +0100

Hi Ulrich,

Ultimately we'd like to ask the WG for adoption for this draft as well, if there's interest in that, but it'd have to come after draft-gerla-manet-odmrp. There is an ongoing implementation for draft-gerla-manet-odmrp, but it's not completely up-to-date, and none for the -asym draft for the moment. I'm working on that though, so there should be progress on both sides within a month or two.

Best,

Axel

---

From: Ulrich Herberg <[email-masked]>
Date: Sun, 16 Nov 2014 12:26:04 -0800

Thanks!