Subject: [manet] draft-ietf-manet-olsrv2-multitopology and draft-dearlove-manet-tlv-naming-00.txt

From: Thomas Heide Clausen <[email-masked]>
Date: Tue, 11 Nov 2014 04:32:08 +0100

Since, of course, all y’all are compulsively reading the ID-announce mailing list ;) you’ll have seen draft-dearlove-manet-tlv-naming-00.txt document appear just today.

This is in response to the review from our AD on draft-ietf-manet-olsrv2-multitopology (http://www.ietf.org/mail-archive/web/manet/current/msg16875.html <http://www.ietf.org/mail-archive/web/manet/current/msg16875.html>), in which he indicates that we probably should re-think the way we name TLV types. 

As our AD requested, the authors did re-think, discuss a bit also with our AD and chairs, and came to a conclusion ... and that conclusion is in this I-D.

I think that it is safe to say that our AD is going to sit on, and therefore block progress for, draft-ietf-manet-olsrv2-multitopology — and that, until we see draft-dearlove-manet-tlv-naming move ahead (or, until we propose an alternative way forward, of course).

Given that, and in case there is time on the meeting agenda, then — if the WG is interested  and the WG chairs believe that it will be helpful in order to see progress — I’d be happy to say a few words on this topic, and try to answer any questions there might be.

Either way, I believe that we’ll very soon be soliciting the WG chairs to issue a call-for-WG-adoption (with a suitable lead period to read the document), followed by a WGLC, such that this document may make progress and “unblock” draft-ietf-manet-olsrv2-multitopology also.

Best,

Thomas

> Begin forwarded message:
> 
> From: [email-masked]
> To: Thomas Heide Clausen <[email-masked]>, "Christopher Dearlove" <[email-masked]>, "Thomas H. Clausen" <[email-masked]>, Christopher Dearlove <[email-masked]>
> Subject: New Version Notification for draft-dearlove-manet-tlv-naming-00.txt
> Date: 11 Nov 2014 01:51:14 CET
> 
> 
> A new version of I-D, draft-dearlove-manet-tlv-naming-00.txt
> has been successfully submitted by Thomas Heide Clausen and posted to the
> IETF repository.
> 
> Name:		draft-dearlove-manet-tlv-naming
> Revision:	00
> Title:		TLV Naming in the MANET Generalized Packet/Message Format
> Document date:	2014-11-10
> Group:		Individual Submission
> Pages:		16
> URL:            http://www.ietf.org/internet-drafts/draft-dearlove-manet-tlv-naming-00.txt
> Status:         https://datatracker.ietf.org/doc/draft-dearlove-manet-tlv-naming/
> Htmlized:       http://tools.ietf.org/html/draft-dearlove-manet-tlv-naming-00
> 
> 
> Abstract:
>   TLVs (type-length-value structures) as defined by RFC5444 have both a
>   type (one octet) and a type extension (one octet), together forming a
>   full type (of two octets).  RFC5444 sets up IANA registries for TLV
>   types, specifying that an allocation of a TLV type entails creation
>   of an IANA registry for the corresponding type extensions.
> 
>   In some cases, reserving all 256 type extensions for use for a common
>   purpose for a given TLV is meaningful, and thus it makes sense to
>   record a common name for such a TLV type (and all of its type
>   extensions) in the corresponding IANA registries.  An example of such
>   is a LINK_METRIC TLV Type, with its type extensions reserved for use
>   to be indicating the "kind" of metric expressed by the value of the
>   TLV.
> 
>   In some other cases, there may not be 256 full types that share a
>   common purpose and, as such, it is not meaningful to record a common
>   name for all the type extensions for a TLV type in the corresponding
>   IANA registries.  Rather, it is appropriate to record an individual
>   name per full type.
> 
>   This document reorganizes the naming of already allocated TLV types
>   and type extensions in those registries to use names appropriately.
>   It has no consequences in terms of any protocol implementation.
> 
>   This document also updates the Expert Review guidelines from RFC5444,
>   so as to establish a policy for consistent naming of future TLV type
>   and type extension allocations.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
>

---

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 11 Nov 2014 05:16:26 -0000

> I think that it is safe to say that our AD is going to sit on, and therefore block
> progress for, draft-ietf-manet-olsrv2-multitopology
 
Oh! Harsh use of language.
But basically true.
 
So thanks to Thomas and Christopher for writing this document. I would love for this to move fast partly because it unblocks the other draft, and partly because it will set the WG up so that future work can be aligned.
 
If there is time on the agenda then it would be cool to spend some time explaining the plan f2f.
 
Adrian
 
From: Thomas Heide Clausen [mailto:[email-masked]] 
Sent: 11 November 2014 03:32
To: manet
Cc: Adrian Farrel
Subject: draft-ietf-manet-olsrv2-multitopology and draft-dearlove-manet-tlv-naming-00.txt

This is in response to the review from our AD on draft-ietf-manet-olsrv2-multitopology (http://www.ietf.org/mail-archive/web/manet/current/msg16875.html), in which he indicates that we probably should re-think the way we name TLV types. 

 

Best,
 
Thomas

Begin forwarded message:

Abstract:

The IETF Secretariat

---

From: Abdussalam Baryun <[email-masked]>
Date: Thu, 20 Nov 2014 18:21:06 -0800

Hi All,

I don't know why we have to move things fast. Moving things fast adds
possible errors, and may confuse the community. We need to consider
that participants need to give a decision on when to move things fast
and when not to move things fast. I don't agree to move this draft
fast nor agreed to move the multitopology draft fast. We could have
done fast process if the draft was discussed before published, so that
the WG can decide if fast is required. Just my opinion how things go
fast in organisation that involve all.

On 11/10/14, Thomas Heide Clausen <[email-masked]> wrote:
> Since, of course, all y’all are compulsively reading the ID-announce mailing
> list ;) you’ll have seen draft-dearlove-manet-tlv-naming-00.txt document
> appear just today.
>
> This is in response to the review from our AD on
> draft-ietf-manet-olsrv2-multitopology
> (http://www.ietf.org/mail-archive/web/manet/current/msg16875.html
> <http://www.ietf.org/mail-archive/web/manet/current/msg16875.html>), in
> which he indicates that we probably should re-think the way we name TLV
> types.
>
> As our AD requested, the authors did re-think, discuss a bit also with our
> AD and chairs, and came to a conclusion ... and that conclusion is in this
> I-D.

I request that our discussions related to adopted work and future
discussions to be done on the list or within minutes. I think the WG
should be able to be included in discussion between AD and authors,
why WG was excluded?

Best Regards,

AB

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Fri, 21 Nov 2014 09:59:09 +0000

I would find it hard to describe this as fast. Fast would be good, but instead we have processes to follow. As it is, from this point (never mind the time lost so far, in part because the authors had to make time to write the draft) there will be (at best, and therefore I hope) a few weeks delay before we can make progress on MT-OLSRv2 (unless our AD regards WG acceptance as enough to move that on, rather than WGLC, another stage to go through after this).

The observation by the AD has been on file for a while, and discussion on the need for a draft has been held. In its current state as an author draft, this discussion about WG acceptance is exactly the discussion on the form of the draft.

And I'm sorry, you may not have agreed to move the MT draft fast. But the WG accepted a WGLC, at a rate I'd call moderate, not fast.

-- 
Christopher Dearlove
Senior Principal Engineer, Information Assurance Group
Communications, Networks and Image Analysis Capability
BAE Systems Advanced Technology Centre
West Hanningfield Road, Great Baddow, Chelmsford, CM2 8HN, UK
Tel: +44 1245 242194 |  Fax: +44 1245 242124
[email-masked] | http://www.baesystems.com

BAE Systems (Operations) Limited
Registered Office: Warwick House, PO Box 87, Farnborough Aerospace Centre, Farnborough, Hants, GU14 6YU, UK
Registered in England & Wales No: 1996687

-----Original Message-----
From: manet [mailto:[email-masked]] On Behalf Of Abdussalam Baryun
Sent: 21 November 2014 02:21
To: Thomas Heide Clausen
Cc: manet
Subject: Re: [manet] draft-ietf-manet-olsrv2-multitopology and draft-dearlove-manet-tlv-naming-00.txt

----------------------! WARNING ! ---------------------- This message originates from outside our organisation, either from an external partner or from the internet.
Consider carefully whether you should click on any links, open any attachments or reply.
Follow the 'Report Suspicious Emails' link on IT matters for instructions on reporting suspicious email messages.
--------------------------------------------------------

Hi All,

I don't know why we have to move things fast. Moving things fast adds possible errors, and may confuse the community. We need to consider that participants need to give a decision on when to move things fast and when not to move things fast. I don't agree to move this draft fast nor agreed to move the multitopology draft fast. We could have done fast process if the draft was discussed before published, so that the WG can decide if fast is required. Just my opinion how things go fast in organisation that involve all.

On 11/10/14, Thomas Heide Clausen <[email-masked]> wrote:
> Since, of course, all y’all are compulsively reading the ID-announce 
> mailing list ;) you’ll have seen 
> draft-dearlove-manet-tlv-naming-00.txt document appear just today.
>
> <http://www.ietf.org/mail-archive/web/manet/current/msg16875.html>), 
> in which he indicates that we probably should re-think the way we name 
> TLV types.
>
> As our AD requested, the authors did re-think, discuss a bit also with 
> our AD and chairs, and came to a conclusion ... and that conclusion is 
> in this I-D.

I request that our discussions related to adopted work and future discussions to be done on the list or within minutes. I think the WG should be able to be included in discussion between AD and authors, why WG was excluded?

Best Regards,

AB

_______________________________________________
manet mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/manet
********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************

---

From: Stan Ratliff <[email-masked]>
Date: Fri, 21 Nov 2014 15:00:40 -0500

AB,

I don't believe the WG has been excluded, primarily because there is an I-D
posted for the WG's consideration and approval.

Regards,
Stan

On Thu, Nov 20, 2014 at 9:21 PM, Abdussalam Baryun <
[email-masked]> wrote:

> mailing
> our